Introduction

Welcome to the Perception COM-RPC interface. The COM-RPC enables local and remote control of the Perception software. The interface uses the RPC (Remote Procedure Call) and COM technology, for more details look at the System Overview help item. A COM wrapper has been build around an RPC Client. This has been done to make it easier for you to create custom Perception control programs. The COM-RPC wrapper can be used on all Microsoft® Windows® based operating systems. If you however will create client programs at other operating systems like for example Unix or Linux than you can not use the COM wrapper anymore and you should use the RPC calls directly in your program. The same functionality will be available and therefore you can use this help file also for cases like this as a reference, however the example code in the help file is not applicable. During the install of the COM-RPC interface some example code will be made available to show you how create RPC client programs without using the COM wrapper.

A data acquisition system consisting of a GEN series data acquisition system in combination with Perception controlling software can be part of a larger data acquisition system. Programmers of the overall system might want to control the acquisition subsystem from other software, which might run on the same PC as the Perception software, but (more often) which could also run on another computer on the local area network. This other computer can be a Windows-based platform but also Linux and Unix based platforms are used as overall controlling computers. It is not possible to control the data acquisition systems directly, but the user can control Perception (which controls the hardware), and from both an application and a programming point of view this is then the same. It does not matter where to sent a command to – to a receiving hardware or a receiving software - as long as the desired result is achieved. In order to control the Perception software from another application, the Perception RPC interface can be used. This option enables Perception to be remotely controlled. This help file describes the COM-RPC interface to control Perception. It contains a command overview, command reference and examples. Examples are written in C# using the Microsoft Visual Studio development environment.

Intended audience

COM-RPC is designed to be used by .NET C# programmers. You must be proficient in your programming language in order to write custom programs. No specific RPC knowledge is needed, however you can also develop programs in C/C++ and directly use the RPC calls instead of using our COM-RPC wrapper, in this case you should have knowledge of RPC interface technology.
This documentation assumes you understand your Perception, software, and basic acquisition terminology.
Understanding acquisition terminology is vital to understanding digital recordings: trigger, sample rate, pre-/post trigger, etc.


What's new

Perception 7.10

In Perception 7.10 the following methods were added.

Name | Comment
StartAsyncRTFDBSubscription | - - -
StopAsyncRTFDBSubscription | - - -
GetAsyncRTFDBValues | - - -
GetAsyncRTFDBNames | - - -
Abort | - - -

Perception 7.00

In Perception 7.00 the following methods were added.

Name | Comment
GetSystemHealth | - - -
GetSystemHealthProblems | Not implemented
GetESIFile | - - -
GetModule2EtherCATMapping | - - -

Perception 6.70

In Perception 6.70 the following methods were added.

Name | Comment
PerformeDriveAction | - - -

Perception 6.60

In Perception 6.60 the following methods were added:

Name | Comment
GetConnectedMainframeCount | - - -
GetRecorderCount | - - -
SetCalcChannelEnabled | - - -
GetCalcChannelEnabled | - - -
GetCalcChannelName | - - -
GetCalcCommonSettings | - - -
SetCalcCommonSettings | - - -
GetCalcTriggerSettings | - - -
SetCalcTriggerSettings | - - -
SetCalcUserScalingSettings | - - -
GetCalcUserScalingSettings | - - -
SetCalcInputRangeSettings | - - -
GetCalcInputRangeSettings | - - -
GetCalculatedChannelCount | - - -
SetCalcMathSettings | - - -
GetCalcMathSettings | - - -
GetCycleMasterSettings | - - -
SetCycleMasterSettings | - - -
SetInformationStringValue | - - -
SetInformationNumericalValue | - - -
ExecuteCommand | - - -
ExecuteRequest | - - -

Perception 6.50

In Perception 6.50 the following methods were added:

Name | Comment
SetMFExternalStartStopSettings | - - -
GetMFExternalStartStopSettings | - - -
GeteDriveEngineNames | - - -
GeteDriveValues | - - -
GeteDriveConfiguration | - - -
SeteDriveConfiguration | - - -
GetArchiveFolder | - - -
SetArchiveFolder | - - -
SeteDriveNextRecordingComment | - - -
GeteDriveNextRecordingComment | - - -

Perception 6.30

In Perception 6.30 several methods are no longer supported. When calling one of these methods, Perception will show a message and the RPC connection is terminated.

The following table shows the functions which have been marked as obsolete and the new functions which should be used instead.

Old method | Relaced by
GetMasterTimebaseSettings | GetMasterTimebaseSettingsEx
SetMasterTimebaseSettings | SetMasterTimebaseSettingsEx
GetRecTimebaseSettings | GetGroupTimebaseSettings
SetRecTimebaseSettings | SetGroupTimebaseSettings
GetTimebaseSettings | GetGroupTimebaseSettings
SetTimebaseSettings | SetGroupTimebaseSettings
GetStorageSettings | GetGroupStorageSettings
SetStorageSettings | SetGroupStorageSettings
GetSweepSettings | GetGroupSweepSettings
SetSweepSettings | GetGroupSweepSettings
GetContinuousSettings | GetGroupStorageSettings
SetContinuousSettings | SetGroupStorageSettings
GetRecSweepSettings | GetGroupSweepSettings
SetRecSweepSettings | SetGroupSweepSettings
SetRecStorageSettings | SetGroupStorageSettings
GetRecStorageSettings | GetGroupStorageSettings
SetRecDefaultSettings | SetDefaultSettings
Configuration | No longer supported
MainframeSetDefaultSettings | SetDefaultSettings
GetRecSweepSettingsEx | GetGroupSweepSettings
SetRecSweepSettingsEx | SetGroupSweepSettings


Getting Started

Getting started Perception COM-RPC

  • Install latest Perception build, this build also installs the RPC client, server and COM wrapper software on your PC.
  • If you want to work on a remote PC you do not need to install Perception, but you should install “Perception COM-RPC “, this installs the COM-RPC wrapper (PerceptionComRpc.exe), help and demo files. If you work on the same machine as Perception you do not need to install this software, however if you like to have the demo files you have to install it.
  • At a remote PC you do not need a Perception dongle, the only thing you need is the file: "PerceptionComRpc.exe". This file contains the COM/RPC wrapper and is the same as the one installed at the PC where Perception is installed (See folder C:\Program Files\Common Files\HBM\Components).
  • The Perception RPC server is only available if the option Remote API of the Perception HASP®4 USB Token has been enabled. This option is listed as Remote API in the Perception menu: Help > About Perception > More... > Options page.
  • Be sure the Perception RPC Server is enabled. You should go to the Preferences dialog and enable the RPC server.

  • Start Microsoft Visual Studio 2005 or Microsoft Visual C# 2005 Express Edition.
  • Create a new project using the "Windows Application" template
  • Add a reference to PerceptionComRpc. To do this right click at references and add a reference to the COM component “Perception COM Support”
  • If "Perception Com Support" does not show up in the COM tab of the Add Reference Dialog, then register the "PerceptionComRpc.exe" manually. Most probably this file is located in the folder: C:\Program Files\Common Files\HBM\Components. To register this file you should run the following command: "C:\Program Files\Common Files\HBM\Components\PerceptionComRpc.exe /RegServer"

  • Add "using PerceptionComRpc;" to your source code file.
  • To write your first client program we advise to open the help item "SetServerAddress", in this help item you can find example code how to start.


System Overview


Timebase groups

Time-base grouping

With the release of Perception 6.30, a new concept has been introduced to the software which also impacts the CSI / RPC users of Perception.

Introduction

The Perception / GEN Series architecture allows for a very wide range of setting combinations. To allow for easier and more intuitive setup of the data acquisition system, time-base groups are introduced.

Connecting

When connecting to hardware Perception will now automatically created groups based on what the maximum sample-rate of boards in mainframes are. Lets illustrate this for a specific example using a mainframe contains 3 x 1MS/s boards (A, B, E), 2 x 100MS/s boards (D, G) and a 1 x 250kS/s board (F).

After connecting the following setup is expected:

Group1 containing:

Ø Recorder A (1MS/s)

Ø Recorder B (1MS/s)

Ø Recorder E (1MS/s)

Group2 containing:

Ø Recorder C (100MS/s)

Ø Recorder G(100MS/s)

Group 3 containing:

Ø Recorder D (250kS/s)

It is still possible to manually or programmatically change the configuration of the groups and which recorders they contain. There are some limitations and side effects that will be described later in this document.

Sample-rate and other related settings are now operated based on group level. So it is no longer possible to set the sample rate of recorder A, instead the sample rate of Group1 should be set, causing all recorders in that group to be updated.

Disabled group

Another new addition to Perception is the disabled group. Previously recorders could be disabled within their existing group. This has now changed with the following consequences:

1) Whenever a recorder is disabled, it is automatically moved to the disabled group.

2) If a recorder is moved from the disabled group to a non-disabled group it will automatically be enabled.

3) If a recorder is moved from a group to the disabled group is will be automatically be disabled.

4) If a recorder is enabled, a new group will automatically be created for it, and it will be added to that group.

Loading VWB

When loading an existing VWB, some changes may occur in the way groups were stored. Basically what happens is that the configuration is scanned for “time-base conflicts”, meaning recorders that are configured in the same group, but have different sample rates. Let’s illustrate using an example:

Consider the following stored setup:

Left Wing:

Ø Recorder A(1MS/s @ 100kS/s)

Ø Recorder C(100MS/s @ 100kS/s)

Ø Recorder G(100MS/s @ 30MS/s)

Right Wing:

Ø Recorder B(1MS/s @ 100kS/s)

Ø Recorder E (1MS/s @1MS/s )

Ø Recorder D(250kS/s @ 200kS/s)

Note that both groups contain a mix of multiple sample rates that are no longer allowed within the time-base grouping concept. When loading this file, these conflicts will be detected and resolved by automatically creating new groups. When loaded the following group configuration will be created:

Left Wing:

Ø Recorder A(1MS/s @ 100kS/s)

Ø Recorder C(100MS/s @ 100kS/s)

Left Wing _1:

Ø Recorder G(100MS/s @ 30MS/s)

Right Wing:

Ø Recorder B(1MS/s @ 100kS/s)

Right Wing _1:

Ø Recorder E (1MS/s @1MS/s )

Right Wing _2:

Ø Recorder D(250kS/s @ 200kS/s)

Note the following behavior:

1) All recorders are loaded with the same settings as saved in the settings file

2) Recorders that have sample rates that differ from the first recorder in the group are moved to another group. Display setup and formulas will be automatically updated. The new group created is based on the name of the original group.

Group limitations

As all recorders within a group are now forced to the same sample rate, some limitations may apply, depending on how recorders are grouped or are allowed to be grouped.

1) Sample rate clipping. Consider the following example:

Group1:

Ø Recorder A(1MS/s @ 1MS/s)

Ø Recorder B(100MS/s @ 1MS/s)

Clipping: The maximum selectable sample rate for group1 will be 1MS/s as this is the maximum for the slowest recorder. The maximum sample rate is dynamically updated as recorders are added to or removed from the group.

2) Recorder not allowed in a group. Consider the following example:

Group1:

Ø Recorder A(1MS/s @ 1MS/s)

Ø Recorder B(100MS/s @ 1MS/s)

Limitation: Now we want to add (Recorder C 250kS/s @ 250kS/s), this is not allowed!

API note: When using the CSI/RPC interface to set sample rates and configure groups, the limitations are a bit different.

1) When moving a slow recorder to a fast group. The group and all recorders in it will be clipped to the fastest sample rate of the slow recorder. Example:

Group1:

Ø Recorder A(1MS/s @ 1MS/s)

Ø Recorder B(100MS/s @ 1MS/s)

Now we add a new recorder to this group (Recorder C 250kS/s @ 250kS/s). In Perception this is not allowed as the recorder cannot be set to 1MS/s. Using CSI/RPC this is allowed and will result in the following group setup:

Group1:

Ø Recorder A(1MS/s @ 250kS/s)

Ø Recorder B(100MS/s @ 250kS/s)

Ø Recorder C(250kS/s @ 250kS/s)

2) When setting a group to sample rates higher than the slowest recorder can support. The sample rate will be clipped to the fastest common sample rate of all recorders in the group.

GEN2i limitation

A GEN2i always uses a single group. This means that both recorders in the system are clipped to the maximum sample rate. So:

When the GEN2i contains:

Ø Recorder A(100MS/s)

Ø Recorder B(250kS/s)

The maximum selectable sample rate will be 250kS/s!

Interface changes

Function removed / replaced

Please refer to the RPC/CSI help files for specific information on functions that are now obsolete.

What to do now

As a user of Perception there are a few things to consider:

1) Will my existing VWBs be impacted by the time-group change, and if so, is the default conflict resolving behavior OK for me.

a. Yes: You don’t need to do anything. Resaving the workbench after it has been loaded once might improve the load-time.

b. No: Redefine the required configuration or rename the groups created by default. Unfortunately it is no longer possible to make combinations of recorders with different sample rates within one group.

API notes:

For users of the CSI / RPC interface some additional steps are required.

1) When using groups in your CSI project, be aware that groups may automatically change. This means you need to make sure you use the interface to the correct group. See the following pseudo code example:

itfGroup.Name = “MyCustomGroupName”;

ICtrlGroup itfGroup = myRecorder.Group; //myRecorder is only recorder in Group

itfGroup.HighSampleRate = 100k;

myRecorder.Enabled = false;

myRecorder.Enabled = true;

itfGroup.HighSampleRate = 10k;

Note 1: The expectation of this piece of code maybe that recorder “myRecorder” is set to a samplerate of 10kS/s. However this will not happen because “myRecorder” is no longer part of the group after disabling (group set to disabled group) and enabling again (group is now set to a newly created group. To solve this, get the group from the recorder and use that interface to set the sample rate.

Continuing with this example consider the following:

myRecorder2.Group = itfGroup

Note 2: The expectation now maybe that myRecorder2 is in the group “MyCustomGroupName”. This is not correct, most likely a software failure will occur now, or myRecorder2 will “disappear”.

This happens because as the only recorder “myRecorder” in the group was removed, the group itself was removed as well, the object no longer being a part of the groups collection, but still existing because of the reference you hold to it via the itfGroup interface. So please note the importance of being very precise and cautious when dealing with these kind of situations.

2) Recompile your CSI project against the latest version of Perception. Your compiler will warn you in case you are using any of the obsolete functions.

3) If you are using the RPC interface to communicate with Perception, please refer to the updated RPC help file for a list of obsolete functions.

Note: If you do not update your project and call an obsolete function, Perception will show a message stating this fact.


Hardware settings

How a recording is made is determined by a variety of 'settings' that are stored in the actual hardware. They determine at what rate data is converted, when to trigger, what to store, etc.

There are numerous settings. The Perception RPC interface allows you to query and modify the settings most relevant to basic recording capabilities.
The settings described in this section require one or more of the following parameters:

  • Mainframe - a mainframe is the physical housing that comprises one or more recorders.
  • Recorder - a recorder is usually a single board with a number of channels. Each recorder can have its own time base and trigger settings.
  • Channel - one or more channels are within a single recorder. All channels within a single recorder use the same time base and trigger settings. These parameters can be either an index in the form of $<n>$, or the actual name. The actual name can be retrieved by one of the Get...Name functions as described at the end of this section.


Identifying RPC Servers

How to identify Perception RPC servers on the network

Subject:

RPC Find servers via socket protocol description.

Outline:

This document describes the protocol used to identify Running Perception RPC servers on a network.

The protocol can be used to identify RPC servers

Minimum requirements:

Perception 6.14 or higher.

Required knowledge:

For implementing / using this document you need a working knowlegde of sockets.

All examples that maybe included in this document or supplied with RPC installation are based on Windows API calls.

Firewalls may interfere with the proper operation of the protocol.

Protocol description:

Detailed description:

This is a high level description containing all information required for a full implementation.

  • On (1) Setup listening socket on port 8998
  • On (1) Send broadcast to network on port 8999. Broadcast content should be “WHO_IS_RPC_SERVER” in ASCII characters.
  • (2) and (3) will send reply to (1) on port 8998. Reply content will be “I_AM_RPC_SERVER” in ASCII characters.
  • Upon message reception (1) should be able to determine originating IP address without parsing the message content.


How to use generic RPC methods

How to us generic RPC methods

Note:

It is assumed that the user is familiar with creating CSI based code.

The following generic RPC methods are available which can be used to send information to or request information from CSI based code.

void ExecuteCommand(string Topic, string Item, string Command);

void ExecuteRequest(string Topic, string Item, string Request, out string Result);

These methods are string based. They have the following parameters.

Topic: ID of the handler of the command

Item: Additional information which can be used by the handler of the command

Command: String which contains a description of the command to be executed

Request: String which contains a description of the request

Result: Result of the request as string

CSI example

In the following example a class MyCSI is implemented which handles two instances of class MyValue. A class MyValue is implemented which can store a double value and implements methods to set and get this value. A class MyRPCHandler is implemented which handles incoming RPC calls to set and retrieve these values. Program MyProgram shows how to set and retrieve values from class . MyCSI by using the generic RPC methods

These classes must do the following:

Class MyCSI

1. Create an instance of the RPC handler

2. Initialize the RPC handler

3. Implement custom CSI based code

Class MyValue

1. Stores a double value

2. Set and get the value

Class MyRPCHandler

1. Implement interface IRPC_GenericCallbackHandler

2. Register itself to the GenericCallbackHandler

3. Unregister itself from the GenericCallbackHandler if no longer needed

4. Parse the incoming Command and/or Request string and pass it to the method which handles it

Class MyProgram

1. Connect to the RPC server

2. Execute the generic RPC commands

Example code

using System;

using System.Collections.Generic;

using PerceptionCommon;

using Perception.RPC_Callback;

/// <summary>

/// This class implements custom CSI based code

/// </summary>

public class MyCSI

{

     #region Members

     private List<MyValue> m_MyCSIValues;

     #endregion

     #region Constructor

     public MyCSI()

     {

          IProgram program = Perception.Common.ProgramProvider.Program;

          MyValue myValue_1 = new MyValue();

          MyValue myValue_2 = new MyValue();

          m_MyCSIValues = new List<MyValue>();

          m_MyCSIValues.Add(myValue_1);

          m_MyCSIValues.Add(myValue_2);

          // Subscribe to RPC calls to be handled by this CSI class

          MyRPCHandler myRPCHandler = new MyRPCHandler(this);

          myRPCHandler.Init(program.RPC_CallbackManager);

     }

     public List<MyValue> MyCSIValues { get { return m_MyCSIValues; } }

     #endregion

}

/// <summary>

/// This class stores a double value

/// </summary>

public class MyValue

{

     #region Members

     private double m_Value = double.NaN;

     #endregion

     #region CSI Functionality

     public bool SetValue(int value)

     {

          m_Value = value;

          return true;

     }

     public bool GetValue(out double value)

     {

          value = m_Value;

          return true;

     }

     #endregion

}

/// <summary>

/// This class handles incoming RPC calls for RPC handler with topic ID "MyRPCHandler"

/// </summary>

public class MyRPCHandler : IRPC_GenericCallbackHandler, IDisposable

{

     #region Members

     private const string SetValue = "SetValue";

     private const string GetValue = "GetValue";

     private const string ValueOne = "ValueOne";

     private const string ValueTwo = "ValueTwo";

     private IRPC_GenericCallbackManager m_RPC_GenericCallbackManager;

     private MyCSI m_MyCSI;

     #endregion

     #region Constructor

     public MyRPCHandler(MyCSI myCSI)

     {

          m_MyCSI = myCSI;

     }

     ~MyRPCHandler()

     {

          Dispose(false);

     }

     #endregion

     #region IDispose

     public void Dispose()

     {

          Dispose(true);

     }

     private void Dispose(bool disposing)

     {

          if (disposing)

          {

               m_RPC_GenericCallbackManager.UnregisterHandler(this);

          }

     }

     #endregion

     #region IRPC_GenericCallbackHandler

     /// <summary>

     /// Unique ID of the RPC handler

     /// </summary>

     public string Topic { get { return "MyRPCHandler"; } }

     public IRPC_GenericCallbackHandler GetItem(string item)

     {

          return null;

     }

     public RPC_CallbackResult ExecuteCommand(string item, string command)

     {

          bool result = false;

          string action;

          int value;

          ParseCommand(command, out action, out value);

          if (action.Equals(SetValue))

          {

               if (item == ValueOne)

               {

                    result = m_MyCSI.MyCSIValues[1].SetValue(value);

               }

               if (item == ValueTwo)

               {

                    result = m_MyCSI.MyCSIValues[2].SetValue(value);

               }

          }

          return result ?

               RPC_CallbackResult.RPC_CallbackResult_Success :

               RPC_CallbackResult.RPC_CallbackResult_Fail;

     }

     public RPC_CallbackResult ExecuteRequest( string item, string request, out string requestResult)

     {

          bool result = false;

          string action;

          double value = double.NaN;

          ParseRequest(request, out action);

          if (action.Equals(GetValue))

          {

               if (item == ValueOne)

               {

                    result = m_MyCSI.MyCSIValues[1].GetValue(out value);

               }

               else if (item == ValueTwo)

               {

                    result = m_MyCSI.MyCSIValues[2].GetValue(out value);

               }

               else

               {

                    requestResult = String.Empty;

                    return RPC_CallbackResult.RPC_CallbackResult_Unavailable;

               }

          }

          requestResult = value.ToString();

          return result ?

               RPC_CallbackResult.RPC_CallbackResult_Success :

               RPC_CallbackResult.RPC_CallbackResult_Fail;

     }

     #endregion

     #region Helper Methods

     public bool Init(IRPC_CallbackManager rpcCallbackManager)

     {

          m_RPC_GenericCallbackManager =

               rpcCallbackManager as IRPC_GenericCallbackManager;

          return m_RPC_GenericCallbackManager.RegisterHandler(this);

     }

     private void ParseCommand(string command, out string action, out int value)

     {

          action = command.Split('(')[0];

          string strValue = command.Split('(')[1];

          strValue = strValue.Split('(')[0];

          value = int.Parse(strValue);

     }

     private void ParseRequest(string request, out string action)

     {

          action = request.Split('(')[0];

     }

     #endregion

}

/// <summary>

/// This class sets value to and gets value from CSI class MyCSI

/// </summary>

class MyProgram

{

     static void Main(string[] args)

     {

          IPerceptionCOM rpcServer = new PerceptionCOM();

          rpcServer.SetServerAddress("127.0.0.1");

          rpcServer.ConnectToServer();

          rpcServer.ExecuteCommand("MyRPCHandler", "ValueOne", "SetValue(3)");

          rpcServer.ExecuteCommand("MyRPCHandler", "ValueTwo", "SetValue(5)");

          string requestResult = String.Empty;

          rpcServer.ExecuteRequest("MyRPCHandler", "ValueOne", "GetValue()", out requestResult);

          // requestResult is "3"

          rpcServer.ExecuteRequest("MyRPCHandler", "ValueTwo", "GetValue()", out requestResult);

          // requestResult is "5"

     }

}


RPC_COM Namespace

RPC/COM Perception Interfaces
Interfaces
 | Interface | Description
Public interface | IPerceptionCOM | This is the Perception COM interface description
Enumerations
 | Enumeration | Description
Public enumeration | COMBatAgeStatus | Battery age status
Public enumeration | COMBatChargeStat | Battery charging status
Public enumeration | COMCalcCommonSettingsSettingItem | Non specific settings related to a calculated channel
Public enumeration | COMCalcInputRangeSettingsSettingItem | Specifies what the intended measurement range is
Public enumeration | COMCalcPublishToFieldBus | Obsolete. Defines if and how information can be potentially published to the field-bus, actual publication depends on field-bus setup
Public enumeration | COMCalcTriggerSettingsSettingItem | Settings related to triggering on calculated channels, please note the system bus 3 should be set to software trigger to allow triggering between boards on calculated channels.
Public enumeration | COMCalculatedMathSettingsSettingItem | Specifies which math settings to set
Public enumeration | COMCalculatedMathType | Real time Math functions For detailed information on the calculations performed, please refer to the manual
Public enumeration | COMChannelTriggerDirection | Defines how the signal should cross the level(s) in order for a trigger to occur
Public enumeration | COMChannelTriggerMode | Trigger modes potentially available on (calculated) channels, actual availability depends on recorder type
Public enumeration | COMClockSource | Group clock-source
Public enumeration | COMCycleMasterSettingsSettingItem | Settings mask for cycle detector settings
Public enumeration | COMCycleMasterType | Cycle detection type
Public enumeration | COMDiskLocation | Possible disk locations
Public enumeration | COMDSType | Data source type
Public enumeration | COMeDriveActionType | eDrive action type
Public enumeration | COMeDriveConfigKey | Identifiers returned in GeteDriveConfiguration
Public enumeration | COMeDriveConfigStringKey | Identifiers returned in GeteDriveConfigurationStrings
Public enumeration | COMeDriveCycleModeType | Possible values for cycle mode
Public enumeration | COMeDriveInverterBlockType | Possible values for GeteDriveConfiguration when key is InverterOutput_Type or InverterInput_Type
Public enumeration | COMeDriveKeys | Identifiers returned in GeteDriveValues
Public enumeration | COMeDriveMechanicalBlockType | Possible values for GeteDriveConfiguration when key is Mechanical_Type
Public enumeration | COMeDrivePowerBlockType | Possible values for GeteDriveConfiguration when key is PowerSource_Type or PowerInput_Type
Public enumeration | COMeDriveRPC_UpdateRate | Possible values for GeteDriveConfiguration when key is Calculator_UpdateRate
Public enumeration | COMExternalPowerStatus | External power status
Public enumeration | COMExternalStartStopMode | Mode that can be used for external start or stop
Public enumeration | COMExternalTriggerIn | External trigger in
Public enumeration | COMExternalTriggerOut | External trigger out
Public enumeration | COMISCSISettings | Used to identify which settings to set. Combine using or operator to set multiple settings in one call
Public enumeration | COMIScsiStatus | iSCSI status
Public enumeration | COMLinkStatus | Gives information about the communication status
Public enumeration | COMMainframeExtStartStopSettingItem | Used to identify which settings to set. Combine using or operator to set multiple settings in one call
Public enumeration | COMMasterSlaveMode | Possible master slave mode
Public enumeration | COMMasterTimebaseMode | Possible timebase modes
Public enumeration | COMMasterTimebaseSyncSource | Possible timebase sync-sources
Public enumeration | COMMasterTimebaseSyncStatus | Possible status of the timebase synchronization process
Public enumeration | COMMasterTmbSettingsItem | Used to identify which settings to set. Combine using or operator to set multiple settings in one call
Public enumeration | COMNetworkSelect | Possible network devices for the unit
Public enumeration | COMPowerLevel | Power level of remote front-end channel
Public enumeration | COMPowerSource | Power source
Public enumeration | COMPowerStatus | Power status of remote front-end channel
Public enumeration | COMRecordingMode | Possible recording modes
Public enumeration | COMStatusID | Status parameter identifier.
Public enumeration | COMStorageMode | Possible storage modes
Public enumeration | COMStorageSettingItem | Used to identify which settings to set. Combine using or operator to set multiple settings in one call
Public enumeration | COMSweepMode | Gives information about the trigger mode
Public enumeration | COMSweepSettingItem | Used to identify which settings to set. Combine using or operator to set multiple settings in one call
Public enumeration | COMSystemHealth | System health
Public enumeration | COMTimebaseSettingItem | Used to identify which settings to set. Combine using or operator to set multiple settings in one call
Public enumeration | COMUserScalingSettingItem | Defines the items to be used to scale the signal
Public enumeration | COMWindowState | Gives information on the workbook state

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMBatAgeStatus Enumeration

Battery age status

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMBatAgeStatus
Public Enumeration COMBatAgeStatus
public enum class COMBatAgeStatus
type COMBatAgeStatus
Members
Member name | Value | Description
COMBatAgeStatus_Nominal | 0 | Nominal
COMBatAgeStatus_ReplaceSoon | 1 | Replace soon
COMBatAgeStatus_ReplaceNow | 2 | Replace now
COMBatAgeStatus_Unknown | 3 | Unknown
See Also

Reference

RPC_COM Namespace


COMBatChargeStat Enumeration

Battery charging status

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMBatChargeStat
Public Enumeration COMBatChargeStat
public enum class COMBatChargeStat
type COMBatChargeStat
Members
Member name | Value | Description
COMBatChargeStat_Charging | 0 | Charging
COMBatChargeStat_ChargeCompleted | 1 | Charge completed
COMBatChargeStat_DisCharging | 2 | Dis-charging
COMBatChargeStat_Idle | 3 | Idle
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMCalcCommonSettingsSettingItem Enumeration

Non specific settings related to a calculated channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMCalcCommonSettingsSettingItem
Public Enumeration COMCalcCommonSettingsSettingItem
public enum class COMCalcCommonSettingsSettingItem
type COMCalcCommonSettingsSettingItem
Members
Member name | Value | Description
Enabled | 1 | Indicates if the channel is enabled
PhysicalName | 2 | The physical name of the channel, typically fixed, may change when math-type is changed
Name | 4 | The user name of the channel, freely configurable
PrimaryColor | 8 | Primary color of the channel, used when displaying in Perception
SecondColor | 16 | Secondary color of the channel, currently unused
PublToFieldBus | 32 | Indicates if and how the data of the channel should be made available on a field-bus
UserNote1 | 64 | User note 1
UserNote2 | 128 | User note 2
UserNote3 | 256 | User note 3
UserNote4 | 512 | User note 4
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMCalcInputRangeSettingsSettingItem Enumeration

Specifies what the intended measurement range is

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMCalcInputRangeSettingsSettingItem
Public Enumeration COMCalcInputRangeSettingsSettingItem
public enum class COMCalcInputRangeSettingsSettingItem
type COMCalcInputRangeSettingsSettingItem
Members
Member name | Value | Description
UpperValue | 1 | (1) Upper limit to measurement range
LowerValue | 2 | (2) Lower limit to measurement range
See Also

Reference

RPC_COM Namespace
IPerceptionCOMSetCalcInputRangeSettings(String, String, String, COMCalcInputRangeSettingsSettingItem, Double, Double)


COMCalcPublishToFieldBus Enumeration

Note: This API is now obsolete.

Defines if and how information can be potentially published to the field-bus, actual publication depends on field-bus setup

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This enumeration is no longer used", true)]
public enum COMCalcPublishToFieldBus
<ObsoleteAttribute("This enumeration is no longer used", true)>
Public Enumeration COMCalcPublishToFieldBus
[ObsoleteAttribute(L"This enumeration is no longer used", true)]
public enum class COMCalcPublishToFieldBus
[<ObsoleteAttribute("This enumeration is no longer used", true)>]
type COMCalcPublishToFieldBus
Members
Member name | Value | Description
No | 0 | Do not publish the channel
SDO_Only | 1 | Publish for polling availability only
SDO_PDO | 2 | Publish for polling and push availability
Remarks
In Perception 7.0 this enumeration has been removed and data is now always PDO and SDO.
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMCalcTriggerSettingsSettingItem Enumeration

Settings related to triggering on calculated channels, please note the system bus 3 should be set to software trigger to allow triggering between boards on calculated channels.

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMCalcTriggerSettingsSettingItem
Public Enumeration COMCalcTriggerSettingsSettingItem
public enum class COMCalcTriggerSettingsSettingItem
type COMCalcTriggerSettingsSettingItem
Members
Member name | Value | Description
Mode | 1 | Trigger mode
PrimaryLevel | 2 | Primary trigger level
SecondaryLevel | 4 | Secondary trigger level, usage depends on mode
Direction | 8 | Trigger direction of primary level, secondary trigger will typically trigger in reverse direction
Hystersis | 16 | Hysteresis to apply on trigger levels
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMCalculatedMathSettingsSettingItem Enumeration

Specifies which math settings to set

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMCalculatedMathSettingsSettingItem
Public Enumeration COMCalculatedMathSettingsSettingItem
public enum class COMCalculatedMathSettingsSettingItem
type COMCalculatedMathSettingsSettingItem
Members
Member name | Value | Description
MathType | 1 | (1) Select the math type
Detector | 2 | (2) Select the cycle detector source
InputChannel1 | 4 | (4) Select input channel source for parameter 1
InputChannel2 | 8 | (8) Select input channel source for parameter 2
InputChannel3 | 16 | (16) Select input channel source for parameter 3
InputChannel4 | 32 | (32) Select input channel source for parameter 4
InputChannel5 | 64 | (64) Select input channel source for parameter 5
InputChannel6 | 128 | (128) Select input channel source for parameter 6
TimerCounterMaxNoPulsesPeriods | 256 | (256) Select the maximum number of pulses per period for a timer counter
See Also

Reference

RPC_COM Namespace
IPerceptionCOMSetCalcMathSettings(String, String, String, COMCalculatedMathSettingsSettingItem, COMCalculatedMathType, Int64, Array)
IPerceptionCOMGetCalcMathSettings(String, String, String, COMCalculatedMathSettingsSettingItem, COMCalculatedMathType, Int64, Array)


COMCalculatedMathType Enumeration

Real time Math functions For detailed information on the calculations performed, please refer to the manual

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMCalculatedMathType
Public Enumeration COMCalculatedMathType
public enum class COMCalculatedMathType
type COMCalculatedMathType
Members
Member name | Value | Description
None | -1 | (-1) Do not perform any math
SingleChannel_RMS | 0 | (0) Calculated the RMS for 1 channel over the cycle as defined by the cycle source
SingleChannel_Minimum | 1 | (1) Calculated the minimum for 1 channel over the cycle as defined by the cycle source
SingleChannel_Maximum | 2 | (2) Calculated the maximum for 1 channel over the cycle as defined by the cycle source
SingleChannel_Mean | 3 | (3) Calculated the mean for 1 channel over the cycle as defined by the cycle source
SingleChannel_PeakToPeak | 4 | (4) Calculated the peak to peak for 1 channel over the cycle as defined by the cycle source
SingleChannel_Area | 5 | (5) Calculated the area for 1 channel over the cycle as defined by the cycle source
SingleChannel_Energy | 6 | (6) Calculated the energy for 1 channel over the cycle as defined by the cycle source
TimerCounterChannel_Frequency | 7 | (7) Calculated the frequency for 1 timer counter channel
CS_SquareWave | 8 | (8) Create a square wave output displaying the cycles as provided per the cycle detection source
CS_Frequency | 9 | (9) Create a square wave output displaying the frequency per cycle as provided per the cycle detection source
TwoChannel_MeanOfMult | 10 | (10) Mean of the multiplication of two channels over the cycle as defined by the cycle source
TimerCounterChannel_RPMfromAngle | 11 | (11) Calculate the RPM from a give input signal that is an angle of a rotary sensor
See Also

Reference

RPC_COM Namespace
IPerceptionCOMSetCalcMathSettings(String, String, String, COMCalculatedMathSettingsSettingItem, COMCalculatedMathType, Int64, Array)
IPerceptionCOMGetCalcMathSettings(String, String, String, COMCalculatedMathSettingsSettingItem, COMCalculatedMathType, Int64, Array)


COMChannelTriggerDirection Enumeration

Defines how the signal should cross the level(s) in order for a trigger to occur

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMChannelTriggerDirection
Public Enumeration COMChannelTriggerDirection
public enum class COMChannelTriggerDirection
type COMChannelTriggerDirection
Members
Member name | Value | Description
RisingEdge | 0 | The signal should move from under to above the level
FallingEdge | 1 | The signal should move from above to under the level
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMChannelTriggerMode Enumeration

Trigger modes potentially available on (calculated) channels, actual availability depends on recorder type

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMChannelTriggerMode
Public Enumeration COMChannelTriggerMode
public enum class COMChannelTriggerMode
type COMChannelTriggerMode
Members
Member name | Value | Description
Off | 0 | No triggering
Basic | 1 | Trigger on primary level in direction specified with hysteresis specified
Dual | 2 | Trigger on primary and secondary level
Window | 3 | Please refer to manual for specifics on this trigger mode
DualWindow | 4 | Please refer to manual for specifics on this trigger mode
Sequential | 5 | Please refer to manual for specifics on this trigger mode
BasicQualifier | 6 | Please refer to manual for specifics on this trigger mode
DualQualifier | 7 | Please refer to manual for specifics on this trigger mode
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMClockSource Enumeration

Group clock-source

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMClockSource
Public Enumeration COMClockSource
public enum class COMClockSource
type COMClockSource
Members
Member name | Value | Description
COMClockSource_Internal | 0 | Use the internal clock
COMClockSource_ExternalA | 1 | Use the external clock source
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMCycleMasterSettingsSettingItem Enumeration

Settings mask for cycle detector settings

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMCycleMasterSettingsSettingItem
Public Enumeration COMCycleMasterSettingsSettingItem
public enum class COMCycleMasterSettingsSettingItem
type COMCycleMasterSettingsSettingItem
Members
Member name | Value | Description
CycleDetectorType | 1 | (1) Sets the detector type
InputChannel | 2 | (2) Name of input channel consume
Level | 4 | (4) Cycle detection level
ThresHold | 8 | (8) Cycle detection threshold
NumCycles | 16 | (16) Number of cycles to use
Direction | 32 | (32) Cycle direction (ignored when using half cycles)
Timer | 64 | (64) Time in case of using periodic detector
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMCycleMasterType Enumeration

Cycle detection type

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMCycleMasterType
Public Enumeration COMCycleMasterType
public enum class COMCycleMasterType
type COMCycleMasterType
Members
Member name | Value | Description
CycleSimple | 0 | (0) Cycle detection using non filtered linear interpolation and levels
Period | 1 | (1) Periodic cycle detection
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMDiskLocation Enumeration

Possible disk locations

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMDiskLocation
Public Enumeration COMDiskLocation
public enum class COMDiskLocation
type COMDiskLocation
Members
Member name | Value | Description
COMDiskLocation_None | 0 | Do not store the data
COMDiskLocation_Remote | 1 | Us PC storage
COMDiskLocation_Local1 | 2 | Mainframe storage to local drive 1
COMDiskLocation_Local2 | 3 | Mainframe storage to local drive 2
COMDiskLocation_iSCSI1 | 4 | Mainframe storage to iSCSI drive 1
COMDiskLocation_iSCSI2 | 5 | Mainframe storage to iSCSI drive 2
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMDSType Enumeration

Data source type

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMDSType
Public Enumeration COMDSType
public enum class COMDSType
type COMDSType
Members
Member name | Value | Description
COMDSType_Invalid | -1 | Invalid data source type
COMDSType_Unknown | 0 | Unknown data source type
COMDSType_Numerical | 1 | Numerical data source
COMDSType_String | 2 | String data source
COMDSType_AnalogWaveform | 3 | Analog waveform data source
COMDSType_DigitalWaveform | 4 | Digital waveform data source
COMDSType_TimeMarks | 10 | Time-marks data source
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMeDriveActionType Enumeration

eDrive action type

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMeDriveActionType
Public Enumeration COMeDriveActionType
public enum class COMeDriveActionType
type COMeDriveActionType
Members
Member name | Value | Description
LogValues | 0 | 0 Log the current values of the live sheet to a log file. If in preview mode, this will also open Excel and show/update it.
FreezeValues | 1 | 1 Freeze the updating of the values.
DefrostValues | 2 | 2 Defrost the updating of the values.
See Also

Reference

RPC_COM Namespace
IPerceptionCOMPerformeDriveAction(Int32, COMeDriveActionType, Array)


COMeDriveConfigKey Enumeration

Identifiers returned in GeteDriveConfiguration

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMeDriveConfigKey
Public Enumeration COMeDriveConfigKey
public enum class COMeDriveConfigKey
type COMeDriveConfigKey
Members
Member name | Value | Description
Calculator_UpdateRate | 0 | 0 Calculation and UI update rate. Value must be one of COMeDriveRPC_UpdateRate
PowerSource_NumberOfCycles | 1 | 1 Number of cycles in PowerSource to perform calculations on. Valid values:0.5, 1, 2, 3, 4, 5, 10, 20, 50
PowerSource_CycleLevel | 2 | 2 Level for PowerSource cycle detector
PowerSource_CycleHysteresis | 3 | 3 Hysteresis for PowerSource cycle detector
PowerSource_VoltageSpan | 4 | 4 PowerSource voltage span in V.
PowerSource_CurrentSpan | 5 | 5 PowerSource current span in A.
InverterOutput_NumberOfCycles | 6 | 6 Number of cycles in InvertOutput to perform calculations on. Valid values:0.5, 1, 2, 3, 4, 5, 10, 20, 50
InverterOutput_CycleLevel | 7 | 7 Level for InverterOutput cycle detector
InverterOutput_CycleHysteresis | 8 | 8 Hysteresis for InverterOutput cycle detector
InverterOutput_VoltageSpan | 9 | 9 InverterOutput voltage span in V.
InverterOutput_CurrentSpan | 10 | 10 InverterOutput current span in A.
Mechanical_TorqueSpan_A | 11 | 11 MotorOutput Torque span, input A
Mechanical_TorqueSpan_B | 12 | 12 MotorOutput Torque span, input B
Mechanical_RpmSpan_A | 13 | 13 MotorOutput RPM span, input A
Mechanical_RpmSpan_B | 14 | 14 MotorOutput RPM span, input B
Acquisition_SampleRate | 15 | 15 Sample-rate, in Samples per second
Acquisition_FilterEnabled | 16 | 16 Input filter enabled. A value of 0 when disabled, any other value for enabled
Acquisition_Current_FilterFrequency | 17 | 17 Input filter frequency for current channels, in Hz
Acquisition_Voltage_FilterFrequency | 18 | 18 Input filter frequency for voltage channels, in Hz
InverterInput_NumberOfCycles | 19 | 19 Number of cycles in InvertInput to perform calculations on. Valid values:0.5, 1, 2, 3, 4, 5, 10, 20, 50
InverterInput_CycleLevel | 20 | 20 Level for InverterInput cycle detector
InverterInput_CycleHysteresis | 21 | 21 Hysteresis for InverterInput cycle detector
InverterInput_VoltageSpan | 22 | 22 InverterInput voltage span in V.
InverterInput_CurrentSpan | 23 | 23 InverterInput current span in A.
PowerInput_NumberOfCycles | 24 | 24 Number of cycles in PowerInput to perform calculations on. Valid values:0.5, 1, 2, 3, 4, 5, 10, 20, 50
PowerInput_CycleLevel | 25 | 25 Level for PowerInput cycle detector
PowerInput_CycleHysteresis | 26 | 26 Hysteresis for PowerInput cycle detector
PowerInput_VoltageSpan | 27 | 27 PowerInput voltage span in V.
PowerInput_CurrentSpan | 28 | 28 PowerInput current span in A.
Mechanical_Angle_Offset_A | 29 | 29 MotorOutput mechanical angle offset in degrees, input A
Mechanical_Angle_Offset_B | 30 | 30 MotorOutput mechanical angle offset in degrees, input B
Mechanical_Pole_Pairs_Motor | 31 | 31 Number of pole pairs in a motor.
Mechanical_Pole_Pairs_Generator | 32 | 32 Number of pole pairs in a generator.
PowerSource_Type | 33 | 33 PowerSource type. Value must be one of COMeDrivePowerBlockType
InverterOutput_Type | 34 | 34 InverterOutput type. Value must be one of COMeDriveInverterBlockType
Mechanical_Type | 35 | 35 Mechanical type. Value must be one of COMeDriveMechanicalBlockType
InverterInput_Type | 36 | 36 InverterInput type. Value must be one of COMeDriveInverterBlockType
PowerInput_Type | 37 | 37 PowerInput type. Value must be one of COMeDrivePowerBlockType
PowerSource_CycleMode | 38 | 38 PowerSource cycle mode. Value must be one of COMeDriveCycleModeType
InverterOutput_CycleMode | 39 | 39 InverterOutput cycle mode. Value must be one of COMeDriveCycleModeType
Mechanical_CycleMode | 40 | 40 Mechanical cycle mode. Value must be one of COMeDriveCycleModeType
InverterInput_CycleMode | 41 | 41 InverterInput cycle mode. Value must be one of COMeDriveCycleModeType
PowerInput_CycleMode | 42 | 42 PowerInput cycle mode. Value must be one of COMeDriveCycleModeType
Acquisition_Use_DC_Filter | 43 | 43 Use special filter for channels of DC configurations . A value of 0 when disabled, any other value for enabled
Acquisition_DC_FilterEnabled | 44 | 44 Input filter for channels of DC configurations enabled. A value of 0 when disabled, any other value for enabled
Acquisition_DC_Current_FilterFrequency | 45 | 45 Input filter frequency for current channels of DC configurations, in Hz
Acquisition_DC_Voltage_FilterFrequency | 46 | 46 Input filter frequency for voltage channels of DC configurations, in Hz
Calculator_AverageValues | 47 | 47 Average the values during the update rate, or use the latest value during the update rate. A value of 0 represents the use of the latest value, any other value the use of average values.
MotorOutput_TorqueSpan_A | 11 | Obsolete. 11 MotorOutput Torque span, input A
MotorOutput_TorqueSpan_B | 12 | Obsolete. 12 MotorOutput Torque span, input B
MotorOutput_RpmSpan_A | 13 | Obsolete. 13 MotorOutput RPM span, input A
MotorOutput_RpmSpan_B | 14 | Obsolete. 14 MotorOutput RPM span, input B
See Also

Reference

RPC_COM Namespace
IPerceptionCOMGeteDriveConfiguration(Int32, Array, Array)


COMeDriveConfigStringKey Enumeration

Identifiers returned in GeteDriveConfigurationStrings
Keys used to report configuration values.

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMeDriveConfigStringKey
Public Enumeration COMeDriveConfigStringKey
public enum class COMeDriveConfigStringKey
type COMeDriveConfigStringKey
Members
Member name | Value | Description
PowerSource_Transducer_Current_1 | 1 | 1 Transducer used to measure Current phase 1 of PowerSource
PowerSource_Transducer_Current_2 | 2 | 2 Transducer used to measure Current phase 2 of PowerSource
PowerSource_Transducer_Current_3 | 3 | 3 Transducer used to measure Current phase 3 of PowerSource
PowerSource_Transducer_Current_4 | 4 | 4 Transducer used to measure Current phase 4 (single 6-phase) or 1 of second(dual 3-phase) of PowerSource
PowerSource_Transducer_Current_5 | 5 | 5 Transducer used to measure Current phase 5 (single 6-phase) or 2 of second(dual 3-phase) of PowerSource
PowerSource_Transducer_Current_6 | 6 | 6 Transducer used to measure Current phase 6 (single 6-phase) or 3 of second(dual 3-phase) of PowerSource
PowerSource_Transducer_Voltage_1 | 7 | 7 Transducer used to measure Voltage phase 1 of PowerSource
PowerSource_Transducer_Voltage_2 | 8 | 8 Transducer used to measure Voltage phase 2 of PowerSource
PowerSource_Transducer_Voltage_3 | 9 | 9 Transducer used to measure Voltage phase 3 of PowerSource
PowerSource_Transducer_Voltage_4 | 10 | 10 Transducer used to measure Voltage phase 4 (single 6-phase) or 1 of second(dual 3-phase) of PowerSource
PowerSource_Transducer_Voltage_5 | 11 | 11 Transducer used to measure Voltage phase 5 (single 6-phase) or 2 of second(dual 3-phase) of PowerSource
PowerSource_Transducer_Voltage_6 | 12 | 12 Transducer used to measure Voltage phase 6 (single 6-phase) or 3 of second(dual 3-phase) of PowerSource
InverterOutput_Transducer_Current_1 | 13 | 13 Transducer used to measure Current phase 1 of Inverter output
InverterOutput_Transducer_Current_2 | 14 | 14 Transducer used to measure Current phase 2 of Inverter output
InverterOutput_Transducer_Current_3 | 15 | 15 Transducer used to measure Current phase 3 of Inverter output
InverterOutput_Transducer_Current_4 | 16 | 16 Transducer used to measure Current phase 4 (single 6-phase) or 1 of second(dual 3-phase) of Inverter output
InverterOutput_Transducer_Current_5 | 17 | 17 Transducer used to measure Current phase 5 (single 6-phase) or 2 of second(dual 3-phase) of Inverter output
InverterOutput_Transducer_Current_6 | 18 | 18 Transducer used to measure Current phase 6 (single 6-phase) or 3 of second(dual 3-phase) of Inverter output
InverterOutput_Transducer_Voltage_1 | 19 | 19 Transducer used to measure Voltage phase 1 of Inverter output
InverterOutput_Transducer_Voltage_2 | 20 | 20 Transducer used to measure Voltage phase 2 of Inverter output
InverterOutput_Transducer_Voltage_3 | 21 | 21 Transducer used to measure Voltage phase 3 of Inverter output
InverterOutput_Transducer_Voltage_4 | 22 | 22 Transducer used to measure Voltage phase 4 (single 6-phase) or 1 of second(dual 3-phase) of Inverter output
InverterOutput_Transducer_Voltage_5 | 23 | 23 Transducer used to measure Voltage phase 5 (single 6-phase) or 2 of second(dual 3-phase) of Inverter output
InverterOutput_Transducer_Voltage_6 | 24 | 24 Transducer used to measure Voltage phase 6 (single 6-phase) or 3 of second(dual 3-phase) of Inverter output
InverterInput_Transducer_Current_1 | 25 | 25 Transducer used to measure Current phase 1 of Inverter input
InverterInput_Transducer_Current_2 | 26 | 26 Transducer used to measure Current phase 2 of Inverter input
InverterInput_Transducer_Current_3 | 27 | 27 Transducer used to measure Current phase 3 of Inverter input
InverterInput_Transducer_Voltage_1 | 28 | 28 Transducer used to measure Voltage phase 1 of Inverter input
InverterInput_Transducer_Voltage_2 | 29 | 29 Transducer used to measure Voltage phase 2 of Inverter input
InverterInput_Transducer_Voltage_3 | 30 | 30 Transducer used to measure Voltage phase 3 of Inverter input
PowerInput_Transducer_Current_1 | 31 | 31 Transducer used to measure Current phase 1 of Power input
PowerInput_Transducer_Current_2 | 32 | 32 Transducer used to measure Current phase 2 of Power input
PowerInput_Transducer_Current_3 | 33 | 33 Transducer used to measure Current phase 3 of Power input
PowerInput_Transducer_Voltage_1 | 34 | 34 Transducer used to measure Voltage phase 1 of Power input
PowerInput_Transducer_Voltage_2 | 35 | 35 Transducer used to measure Voltage phase 1 of Power input
PowerInput_Transducer_Voltage_3 | 36 | 36 Transducer used to measure Voltage phase 1 of Power input
Torque_A_Transducer | 37 | 37 Transducer used to measure Torque A
Torque_B_Transducer | 38 | 38 Transducer used to measure Torque B
Speed_A_Transducer | 39 | 39 Transducer used to measure Speed A
Speed_B_Transducer | 40 | 40 Transducer used to measure Speed B
See Also

Reference

RPC_COM Namespace
IPerceptionCOMGeteDriveConfigurationStrings(Int32, Array, Array)


COMeDriveCycleModeType Enumeration

Possible values for cycle mode

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMeDriveCycleModeType
Public Enumeration COMeDriveCycleModeType
public enum class COMeDriveCycleModeType
type COMeDriveCycleModeType
Members
Member name | Value | Description
Cycle_Detect | 0 | 0 Using a cycle detect
Timed | 1 | 1 Using a timed interval
Linked | 2 | 2 Linked to another setup block
Cycle_Event | 3 | 3 Using a cycle event
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMeDriveInverterBlockType Enumeration

Possible values for GeteDriveConfiguration when key is InverterOutput_Type or InverterInput_Type

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMeDriveInverterBlockType
Public Enumeration COMeDriveInverterBlockType
public enum class COMeDriveInverterBlockType
type COMeDriveInverterBlockType
Members
Member name | Value | Description
AC_3_Phase_Phase_to_Phase | 0 | 0 A 3-phase phase-to-phase configuration
AC_3_Phase_Phase_to_Artificial_Star | 1 | 1 A 3-phase phase-to-artificial star configuration
AC_3_Phase_Phase_to_Star | 2 | 2 A 3-phase phase-to-star configuration
AC_3_Phase_Phase_to_Phase_Aron | 3 | 3 A 3-phase Aron configuration
AC_3_Phase_Phase_to_Ground | 4 | 4 A 3-phase phaso-to-ground configuration
None | 5 | 5 No inverter configuration
Dual_AC_3_Phase_Phase_to_Phase | 6 | 6 A dual 3-phase phase-to-phase configuration
Dual_AC_3_Phase_Phase_to_Artificial_Star | 7 | 7 A dual 3-phase phase-to-artificial star configuration
Dual_AC_3_Phase_Phase_to_Star | 8 | 8 A dual 3-phase phase-to-star configuration
Dual_AC_3_Phase_Phase_to_Phase_Aron | 9 | 9 A dual 3-phase Aron configuration
Dual_AC_3_Phase_Phase_to_Ground | 10 | 10 A dual 3-phase phase-to-ground configuration
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMeDriveKeys Enumeration

Identifiers returned in GeteDriveValues

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMeDriveKeys
Public Enumeration COMeDriveKeys
public enum class COMeDriveKeys
type COMeDriveKeys
Members
Member name | Value | Description
eDriveKey_UpdateCounter | 0 | 0 Counter which increases with every performed calculation. If number remains the same, no new calculations have been performed since last call
eDriveKey_EngineStarted | 1 | 1 Indicates whether calculator engine is enabled (0: not enabled, any other value: enabled)
eDriveKey_RecordingTime | 2 | 2 Start time of recording (total number of seconds since 1 Jan 1970)
eDriveKey_CycleCount_in | 3 | 3 Number of cycles detected in input signal (PowerOutput)
eDriveKey_CycleFrequency_in | 4 | 4 Cycles per second detected in input signal (PowerOutput)
eDriveKey_Start_in | 5 | 5 Time of first sample used in calculations (PowerOutput)
eDriveKey_End_in | 6 | 6 Time of last sample used in calculations (PowerOutput)
eDriveKey_U_in | 11 | 11 Collective DC mean, or AC single phase voltage (PowerOutput)
eDriveKey_U_123_in | 288 | 288 Collective phase 1, 2 and 3 voltage (PowerOutput)
eDriveKey_U_456_in | 289 | 289 Collective phase 4, 5 and 6 voltage (PowerOutput)
eDriveKey_U1_in | 12 | 12 RMS voltage phase 1 (PowerOutput)
eDriveKey_U2_in | 13 | 13 RMS voltage phase 2 (PowerOutput)
eDriveKey_U3_in | 14 | 14 RMS voltage phase 3 (PowerOutput)
eDriveKey_U4_in | 290 | 290 RMS voltage phase 4 (PowerOutput)
eDriveKey_U5_in | 291 | 291 RMS voltage phase 5 (PowerOutput)
eDriveKey_U6_in | 292 | 292 RMS voltage phase 6 (PowerOutput)
eDriveKey_U1_2_in | 273 | 273 RMS voltage 1_2 (PowerOutput)
eDriveKey_U2_3_in | 274 | 274 RMS voltage 2_3 (PowerOutput)
eDriveKey_U3_1_in | 275 | 275 RMS voltage 3_1 (PowerOutput)
eDriveKey_U4_5_in | 293 | 293 RMS voltage 4_5 (PowerOutput)
eDriveKey_U5_6_in | 294 | 294 RMS voltage 5_6 (PowerOutput)
eDriveKey_U6_4_in | 295 | 295 RMS voltage 6_4 (PowerOutput)
eDriveKey_I_in | 15 | 15 Collective, DC, or AC single phase current (PowerOutput)
eDriveKey_I_123_in | 296 | 296 Collective, DC, or AC phase 1, 2 and 3 current (PowerOutput)
eDriveKey_I_456_in | 297 | 297 Collective, DC, or AC phase 4, 5 and 6 current (PowerOutput)
eDriveKey_I1_in | 16 | 16 RMS current phase 1 (PowerOutput)
eDriveKey_I2_in | 17 | 17 RMS current phase 2 (PowerOutput)
eDriveKey_I3_in | 18 | 18 RMS current phase 3 (PowerOutput)
eDriveKey_I4_in | 298 | 298 RMS current phase 4 (PowerOutput)
eDriveKey_I5_in | 299 | 299 RMS current phase 5 (PowerOutput)
eDriveKey_I6_in | 300 | 300 RMS current phase 6 (PowerOutput)
eDriveKey_P_in | 19 | 19 Total active power (PowerOutput)
eDriveKey_P_123_in | 301 | 301 Total active power phase 1, 2 and 3 (PowerOutput)
eDriveKey_P_456_in | 302 | 302 Total active power phase 4, 5 and 6 (PowerOutput)
eDriveKey_P1_in | 20 | 20 Active power phase 1 (PowerOutput)
eDriveKey_P2_in | 21 | 21 Active power phase 2 (PowerOutput)
eDriveKey_P3_in | 22 | 22 Active power phase 3 (PowerOutput)
eDriveKey_P4_in | 303 | 303 Active power phase 4 (PowerOutput)
eDriveKey_P5_in | 304 | 304 Active power phase 5 (PowerOutput)
eDriveKey_P6_in | 305 | 305 Active power phase 6 (PowerOutput)
eDriveKey_Q_in | 23 | 23 Total reactive power (PowerOutput)
eDriveKey_Q1_in | 24 | 24 Reactive power phase 1 (PowerOutput)
eDriveKey_Q123_in | 311 | 311 Reactive power phase 1, 2 and 3 (PowerOutput)
eDriveKey_Q456_in | 312 | 312 Reactive power phase 4, 5 and 6 (PowerOutput)
eDriveKey_Q2_in | 25 | 25 Reactive power phase 2 (PowerOutput)
eDriveKey_Q3_in | 26 | 26 Reactive power phase 3 (PowerOutput)
eDriveKey_Q4_in | 313 | 313 Reactive power phase 4 (PowerOutput)
eDriveKey_Q5_in | 314 | 314 Reactive power phase 5 (PowerOutput)
eDriveKey_Q6_in | 315 | 315 Reactive power phase 6 (PowerOutput)
eDriveKey_S_in | 27 | 27 Total apparent power (PowerOutput)
eDriveKey_S1_in | 28 | 28 Apparent power phase 1 (PowerOutput)
eDriveKey_S123_in | 306 | 306 Apparent power phase 1, 2 and 3 (PowerOutput)
eDriveKey_S456_in | 307 | 307 Apparent power phase 4, 5 and 6 (PowerOutput)
eDriveKey_S2_in | 29 | 29 Apparent power phase 2 (PowerOutput)
eDriveKey_S3_in | 30 | 30 Apparent power phase 3 (PowerOutput)
eDriveKey_S4_in | 308 | 308 Apparent power phase 4 (PowerOutput)
eDriveKey_S5_in | 309 | 309 Apparent power phase 5 (PowerOutput)
eDriveKey_S6_in | 310 | 310 Apparent power phase 6 (PowerOutput)
eDriveKey_Lambda_in | 31 | 31 Power factor (PowerOutput)
eDriveKey_Lambda1_in | 261 | 261 Power factor phase 1 (PowerOutput)
eDriveKey_Lambda123_in | 316 | 316 Power factor phase 1, 2 and 3 (PowerOutput)
eDriveKey_Lambda456_in | 317 | 317 Power factor phase 4, 5 and 6 (PowerOutput)
eDriveKey_Lambda2_in | 262 | 262 Power factor phase 2 (PowerOutput)
eDriveKey_Lambda3_in | 263 | 263 Power factor phase 3 (PowerOutput)
eDriveKey_Lambda4_in | 318 | 318 Power factor phase 3 (PowerOutput)
eDriveKey_Lambda5_in | 319 | 319 Power factor phase 3 (PowerOutput)
eDriveKey_Lambda6_in | 320 | 320 Power factor phase 3 (PowerOutput)
eDriveKey_THD_U_in | 81 | Obsolete. 81 THD of Input Voltage (1 phase) (PowerOutput)
eDriveKey_U_in_THD | 81 | Obsolete. 81 THD of Input Voltage (1 phase) (PowerOutput)
eDriveKey_THD_U1_in | 82 | Obsolete. 82 THD of Input Voltage phase 1 (PowerOutput)
eDriveKey_U1_in_THD | 82 | Obsolete. 82 THD of Input Voltage phase 1 (PowerOutput)
eDriveKey_THD_U2_in | 83 | Obsolete. 83 THD of Input Voltage phase 2 (PowerOutput)
eDriveKey_U2_in_THD | 83 | Obsolete. 83 THD of Input Voltage phase 2 (PowerOutput)
eDriveKey_THD_U3_in | 84 | Obsolete. 84 THD of Input Voltage phase 3 (PowerOutput)
eDriveKey_U3_in_THD | 84 | Obsolete. 84 THD of Input Voltage phase 3 (PowerOutput)
eDriveKey_THD_I_in | 89 | Obsolete. 89 THD of Input Current (1 phase) (PowerOutput)
eDriveKey_I_in_THD | 89 | Obsolete. 89 THD of Input Current (1 phase) (PowerOutput)
eDriveKey_THD_I1_in | 90 | Obsolete. 90 THD of Input Current phase 1 (PowerOutput)
eDriveKey_I1_in_THD | 90 | Obsolete. 90 THD of Input Current phase 1 (PowerOutput)
eDriveKey_THD_I2_in | 91 | Obsolete. 91 THD of Input Current phase 2 (PowerOutput)
eDriveKey_I2_in_THD | 91 | Obsolete. 91 THD of Input Current phase 2 (PowerOutput)
eDriveKey_THD_I3_in | 92 | Obsolete. 92 THD of Input Current phase 3 (PowerOutput)
eDriveKey_I3_in_THD | 92 | Obsolete. 92 THD of Input Current phase 3 (PowerOutput)
eDriveKey_U_FundamentalRMS_in | 97 | Obsolete. 97 FundamentalRMS of Input Voltage (1 phase) (PowerOutput)
eDriveKey_U_in_fund_RMS | 97 | 97 FundamentalRMS of Input Voltage (1 phase) (PowerOutput)
eDriveKey_U1_FundamentalRMS_in | 98 | Obsolete. 98 FundamentalRMS of Input Voltage phase 1 (PowerOutput)
eDriveKey_U1_in_fund_RMS | 98 | 98 FundamentalRMS of Input Voltage phase 1 (PowerOutput)
eDriveKey_U123_in_fund_RMS | 321 | 321 FundamentalRMS of Input Voltage phase 1, 2 and 3 (PowerOutput)
eDriveKey_U456_in_fund_RMS | 322 | 322 FundamentalRMS of Input Voltage phase 4, 5 and 6 (PowerOutput)
eDriveKey_U2_FundamentalRMS_in | 99 | Obsolete. 99 FundamentalRMS of Input Voltage phase 2 (PowerOutput)
eDriveKey_U2_in_fund_RMS | 99 | 99 FundamentalRMS of Input Voltage phase 2 (PowerOutput)
eDriveKey_U3_FundamentalRMS_in | 100 | Obsolete. 100 FundamentalRMS of Input Voltage phase 3 (PowerOutput)
eDriveKey_U3_in_fund_RMS | 100 | 100 FundamentalRMS of Input Voltage phase 3 (PowerOutput)
eDriveKey_U4_in_fund_RMS | 323 | 323 FundamentalRMS of Input Voltage phase 4 (PowerOutput)
eDriveKey_U5_in_fund_RMS | 324 | 324 FundamentalRMS of Input Voltage phase 5 (PowerOutput)
eDriveKey_U6_in_fund_RMS | 325 | 325 FundamentalRMS of Input Voltage phase 6 (PowerOutput)
eDriveKey_I_FundamentalRMS_in | 105 | Obsolete. 105 FundamentalRMS of Input Current (1 phase) (PowerOutput)
eDriveKey_I_in_fund_RMS | 105 | 105 FundamentalRMS of Input Current (1 phase) (PowerOutput)
eDriveKey_I1_FundamentalRMS_in | 106 | Obsolete. 106 FundamentalRMS of Input Current phase 1 (PowerOutput)
eDriveKey_I1_in_fund_RMS | 106 | 106 FundamentalRMS of Input Current phase 1 (PowerOutput)
eDriveKey_I123_in_fund_RMS | 326 | 326 FundamentalRMS of Input Current phase 1, 2 and 3 (PowerOutput)
eDriveKey_I456_in_fund_RMS | 327 | 327 FundamentalRMS of Input Current phase 4, 5 and 6 (PowerOutput)
eDriveKey_I2_FundamentalRMS_in | 107 | Obsolete. 107 FundamentalRMS of Input Current phase 2 (PowerOutput)
eDriveKey_I2_in_fund_RMS | 107 | 107 FundamentalRMS of Input Current phase 2 (PowerOutput)
eDriveKey_I3_FundamentalRMS_in | 108 | Obsolete. 108 FundamentalRMS of Input Current phase 3 (PowerOutput)
eDriveKey_I3_in_fund_RMS | 108 | 108 FundamentalRMS of Input Current phase 3 (PowerOutput)
eDriveKey_I4_in_fund_RMS | 328 | 328 FundamentalRMS of Input Current phase 4 (PowerOutput)
eDriveKey_I5_in_fund_RMS | 329 | 329 FundamentalRMS of Input Current phase 5 (PowerOutput)
eDriveKey_I6_in_fund_RMS | 330 | 330 FundamentalRMS of Input Current phase 6 (PowerOutput)
eDriveKey_P_in_fund | 211 | Obsolete. 211 Total Fundamental TRUE power (PowerOutput)
eDriveKey_P1_in_fund | 212 | Obsolete. 212 Fundamental TRUE power phase 1 (PowerOutput)
eDriveKey_P2_in_fund | 213 | Obsolete. 213 Fundamental TRUE power phase 2 (PowerOutput)
eDriveKey_P3_in_fund | 214 | Obsolete. 214 Fundamental TRUE power phase 3 (PowerOutput)
eDriveKey_CosPHI_fund_in | 227 | 227 Cos PHI of the fundamental of phase (1 phase) (PowerOutput)
eDriveKey_CosPHI_fund_1_in | 228 | 228 Cos PHI of the fundamental of phase 1 (PowerOutput)
eDriveKey_CosPHI_fund_2_in | 229 | 229 Cos PHI of the fundamental of phase 2 (PowerOutput)
eDriveKey_CosPHI_fund_3_in | 230 | 230 Cos PHI of the fundamental of phase 3 (PowerOutput)
eDriveKey_CosPHI_fund_4_in | 331 | 331 Cos PHI of the fundamental of phase 4 (PowerOutput)
eDriveKey_CosPHI_fund_5_in | 332 | 332 Cos PHI of the fundamental of phase 5 (PowerOutput)
eDriveKey_CosPHI_fund_6_in | 333 | 333 Cos PHI of the fundamental of phase 6 (PowerOutput)
eDriveKey_PHI_fund_in | 245 | 245 PHI of the fundamental of phase (1 phase) (PowerOutput)
eDriveKey_PHI_fund_1_in | 246 | 246 PHI of the fundamental of phase 1 (PowerOutput)
eDriveKey_PHI_fund_2_in | 247 | 247 PHI of the fundamental of phase 2 (PowerOutput)
eDriveKey_PHI_fund_3_in | 248 | 248 PHI of the fundamental of phase 3 (PowerOutput)
eDriveKey_PHI_fund_4_in | 334 | 334 PHI of the fundamental of phase 4 (PowerOutput)
eDriveKey_PHI_fund_5_in | 335 | 335 PHI of the fundamental of phase 5 (PowerOutput)
eDriveKey_PHI_fund_6_in | 336 | 336 PHI of the fundamental of phase 6 (PowerOutput)
eDriveKey_CycleCount | 7 | 7 Number of cycles detected in input signal (InverterOutput)
eDriveKey_CycleFrequency | 8 | 8 Cycles per second detected in input signal (InverterOutput)
eDriveKey_Start | 9 | 9 Time of first sample used in calculations (InverterOutput)
eDriveKey_End | 10 | 10 Time of last sample used in calculations (InverterOutput)
eDriveKey_U | 32 | 32 Collective voltage (InverterOutput)
eDriveKey_U_123 | 337 | 337 Collective voltage phase 1, 2 and 3 (InverterOutput)
eDriveKey_U_456 | 338 | 338 Collective voltage phase 4, 5 and 6 (InverterOutput)
eDriveKey_U1 | 33 | 33 RMS voltage phase 1 (InverterOutput)
eDriveKey_U2 | 34 | 34 RMS voltage phase 2 (InverterOutput)
eDriveKey_U3 | 35 | 35 RMS voltage phase 3 (InverterOutput)
eDriveKey_U4 | 339 | 339 RMS voltage phase 4 (InverterOutput)
eDriveKey_U5 | 340 | 340 RMS voltage phase 5 (InverterOutput)
eDriveKey_U6 | 341 | 341 RMS voltage phase 6 (InverterOutput)
eDriveKey_U1_2 | 276 | 276 RMS voltage 1_2 (InverterOutput)
eDriveKey_U2_3 | 277 | 277 RMS voltage 2_3 (InverterOutput)
eDriveKey_U3_1 | 278 | 278 RMS voltage 3_1 (InverterOutput)
eDriveKey_U4_5 | 342 | 342 RMS voltage 4_5 (InverterOutput)
eDriveKey_U5_6 | 343 | 343 RMS voltage 5_6 (InverterOutput)
eDriveKey_U6_4 | 344 | 344 RMS voltage 6_4 (InverterOutput)
eDriveKey_I | 36 | 36 Collective current (InverterOutput)
eDriveKey_I1 | 37 | 37 RMS current phase 1 (InverterOutput)
eDriveKey_I123 | 345 | 345 RMS current phase 1, 2 and 3 (InverterOutput)
eDriveKey_I456 | 346 | 346 RMS current phase 4, 5 and 6 (InverterOutput)
eDriveKey_I2 | 38 | 38 RMS current phase 2 (InverterOutput)
eDriveKey_I3 | 39 | 39 RMS current phase 3 (InverterOutput)
eDriveKey_I4 | 347 | 347 RMS current phase 4 (InverterOutput)
eDriveKey_I5 | 348 | 348 RMS current phase 5 (InverterOutput)
eDriveKey_I6 | 349 | 349 RMS current phase 6 (InverterOutput)
eDriveKey_P | 40 | 40 Total active power (InverterOutput)
eDriveKey_P123 | 350 | 350 Active power phase 1, 2 and 3 (InverterOutput)
eDriveKey_P456 | 351 | 351 Active power phase 4, 5 and 6 (InverterOutput)
eDriveKey_P1 | 41 | 41 Active power phase 1 (InverterOutput)
eDriveKey_P2 | 42 | 42 Active power phase 2 (InverterOutput)
eDriveKey_P3 | 43 | 43 Active power phase 3 (InverterOutput)
eDriveKey_P4 | 352 | 352 Active power phase 4 (InverterOutput)
eDriveKey_P5 | 353 | 353 Active power phase 5 (InverterOutput)
eDriveKey_P6 | 354 | 354 Active power phase 6 (InverterOutput)
eDriveKey_Q | 44 | 44 Total reactive power (InverterOutput)
eDriveKey_Q1 | 45 | 45 Reactive power phase 1 (InverterOutput)
eDriveKey_Q123 | 360 | 360 Reactive power phase 1, 2 and 3 (InverterOutput)
eDriveKey_Q456 | 361 | 361 Reactive power phase 4, 5 and 6 (InverterOutput)
eDriveKey_Q2 | 46 | 46 Reactive power phase 2 (InverterOutput)
eDriveKey_Q3 | 47 | 47 Reactive power phase 3 (InverterOutput)
eDriveKey_Q4 | 362 | 362 Reactive power phase 4 (InverterOutput)
eDriveKey_Q5 | 363 | 363 Reactive power phase 5 (InverterOutput)
eDriveKey_Q6 | 364 | 364 Reactive power phase 6 (InverterOutput)
eDriveKey_S | 48 | 48 Total apparent power (InverterOutput)
eDriveKey_S1 | 49 | 49 Apparent power phase 1 (InverterOutput)
eDriveKey_S123 | 355 | 355 Apparent power phase 1, 2 and 3 (InverterOutput)
eDriveKey_S456 | 356 | 356 Apparent power phase 4, 5 and 6 (InverterOutput)
eDriveKey_S2 | 50 | 50 Apparent power phase 2 (InverterOutput)
eDriveKey_S3 | 51 | 51 Apparent power phase 3 (InverterOutput)
eDriveKey_S4 | 357 | 357 Apparent power phase 4 (InverterOutput)
eDriveKey_S5 | 358 | 358 Apparent power phase 5 (InverterOutput)
eDriveKey_S6 | 359 | 359 Apparent power phase 6 (InverterOutput)
eDriveKey_Lambda | 52 | 52 Power factor (InverterOutput)
eDriveKey_Lambda1 | 264 | 264 Power factor phase 1 (InverterOutput)
eDriveKey_Lambda123 | 365 | 365 Power factor phase 1, 2 and 3 (InverterOutput)
eDriveKey_Lambda456 | 366 | 366 Power factor phase 4, 5 and 6 (InverterOutput)
eDriveKey_Lambda2 | 265 | 265 Power factor phase 2 (InverterOutput)
eDriveKey_Lambda3 | 266 | 266 Power factor phase 3 (InverterOutput)
eDriveKey_Lambda4 | 367 | 367 Power factor phase 4 (InverterOutput)
eDriveKey_Lambda5 | 368 | 368 Power factor phase 5 (InverterOutput)
eDriveKey_Lambda6 | 369 | 369 Power factor phase 6 (InverterOutput)
eDriveKey_THD_U | 85 | Obsolete. 85 THD of Inverter Output Voltage (1 phase) (InverterOutput)
eDriveKey_U_THD | 85 | Obsolete. 85 THD of Inverter Output Voltage (1 phase) (InverterOutput)
eDriveKey_THD_U1 | 86 | Obsolete. 86 THD of Inverter Output Voltage phase 1 (InverterOutput)
eDriveKey_U1_THD | 86 | Obsolete. 86 THD of Inverter Output Voltage phase 1 (InverterOutput)
eDriveKey_THD_U2 | 87 | Obsolete. 87 THD of Inverter Output Voltage phase 2 (InverterOutput)
eDriveKey_U2_THD | 87 | Obsolete. 87 THD of Inverter Output Voltage phase 2 (InverterOutput)
eDriveKey_THD_U3 | 88 | Obsolete. 88 THD of Inverter Output Voltage phase 3 (InverterOutput)
eDriveKey_U3_THD | 88 | Obsolete. 88 THD of Inverter Output Voltage phase 3 (InverterOutput)
eDriveKey_THD_I | 93 | Obsolete. 93 THD of Inverter Output Current (1 phase) (InverterOutput)
eDriveKey_I_THD | 93 | Obsolete. 93 THD of Inverter Output Current (1 phase) (InverterOutput)
eDriveKey_THD_I1 | 94 | Obsolete. 94 THD of Inverter Output Current phase 1 (InverterOutput)
eDriveKey_I1_THD | 94 | Obsolete. 94 THD of Inverter Output Current phase 1 (InverterOutput)
eDriveKey_THD_I2 | 95 | Obsolete. 95 THD of Inverter Output Current phase 2 (InverterOutput)
eDriveKey_I2_THD | 95 | Obsolete. 95 THD of Inverter Output Current phase 2 (InverterOutput)
eDriveKey_THD_I3 | 96 | Obsolete. 96 THD of Inverter Output Current phase 3 (InverterOutput)
eDriveKey_I3_THD | 96 | Obsolete. 96 THD of Inverter Output Current phase 3 (InverterOutput)
eDriveKey_FundamentalRMS_U | 101 | Obsolete. 101 FundamentalRMS of Inverter Output Voltage (1 phase) (InverterOutput)
eDriveKey_U_fund_RMS | 101 | 101 FundamentalRMS of Inverter Output Voltage (1 phase) (InverterOutput)
eDriveKey_FundamentalRMS_U1 | 102 | Obsolete. 102 FundamentalRMS of Inverter Output Voltage phase 1 (InverterOutput)
eDriveKey_U1_fund_RMS | 102 | 102 FundamentalRMS of Inverter Output Voltage phase 1 (InverterOutput)
eDriveKey_U123_fund_RMS | 370 | 370 FundamentalRMS of Inverter Output Voltage phase 1, 2 and 3 (InverterOutput)
eDriveKey_U456_fund_RMS | 371 | 371 FundamentalRMS of Inverter Output Voltage phase 4, 5 and 6 (InverterOutput)
eDriveKey_FundamentalRMS_U2 | 103 | Obsolete. 103 FundamentalRMS of Inverter Output Voltage phase 2 (InverterOutput)
eDriveKey_U2_fund_RMS | 103 | 103 FundamentalRMS of Inverter Output Voltage phase 2 (InverterOutput)
eDriveKey_FundamentalRMS_U3 | 104 | Obsolete. 104 FundamentalRMS of Inverter Output Voltage phase 3 (InverterOutput)
eDriveKey_U3_fund_RMS | 104 | 104 FundamentalRMS of Inverter Output Voltage phase 3 (InverterOutput)
eDriveKey_U4_fund_RMS | 372 | 372 FundamentalRMS of Inverter Output Voltage phase 4 (InverterOutput)
eDriveKey_U5_fund_RMS | 373 | 373 FundamentalRMS of Inverter Output Voltage phase 5 (InverterOutput)
eDriveKey_U6_fund_RMS | 374 | 374 FundamentalRMS of Inverter Output Voltage phase 6 (InverterOutput)
eDriveKey_FundamentalRMS_I | 109 | Obsolete. 109 FundamentalRMS of Inverter Output Current (1 phase) (InverterOutput)
eDriveKey_I_fund_RMS | 109 | 109 FundamentalRMS of Inverter Output Current (1 phase) (InverterOutput)
eDriveKey_FundamentalRMS_I1 | 110 | Obsolete. 110 FundamentalRMS of Inverter Output Current phase 1 (InverterOutput)
eDriveKey_I123_fund_RMS | 375 | 375 FundamentalRMS of Inverter Output Current phase 1, 2 and 3 (InverterOutput)
eDriveKey_I456_fund_RMS | 376 | 376 FundamentalRMS of Inverter Output Current phase 4, 5 and 6 (InverterOutput)
eDriveKey_I1_fund_RMS | 110 | 110 FundamentalRMS of Inverter Output Current phase 1 (InverterOutput)
eDriveKey_FundamentalRMS_I2 | 111 | Obsolete. 111 FundamentalRMS of Inverter Output Current phase 2 (InverterOutput)
eDriveKey_I2_fund_RMS | 111 | 111 FundamentalRMS of Inverter Output Current phase 2 (InverterOutput)
eDriveKey_FundamentalRMS_I3 | 112 | Obsolete. 112 FundamentalRMS of Inverter Output Current phase 3 (InverterOutput)
eDriveKey_I3_fund_RMS | 112 | 112 FundamentalRMS of Inverter Output Current phase 3 (InverterOutput)
eDriveKey_I4_fund_RMS | 377 | 377 FundamentalRMS of Inverter Output Current phase 4 (InverterOutput)
eDriveKey_I5_fund_RMS | 378 | 378 FundamentalRMS of Inverter Output Current phase 5 (InverterOutput)
eDriveKey_I6_fund_RMS | 379 | 379 FundamentalRMS of Inverter Output Current phase 6 (InverterOutput)
eDriveKey_P_fund | 215 | 215 Total Fundamental TRUE power (InverterOutput)
eDriveKey_P1_fund | 216 | 216 Fundamental TRUE power phase 1 (InverterOutput)
eDriveKey_P2_fund | 217 | 217 Fundamental TRUE power phase 2 (InverterOutput)
eDriveKey_P3_fund | 218 | 218 Fundamental TRUE power phase 3 (InverterOutput)
eDriveKey_CosPHI_fund | 231 | 231 Cos PHI of the fundamental of Inverter Output phase (1 phase) (InverterOutput)
eDriveKey_CosPHI_fund_1 | 232 | 232 Cos PHI of the fundamental of Inverter Output phase 1 (InverterOutput)
eDriveKey_CosPHI_fund_2 | 233 | 233 Cos PHI of the fundamental of Inverter Output phase 2 (InverterOutput)
eDriveKey_CosPHI_fund_3 | 234 | 234 Cos PHI of the fundamental of Inverter Output phase 3 (InverterOutput)
eDriveKey_CosPHI_fund_4 | 380 | 380 Cos PHI of the fundamental of Inverter Output phase 4 (InverterOutput)
eDriveKey_CosPHI_fund_5 | 381 | 381 Cos PHI of the fundamental of Inverter Output phase 5 (InverterOutput)
eDriveKey_CosPHI_fund_6 | 382 | 382 Cos PHI of the fundamental of Inverter Output phase 6 (InverterOutput)
eDriveKey_PHI_fund | 249 | Obsolete. 249 PHI of the fundamental of Inverter Output phase (1 phase) (InverterOutput)
eDriveKey_PHI_fund_1 | 250 | 250 PHI of the fundamental of Inverter Output phase 1 (InverterOutput)
eDriveKey_PHI_fund_2 | 251 | 251 PHI of the fundamental of Inverter Output phase 2 (InverterOutput)
eDriveKey_PHI_fund_3 | 252 | 252 PHI of the fundamental of Inverter Output phase 3 (InverterOutput)
eDriveKey_PHI_fund_4 | 383 | 383 PHI of the fundamental of Inverter Output phase 4 (InverterOutput)
eDriveKey_PHI_fund_5 | 384 | 384 PHI of the fundamental of Inverter Output phase 5 (InverterOutput)
eDriveKey_PHI_fund_6 | 385 | 385 PHI of the fundamental of Inverter Output phase 6 (InverterOutput)
eDriveKey_CycleFrequency_mech | 285 | 285 Cycles per second detected in input signal (Mechanical)
eDriveKey_Start_mech | 286 | 286 Time of first sample used in calculations (Mechanical)
eDriveKey_End_mech | 287 | 287 Time of last sample used in calculations (Mechanical)
eDriveKey_M | 63 | 63 Torque (Mechanical, in ShaftOnly mode)
eDriveKey_M_motor | 64 | 64 Motor torque (Mechanical, in Transmission mode)
eDriveKey_M_mech | 65 | 65 Mechanical torque (Mechanical, in Transmission mode)
eDriveKey_n | 66 | 66 RPM (Mechanical, in ShaftOnly mode)
eDriveKey_n_motor | 67 | 67 Motor RPM (Mechanical, in Transmission mode)
eDriveKey_n_mech | 68 | 68 Transmission output RPM (Mechanical, in Transmission mode)
eDriveKey_M_A | 69 | 69 Torque A (Mechanical, in Diff.Lock mode)
eDriveKey_M_B | 70 | 70 Torque B (Mechanical, in Diff.Lock mode)
eDriveKey_P_motor | 71 | 71 Motor output power (Mechanical, in Transmission mode)
eDriveKey_P_mech | 72 | 72 Total mechanical output power (Mechanical)
eDriveKey_P_mech_A | 73 | 73 Mechanical output power A (Mechanical, in Diff.Lock mode)
eDriveKey_P_mech_B | 74 | 74 Mechanical output power B (Mechanical, in Diff.Lock mode)
eDriveKey_n_A | 75 | 75 RPM A (Mechanical, in Diff.Lock mode)
eDriveKey_n_B | 76 | 76 RPM B (Mechanical, in Diff.Lock mode)
eDriveKey_M_diff | 77 | 77 Differential Torque (Mechanical, in Diff.Lock mode)
eDriveKey_n_diff | 78 | 78 Differential speed (Mechanical, in Diff.Lock mode)
eDriveKey_M_AB | 79 | 79 Drive Torque (Mechanical, in Diff.Lock mode)
eDriveKey_n_AB | 80 | 80 Output speed (Mechanical, in Diff.Lock mode)
eDriveKey_Efficiency_Inv | 53 | 53 Inverter efficiency (Analysis)
eDriveKey_Efficiency_Inv_Gen | 113 | 113 Inverter efficiency as Generator (Analysis)
eDriveKey_Efficiency_Inv_123 | 386 | 386 Inverter efficiency Phase 1, 2 and 3 (Analysis)
eDriveKey_Efficiency_Inv_456 | 387 | 387 Inverter efficiency Phase 4, 5 and 6 (Analysis)
eDriveKey_Efficiency_Inv_123_Gen | 388 | 388 Inverter efficiency as Generator Phase 1, 2 and 3 (Analysis)
eDriveKey_Efficiency_Inv_456_Gen | 389 | 389 Inverter efficiency as Generator Phase 4, 5 and 6 (Analysis)
eDriveKey_Efficiency_Motor | 54 | 54 Motor efficiency (Mechanical, in Transmission mode)
eDriveKey_Efficiency_Motor_Gen | 114 | 114 Motor efficiency as Generator (Mechanical, in Transmission mode)
eDriveKey_Efficiency_Mech | 55 | 55 Mechanical efficiency (Analysis)
eDriveKey_Efficiency_Mech_Gen | 115 | 115 Mechanical efficiency as Generator (Analysis)
eDriveKey_Efficiency_Trans | 56 | 56 Transmission efficiency (Mechanical, in Transmission mode)
eDriveKey_Efficiency_Trans_Gen | 116 | 116 Transmission efficiency as Generator (Mechanical, in Transmission mode)
eDriveKey_Efficiency_Total | 57 | 57 Total efficiency (Analysis)
eDriveKey_Efficiency_Total_Gen | 117 | 117 Total efficiency as Generator (Analysis)
eDriveKey_PowerLoss_Inv | 58 | 58 Inverter power loss (Analysis)
eDriveKey_PowerLoss_123_Inv | 390 | 390 Inverter power loss Phase 1, 2 and 3 (Analysis)
eDriveKey_PowerLoss_456_Inv | 391 | 391 Inverter power loss Phase 4, 5 and 6 (Analysis)
eDriveKey_PowerLoss_Motor | 59 | 59 Power loss Motor (Mechanical, in Transmission mode)
eDriveKey_PowerLoss_Mech | 60 | 60 Mechanical power loss (Analysis)
eDriveKey_PowerLoss_Trans | 61 | 61 Power loss transmission (Mechanical, in Transmission mode)
eDriveKey_PowerLoss_Total | 62 | 62 Total power loss (Analysis)
eDriveKey_CycleCount_dr | 7 | 7 Number of cycles detected in input signal (DriveInverterOutput)
eDriveKey_CycleFrequency_dr | 8 | 8 Cycles per second detected in input signal (DriveInverterOutput)
eDriveKey_Start_dr | 9 | 9 Time of first sample used in calculations (DriveInverterOutput)
eDriveKey_End_dr | 10 | 10 Time of last sample used in calculations (DriveInverterOutput)
eDriveKey_U_dr | 32 | 32 Collective voltage (DriveInverterOutput)
eDriveKey_U1_dr | 33 | 33 RMS voltage phase 1 (DriveInverterOutput)
eDriveKey_U2_dr | 34 | 34 RMS voltage phase 2 (DriveInverterOutput)
eDriveKey_U3_dr | 35 | 35 RMS voltage phase 3 (DriveInverterOutput)
eDriveKey_U1_2_dr | 276 | 276 RMS voltage 1_2 (DriveInverterOutput)
eDriveKey_U2_3_dr | 277 | 277 RMS voltage 2_3 (DriveInverterOutput)
eDriveKey_U3_1_dr | 278 | 278 RMS voltage 3_1 (DriveInverterOutput)
eDriveKey_I_dr | 36 | 36 Collective current (DriveInverterOutput)
eDriveKey_I1_dr | 37 | 37 RMS current phase 1 (DriveInverterOutput)
eDriveKey_I2_dr | 38 | 38 RMS current phase 2 (DriveInverterOutput)
eDriveKey_I3_dr | 39 | 39 RMS current phase 3 (DriveInverterOutput)
eDriveKey_P_dr | 40 | 40 Total active power (DriveInverterOutput)
eDriveKey_P1_dr | 41 | 41 Active power phase 1 (DriveInverterOutput)
eDriveKey_P2_dr | 42 | 42 Active power phase 2 (DriveInverterOutput)
eDriveKey_P3_dr | 43 | 43 Active power phase 3 (DriveInverterOutput)
eDriveKey_Q_dr | 44 | 44 Total reactive power (DriveInverterOutput)
eDriveKey_Q1_dr | 45 | 45 Reactive power phase 1 (DriveInverterOutput)
eDriveKey_Q2_dr | 46 | 46 Reactive power phase 2 (DriveInverterOutput)
eDriveKey_Q3_dr | 47 | 47 Reactive power phase 3 (DriveInverterOutput)
eDriveKey_S_dr | 48 | 48 Total apparent power (DriveInverterOutput)
eDriveKey_S1_dr | 49 | 49 Apparent power phase 1 (DriveInverterOutput)
eDriveKey_S2_dr | 50 | 50 Apparent power phase 2 (DriveInverterOutput)
eDriveKey_S3_dr | 51 | 51 Apparent power phase 3 (DriveInverterOutput)
eDriveKey_Lambda_dr | 52 | 52 Power factor (DriveInverterOutput)
eDriveKey_Lambda1_dr | 264 | 264 Power factor phase 1 (DriveInverterOutput)
eDriveKey_Lambda2_dr | 265 | 265 Power factor phase 2 (DriveInverterOutput)
eDriveKey_Lambda3_dr | 266 | 266 Power factor phase 3 (DriveInverterOutput)
eDriveKey_U_THD_dr | 85 | Obsolete. 85 THD of Drive Inverter Output Voltage (1 phase) (DriveInverterOutput)
eDriveKey_U1_THD_dr | 86 | Obsolete. 86 THD of Drive Inverter Output Voltage phase 1 (DriveInverterOutput)
eDriveKey_U2_THD_dr | 87 | Obsolete. 87 THD of Drive Inverter Output Voltage phase 2 (DriveInverterOutput)
eDriveKey_U3_THD_dr | 88 | Obsolete. 88 THD of Drive Inverter Output Voltage phase 3 (DriveInverterOutput)
eDriveKey_I_THD_dr | 93 | Obsolete. 93 THD of Drive Inverter Output Current (1 phase) (DriveInverterOutput)
eDriveKey_I1_THD_dr | 94 | Obsolete. 94 THD of Drive Inverter Output Current phase 1 (DriveInverterOutput)
eDriveKey_I2_THD_dr | 95 | Obsolete. 95 THD of Drive Inverter Output Current phase 2 (DriveInverterOutput)
eDriveKey_I3_THD_dr | 96 | Obsolete. 96 THD of Drive Inverter Output Current phase 3 (DriveInverterOutput)
eDriveKey_U_fund_dr_RMS | 101 | 101 FundamentalRMS of Drive Inverter Output Voltage (1 phase) (DriveInverterOutput)
eDriveKey_U1_fund_dr_RMS | 102 | 102 FundamentalRMS of Drive Inverter Output Voltage phase 1 (DriveInverterOutput)
eDriveKey_U2_fund_dr_RMS | 103 | 103 FundamentalRMS of Drive Inverter Output Voltage phase 2 (DriveInverterOutput)
eDriveKey_U3_fund_dr_RMS | 104 | 104 FundamentalRMS of Drive Inverter Output Voltage phase 3 (DriveInverterOutput)
eDriveKey_I_fund_dr_RMS | 109 | 109 FundamentalRMS of Drive Inverter Output Current (1 phase) (DriveInverterOutput)
eDriveKey_I1_fund_dr_RMS | 110 | 110 FundamentalRMS of Drive Inverter Output Current phase 1 (DriveInverterOutput)
eDriveKey_I2_fund_dr_RMS | 111 | 111 FundamentalRMS of Drive Inverter Output Current phase 2 (DriveInverterOutput)
eDriveKey_I3_fund_dr_RMS | 112 | 112 FundamentalRMS of Drive Inverter Output Current phase 3 (DriveInverterOutput)
eDriveKey_P_fund_dr | 215 | Obsolete. 215 Total Fundamental TRUE power (DriveInverterOutput)
eDriveKey_P1_fund_dr | 216 | Obsolete. 216 Fundamental TRUE power phase 1 (DriveInverterOutput)
eDriveKey_P2_fund_dr | 217 | Obsolete. 217 Fundamental TRUE power phase 2 (DriveInverterOutput)
eDriveKey_P3_fund_dr | 218 | Obsolete. 218 Fundamental TRUE power phase 3 (DriveInverterOutput)
eDriveKey_CosPHI_fund_dr | 231 | Obsolete. 231 Cos PHI of the fundamental of Drive Inverter Output phase (1 phase) (DriveInverterOutput)
eDriveKey_CosPHI_fund_1_dr | 232 | 232 Cos PHI of the fundamental of Drive Inverter Output phase 1 (DriveInverterOutput)
eDriveKey_CosPHI_fund_2_dr | 233 | 233 Cos PHI of the fundamental of Drive Inverter Output phase 2 (DriveInverterOutput)
eDriveKey_CosPHI_fund_3_dr | 234 | 234 Cos PHI of the fundamental of Drive Inverter Output phase 3 (DriveInverterOutput)
eDriveKey_PHI_fund_dr | 249 | Obsolete. 249 PHI of the fundamental of Drive Inverter Output phase (1 phase) (DriveInverterOutput)
eDriveKey_PHI_fund_1_dr | 250 | 250 PHI of the fundamental of Drive Inverter Output phase 1 (DriveInverterOutput)
eDriveKey_PHI_fund_2_dr | 251 | 251 PHI of the fundamental of Drive Inverter Output phase 2 (DriveInverterOutput)
eDriveKey_PHI_fund_3_dr | 252 | 252 PHI of the fundamental of Drive Inverter Output phase 3 (DriveInverterOutput)
eDriveKey_CycleCount_gr | 7 | 7 Number of cycles detected in input signal (Grid)
eDriveKey_CycleFrequency_gr | 8 | 8 Cycles per second detected in input signal (Grid)
eDriveKey_Start_gr | 9 | 9 Time of first sample used in calculations (Grid)
eDriveKey_End_gr | 10 | 10 Time of last sample used in calculations (Grid)
eDriveKey_U_gr | 32 | 32 Collective voltage (Grid)
eDriveKey_U1_gr | 33 | 33 RMS voltage phase 1 (Grid)
eDriveKey_U2_gr | 34 | 34 RMS voltage phase 2 (Grid)
eDriveKey_U3_gr | 35 | 35 RMS voltage phase 3 (Grid)
eDriveKey_U1_2_gr | 276 | 276 RMS voltage 1_2 (Grid)
eDriveKey_U2_3_gr | 277 | 277 RMS voltage 2_3 (Grid)
eDriveKey_U3_1_gr | 278 | 278 RMS voltage 3_1 (Grid)
eDriveKey_I_gr | 36 | 36 Collective current (Grid)
eDriveKey_I1_gr | 37 | 37 RMS current phase 1 (Grid)
eDriveKey_I2_gr | 38 | 38 RMS current phase 2 (Grid)
eDriveKey_I3_gr | 39 | 39 RMS current phase 3 (Grid)
eDriveKey_P_gr | 40 | 40 Total active power (Grid)
eDriveKey_P1_gr | 41 | 41 Active power phase 1 (Grid)
eDriveKey_P2_gr | 42 | 42 Active power phase 2 (Grid)
eDriveKey_P3_gr | 43 | 43 Active power phase 3 (Grid)
eDriveKey_Q_gr | 44 | 44 Total reactive power (Grid)
eDriveKey_Q1_gr | 45 | 45 Reactive power phase 1 (Grid)
eDriveKey_Q2_gr | 46 | 46 Reactive power phase 2 (Grid)
eDriveKey_Q3_gr | 47 | 47 Reactive power phase 3 (Grid)
eDriveKey_S_gr | 48 | 48 Total apparent power (Grid)
eDriveKey_S1_gr | 49 | 49 Apparent power phase 1 (Grid)
eDriveKey_S2_gr | 50 | 50 Apparent power phase 2 (Grid)
eDriveKey_S3_gr | 51 | 51 Apparent power phase 3 (Grid)
eDriveKey_Lambda_gr | 52 | 52 Power factor (Grid)
eDriveKey_Lambda1_gr | 264 | 264 Power factor phase 1 (Grid)
eDriveKey_Lambda2_gr | 265 | 265 Power factor phase 2 (Grid)
eDriveKey_Lambda3_gr | 266 | 266 Power factor phase 3 (Grid)
eDriveKey_U_fund_gr_RMS | 101 | 101 FundamentalRMS of Grid Voltage (1 phase) (Grid)
eDriveKey_U1_fund_gr_RMS | 102 | 102 FundamentalRMS of Grid Voltage phase 1 (Grid)
eDriveKey_U2_fund_gr_RMS | 103 | 103 FundamentalRMS of Grid Voltage phase 2 (Grid)
eDriveKey_U3_fund_gr_RMS | 104 | 104 FundamentalRMS of Grid Voltage phase 3 (Grid)
eDriveKey_I_fund_gr_RMS | 109 | 109 FundamentalRMS of Grid Current (1 phase) (Grid)
eDriveKey_I1_fund_gr_RMS | 110 | 110 FundamentalRMS of Grid Current phase 1 (Grid)
eDriveKey_I2_fund_gr_RMS | 111 | 111 FundamentalRMS of Grid Current phase 2 (Grid)
eDriveKey_I3_fund_gr_RMS | 112 | 112 FundamentalRMS of Grid Current phase 3 (Grid)
eDriveKey_CosPHI_fund_1_gr | 232 | 232 Cos PHI of the fundamental of Grid phase 1 (Grid)
eDriveKey_CosPHI_fund_2_gr | 233 | 233 Cos PHI of the fundamental of Grid phase 2 (Grid)
eDriveKey_CosPHI_fund_3_gr | 234 | 234 Cos PHI of the fundamental of Grid phase 3 (Grid)
eDriveKey_PHI_fund_1_gr | 250 | 250 PHI of the fundamental of Grid phase 1 (Grid)
eDriveKey_PHI_fund_2_gr | 251 | 251 PHI of the fundamental of Grid phase 2 (Grid)
eDriveKey_PHI_fund_3_gr | 252 | 252 PHI of the fundamental of Grid phase 3 (Grid)
eDriveKey_CycleCount_br | 118 | 118 Number of cycles detected in input signal (BrakeInverterInput)
eDriveKey_CycleFrequency_br | 119 | 119 Cycles per second detected in input signal (BrakeInverterInput)
eDriveKey_Start_br | 120 | 120 Time of first sample used in calculations (BrakeInverterInput)
eDriveKey_End_br | 121 | 121 Time of last sample used in calculations (BrakeInverterInput)
eDriveKey_U_br | 122 | 122 Collective voltage (BrakeInverterInput)
eDriveKey_U1_br | 123 | 123 RMS voltage phase 1 (BrakeInverterInput)
eDriveKey_U2_br | 124 | 124 RMS voltage phase 2 (BrakeInverterInput)
eDriveKey_U3_br | 125 | 125 RMS voltage phase 3 (BrakeInverterInput)
eDriveKey_I_br | 126 | 126 Collective current (BrakeInverterInput)
eDriveKey_I1_br | 127 | 127 RMS current phase 1 (BrakeInverterInput)
eDriveKey_I2_br | 128 | 128 RMS current phase 2 (BrakeInverterInput)
eDriveKey_I3_br | 129 | 129 RMS current phase 3 (BrakeInverterInput)
eDriveKey_P_br | 130 | 130 Total active power (BrakeInverterInput)
eDriveKey_P1_br | 131 | 131 Active power phase 1 (BrakeInverterInput)
eDriveKey_P2_br | 132 | 132 Active power phase 2 (BrakeInverterInput)
eDriveKey_P3_br | 133 | 133 Active power phase 3 (BrakeInverterInput)
eDriveKey_Q_br | 134 | 134 Total reactive power (BrakeInverterInput)
eDriveKey_Q1_br | 135 | 135 Reactive power phase 1 (BrakeInverterInput)
eDriveKey_Q2_br | 136 | 136 Reactive power phase 2 (BrakeInverterInput)
eDriveKey_Q3_br | 137 | 137 Reactive power phase 3 (BrakeInverterInput)
eDriveKey_S_br | 138 | 138 Total apparent power (BrakeInverterInput)
eDriveKey_S1_br | 139 | 139 Apparent power phase 1 (BrakeInverterInput)
eDriveKey_S2_br | 140 | 140 Apparent power phase 2 (BrakeInverterInput)
eDriveKey_S3_br | 141 | 141 Apparent power phase 3 (BrakeInverterInput)
eDriveKey_Lambda_br | 142 | 142 Power factor (BrakeInverterInput)
eDriveKey_Lambda1_br | 267 | 267 Power factor phase 1 (BrakeInverterInput)
eDriveKey_Lambda2_br | 268 | 268 Power factor phase 2 (BrakeInverterInput)
eDriveKey_Lambda3_br | 269 | 269 Power factor phase 3 (BrakeInverterInput)
eDriveKey_U_THD_br | 143 | Obsolete. 143 THD of Brake Inverter Input Voltage (1 phase) (BrakeInverterInput)
eDriveKey_U1_THD_br | 144 | Obsolete. 144 THD of Brake Inverter Input Voltage phase 1 (BrakeInverterInput)
eDriveKey_U2_THD_br | 145 | Obsolete. 145 THD of Brake Inverter Input Voltage phase 2 (BrakeInverterInput)
eDriveKey_U3_THD_br | 146 | Obsolete. 146 THD of Brake Inverter Input Voltage phase 3 (BrakeInverterInput)
eDriveKey_I_THD_br | 147 | Obsolete. 147 THD of Brake Inverter Input Current (1 phase) (BrakeInverterInput)
eDriveKey_I1_THD_br | 148 | Obsolete. 148 THD of Brake Inverter Input Current phase 1 (BrakeInverterInput)
eDriveKey_I2_THD_br | 149 | Obsolete. 149 THD of Brake Inverter Input Current phase 2 (BrakeInverterInput)
eDriveKey_I3_THD_br | 150 | Obsolete. 150 THD of Brake Inverter Input Current phase 3 (BrakeInverterInput)
eDriveKey_U_fund_br_RMS | 151 | 151 FundamentalRMS of Brake Inverter Input Voltage (1 phase) (BrakeInverterInput)
eDriveKey_U1_fund_br_RMS | 152 | 152 FundamentalRMS of Brake Inverter Input Voltage phase 1 (BrakeInverterInput)
eDriveKey_U2_fund_br_RMS | 153 | 153 FundamentalRMS of Brake Inverter Input Voltage phase 2 (BrakeInverterInput)
eDriveKey_U3_fund_br_RMS | 154 | 154 FundamentalRMS of Brake Inverter Input Voltage phase 3 (BrakeInverterInput)
eDriveKey_I_fund_br_RMS | 155 | 155 FundamentalRMS of Brake Inverter Input Current (1 phase) (BrakeInverterInput)
eDriveKey_I1_fund_br_RMS | 156 | 156 FundamentalRMS of Brake Inverter Input Current phase 1 (BrakeInverterInput)
eDriveKey_I2_fund_br_RMS | 157 | 157 FundamentalRMS of Brake Inverter Input Current phase 2 (BrakeInverterInput)
eDriveKey_I3_fund_br_RMS | 158 | 158 FundamentalRMS of Brake Inverter Input Current phase 3 (BrakeInverterInput)
eDriveKey_P_fund_br | 219 | Obsolete. 219 Total Fundamental TRUE power (BrakeInverterInput)
eDriveKey_P1_fund_br | 220 | Obsolete. 220 Fundamental TRUE power phase 1 (BrakeInverterInput)
eDriveKey_P2_fund_br | 221 | Obsolete. 221 Fundamental TRUE power phase 2 (BrakeInverterInput)
eDriveKey_P3_fund_br | 222 | Obsolete. 222 Fundamental TRUE power phase 3 (BrakeInverterInput)
eDriveKey_CosPHI_fund_br | 235 | Obsolete. 235 Cos PHI of the fundamental of Brake Inverter Input phase (1 phase) (BrakeInverterInput)
eDriveKey_CosPHI_fund_1_br | 236 | 236 Cos PHI of the fundamental of Brake Inverter Input phase 1 (BrakeInverterInput)
eDriveKey_CosPHI_fund_2_br | 237 | 237 Cos PHI of the fundamental of Brake Inverter Input phase 2 (BrakeInverterInput)
eDriveKey_CosPHI_fund_3_br | 238 | 238 Cos PHI of the fundamental of Brake Inverter Input phase 3 (BrakeInverterInput)
eDriveKey_PHI_fund_br | 253 | Obsolete. 253 PHI of the fundamental of Brake Inverter Input phase (1 phase) (BrakeInverterInput)
eDriveKey_PHI_fund_1_br | 254 | 254 PHI of the fundamental of Brake Inverter Input phase 1 (BrakeInverterInput)
eDriveKey_PHI_fund_2_br | 255 | 255 PHI of the fundamental of Brake Inverter Input phase 2 (BrakeInverterInput)
eDriveKey_PHI_fund_3_br | 256 | 256 PHI of the fundamental of Brake Inverter Input phase 3 (BrakeInverterInput)
eDriveKey_CycleCount_out | 159 | 159 Number of cycles detected in input signal (PowerInput)
eDriveKey_CycleFrequency_out | 160 | 160 Cycles per second detected in input signal (PowerInput)
eDriveKey_Start_out | 161 | 161 Time of first sample used in calculations (PowerInput)
eDriveKey_End_out | 162 | 162 Time of last sample used in calculations (PowerInput)
eDriveKey_U_out | 163 | 163 Collective DC mean, or AC single phase voltage (PowerInput)
eDriveKey_U1_out | 164 | 164 RMS voltage phase 1 (PowerInput)
eDriveKey_U2_out | 165 | 165 RMS voltage phase 2 (PowerInput)
eDriveKey_U3_out | 166 | 166 RMS voltage phase 3 (PowerInput)
eDriveKey_I_out | 167 | 167 Collective, DC, or AC single phase current (PowerInput)
eDriveKey_I1_out | 168 | 168 RMS current phase 1 (PowerInput)
eDriveKey_I2_out | 169 | 169 RMS current phase 2 (PowerInput)
eDriveKey_I3_out | 170 | 170 RMS current phase 3 (PowerInput)
eDriveKey_P_out | 171 | 171 Total active power (PowerInput)
eDriveKey_P1_out | 172 | 172 Active power phase 1 (PowerInput)
eDriveKey_P2_out | 173 | 173 Active power phase 2 (PowerInput)
eDriveKey_P3_out | 174 | 174 Active power phase 3 (PowerInput)
eDriveKey_Q_out | 175 | 175 Total reactive power (PowerInput)
eDriveKey_Q1_out | 176 | 176 Reactive power phase 1 (PowerInput)
eDriveKey_Q2_out | 177 | 177 Reactive power phase 2 (PowerInput)
eDriveKey_Q3_out | 178 | 178 Reactive power phase 3 (PowerInput)
eDriveKey_S_out | 179 | 179 Total apparent power (PowerInput)
eDriveKey_S1_out | 180 | 180 Apparent power phase 1 (PowerInput)
eDriveKey_S2_out | 181 | 181 Apparent power phase 2 (PowerInput)
eDriveKey_S3_out | 182 | 182 Apparent power phase 3 (PowerInput)
eDriveKey_Lambda_out | 183 | 183 Power factor (PowerInput)
eDriveKey_Lambda1_out | 270 | 270 Power factor phase 1 (PowerInput)
eDriveKey_Lambda2_out | 271 | 271 Power factor phase 2 (PowerInput)
eDriveKey_Lambda3_out | 272 | 272 Power factor phase 3 (PowerInput)
eDriveKey_U_THD_out | 184 | Obsolete. 184 THD of Output Voltage (1 phase) (PowerInput)
eDriveKey_U1_THD_out | 185 | Obsolete. 185 THD of Output Voltage phase 1 (PowerInput)
eDriveKey_U2_THD_out | 186 | Obsolete. 186 THD of Output Voltage phase 2 (PowerInput)
eDriveKey_U3_THD_out | 187 | Obsolete. 187 THD of Output Voltage phase 3 (PowerInput)
eDriveKey_I_THD_out | 188 | Obsolete. 188 THD of Output Current (1 phase) (PowerInput)
eDriveKey_I1_THD_out | 189 | Obsolete. 189 THD of Output Current phase 1 (PowerInput)
eDriveKey_I2_THD_out | 190 | Obsolete. 190 THD of Output Current phase 2 (PowerInput)
eDriveKey_I3_THD_out | 191 | Obsolete. 191 THD of Output Current phase 3 (PowerInput)
eDriveKey_U_fund_out_RMS | 192 | 192 FundamentalRMS of Output Voltage (1 phase) (PowerInput)
eDriveKey_U1_fund_out_RMS | 193 | 193 FundamentalRMS of Output Voltage phase 1 (PowerInput)
eDriveKey_U2_fund_out_RMS | 194 | 194 FundamentalRMS of Output Voltage phase 2 (PowerInput)
eDriveKey_U3_fund_out_RMS | 195 | 195 FundamentalRMS of Output Voltage phase 3 (PowerInput)
eDriveKey_I_fund_out_RMS | 196 | 196 FundamentalRMS of Output Current (1 phase) (PowerInput)
eDriveKey_I1_fund_out_RMS | 197 | 197 FundamentalRMS of Output Current phase 1 (PowerInput)
eDriveKey_I2_fund_out_RMS | 198 | 198 FundamentalRMS of Output Current phase 2 (PowerInput)
eDriveKey_I3_fund_out_RMS | 199 | 199 FundamentalRMS of Output Current phase 3 (PowerInput)
eDriveKey_P_fund_out | 223 | Obsolete. 223 Total Fundamental TRUE power (PowerInput)
eDriveKey_P1_fund_out | 224 | Obsolete. 224 Fundamental TRUE power phase 1 (PowerInput)
eDriveKey_P2_fund_out | 225 | Obsolete. 225 Fundamental TRUE power phase 2 (PowerInput)
eDriveKey_P3_fund_out | 226 | Obsolete. 226 Fundamental TRUE power phase 3 (PowerInput)
eDriveKey_CosPHI_fund_out | 239 | 239 Cos PHI of the fundamental of Output phase (1 phase) (PowerInput)
eDriveKey_CosPHI_fund_1_out | 240 | 240 Cos PHI of the fundamental of Output phase 1 (PowerInput)
eDriveKey_CosPHI_fund_2_out | 241 | 241 Cos PHI of the fundamental of Output phase 2 (PowerInput)
eDriveKey_CosPHI_fund_3_out | 244 | 244 Cos PHI of the fundamental of Output phase 3 (PowerInput)
eDriveKey_PHI_fund_out | 257 | 257 PHI of the fundamental of Output phase (1 phase) (PowerInput)
eDriveKey_PHI_fund_1_out | 258 | 258 PHI of the fundamental of Output phase 1 (PowerInput)
eDriveKey_PHI_fund_2_out | 259 | 259 PHI of the fundamental of Output phase 2 (PowerInput)
eDriveKey_PHI_fund_3_out | 260 | 260 PHI of the fundamental of Output phase 3 (PowerInput)
eDriveKey_M_generator | 200 | 200 Generator torque (Mechanical)
eDriveKey_n_generator | 201 | 201 Generator RPM (Mechanical)
eDriveKey_Efficiency_Inv_dr | 53 | 53 Inverter efficiency (Analysis)
eDriveKey_Efficiency_Total_dr | 57 | 57 Total efficiency (Analysis)
eDriveKey_PowerLoss_Inv_dr | 58 | 58 Inverter power loss (Analysis)
eDriveKey_PowerLoss_Total_dr | 62 | 62 Total power loss (Analysis)
eDriveKey_Efficiency_Generator | 202 | 202 Generator efficiency (Mechanical)
eDriveKey_Efficiency_Inv_br | 203 | 203 Brake Inverter efficiency (Analysis)
eDriveKey_Efficiency_Total_br | 204 | 204 Total Brake efficiency (Analysis)
eDriveKey_PowerLoss_Generator | 205 | 205 Power loss Generator (Mechanical)
eDriveKey_PowerLoss_Inv_br | 206 | 206 Brake Inverter power loss (Analysis)
eDriveKey_PowerLoss_Total_br | 207 | 207 Total brake power loss (Analysis)
eDriveKey_Efficiency_Generator_Mot | 208 | 208 Generator efficiency as Motor (Mechanical)
eDriveKey_Efficiency_Inv_br_Mot | 209 | 209 Brake Inverter efficiency as Motor (Analysis)
eDriveKey_Efficiency_Total_br_Mot | 210 | 210 Total Brake efficiency as Motor (Analysis)
eDriveKey_U1_2_br | 279 | 279 RMS voltage 1_2 (BrakeInverterInput)
eDriveKey_U2_3_br | 280 | 280 RMS voltage 2_3 (BrakeInverterInput)
eDriveKey_U3_1_br | 281 | 281 RMS voltage 3_1 (BrakeInverterInput)
eDriveKey_U1_2_out | 282 | 282 RMS voltage 1_2 (PowerInput)
eDriveKey_U2_3_out | 283 | 283 RMS voltage 2_3 (PowerInput)
eDriveKey_U3_1_out | 284 | 284 RMS voltage 3_1 (PowerInput)
See Also

Reference

RPC_COM Namespace
IPerceptionCOMGeteDriveValues(Int32, Array, Array)


COMeDriveMechanicalBlockType Enumeration

Possible values for GeteDriveConfiguration when key is Mechanical_Type

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMeDriveMechanicalBlockType
Public Enumeration COMeDriveMechanicalBlockType
public enum class COMeDriveMechanicalBlockType
type COMeDriveMechanicalBlockType
Members
Member name | Value | Description
None | 0 | 0 No Mechanical configuration
Shaft_Only | 1 | 1 A shaft only configuration
Shaft_And_Transmission | 2 | 2 A shaft and transmission configuration
DifferentialLock_Only | 3 | 3 A differential lock configuration
Shaft_Only_with_Position | 4 | 4 A shaft only, using position configuration
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMeDrivePowerBlockType Enumeration

Possible values for GeteDriveConfiguration when key is PowerSource_Type or PowerInput_Type

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMeDrivePowerBlockType
Public Enumeration COMeDrivePowerBlockType
public enum class COMeDrivePowerBlockType
type COMeDrivePowerBlockType
Members
Member name | Value | Description
None | 0 | 0 No Power configuration
DC | 1 | 1 A DC power configuration
AC_1_Phase | 2 | 2 An AC single phase (or pulsed DC) configuration
AC_3_Phase_Phase_to_Phase | 3 | 3 A 3-phase phase-to-phase configuration
AC_3_Phase_Phase_to_Neutral | 4 | 4 A 3-phase phase-to-neutral configuration
Dual_DC | 5 | 5 A dual DC power configuration
Dual_AC_1_Phase | 6 | 6 A dual AC single phase (or pulsed DC) configuration
Dual_AC_3_Phase_Phase_to_Phase | 7 | 7 A dual 3-phase phase-to-phase configuration
Dual_AC_3_Phase_Phase_to_Neutral | 8 | 8 A dual 3-phase phase-to-neutral configuration
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMeDriveRPC_UpdateRate Enumeration

Possible values for GeteDriveConfiguration when key is Calculator_UpdateRate

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMeDriveRPC_UpdateRate
Public Enumeration COMeDriveRPC_UpdateRate
public enum class COMeDriveRPC_UpdateRate
type COMeDriveRPC_UpdateRate
Members
Member name | Value | Description
Auto | 0 | 0 Switches update rate automatically, depending on number of found cycles
Slow | 1 | 1 Updates occur every second
Medium | 2 | 2 Updates occur 2 times per second
Fast | 3 | 3 Updates occur 5 times per second
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMExternalPowerStatus Enumeration

External power status

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMExternalPowerStatus
Public Enumeration COMExternalPowerStatus
public enum class COMExternalPowerStatus
type COMExternalPowerStatus
Members
Member name | Value | Description
COMExternalPowerStatus_NotValid | -1 | Not valid
COMExternalPowerStatus_Nominal | 0 | Nominal
COMExternalPowerStatus_UnderRange | 1 | Under range
COMExternalPowerStatus_OverRange | 2 | Over range
COMExternalPowerStatus_ReversePolarity | 3 | Reverse polarity
COMExternalPowerStatus_BlownFuse | 4 | Blown fuse
COMExternalPowerStatus_NotPresent | 5 | Not present
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMExternalStartStopMode Enumeration

Mode that can be used for external start or stop

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMExternalStartStopMode
Public Enumeration COMExternalStartStopMode
public enum class COMExternalStartStopMode
type COMExternalStartStopMode
Members
Member name | Value | Description
COMExternalStartStopMode_Disabled | 0 | External start / stop is disabled
COMExternalStartStopMode_RisingEdge | 1 | External start / stop is triggered by the rising edge of the external start stop signal
COMExternalStartStopMode_FallingEdge | 2 | External start / stop is triggered by the falling edge of the external start stop signal
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMExternalTriggerIn Enumeration

External trigger in

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMExternalTriggerIn
Public Enumeration COMExternalTriggerIn
public enum class COMExternalTriggerIn
type COMExternalTriggerIn
Members
Member name | Value | Description
COMExternalTriggerIn_Disabled | 0 | Disabled
COMExternalTriggerIn_RisingEdge | 1 | Rising edge
COMExternalTriggerIn_FallingEdge | 2 | Falling edge
COMExternalTriggerIn_RisingEdge_InToOut | 3 | Rising edge in to out
COMExternalTriggerIn_FallingEdge_InToOut | 4 | Falling edge in to out
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMExternalTriggerOut Enumeration

External trigger out

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMExternalTriggerOut
Public Enumeration COMExternalTriggerOut
public enum class COMExternalTriggerOut
type COMExternalTriggerOut
Members
Member name | Value | Description
COMExternalTriggerOut_Disabled | 0 | Disabled
COMExternalTriggerOut_HighLevel | 1 | High level
COMExternalTriggerOut_LowLevel | 2 | Low level
COMExternalTriggerOut_HoldHighLevel | 3 | Hold high level
COMExternalTriggerOut_HoldLowLevel | 4 | Hold low level
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMISCSISettings Enumeration

Used to identify which settings to set. Combine using or operator to set multiple settings in one call

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMISCSISettings
Public Enumeration COMISCSISettings
public enum class COMISCSISettings
type COMISCSISettings
Members
Member name | Value | Description
COMISCSISettings_NetworkSelect | 1 | (1) Set the network the iSCSI device is connected to
COMISCSISettings_IPAddress | 2 | (2) Set the IP-address
COMISCSISettings_PortNumber | 4 | (4) Set the port number
COMISCSISettings_TargetName | 8 | (8) Set the target name
COMISCSISettings_UserName | 16 | (16) Set the user name to login to the iSCSI device
COMISCSISettings_Password | 32 | (32) Set the password to login to the iSCSI device
COMISCSISettings_Enabled | 64 | (64) Set enabled
COMISCSISettings_Status | 128 | (128) Get the current status
COMISCSISettings_PhysicalName | 256 | (256) The physical name
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMIScsiStatus Enumeration

iSCSI status

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMIScsiStatus
Public Enumeration COMIScsiStatus
public enum class COMIScsiStatus
type COMIScsiStatus
Members
Member name | Value | Description
COMIScsi_OK | 0 | OK
COMIscsi_MountFailed | 1 | Unable to mount disk
COMIScsi_LoginFailed | 2 | Unable to login to the iSCSI unit
COMIScsi_UnknownTarget | 3 | The target is unknown
COMIScsi_NoIScsiHost | 4 |
COMIScsi_HostUnreachable | 5 |
COMIScsi_Offline | 6 | iSCSI device is off-line
COMIScsi_Mounting | 7 | iSCSI disk is mounting
COMIScsi_PortInUse | 8 | iSCSI port is already in use
COMIScsi_Formatting | 9 | iSCSI device is being formatted
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMLinkStatus Enumeration

Gives information about the communication status

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMLinkStatus
Public Enumeration COMLinkStatus
public enum class COMLinkStatus
type COMLinkStatus
Members
Member name | Value | Description
COMLinkStatus_NotValid | -1 | Not valid
COMLinkStatus_Offline | 0 | Off-line
COMLinkStatus_Bad | 1 | Bad
COMLinkStatus_OK | 2 | OK
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMMainframeExtStartStopSettingItem Enumeration

Used to identify which settings to set. Combine using or operator to set multiple settings in one call

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMMainframeExtStartStopSettingItem
Public Enumeration COMMainframeExtStartStopSettingItem
public enum class COMMainframeExtStartStopSettingItem
type COMMainframeExtStartStopSettingItem
Members
Member name | Value | Description
COMMainframeExtStartStopSettingItem_Start | 1 | Use this item to control the setting of the mainframe external start.
COMMainframeExtStartStopSettingItem_Stop | 2 | Use this item to control the setting of the mainframe external stop.
Remarks
This setting is not available on all mainframes. Please refer to the GEN Series manual to verify if the mainframe used supports this setting.
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMMasterSlaveMode Enumeration

Possible master slave mode

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMMasterSlaveMode
Public Enumeration COMMasterSlaveMode
public enum class COMMasterSlaveMode
type COMMasterSlaveMode
Members
Member name | Value | Description
COMMasterSlaveMode_StandAlone | 0 | The unit is not part of a master-slave setup
COMMasterSlaveMode_Master | 1 | The unit is the master in the master-slave setup
COMMasterSlaveMode_Slave | 2 | The unit is a slave in the master-slave setup
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMMasterTimebaseMode Enumeration

Possible timebase modes

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMMasterTimebaseMode
Public Enumeration COMMasterTimebaseMode
public enum class COMMasterTimebaseMode
type COMMasterTimebaseMode
Members
Member name | Value | Description
COMMasterTimebaseMode_Decimal | 0 | Use decimal time-base mode
COMMasterTimebaseMode_Binary | 1 | Use binary time-base mode
COMMasterTimebaseMode_External | 2 | Use external time-base mode
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMMasterTimebaseSyncSource Enumeration

Possible timebase sync-sources

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMMasterTimebaseSyncSource
Public Enumeration COMMasterTimebaseSyncSource
public enum class COMMasterTimebaseSyncSource
type COMMasterTimebaseSyncSource
Members
Member name | Value | Description
COMMasterTimebaseSyncSource_RTC | 0 | Use the internal real-time clock
COMMasterTimebaseSyncSource_IRIG | 1 | Use an IRIG source
COMMasterTimebaseSyncSource_GPS | 2 | Use a GPS source
COMMasterTimebaseSyncSource_MasterSlave | 3 | Use the dedicated master-slave hardware
COMMasterTimebaseSyncSource_IRIG_A_AM | 4 | Use an IRIG A AM source
COMMasterTimebaseSyncSource_IRIG_B_AM | 5 | Use an IRIG B AM source
COMMasterTimebaseSyncSource_IRIG_A_DCLS | 6 | Use an IRIG A DCLS source
COMMasterTimebaseSyncSource_IRIG_B_DCLS | 7 | Use an IRIG B DCLS source
COMMasterTimebaseSyncSource_IEEE1344 | 8 | Use and IEEE 1344 source
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMMasterTimebaseSyncStatus Enumeration

Possible status of the timebase synchronization process

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMMasterTimebaseSyncStatus
Public Enumeration COMMasterTimebaseSyncStatus
public enum class COMMasterTimebaseSyncStatus
type COMMasterTimebaseSyncStatus
Members
Member name | Value | Description
COMMasterTimebaseSyncStatus_NotSynced | 0 | Not synchronized
COMMasterTimebaseSyncStatus_Syncing | 1 | Busy synchronizing
COMMasterTimebaseSyncStatus_Synced | 2 | Synchronized with the source
COMMasterTimebaseSyncStatus_SyncLost | 3 | No longer synchronized
COMMasterTimebaseSyncStatus_NoSignal | 4 | Unable to detect the synchronization source signal
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMMasterTmbSettingsItem Enumeration

Used to identify which settings to set. Combine using or operator to set multiple settings in one call

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMMasterTmbSettingsItem
Public Enumeration COMMasterTmbSettingsItem
public enum class COMMasterTmbSettingsItem
type COMMasterTmbSettingsItem
Members
Member name | Value | Description
COMMasterTmbSettingsItem_SyncSource | 2 | Set the sync source
COMMasterTmbSettingsItem_SyncStatus | 4 | Get the sync status
COMMasterTmbSettingsItem_MasterSlaveMode | 8 | Set the master-slave mode
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMNetworkSelect Enumeration

Possible network devices for the unit

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMNetworkSelect
Public Enumeration COMNetworkSelect
public enum class COMNetworkSelect
type COMNetworkSelect
Members
Member name | Value | Description
COMNetwork_RJ45 | 0 | Standard network connection
COMNetwork_SFP | 1 | Single mode fiber
COMNetwork_Ext1 | 2 | Extended 1
COMNetwork_Ext2 | 3 | Extended 2
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMPowerLevel Enumeration

Power level of remote front-end channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMPowerLevel
Public Enumeration COMPowerLevel
public enum class COMPowerLevel
type COMPowerLevel
Members
Member name | Value | Description
COMPowerLevel_NotValid | -1 | Not valid
COMPowerLevel_Low | 0 | Low
COMPowerLevel_OK | 1 | OK
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMPowerSource Enumeration

Power source

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMPowerSource
Public Enumeration COMPowerSource
public enum class COMPowerSource
type COMPowerSource
Members
Member name | Value | Description
COMPowerSource_NotValid | -1 | Not valid
COMPowerSource_External | 0 | External
COMPowerSource_Battery | 1 | Battery
COMPowerSource_Undetermined | 2 | Undetermined
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMPowerStatus Enumeration

Power status of remote front-end channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMPowerStatus
Public Enumeration COMPowerStatus
public enum class COMPowerStatus
type COMPowerStatus
Members
Member name | Value | Description
COMPowerStatus_PowerOff | 0 | Power off
COMPowerStatus_NoSignal | 1 | No signal
COMPowerStatus_WarmingUp | 2 | Warming up
COMPowerStatus_BatteryLow | 3 | Battery low
COMPowerStatus_PowerOK | 4 | Power OK
COMPowerStatus_ThermalShutdown | 5 | Thermal shutdown
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMRecordingMode Enumeration

Possible recording modes

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMRecordingMode
Public Enumeration COMRecordingMode
public enum class COMRecordingMode
type COMRecordingMode
Members
Member name | Value | Description
COMRecordingMode_StopOnFull | 0 | Recording will stop when the target location is full.
COMRecordingMode_CircularRecording | 1 | Recording will use a fixed amount of disk-space.
COMRecordingMode_LimitedRecording | 2 | Recording will stop when limit is reached.
COMRecordingMode_StopOnTrigger | 3 | Recording will stop when trigger is reached, potentially extended with the post trigger time.
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMStatusID Enumeration

Status parameter identifier.

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMStatusID
Public Enumeration COMStatusID
public enum class COMStatusID
type COMStatusID
Members
Member name | Value | Description
COMStatusID_Int | 268435456 | Mask bit
COMStatusID_LinkStatus | 268435466 | Link status
COMStatusID_PowerStatus | 268435486 | Power status
COMStatusID_ExternalPowerStatus | 268435487 | External power status
COMStatusID_PowerSource | 268435488 | Power source
COMStatusID_RemainCap | 268435489 | Remaining capacity
COMStatusID_RemainTime | 268435490 | Remaining time
COMStatusID_Bat1Condition | 268435496 | Condition battery A
COMStatusID_Bat1CycleCount | 268435497 | Cycle count battery A
COMStatusID_Bat1ChargeStatus | 268435498 | Charge status battery A
COMStatusID_Bat1RemainCap | 268435503 | Remaining capacity battery A
COMStatusID_Bat2Condition | 268435506 | Condition battery B
COMStatusID_Bat2CycleCount | 268435507 | Cycle count battery B
COMStatusID_Bat2ChargeStatus | 268435508 | Charge status battery B
COMStatusID_Bat2RemainCap | 268435513 | Remaining capacity battery B
COMStatusID_SfpStatus | 268435517 | Status of Sfp, maps to Sfp status enumeration values
COMStatusID_Double | 536870912 | Mask bit
COMStatusID_LinkQuality | 536870923 | Link quality
COMStatusID_LinkCableLength | 536870924 | Cable length
COMStatusID_Temperature | 536870932 | Temperature
COMStatusID_Bat1Temperature | 536870955 | Temperature battery A
COMStatusID_Bat1Voltage | 536870956 | Voltage battery A
COMStatusID_Bat1Current | 536870957 | Current battery A
COMStatusID_Bat1Capacity | 536870958 | Capacity battery A
COMStatusID_Bat2Temperature | 536870965 | Temperature battery B
COMStatusID_Bat2Voltage | 536870966 | Voltage battery B
COMStatusID_Bat2Current | 536870967 | Current battery B
COMStatusID_Bat2Capacity | 536870968 | Capacity battery B
COMStatusID_SfpTemperature | 536870970 | Sfp degree in Celsius
COMStatusID_SfpTxPower | 536870971 | Sfp write power in Watt
COMStatusID_SfpRxPower | 536870972 | Sfp read power in Watt
COMStatusID_SfpWavelength | 536870974 | Sfp wavelength in m.
COMStatusID_SfpVoltage | 536870978 | Sfp voltage in V
COMStatusID_Widestring | 1073741824 | Mask bit
COMStatusID_SfpVendor | 1073741887 | Sfp vendor
COMStatusID_SfpPartNumber | 1073741888 | Sfp part number
COMStatusID_SfpSerial | 1073741889 | Sfp serial number
COMStatusID_TransmitterSerial | 1073741891 | Transmitter serial number
Remarks
The COMStatusID_Int and COMStatusID_Double are mask bits and are only for internal use.
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMStorageMode Enumeration

Possible storage modes

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMStorageMode
Public Enumeration COMStorageMode
public enum class COMStorageMode
type COMStorageMode
Members
Member name | Value | Description
COMStorageMode_None | 0 | No storage, no data will be written into the recording.
COMStorageMode_Sweeps | 1 | Sweeped storage, allows high sample-rates
COMStorageMode_Continuous | 2 | Continuous data storage
COMStorageMode_Dual | 3 | Continuous data storage with high rate sweep segments
COMStorageMode_ABASweep | 4 | Slow fast storage mode
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMStorageSettingItem Enumeration

Used to identify which settings to set. Combine using or operator to set multiple settings in one call

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMStorageSettingItem
Public Enumeration COMStorageSettingItem
public enum class COMStorageSettingItem
type COMStorageSettingItem
Members
Member name | Value | Description
COMStorageSettingItem_StorageMode | 1 | Set the storage mode
COMStorageSettingItem_RecordingMode | 2 | Set the recording mode
COMStorageSettingItem_RecordingTimeHistory | 4 | Set the recording time history
COMStorageSettingItem_PostTriggerRecordingTime | 8 | Set the post trigger recording time
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMSweepMode Enumeration

Gives information about the trigger mode

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMSweepMode
Public Enumeration COMSweepMode
public enum class COMSweepMode
type COMSweepMode
Members
Member name | Value | Description
COMSweepMode_Normal | 0 | Sweep starts at trigger
COMSweepMode_PreTrigger | 1 | Sweep starts before trigger
COMSweepMode_Delayed | 2 | Sweep starts after trigger
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMSweepSettingItem Enumeration

Used to identify which settings to set. Combine using or operator to set multiple settings in one call

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMSweepSettingItem
Public Enumeration COMSweepSettingItem
public enum class COMSweepSettingItem
type COMSweepSettingItem
Members
Member name | Value | Description
COMSweepSettingItem_SweepLength | 1 | Set fast sweep length
COMSweepSettingItem_TriggerPosition | 2 | Set fast sweep trigger position, requires sweep mode to be set to PreTrigger to take affect.
COMSweepSettingItem_Delay | 4 | Set delay, requires sweep mode to be set to Delay to take affect.
COMSweepSettingItem_Mode | 8 | Set the sweep mode
COMSweepSettingItem_SweepCountEnabled | 16 | Set sweep count enabled
COMSweepSettingItem_SweepCount | 32 | Set the maximum number of sweeps in the recording. The recording will automatically stop if this number is reached, or if the recording is stopped earlier. Requires SweepCountEnabled to be enabled to take affect.
COMSweepSettingItem_SlowSweepLength | 64 | Set the slow sweep length
COMSweepSettingItem_SlowTriggerPosition | 128 | Set the slow sweep trigger position
COMSweepSettingItem_SweepStretchEnabled | 256 | Set the sweep stretch enabled
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMSystemHealth Enumeration

System health

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMSystemHealth
Public Enumeration COMSystemHealth
public enum class COMSystemHealth
type COMSystemHealth
Members
Member name | Value | Description
COMSystemHealth_OK | 0 | No system problem are reported.
COMSystemHealth_Problems | 1 | One or more problems are reported
See Also

Reference

RPC_COM Namespace
IPerceptionCOMSystemHealth
IPerceptionCOMSystemHealthProblems


COMTimebaseSettingItem Enumeration

Used to identify which settings to set. Combine using or operator to set multiple settings in one call

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMTimebaseSettingItem
Public Enumeration COMTimebaseSettingItem
public enum class COMTimebaseSettingItem
type COMTimebaseSettingItem
Members
Member name | Value | Description
COMTimebaseSettingItem_HighFrequency | 1 | Set the high sampling frequency
COMTimebaseSettingItem_LowFrequency | 2 | Set the low sampling frequency
COMTimebaseSettingItem_ClockSource | 4 | Set the clock source
COMTimebaseSettingItem_ExtClockDiv | 8 | Set the external clock divider for the group
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMUserScalingSettingItem Enumeration

Defines the items to be used to scale the signal

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMUserScalingSettingItem
Public Enumeration COMUserScalingSettingItem
public enum class COMUserScalingSettingItem
type COMUserScalingSettingItem
Members
Member name | Value | Description
Multiplier | 1 | (1) Signal multiplier to apply from physical to user units
Offset | 2 | (2) Signal offset to apply to get from physical to user units
UserUnits | 4 | (4) User units
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COMWindowState Enumeration

Gives information on the workbook state

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public enum COMWindowState
Public Enumeration COMWindowState
public enum class COMWindowState
type COMWindowState
Members
Member name | Value | Description
COMWindowState_Show | 0 | Non maximized visible window
COMWindowState_Hide | 1 | Hidden window
COMWindowState_ShowMinimized | 2 | Minimized window
COMWindowState_ShowMaximized | 3 | Maximized windows
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


IPerceptionCOM Interface

This is the Perception COM interface description

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
public interface IPerceptionCOM
Public Interface IPerceptionCOM
public interface class IPerceptionCOM
type IPerceptionCOM =  interface end

The IPerceptionCOM type exposes the following members.

Properties
 | Name | Description
Public property | ReturnErrorCodes | Use this property to manage the way COMRPC deals with RPC errors. If set to true all non zero return values will be converted to a COM error return on the COM interface.
Public property | SystemHealth | Returns the overall system health.
Public property | SystemHealthProblems | Returns specific list (strings, descriptions) of known issues in case of problems reported with system health.
Top
Methods
 | Name | Description
Public method | Abort | Stops an acquisition
 | ChannelScType | Get the channel type of a channel
 | CloseActiveRecording | Closes the currently active recording.
Public method | Configuration | Obsolete. This method is no longer supported
 | ConnectToServer | Connects to Perception server
Public method | ControlledStart | Controlled start of the acquisition.
 | CurrentlyActiveVWB | Returns the full path of the currently active virtual workbench
 | DisconnectFromServer | Disconnects from Perception server
Public method | DSGetName | Get the name of the data source
Public method | DSGetNumericalValue | Get numerical value of the specified data source
Public method | DSGetStringValue | Get the string value of the specified data source
 | DSGetType | Get the type of the data source variable
Public method | DSGetUnits | Get the horizontal and vertical units of the data source
Public method | ExecuteCommand | Executes a command as described by string Command
Public method | ExecuteRequest | Executes a request as described by string Request
 | GetAcquisitionState | Use this function to retrieve the acquisition status of all available recorders.
 | GetActiveSheet | Returns the name of the currently active sheet
 | GetAlarmLevelSettings | Get the alarm settings of a channel
Public method | GetArchiveFolder | Get current archive folder.
Public method | GetAsyncRTFDBNames | This call returns a list of Names in the same order as the GetAsyncRTFDBValues.
Public method | GetAsyncRTFDBValues | Returns a time-stamp and a set of values for all asynchronous channels. Synchronized means all values apply against the exact same time-stamp The time-stamp is as recent as can be, but never newer than the oldest update of any channel. Example: Consider a 2 channel system, one channel updates at 100 times/second and the other at 1 time/second. This system is ‘probed’ by calling GetAsyncRTFDB() 100 times/second. For this setup the time stamp of the results will change at a rate of 1 time/second. The supplied values would change for each call (only for the fast channel).
Public method | GetAutomationEnabled | Gets the recording automation enabled
 | GetAvailableWaveforms | Retrieve all available waveform names
Public method | GetCalcChannelEnabled | Gets if channel is enabled or disabled
Public method | GetCalcChannelName | Gets the user name of a channel
Public method | GetCalcCommonSettings | Sets general settings of the channel
Public method | GetCalcInputRangeSettings | Get the measurement range of the channel
Public method | GetCalcMathSettings | Set the math calculation settings for the calculated channel
Public method | GetCalcTriggerSettings | Gets the trigger settings for the specified channel
Public method | GetCalculatedChannelCount | Get the number of calculated channels available on a recorder, note that this number may change depending on system configuration
Public method | GetCalcUserScalingSettings | Sets the settings used to transform between physical units and user units
 | GetCalibrationInfo | Get channel calibration information
Public method | GetCalibrationSettings | Get the calibration settings of a channel
 | GetChannelBatteryStatus | Get the battery status of a fiber channel
Public method | GetChannelEnabled | Returns whether a channels data is stored or not.
 | GetChannelName | Retrieve the name of a channel
 | GetCommonSettings | Get the common settings of a mainframe
Public method | GetCommunicationAddress | Get the communication address of a mainframe
Public method | GetConnectedMainframeCount | Returns the amount of currently connected mainframes
Public method | GetContinuousSettings | Obsolete. This method is no longer supported and has been replaced by the GetGroupStorageSettings
 | GetControlOut | Getting the status of the control output (7600 Isolated Digitizer Subsystem)
Public method | GetCycleMasterSettings | Setup the cycle detector
 | GetData | Get live data from Perception
 | GetDiskMemoryUsage | Get the acquisition disk memory total size and free size
 | GetDiskSettings | Get the disk settings of a mainframe
 | GeteDriveConfiguration | Gets current configuration an eDrive calculator engine
 | GeteDriveConfigurationStrings | Gets current configuration an eDrive calculator engine
 | GeteDriveEngineNames | Gets the ids and names of all available eDrive calculator engines. The ids are used in subsequent calls to GeteDriveValues, GeteDriveConfiguration and SeteDriveConfiguration.
Public method | GeteDriveNextRecordingComment | Get recording comment from eDrive application
 | GeteDriveValues | Gets calculated results from an eDrive calculator engine. Returns 2 output arrays: an array of Int32 Keys, and an array of double values. Key[x] corresponds with Values[x].
Public method | GetESIFile | Returns the content of an ESI file describing the current system setup as published on EtherCAT.
Public method | GetEventChannelEnabled | Returns whether a channels data is stored or not.
Public method | GetFilenames | With this function you can retrieve all available file names that match a search pattern, from a specified directory.
 | GetGroups | Return a list of all the time-base groups currently in the system
 | GetGroupStorageSettings | Get the recorder storage mode
 | GetGroupSweepSettings | Get the group sweep settings
 | GetGroupTimebaseSettings | Get timebase settings of a group
 | GetInfoSettings | Get the channel information
Public method | GetiSCSISettings | Get the iSCSI settings
Public method | GetLastError | The PerceptionCOMRPC makes calls to the RPC server via the RPC protocol. Most calls in the RPC protocol return an integer value indicating pass/failure of the call. This method allows the last returned value to be retrieved.
Public method | GetLinkStatus | Gives information about the communication status
 | GetMacros | Get the names of all available macros in Perception
Public method | GetMainframeBatteryStatus | Get the battery status of a mainframe (LIBERTY)
 | GetMainframeInfoSettings | Get mainframe information
 | GetMainframeName | Retrieve the name of a mainframe
Public method | GetMasterTimebaseMode | Get the current system master-timebase mode
Public method | GetMasterTimebaseSettings | Obsolete. This method is no longer supported and has been replaced by the GetMasterTimebaseSettingsEx
 | GetMasterTimebaseSettingsEx | Get the master timebase settings of a mainframe
Public method | GetMFExternalStartStopSettings | Gets the external start and / or stop behavior of the mainframe when a signal is applied to the external start / stop connector.
Public method | GetModule2EtherCATMapping | Returns the information necessary to map how information from the acquisition system is published on the EtherCAT bus
Public method | GetNetworkSettings | Get a mainframes network settings
 | GetPowerControlSettings | Get the power control settings of a fiber channel
 | GetPowerStatus | Get the power status of a fiber channel
Public method | GetRecCommonSettings | Get common settings of a recorder
 | GetRecInfoSettings | Get recorder information
Public method | GetRecorderCount | Returns the amount of recorders on the specified mainframe
Public method | GetRecorderCountInGroup | Returns the number of recorders in a certain group
Public method | GetRecorderGroup | Returns the name of the group to which the recorder is assigned
 | GetRecorderName | Retrieve the name of a recorder
Public method | GetRecordingName | Gets the current recording name, path is not included.
Public method | GetRecStorageSettings | Obsolete. This method is no longer supported and has been replaced by the GetGroupStorageSettings
Public method | GetRecSweepSettings | Obsolete. This method is no longer supported and has been replaced by the GetGroupSweepSettings
Public method | GetRecSweepSettingsEx | Obsolete. This method is no longer supported and has been replaced by the GetGroupSweepSettings
Public method | GetRecTimebaseSettings | Obsolete. This method is no longer supported and has been replaced by the GetGroupTimebaseSettings
Public method | GetRecTriggerBusSettings | Get the trigger bus settings of a recorder
Public method | GetSCBridgeBalancingSettings | Get the bridge channel balancing settings
Public method | GetSCBridgeCalibrationSettings | Get bridge channel calibration settings
Public method | GetSCBridgeSetupSettings | Get channel bridge setup settings
 | GetSCCommonSettings | Get the common settings of a channel
Public method | GetSCCouplingSettings | Get the couplings settings of a channel
Public method | GetSCExcitationSettings | Get the channel excitation settings
Public method | GetSCFilterSettings | Set the filter settings of a channel
 | GetSCInputRangeSettings | Get the input range settings of a channel
 | GetSCUserScalingSettings | Get the user-scaling of a channel
Public method | GetSheetCount | Returns the number of visible sheets
 | GetSheetName | Gets the name of the sheet at index.
Public method | GetShuntResistorActive | Get the shunt resistor
Public method | GetSilentMode | Retrieves the current setting for silent mode.
Public method | GetStatusDouble | Get a status value as double
Public method | GetStatusInt | Get a status value as integer
Public method | GetStatusString | Get a status value as string
Public method | GetStorageSettings | Obsolete. This method is no longer supported and has been replaced by the GetGroupStorageSettings
Public method | GetSweepSettings | Obsolete. This method is no longer supported and has been replaced by the GetGroupSweepSettings
Public method | GetTemperatureStatus | Get the temperature of an amplifier
Public method | GetTimebaseSettings | Obsolete. This method is no longer supported and has been replaced by the GetGroupTimebaseSettings
Public method | GetTimerCounterChannelEnabled | Returns whether a channels data is stored or not.
Public method | GetTriggerIOSettings | Get the trigger IO settings of a mainframe
 | GetTriggerLevelSettings | Get the trigger level settings of a channel
Public method | GetTriggerPulseDetectorSettings | Get trigger pulse detector settings
Public method | GetTriggerRepeatTimerSettings | Get trigger repeat timer settings
 | GetTriggerSettings | Gets the basic trigger parameters per channel
Public method | GetTriggerState | Use this function to retrieve the trigger status of all available recorders.
Public method | GetWindowState | Gets the window state of the currently active workbook in Perception
Public method | IsAcquisitionBlocked | Returns true if a new acquisition can not be started.
Public method | IsCommunicationActive | Checks if there was communication between controlling PC and mainframe(s) since last call of this function.
Public method | LoadSettings | Use this function to load a saved settings file (*.pSet) into Perception.
Public method | LoadVWB | Use this function to load an existing Virtual WorkBench (*.pVwb) file into Perception.
Public method | MainframeSetDefaultSettings | Obsolete. This method is no longer supported and has been replaced by the SetDefaultSettings
Public method | OneShot | To start a single sweep.
Public method | Pause | Go to pause mode
 | PerformeDriveAction | Execute an eDrive action as described by the Action ID
Public method | RequestAllSettings | Requests all settings of all connected mainframes. Only returns once all settings have been received.
 | RunMacro | Runs a macro in Perception
Public method | SaveSettings | Use this function to save the current hardware settings into a file.
Public method | SaveVWB | Use this function to save the current Perception workbench into a file.
 | ScanRPCServers | Scans the network for running Perception RPC Servers.
 | SetActiveSheet |
 | SetAlarmLevelSettings | Set the alarm settings of a channel
Public method | SetArchiveFolder | Set current archive folder. If the new archive folder is on a disk that has not been profiled yet, the disk will be profiled as part of this call.
Public method | SetAutomationEnabled | Activates/deactivates recording automation
Public method | SetCalcChannelEnabled | Enable or disable a calculated channel
Public method | SetCalcCommonSettings | Sets general settings of the channel
Public method | SetCalcInputRangeSettings | Set the measurement range of the channel
Public method | SetCalcMathSettings | Set the math calculation settings for the calculated channel
Public method | SetCalcTriggerSettings | Sets the trigger settings for the specified channel
Public method | SetCalcUserScalingSettings | Gets the settings used to transform between physical units and user units
Public method | SetCalibrationSettings | Set Calibration settings of a channel
 | SetChannelEnabled | Enable/Disable the storage of a channel
 | SetCommonSettings | Set the common settings of a mainframe
Public method | SetContinuousSettings | Obsolete. This method is no longer supported and has been replaced by the SetGroupStorageSettings
 | SetControlOut | Setting the control output of a 7600 Isolated Digitizer Subsystem
Public method | SetCycleMasterSettings | Setup the cycle detector
Public method | SetDefaultSettings | To restore hardware settings of a system to their factory defaults
Public method | SetDiskSettings | Set disk settings of a mainframe
 | SeteDriveConfiguration | Sets configuration of an eDrive calculator engine
 | SeteDriveConfigurationStrings | Sets configuration of an eDrive calculator engine
Public method | SeteDriveNextRecordingComment | Set next recording comment for eDrive application.
 | SetEventChannelEnabled | Enable/Disable the storage of a marker channel
Public method | SetGroupStorageSettings | Sets the storage mode of a group
 | SetGroupSweepSettings | Set the group sweep settings
 | SetGroupTimebaseSettings | Get timebase settings of a group
Public method | SetInformationNumericalValue | Sets the value of a numerical field on the Information sheet
Public method | SetInformationStringValue | Sets the value of a string field on the Information sheet
Public method | SetiSCSISettings | Set the iSCSI settings
Public method | SetMasterTimebaseMode | Set the system master-timebase mode
Public method | SetMasterTimebaseSettings | Obsolete. This method is no longer supported and has been replaced by the SetMasterTimebaseSettingsEx
 | SetMasterTimebaseSettingsEx | Set the master timebase settings of a mainframe
Public method | SetMFExternalStartStopSettings | Sets the external start and / or stop behavior of the mainframe when a signal is applied to the external start / stop connector.
Public method | SetNetworkSettings | Get a mainframes network settings
 | SetPowerControlSettings | Get the power control settings of a fiber channel
Public method | SetRecCommonSettings | Set common settings of a recorder
Public method | SetRecDefaultSettings | Obsolete. This method is no longer supported and has been replaced by the SetDefaultSettings
Public method | SetRecorderGroup | Sets the group of a recorder
 | SetRecordingName | Sets the recording name and number
Public method | SetRecStorageSettings | Obsolete. This method is no longer supported and has been replaced by the SetGroupStorageSettings
Public method | SetRecSweepSettings | Obsolete. This method is no longer supported and has been replaced by the SetGroupSweepSettings
Public method | SetRecSweepSettingsEx | Obsolete. This method is no longer supported and has been replaced by the SetGroupSweepSettings
Public method | SetRecTimebaseSettings | Obsolete. This method is no longer supported and has been replaced by the SetGroupTimebaseSettings
Public method | SetRecTriggerBusSettings | Set the trigger bus settings of a recorder
Public method | SetSCBridgeBalancingSettings | Set the bridge channel balancing settings
Public method | SetSCBridgeCalibrationSettings | Set bridge channel calibration settings
Public method | SetSCBridgeSetupSettings | Set channel bridge setup settings
 | SetSCCommonSettings | Get the common settings of a channel
Public method | SetSCCouplingSettings | Set the couplings settings of a channel
Public method | SetSCExcitationSettings | Set the channel excitation settings
Public method | SetSCFilterSettings | Get the filter settings of a channel
 | SetSCInputRangeSettings | Set the input range settings of a channel
 | SetSCUserScalingSettings | Set the user-scaling of a channel
 | SetServerAddress | Set the address of the Perception Server machine
Public method | SetShuntResistorActive | Set the shunt resistor
Public method | SetSilentMode | Toggle Perception to run in silent mode. If set to silent mode, most UI interaction will be suppressed and automatically handled.
Public method | SetStorageSettings | Obsolete. This method is no longer supported and has been replaced by the SetGroupStorageSettings
Public method | SetSweepSettings | Obsolete. This method is no longer supported and has been replaced by the SetGroupSweepSettings
Public method | SetTimebaseSettings | Obsolete. This method is no longer supported and has been replaced by the SetGroupTimebaseSettings
 | SetTimerCounterChannelEnabled | Enable/Disable the storage of a timer-counter channel
Public method | SetTriggerIOSettings | Set the trigger IO settings of a mainframe
 | SetTriggerLevelSettings | Set the trigger level settings of a channel
Public method | SetTriggerPulseDetectorSettings | Set trigger pulse detector settings
Public method | SetTriggerRepeatTimerSettings | Set trigger repeat timer settings
 | SetTriggerSettings | Set the basic trigger parameters per channel
Public method | SetWindowState | Sets the window state of all workbooks in Perception
 | Start | The Start command starts acquisition of data.
Public method | StartAsyncRTFDBSubscription | This call prepares the system such that it can yield a snapshot containing all asynchronous RT-FDB channels available at the moment of the call
Public method | StartAutoBalance | Auto balance a bridge channel
Public method | Stop | Stops an acquisition
Public method | StopAsyncRTFDBSubscription | This call cancels snapshot behavior, freeing up system resources
 | StorageActive | Check if the storage of a mainframe is active
Public method | SubscribeLiveWaveform | Function to subscribe to a live waveform stream
 | Trigger | This command initiates a trigger. Depending on the acquisition settings this can finish the active acquisition.
 | UnsubscribeLiveWaveform | Use this function to un-subscribe when your done using the data from a subscribed waveform
Top
See Also

Reference

RPC_COM Namespace

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


IPerceptionCOM Properties

The IPerceptionCOM type exposes the following members.

Properties
 | Name | Description
Public property | ReturnErrorCodes | Use this property to manage the way COMRPC deals with RPC errors. If set to true all non zero return values will be converted to a COM error return on the COM interface.
Public property | SystemHealth | Returns the overall system health.
Public property | SystemHealthProblems | Returns specific list (strings, descriptions) of known issues in case of problems reported with system health.
Top
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.ReturnErrorCodes Property

HBM - RPC/COM Perception Interfaces

IPerceptionCOMReturnErrorCodes Property

Use this property to manage the way COMRPC deals with RPC errors. If set to true all non zero return values will be converted to a COM error return on the COM interface.

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
bool ReturnErrorCodes { get; set; }
Property ReturnErrorCodes As Boolean
    Get
    Set
property bool ReturnErrorCodes {
    bool get ();
    void set (bool value);
}
abstract ReturnErrorCodes : bool with get, set

Property Value

Type: Boolean
Remarks
Please note that COM errors will be converted into exceptions when using a COM object. So setting this property to true requires exception handling in those environments to ensure a stable RPC client application. Please note that communication errors with RPC servers are always converted to COM errors independent of the value of this property.
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.SystemHealth Property

IPerceptionCOMSystemHealth Property

Returns the overall system health.

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
COMSystemHealth SystemHealth { get; }
ReadOnly Property SystemHealth As COMSystemHealth
    Get
property COMSystemHealth SystemHealth {
    COMSystemHealth get ();
}
abstract SystemHealth : COMSystemHealth with get

Property Value

Type: COMSystemHealth
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
RPC_COMCOMSystemHealth
IPerceptionCOMSystemHealthProblems


IPerceptionCOM.SystemHealthProblems Property

IPerceptionCOMSystemHealthProblems Property

Returns specific list (strings, descriptions) of known issues in case of problems reported with system health.

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
Array SystemHealthProblems { get; }
ReadOnly Property SystemHealthProblems As Array
    Get
property Array^ SystemHealthProblems {
    Array^ get ();
}
abstract SystemHealthProblems : Array with get

Property Value

Type: Array
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
RPC_COMCOMSystemHealth
IPerceptionCOMSystemHealth


IPerceptionCOM Methods

The IPerceptionCOM type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Stops an acquisition
 | ChannelScType | Get the channel type of a channel
 | CloseActiveRecording | Closes the currently active recording.
Public method | Configuration | Obsolete. This method is no longer supported
 | ConnectToServer | Connects to Perception server
Public method | ControlledStart | Controlled start of the acquisition.
 | CurrentlyActiveVWB | Returns the full path of the currently active virtual workbench
 | DisconnectFromServer | Disconnects from Perception server
Public method | DSGetName | Get the name of the data source
Public method | DSGetNumericalValue | Get numerical value of the specified data source
Public method | DSGetStringValue | Get the string value of the specified data source
 | DSGetType | Get the type of the data source variable
Public method | DSGetUnits | Get the horizontal and vertical units of the data source
Public method | ExecuteCommand | Executes a command as described by string Command
Public method | ExecuteRequest | Executes a request as described by string Request
 | GetAcquisitionState | Use this function to retrieve the acquisition status of all available recorders.
 | GetActiveSheet | Returns the name of the currently active sheet
 | GetAlarmLevelSettings | Get the alarm settings of a channel
Public method | GetArchiveFolder | Get current archive folder.
Public method | GetAsyncRTFDBNames | This call returns a list of Names in the same order as the GetAsyncRTFDBValues.
Public method | GetAsyncRTFDBValues | Returns a time-stamp and a set of values for all asynchronous channels. Synchronized means all values apply against the exact same time-stamp The time-stamp is as recent as can be, but never newer than the oldest update of any channel. Example: Consider a 2 channel system, one channel updates at 100 times/second and the other at 1 time/second. This system is ‘probed’ by calling GetAsyncRTFDB() 100 times/second. For this setup the time stamp of the results will change at a rate of 1 time/second. The supplied values would change for each call (only for the fast channel).
Public method | GetAutomationEnabled | Gets the recording automation enabled
 | GetAvailableWaveforms | Retrieve all available waveform names
Public method | GetCalcChannelEnabled | Gets if channel is enabled or disabled
Public method | GetCalcChannelName | Gets the user name of a channel
Public method | GetCalcCommonSettings | Sets general settings of the channel
Public method | GetCalcInputRangeSettings | Get the measurement range of the channel
Public method | GetCalcMathSettings | Set the math calculation settings for the calculated channel
Public method | GetCalcTriggerSettings | Gets the trigger settings for the specified channel
Public method | GetCalculatedChannelCount | Get the number of calculated channels available on a recorder, note that this number may change depending on system configuration
Public method | GetCalcUserScalingSettings | Sets the settings used to transform between physical units and user units
 | GetCalibrationInfo | Get channel calibration information
Public method | GetCalibrationSettings | Get the calibration settings of a channel
 | GetChannelBatteryStatus | Get the battery status of a fiber channel
Public method | GetChannelEnabled | Returns whether a channels data is stored or not.
 | GetChannelName | Retrieve the name of a channel
 | GetCommonSettings | Get the common settings of a mainframe
Public method | GetCommunicationAddress | Get the communication address of a mainframe
Public method | GetConnectedMainframeCount | Returns the amount of currently connected mainframes
Public method | GetContinuousSettings | Obsolete. This method is no longer supported and has been replaced by the GetGroupStorageSettings
 | GetControlOut | Getting the status of the control output (7600 Isolated Digitizer Subsystem)
Public method | GetCycleMasterSettings | Setup the cycle detector
 | GetData | Get live data from Perception
 | GetDiskMemoryUsage | Get the acquisition disk memory total size and free size
 | GetDiskSettings | Get the disk settings of a mainframe
 | GeteDriveConfiguration | Gets current configuration an eDrive calculator engine
 | GeteDriveConfigurationStrings | Gets current configuration an eDrive calculator engine
 | GeteDriveEngineNames | Gets the ids and names of all available eDrive calculator engines. The ids are used in subsequent calls to GeteDriveValues, GeteDriveConfiguration and SeteDriveConfiguration.
Public method | GeteDriveNextRecordingComment | Get recording comment from eDrive application
 | GeteDriveValues | Gets calculated results from an eDrive calculator engine. Returns 2 output arrays: an array of Int32 Keys, and an array of double values. Key[x] corresponds with Values[x].
Public method | GetESIFile | Returns the content of an ESI file describing the current system setup as published on EtherCAT.
Public method | GetEventChannelEnabled | Returns whether a channels data is stored or not.
Public method | GetFilenames | With this function you can retrieve all available file names that match a search pattern, from a specified directory.
 | GetGroups | Return a list of all the time-base groups currently in the system
 | GetGroupStorageSettings | Get the recorder storage mode
 | GetGroupSweepSettings | Get the group sweep settings
 | GetGroupTimebaseSettings | Get timebase settings of a group
 | GetInfoSettings | Get the channel information
Public method | GetiSCSISettings | Get the iSCSI settings
Public method | GetLastError | The PerceptionCOMRPC makes calls to the RPC server via the RPC protocol. Most calls in the RPC protocol return an integer value indicating pass/failure of the call. This method allows the last returned value to be retrieved.
Public method | GetLinkStatus | Gives information about the communication status
 | GetMacros | Get the names of all available macros in Perception
Public method | GetMainframeBatteryStatus | Get the battery status of a mainframe (LIBERTY)
 | GetMainframeInfoSettings | Get mainframe information
 | GetMainframeName | Retrieve the name of a mainframe
Public method | GetMasterTimebaseMode | Get the current system master-timebase mode
Public method | GetMasterTimebaseSettings | Obsolete. This method is no longer supported and has been replaced by the GetMasterTimebaseSettingsEx
 | GetMasterTimebaseSettingsEx | Get the master timebase settings of a mainframe
Public method | GetMFExternalStartStopSettings | Gets the external start and / or stop behavior of the mainframe when a signal is applied to the external start / stop connector.
Public method | GetModule2EtherCATMapping | Returns the information necessary to map how information from the acquisition system is published on the EtherCAT bus
Public method | GetNetworkSettings | Get a mainframes network settings
 | GetPowerControlSettings | Get the power control settings of a fiber channel
 | GetPowerStatus | Get the power status of a fiber channel
Public method | GetRecCommonSettings | Get common settings of a recorder
 | GetRecInfoSettings | Get recorder information
Public method | GetRecorderCount | Returns the amount of recorders on the specified mainframe
Public method | GetRecorderCountInGroup | Returns the number of recorders in a certain group
Public method | GetRecorderGroup | Returns the name of the group to which the recorder is assigned
 | GetRecorderName | Retrieve the name of a recorder
Public method | GetRecordingName | Gets the current recording name, path is not included.
Public method | GetRecStorageSettings | Obsolete. This method is no longer supported and has been replaced by the GetGroupStorageSettings
Public method | GetRecSweepSettings | Obsolete. This method is no longer supported and has been replaced by the GetGroupSweepSettings
Public method | GetRecSweepSettingsEx | Obsolete. This method is no longer supported and has been replaced by the GetGroupSweepSettings
Public method | GetRecTimebaseSettings | Obsolete. This method is no longer supported and has been replaced by the GetGroupTimebaseSettings
Public method | GetRecTriggerBusSettings | Get the trigger bus settings of a recorder
Public method | GetSCBridgeBalancingSettings | Get the bridge channel balancing settings
Public method | GetSCBridgeCalibrationSettings | Get bridge channel calibration settings
Public method | GetSCBridgeSetupSettings | Get channel bridge setup settings
 | GetSCCommonSettings | Get the common settings of a channel
Public method | GetSCCouplingSettings | Get the couplings settings of a channel
Public method | GetSCExcitationSettings | Get the channel excitation settings
Public method | GetSCFilterSettings | Set the filter settings of a channel
 | GetSCInputRangeSettings | Get the input range settings of a channel
 | GetSCUserScalingSettings | Get the user-scaling of a channel
Public method | GetSheetCount | Returns the number of visible sheets
 | GetSheetName | Gets the name of the sheet at index.
Public method | GetShuntResistorActive | Get the shunt resistor
Public method | GetSilentMode | Retrieves the current setting for silent mode.
Public method | GetStatusDouble | Get a status value as double
Public method | GetStatusInt | Get a status value as integer
Public method | GetStatusString | Get a status value as string
Public method | GetStorageSettings | Obsolete. This method is no longer supported and has been replaced by the GetGroupStorageSettings
Public method | GetSweepSettings | Obsolete. This method is no longer supported and has been replaced by the GetGroupSweepSettings
Public method | GetTemperatureStatus | Get the temperature of an amplifier
Public method | GetTimebaseSettings | Obsolete. This method is no longer supported and has been replaced by the GetGroupTimebaseSettings
Public method | GetTimerCounterChannelEnabled | Returns whether a channels data is stored or not.
Public method | GetTriggerIOSettings | Get the trigger IO settings of a mainframe
 | GetTriggerLevelSettings | Get the trigger level settings of a channel
Public method | GetTriggerPulseDetectorSettings | Get trigger pulse detector settings
Public method | GetTriggerRepeatTimerSettings | Get trigger repeat timer settings
 | GetTriggerSettings | Gets the basic trigger parameters per channel
Public method | GetTriggerState | Use this function to retrieve the trigger status of all available recorders.
Public method | GetWindowState | Gets the window state of the currently active workbook in Perception
Public method | IsAcquisitionBlocked | Returns true if a new acquisition can not be started.
Public method | IsCommunicationActive | Checks if there was communication between controlling PC and mainframe(s) since last call of this function.
Public method | LoadSettings | Use this function to load a saved settings file (*.pSet) into Perception.
Public method | LoadVWB | Use this function to load an existing Virtual WorkBench (*.pVwb) file into Perception.
Public method | MainframeSetDefaultSettings | Obsolete. This method is no longer supported and has been replaced by the SetDefaultSettings
Public method | OneShot | To start a single sweep.
Public method | Pause | Go to pause mode
 | PerformeDriveAction | Execute an eDrive action as described by the Action ID
Public method | RequestAllSettings | Requests all settings of all connected mainframes. Only returns once all settings have been received.
 | RunMacro | Runs a macro in Perception
Public method | SaveSettings | Use this function to save the current hardware settings into a file.
Public method | SaveVWB | Use this function to save the current Perception workbench into a file.
 | ScanRPCServers | Scans the network for running Perception RPC Servers.
 | SetActiveSheet |
 | SetAlarmLevelSettings | Set the alarm settings of a channel
Public method | SetArchiveFolder | Set current archive folder. If the new archive folder is on a disk that has not been profiled yet, the disk will be profiled as part of this call.
Public method | SetAutomationEnabled | Activates/deactivates recording automation
Public method | SetCalcChannelEnabled | Enable or disable a calculated channel
Public method | SetCalcCommonSettings | Sets general settings of the channel
Public method | SetCalcInputRangeSettings | Set the measurement range of the channel
Public method | SetCalcMathSettings | Set the math calculation settings for the calculated channel
Public method | SetCalcTriggerSettings | Sets the trigger settings for the specified channel
Public method | SetCalcUserScalingSettings | Gets the settings used to transform between physical units and user units
Public method | SetCalibrationSettings | Set Calibration settings of a channel
 | SetChannelEnabled | Enable/Disable the storage of a channel
 | SetCommonSettings | Set the common settings of a mainframe
Public method | SetContinuousSettings | Obsolete. This method is no longer supported and has been replaced by the SetGroupStorageSettings
 | SetControlOut | Setting the control output of a 7600 Isolated Digitizer Subsystem
Public method | SetCycleMasterSettings | Setup the cycle detector
Public method | SetDefaultSettings | To restore hardware settings of a system to their factory defaults
Public method | SetDiskSettings | Set disk settings of a mainframe
 | SeteDriveConfiguration | Sets configuration of an eDrive calculator engine
 | SeteDriveConfigurationStrings | Sets configuration of an eDrive calculator engine
Public method | SeteDriveNextRecordingComment | Set next recording comment for eDrive application.
 | SetEventChannelEnabled | Enable/Disable the storage of a marker channel
Public method | SetGroupStorageSettings | Sets the storage mode of a group
 | SetGroupSweepSettings | Set the group sweep settings
 | SetGroupTimebaseSettings | Get timebase settings of a group
Public method | SetInformationNumericalValue | Sets the value of a numerical field on the Information sheet
Public method | SetInformationStringValue | Sets the value of a string field on the Information sheet
Public method | SetiSCSISettings | Set the iSCSI settings
Public method | SetMasterTimebaseMode | Set the system master-timebase mode
Public method | SetMasterTimebaseSettings | Obsolete. This method is no longer supported and has been replaced by the SetMasterTimebaseSettingsEx
 | SetMasterTimebaseSettingsEx | Set the master timebase settings of a mainframe
Public method | SetMFExternalStartStopSettings | Sets the external start and / or stop behavior of the mainframe when a signal is applied to the external start / stop connector.
Public method | SetNetworkSettings | Get a mainframes network settings
 | SetPowerControlSettings | Get the power control settings of a fiber channel
Public method | SetRecCommonSettings | Set common settings of a recorder
Public method | SetRecDefaultSettings | Obsolete. This method is no longer supported and has been replaced by the SetDefaultSettings
Public method | SetRecorderGroup | Sets the group of a recorder
 | SetRecordingName | Sets the recording name and number
Public method | SetRecStorageSettings | Obsolete. This method is no longer supported and has been replaced by the SetGroupStorageSettings
Public method | SetRecSweepSettings | Obsolete. This method is no longer supported and has been replaced by the SetGroupSweepSettings
Public method | SetRecSweepSettingsEx | Obsolete. This method is no longer supported and has been replaced by the SetGroupSweepSettings
Public method | SetRecTimebaseSettings | Obsolete. This method is no longer supported and has been replaced by the SetGroupTimebaseSettings
Public method | SetRecTriggerBusSettings | Set the trigger bus settings of a recorder
Public method | SetSCBridgeBalancingSettings | Set the bridge channel balancing settings
Public method | SetSCBridgeCalibrationSettings | Set bridge channel calibration settings
Public method | SetSCBridgeSetupSettings | Set channel bridge setup settings
 | SetSCCommonSettings | Get the common settings of a channel
Public method | SetSCCouplingSettings | Set the couplings settings of a channel
Public method | SetSCExcitationSettings | Set the channel excitation settings
Public method | SetSCFilterSettings | Get the filter settings of a channel
 | SetSCInputRangeSettings | Set the input range settings of a channel
 | SetSCUserScalingSettings | Set the user-scaling of a channel
 | SetServerAddress | Set the address of the Perception Server machine
Public method | SetShuntResistorActive | Set the shunt resistor
Public method | SetSilentMode | Toggle Perception to run in silent mode. If set to silent mode, most UI interaction will be suppressed and automatically handled.
Public method | SetStorageSettings | Obsolete. This method is no longer supported and has been replaced by the SetGroupStorageSettings
Public method | SetSweepSettings | Obsolete. This method is no longer supported and has been replaced by the SetGroupSweepSettings
Public method | SetTimebaseSettings | Obsolete. This method is no longer supported and has been replaced by the SetGroupTimebaseSettings
 | SetTimerCounterChannelEnabled | Enable/Disable the storage of a timer-counter channel
Public method | SetTriggerIOSettings | Set the trigger IO settings of a mainframe
 | SetTriggerLevelSettings | Set the trigger level settings of a channel
Public method | SetTriggerPulseDetectorSettings | Set trigger pulse detector settings
Public method | SetTriggerRepeatTimerSettings | Set trigger repeat timer settings
 | SetTriggerSettings | Set the basic trigger parameters per channel
Public method | SetWindowState | Sets the window state of all workbooks in Perception
 | Start | The Start command starts acquisition of data.
Public method | StartAsyncRTFDBSubscription | This call prepares the system such that it can yield a snapshot containing all asynchronous RT-FDB channels available at the moment of the call
Public method | StartAutoBalance | Auto balance a bridge channel
Public method | Stop | Stops an acquisition
Public method | StopAsyncRTFDBSubscription | This call cancels snapshot behavior, freeing up system resources
 | StorageActive | Check if the storage of a mainframe is active
Public method | SubscribeLiveWaveform | Function to subscribe to a live waveform stream
 | Trigger | This command initiates a trigger. Depending on the acquisition settings this can finish the active acquisition.
 | UnsubscribeLiveWaveform | Use this function to un-subscribe when your done using the data from a subscribed waveform
Top
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.Abort Method

IPerceptionCOMAbort Method

Stops an acquisition

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void Abort()
Sub Abort
void Abort()
abstract Abort : unit -> unit
Remarks
The current recording will be aborted. When in a sweep acquisition mode, an abort command while acquiring post-trigger data will be processed immediately, no additional data will be stored; If you want to complete the current sweep and stop after it finishes, you must select the stop command.
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMStart
IPerceptionCOMPause
IPerceptionCOMOneShot
IPerceptionCOMStop


IPerceptionCOM.ChannelScType Method

IPerceptionCOMChannelScType Method

Get the channel type of a channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void ChannelScType(
    string Mainframe,
    string Recorder,
    string Channel,
    out int Type
)
Sub ChannelScType (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    <OutAttribute> ByRef Type As Integer
)
void ChannelScType(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    [OutAttribute] int% Type
)
abstract ChannelScType :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Type : int byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
Type
Type: SystemInt32
Type of channel:
  • Differential = 0
  • Bridge = 1
  • Icp = 2
  • ThermoCouple = 3
Examples
Copy
int ChannelSignalConditionerMode;
string cMainframe = "GEN7t I";
string cRecorder = "Recorder A";
string cChannel = "Ch A1";

m_Perception.ChannelScType(cMainframe, cRecorder, cChannel, out ChannelSignalConditionerMode);
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.CloseActiveRecording Method

IPerceptionCOMCloseActiveRecording Method

Closes the currently active recording.

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void CloseActiveRecording()
Sub CloseActiveRecording
void CloseActiveRecording()
abstract CloseActiveRecording : unit -> unit
Remarks
The active recording cannot be closed if storage is still active. Use the StorageActive function to check if storage is still active.
Examples
Copy
protected bool CloseRecording()
{
      //single mainframe implementation

      // first check if the mainframe is not storing as the recording
      // cannot be closed while storage is active.
      bool bActive = false;
      m_Perception.StorageActive("%1%", out bActive);
      if(bActive)
           return false;

      // The mainframe is no longer recording, we can now close the recording
      m_Perception.CloseActiveRecording();

      int iLastError = 0;
      m_Perception.GetLastError(out iLastError);
      if(iLastError != 0)
           return false;

      return true;
}
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMStorageActive(String, Boolean)


IPerceptionCOM.Configuration Method

IPerceptionCOMConfiguration Method

Note: This API is now obsolete.

This method is no longer supported

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is no longer supported")]
void Configuration(
    string Mainframe,
    out string Config
)
<ObsoleteAttribute("This method is no longer supported")>
Sub Configuration (
    Mainframe As String,
    <OutAttribute> ByRef Config As String
)
[ObsoleteAttribute(L"This method is no longer supported")]
void Configuration(
    String^ Mainframe,
    [OutAttribute] String^% Config
)
[<ObsoleteAttribute("This method is no longer supported")>]
abstract Configuration :
        Mainframe : string *
        Config : string byref -> unit

Parameters

Mainframe
Type: SystemString
Config
Type: SystemString
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.ConnectToServer Method

IPerceptionCOMConnectToServer Method

Connects to Perception server

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void ConnectToServer()
Sub ConnectToServer
void ConnectToServer()
abstract ConnectToServer : unit -> unit
Examples
Copy
using PerceptionComRpc;

private PerceptionCOM m_Perception = new PerceptionCOM();

m_Perception.SetServerAddress("localhost");
m_Perception.ConnectToServer();

// Do your stuff

m_Perception.DisconnectFromServer();
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMDisconnectFromServer
IPerceptionCOMSetServerAddress(String)


IPerceptionCOM.ControlledStart Method

IPerceptionCOMControlledStart Method

Controlled start of the acquisition.

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void ControlledStart(
    bool reserved
)
Sub ControlledStart (
    reserved As Boolean
)
void ControlledStart(
    bool reserved
)
abstract ControlledStart :
        reserved : bool -> unit

Parameters

reserved
Type: SystemBoolean
From Perception 7.0 this parameter is no longer used in the execution of a controlled start.
Remarks
The controlledStart is used to start an acquisition using the start manager, while the start command does not do this and will always start. The start manager checks if the system is ready for starting; if not then dialogs can come up to inform the operator what to do. If for example an info field is set as required, and has not been filed in then the operator will be asked to enter the missing information. Do not use the controlled start if you want to remotely control an unattended Perception
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMStart
IPerceptionCOMPause
IPerceptionCOMOneShot
IPerceptionCOMAbort
IPerceptionCOMIsAcquisitionBlocked(Boolean)


IPerceptionCOM.CurrentlyActiveVWB Method

IPerceptionCOMCurrentlyActiveVWB Method

Returns the full path of the currently active virtual workbench

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void CurrentlyActiveVWB(
    out string Name
)
Sub CurrentlyActiveVWB (
    <OutAttribute> ByRef Name As String
)
void CurrentlyActiveVWB(
    [OutAttribute] String^% Name
)
abstract CurrentlyActiveVWB :
        Name : string byref -> unit

Parameters

Name
Type: SystemString
Full path of active virtual workbench
Examples
Copy
protected string GetActiveVWB()
{
      string strFullPath;
      m_Perception.CurrentlyActiveVWB(out strFullPath);
}
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.DisconnectFromServer Method

IPerceptionCOMDisconnectFromServer Method

Disconnects from Perception server

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void DisconnectFromServer()
Sub DisconnectFromServer
void DisconnectFromServer()
abstract DisconnectFromServer : unit -> unit
Examples
Copy
using PerceptionCOMRpc;

private PerceptionCOM m_Perception = new PerceptionCOM();

m_Perception.SetServerAddress("localhost");
m_Perception.ConnectToServer();

// Do your stuff

m_Perception.DisconnectFromServer();
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMConnectToServer
IPerceptionCOMSetServerAddress(String)


IPerceptionCOM.DSGetName Method

IPerceptionCOMDSGetName Method

Get the name of the data source

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void DSGetName(
    string DataSrcPath,
    out string Result
)
Sub DSGetName (
    DataSrcPath As String,
    <OutAttribute> ByRef Result As String
)
void DSGetName(
    String^ DataSrcPath,
    [OutAttribute] String^% Result
)
abstract DSGetName :
        DataSrcPath : string *
        Result : string byref -> unit

Parameters

DataSrcPath
Type: SystemString
Path/identifier of the data source
Result
Type: SystemString
Name of the data source
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMDSGetNumericalValue(String, Double, Double)
IPerceptionCOMDSGetStringValue(String, String)
IPerceptionCOMDSGetType(String, COMDSType)
IPerceptionCOMDSGetUnits(String, String, String)


IPerceptionCOM.DSGetNumericalValue Method

IPerceptionCOMDSGetNumericalValue Method

Get numerical value of the specified data source

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void DSGetNumericalValue(
    string DataSrcPath,
    out double Value,
    out double TimeOfUpdate
)
Sub DSGetNumericalValue (
    DataSrcPath As String,
    <OutAttribute> ByRef Value As Double,
    <OutAttribute> ByRef TimeOfUpdate As Double
)
void DSGetNumericalValue(
    String^ DataSrcPath,
    [OutAttribute] double% Value,
    [OutAttribute] double% TimeOfUpdate
)
abstract DSGetNumericalValue :
        DataSrcPath : string *
        Value : float byref *
        TimeOfUpdate : float byref -> unit

Parameters

DataSrcPath
Type: SystemString
Path/identifier of the data source
Value
Type: SystemDouble
Numerical value of the data source
TimeOfUpdate
Type: SystemDouble
Time since start recording that value was updated in case of hardware data sources
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMDSGetName(String, String)
IPerceptionCOMDSGetStringValue(String, String)
IPerceptionCOMDSGetType(String, COMDSType)
IPerceptionCOMDSGetUnits(String, String, String)


IPerceptionCOM.DSGetStringValue Method

IPerceptionCOMDSGetStringValue Method

Get the string value of the specified data source

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void DSGetStringValue(
    string DataSrcPath,
    out string Result
)
Sub DSGetStringValue (
    DataSrcPath As String,
    <OutAttribute> ByRef Result As String
)
void DSGetStringValue(
    String^ DataSrcPath,
    [OutAttribute] String^% Result
)
abstract DSGetStringValue :
        DataSrcPath : string *
        Result : string byref -> unit

Parameters

DataSrcPath
Type: SystemString
Path/identifier of the data source
Result
Type: SystemString
String value of the data source
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMDSGetName(String, String)
IPerceptionCOMDSGetNumericalValue(String, Double, Double)
IPerceptionCOMDSGetType(String, COMDSType)
IPerceptionCOMDSGetUnits(String, String, String)


IPerceptionCOM.DSGetType Method

IPerceptionCOMDSGetType Method

Get the type of the data source variable

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void DSGetType(
    string DataSrcPath,
    out COMDSType ResultType
)
Sub DSGetType (
    DataSrcPath As String,
    <OutAttribute> ByRef ResultType As COMDSType
)
void DSGetType(
    String^ DataSrcPath,
    [OutAttribute] COMDSType% ResultType
)
abstract DSGetType :
        DataSrcPath : string *
        ResultType : COMDSType byref -> unit

Parameters

DataSrcPath
Type: SystemString
Path/identifier of the data source
ResultType
Type: RPC_COMCOMDSType
Type of data source
Examples
Copy
bool IsString(string DataSrcID)
{
      COMDSType dt;
      DSGetType("System.Time", out dt);
      return dt == COMDSType_String ;
}
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMDSGetName(String, String)
IPerceptionCOMDSGetNumericalValue(String, Double, Double)
IPerceptionCOMDSGetStringValue(String, String)
IPerceptionCOMDSGetUnits(String, String, String)


IPerceptionCOM.DSGetUnits Method

IPerceptionCOMDSGetUnits Method

Get the horizontal and vertical units of the data source

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void DSGetUnits(
    string DataSrcPath,
    out string XUnit,
    out string YUnit
)
Sub DSGetUnits (
    DataSrcPath As String,
    <OutAttribute> ByRef XUnit As String,
    <OutAttribute> ByRef YUnit As String
)
void DSGetUnits(
    String^ DataSrcPath,
    [OutAttribute] String^% XUnit,
    [OutAttribute] String^% YUnit
)
abstract DSGetUnits :
        DataSrcPath : string *
        XUnit : string byref *
        YUnit : string byref -> unit

Parameters

DataSrcPath
Type: SystemString
Path/identifier of the data source
XUnit
Type: SystemString
The horizontal unit string
YUnit
Type: SystemString
The vertical unit string
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMDSGetName(String, String)
IPerceptionCOMDSGetNumericalValue(String, Double, Double)
IPerceptionCOMDSGetStringValue(String, String)
IPerceptionCOMDSGetType(String, COMDSType)


IPerceptionCOM.ExecuteCommand Method

IPerceptionCOMExecuteCommand Method

Executes a command as described by string Command

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void ExecuteCommand(
    string Topic,
    string Item,
    string Command
)
Sub ExecuteCommand (
    Topic As String,
    Item As String,
    Command As String
)
void ExecuteCommand(
    String^ Topic,
    String^ Item,
    String^ Command
)
abstract ExecuteCommand :
        Topic : string *
        Item : string *
        Command : string -> unit

Parameters

Topic
Type: SystemString
ID of the handler of the command
Item
Type: SystemString
Additional information which can be used by the handler of the command
Command
Type: SystemString
String which contains a description of the command to be executed
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMExecuteRequest(String, String, String, String)


IPerceptionCOM.ExecuteRequest Method

IPerceptionCOMExecuteRequest Method

Executes a request as described by string Request

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void ExecuteRequest(
    string Topic,
    string Item,
    string Request,
    out string Result
)
Sub ExecuteRequest (
    Topic As String,
    Item As String,
    Request As String,
    <OutAttribute> ByRef Result As String
)
void ExecuteRequest(
    String^ Topic,
    String^ Item,
    String^ Request,
    [OutAttribute] String^% Result
)
abstract ExecuteRequest :
        Topic : string *
        Item : string *
        Request : string *
        Result : string byref -> unit

Parameters

Topic
Type: SystemString
ID of the handler of the request
Item
Type: SystemString
Additional information which can be used by the handler of the request
Request
Type: SystemString
String which contains a description of the request
Result
Type: SystemString
Result of the request as string
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMExecuteCommand(String, String, String)


IPerceptionCOM.GetAcquisitionState Method

IPerceptionCOMGetAcquisitionState Method

Use this function to retrieve the acquisition status of all available recorders.

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetAcquisitionState(
    out int Run,
    out int OneShot,
    out int Stop,
    out int Pause,
    out int Idle
)
Sub GetAcquisitionState (
    <OutAttribute> ByRef Run As Integer,
    <OutAttribute> ByRef OneShot As Integer,
    <OutAttribute> ByRef Stop As Integer,
    <OutAttribute> ByRef Pause As Integer,
    <OutAttribute> ByRef Idle As Integer
)
void GetAcquisitionState(
    [OutAttribute] int% Run,
    [OutAttribute] int% OneShot,
    [OutAttribute] int% Stop,
    [OutAttribute] int% Pause,
    [OutAttribute] int% Idle
)
abstract GetAcquisitionState :
        Run : int byref *
        OneShot : int byref *
        Stop : int byref *
        Pause : int byref *
        Idle : int byref -> unit

Parameters

Run
Type: SystemInt32
Number of recorders currently running
OneShot
Type: SystemInt32
Number of recorders currently in sweep mode
Stop
Type: SystemInt32
Number of recorders currently stopped
Pause
Type: SystemInt32
Number of recorders currently in pause mode
Idle
Type: SystemInt32
Number of recorders currently idle
Examples
Copy
using PerceptionCOMRpc;

private PerceptionCOM m_Perception = new PerceptionCOM();

m_Perception.SetServerAddress("localhost");
m_Perception.ConnectToServer();

private void ShowAcquisitionState()
{
     int Run;
     int OneShot;
     int Stop;
     int Pause;
     int Idle;
     m_Perception.GetAcquisitionState(out Run, out OneShot, out Stop, out Pause, out Idle);
     label1.Text = "Run: " + Run.ToString() + " OneShot: " + OneShot.ToString() +
                  " Stop: " + Stop.ToString() + " Pause: " + Pause.ToString() +
                  " Idle: " + Idle.ToString();
}
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetTriggerState(Int32, Int32, Int32, Int32, Int32, Int32, Int32)


IPerceptionCOM.GetActiveSheet Method

IPerceptionCOMGetActiveSheet Method

Returns the name of the currently active sheet

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetActiveSheet(
    out string Name
)
Sub GetActiveSheet (
    <OutAttribute> ByRef Name As String
)
void GetActiveSheet(
    [OutAttribute] String^% Name
)
abstract GetActiveSheet :
        Name : string byref -> unit

Parameters

Name
Type: SystemString
Name of the active sheet
Examples
Copy
protected void SelectActiveSheetInList()
{
      string strActive;
      m_Perception.GetActiveSheet(out strActive);

      int iActiveSheetIndexInList = 0;
      //.. insert code to find this sheet in the list

      lstSheets.SelectedIndex = iActiveSheetIndexInList;
}
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetSheetCount(Int32)
IPerceptionCOMGetSheetName(Int32, String)
IPerceptionCOMSetActiveSheet(String)


IPerceptionCOM.GetAlarmLevelSettings Method

IPerceptionCOMGetAlarmLevelSettings Method

Get the alarm settings of a channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetAlarmLevelSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    int Mask,
    out int Mode,
    out double PrimaryLevel,
    out double SecondaryLevel,
    out int Direction,
    out int ChannelSelect
)
Sub GetAlarmLevelSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As Integer,
    <OutAttribute> ByRef Mode As Integer,
    <OutAttribute> ByRef PrimaryLevel As Double,
    <OutAttribute> ByRef SecondaryLevel As Double,
    <OutAttribute> ByRef Direction As Integer,
    <OutAttribute> ByRef ChannelSelect As Integer
)
void GetAlarmLevelSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    int Mask,
    [OutAttribute] int% Mode,
    [OutAttribute] double% PrimaryLevel,
    [OutAttribute] double% SecondaryLevel,
    [OutAttribute] int% Direction,
    [OutAttribute] int% ChannelSelect
)
abstract GetAlarmLevelSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : int *
        Mode : int byref *
        PrimaryLevel : float byref *
        SecondaryLevel : float byref *
        Direction : int byref *
        ChannelSelect : int byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

  • if Mask = 1 then only the first parameter will be returned in this case Mode
  • if Mask = 2 then only the second parameter will be returned in this case PrimaryLevel
Mode
Type: SystemInt32
Alarm mode:
  • Off = 0
  • Basic = 1
  • Dual = 2
PrimaryLevel
Type: SystemDouble
Primary level in user units for the alarm detection
SecondaryLevel
Type: SystemDouble
Secondary level in user units for the alarm detection
Direction
Type: SystemInt32
Sets the response direction of the primary level. The secondary level will be set to the opposite direction.
  • Rising Edge = 0
  • Falling Edge = 1
ChannelSelect
Type: SystemInt32
UNKNOWN
Examples
Copy
int Mode;
double PrimaryLevel;
double SecondaryLevel;
int Direction;
int ChannelSelect;

RPC.GetAlarmLevelSettings("Rack1", "Recorder A", "Ch A1", Mask, out Mode, out PrimaryLevel, out SecondaryLevel, out Direction, out ChannelSelect);
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetAlarmLevelSettings(String, String, String, Int32, Int32, Double, Double, Int32, Int32)


IPerceptionCOM.GetArchiveFolder Method

IPerceptionCOMGetArchiveFolder Method

Get current archive folder.

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetArchiveFolder(
    out string ArchiveFolder
)
Sub GetArchiveFolder (
    <OutAttribute> ByRef ArchiveFolder As String
)
void GetArchiveFolder(
    [OutAttribute] String^% ArchiveFolder
)
abstract GetArchiveFolder :
        ArchiveFolder : string byref -> unit

Parameters

ArchiveFolder
Type: SystemString
Current archive folder
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetArchiveFolder(String)


IPerceptionCOM.GetAsyncRTFDBNames Method

IPerceptionCOMGetAsyncRTFDBNames Method

This call returns a list of Names in the same order as the GetAsyncRTFDBValues.

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetAsyncRTFDBNames(
    out Array Names
)
Sub GetAsyncRTFDBNames (
    <OutAttribute> ByRef Names As Array
)
void GetAsyncRTFDBNames(
    [OutAttribute] Array^% Names
)
abstract GetAsyncRTFDBNames :
        Names : Array byref -> unit

Parameters

Names
Type: SystemArray
An array containing the names
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMStartAsyncRTFDBSubscription
IPerceptionCOMStopAsyncRTFDBSubscription
IPerceptionCOMGetAsyncRTFDBValues(Double, Array)


IPerceptionCOM.GetAsyncRTFDBValues Method

IPerceptionCOMGetAsyncRTFDBValues Method

Returns a time-stamp and a set of values for all asynchronous channels. Synchronized means all values apply against the exact same time-stamp The time-stamp is as recent as can be, but never newer than the oldest update of any channel. Example: Consider a 2 channel system, one channel updates at 100 times/second and the other at 1 time/second. This system is ‘probed’ by calling GetAsyncRTFDB() 100 times/second. For this setup the time stamp of the results will change at a rate of 1 time/second. The supplied values would change for each call (only for the fast channel).

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetAsyncRTFDBValues(
    out double TimeStamp,
    out Array Values
)
Sub GetAsyncRTFDBValues (
    <OutAttribute> ByRef TimeStamp As Double,
    <OutAttribute> ByRef Values As Array
)
void GetAsyncRTFDBValues(
    [OutAttribute] double% TimeStamp,
    [OutAttribute] Array^% Values
)
abstract GetAsyncRTFDBValues :
        TimeStamp : float byref *
        Values : Array byref -> unit

Parameters

TimeStamp
Type: SystemDouble
The time-stamp used for the values
Values
Type: SystemArray
An array containing the values at the time-stamp
Remarks

This call is based on live subscriptions - a mechanism that might temporarily drop in case of high network load. Also, it comes with inherent jitter on delivery times of individual channels. Therefore it might occur that repetitive GetAsyncRTFDBValues() calls would yield the same time-stamp, yet the value for some channels might be updated to a more recent value. This call will never yield more than 20 updates per second

An example with 3 asynchronous channels, producing updates with different rhythms (i.e cycles are detected at different rates).

See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetAsyncRTFDBNames(Array)
IPerceptionCOMStartAsyncRTFDBSubscription
IPerceptionCOMStopAsyncRTFDBSubscription


IPerceptionCOM.GetAutomationEnabled Method

IPerceptionCOMGetAutomationEnabled Method

Gets the recording automation enabled

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetAutomationEnabled(
    out bool Enabled
)
Sub GetAutomationEnabled (
    <OutAttribute> ByRef Enabled As Boolean
)
void GetAutomationEnabled(
    [OutAttribute] bool% Enabled
)
abstract GetAutomationEnabled :
        Enabled : bool byref -> unit

Parameters

Enabled
Type: SystemBoolean
true if the recording automation is enabled, false otherwise.
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetAutomationEnabled(Boolean)


IPerceptionCOM.GetAvailableWaveforms Method

IPerceptionCOMGetAvailableWaveforms Method

Retrieve all available waveform names

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetAvailableWaveforms(
    out Array waveForms
)
Sub GetAvailableWaveforms (
    <OutAttribute> ByRef waveForms As Array
)
void GetAvailableWaveforms(
    [OutAttribute] Array^% waveForms
)
abstract GetAvailableWaveforms :
        waveForms : Array byref -> unit

Parameters

waveForms
Type: SystemArray
string array that holds the found waveform names
Remarks
This function is used to retrieve live data. It is used together with the functions SubscribeLiveWaveform, UnsubscribeLiveWaveform and GetData.

These functions to fetch a data stream from available waveforms. For each waveform a subscription is needed in order to get the data. This is the same live data that is on a Perception display, i.e. reduced using min-max pairs.

Examples
Copy
// Get all available waveforms
private void btnGetAvailableWaveforms_Click(object sender, EventArgs e)
{
     listBox1.Items.Clear();
     Array aWaveformNames;
     m_Perception.GetAvailableWaveforms(out aWaveformNames);

     string[] strWaveformNames = aWaveformNames as string[];

     // Show names in a listbox
     for (int i = 0; i < strWaveformNames.Length; i++)
     {
          listBox1.Items.Add(strWaveformNames[i]);
     }
}
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSubscribeLiveWaveform(String, Int32, Double, Int32, Double, Int32)
IPerceptionCOMUnsubscribeLiveWaveform(Int32)
IPerceptionCOMGetData(Int32, Int32, Int32, Array, Array, Array, Int32, Array, Array, Int32)


IPerceptionCOM.GetCalcChannelEnabled Method

IPerceptionCOMGetCalcChannelEnabled Method

Gets if channel is enabled or disabled

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetCalcChannelEnabled(
    string Mainframe,
    string Recorder,
    string Channel,
    out bool Enabled
)
Sub GetCalcChannelEnabled (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    <OutAttribute> ByRef Enabled As Boolean
)
void GetCalcChannelEnabled(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    [OutAttribute] bool% Enabled
)
abstract GetCalcChannelEnabled :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Enabled : bool byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Calculated channel name or index
Enabled
Type: SystemBoolean
true to enable the channel, false to disable
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.GetCalcChannelName Method

IPerceptionCOMGetCalcChannelName Method

Gets the user name of a channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetCalcChannelName(
    string Mainframe,
    string Recorder,
    string Channel,
    out string Name
)
Sub GetCalcChannelName (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    <OutAttribute> ByRef Name As String
)
void GetCalcChannelName(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    [OutAttribute] String^% Name
)
abstract GetCalcChannelName :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Name : string byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Calculated channel name or index
Name
Type: SystemString
Name of the channel
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.GetCalcCommonSettings Method

IPerceptionCOMGetCalcCommonSettings Method

Sets general settings of the channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetCalcCommonSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    COMCalcCommonSettingsSettingItem Mask,
    out bool Enabled,
    out string PhysicalName,
    out string Name,
    out long PrimaryColor,
    out long SecondaryColor,
    out bool PublishFieldBus,
    out string UserNote1,
    out string UserNote2,
    out string UserNote3,
    out string UserNote4
)
Sub GetCalcCommonSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As COMCalcCommonSettingsSettingItem,
    <OutAttribute> ByRef Enabled As Boolean,
    <OutAttribute> ByRef PhysicalName As String,
    <OutAttribute> ByRef Name As String,
    <OutAttribute> ByRef PrimaryColor As Long,
    <OutAttribute> ByRef SecondaryColor As Long,
    <OutAttribute> ByRef PublishFieldBus As Boolean,
    <OutAttribute> ByRef UserNote1 As String,
    <OutAttribute> ByRef UserNote2 As String,
    <OutAttribute> ByRef UserNote3 As String,
    <OutAttribute> ByRef UserNote4 As String
)
void GetCalcCommonSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    COMCalcCommonSettingsSettingItem Mask,
    [OutAttribute] bool% Enabled,
    [OutAttribute] String^% PhysicalName,
    [OutAttribute] String^% Name,
    [OutAttribute] long long% PrimaryColor,
    [OutAttribute] long long% SecondaryColor,
    [OutAttribute] bool% PublishFieldBus,
    [OutAttribute] String^% UserNote1,
    [OutAttribute] String^% UserNote2,
    [OutAttribute] String^% UserNote3,
    [OutAttribute] String^% UserNote4
)
abstract GetCalcCommonSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : COMCalcCommonSettingsSettingItem *
        Enabled : bool byref *
        PhysicalName : string byref *
        Name : string byref *
        PrimaryColor : int64 byref *
        SecondaryColor : int64 byref *
        PublishFieldBus : bool byref *
        UserNote1 : string byref *
        UserNote2 : string byref *
        UserNote3 : string byref *
        UserNote4 : string byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Calculated channel name or index
Mask
Type: RPC_COMCOMCalcCommonSettingsSettingItem
Parameter mask, 0xFF, applies all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

Enabled
Type: SystemBoolean
Indicates if a channel is enabled or disabled
PhysicalName
Type: SystemString
The physical name of the channel, fixed, may change depending on the math-type settings of the channel
Name
Type: SystemString
User name assigned to the channel
PrimaryColor
Type: SystemInt64
Primary color of the channel
SecondaryColor
Type: SystemInt64
Secondary color of the channel, currently unused
PublishFieldBus
Type: SystemBoolean
Indicates if and how a channel should be published on a field-bus
UserNote1
Type: SystemString
Entry field for user comments 1
UserNote2
Type: SystemString
Entry field for user comments 2
UserNote3
Type: SystemString
Entry field for user comments 3
UserNote4
Type: SystemString
Entry field for user comments 4
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.GetCalcInputRangeSettings Method

IPerceptionCOMGetCalcInputRangeSettings Method

Get the measurement range of the channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetCalcInputRangeSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    COMCalcInputRangeSettingsSettingItem Mask,
    out double UpperValue,
    out double LowerValue
)
Sub GetCalcInputRangeSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As COMCalcInputRangeSettingsSettingItem,
    <OutAttribute> ByRef UpperValue As Double,
    <OutAttribute> ByRef LowerValue As Double
)
void GetCalcInputRangeSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    COMCalcInputRangeSettingsSettingItem Mask,
    [OutAttribute] double% UpperValue,
    [OutAttribute] double% LowerValue
)
abstract GetCalcInputRangeSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : COMCalcInputRangeSettingsSettingItem *
        UpperValue : float byref *
        LowerValue : float byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Calculated channel name or index
Mask
Type: RPC_COMCOMCalcInputRangeSettingsSettingItem
Parameter mask, 0xFF, applies all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

UpperValue
Type: SystemDouble
Upper limit to measurement range
LowerValue
Type: SystemDouble
Lower limit to measurement range
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
RPC_COMCOMCalcInputRangeSettingsSettingItem
IPerceptionCOMSetCalcInputRangeSettings(String, String, String, COMCalcInputRangeSettingsSettingItem, Double, Double)


IPerceptionCOM.GetCalcMathSettings Method

IPerceptionCOMGetCalcMathSettings Method

Set the math calculation settings for the calculated channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetCalcMathSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    COMCalculatedMathSettingsSettingItem Mask,
    out COMCalculatedMathType MathType,
    out long Detector,
    out Array InputChannels
)
Sub GetCalcMathSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As COMCalculatedMathSettingsSettingItem,
    <OutAttribute> ByRef MathType As COMCalculatedMathType,
    <OutAttribute> ByRef Detector As Long,
    <OutAttribute> ByRef InputChannels As Array
)
void GetCalcMathSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    COMCalculatedMathSettingsSettingItem Mask,
    [OutAttribute] COMCalculatedMathType% MathType,
    [OutAttribute] long long% Detector,
    [OutAttribute] Array^% InputChannels
)
abstract GetCalcMathSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : COMCalculatedMathSettingsSettingItem *
        MathType : COMCalculatedMathType byref *
        Detector : int64 byref *
        InputChannels : Array byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Calculated channel name or index
Mask
Type: RPC_COMCOMCalculatedMathSettingsSettingItem
Parameter mask, 0xFF, applies all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

MathType
Type: RPC_COMCOMCalculatedMathType
The math to be supported by the channel
Detector
Type: SystemInt64
The cycle detection source to consume
InputChannels
Type: SystemArray
The names of the input channels to be used by the calculation, max of 6, requirement depends on selected math type
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetCalcMathSettings(String, String, String, COMCalculatedMathSettingsSettingItem, COMCalculatedMathType, Int64, Array)


IPerceptionCOM.GetCalcTriggerSettings Method

IPerceptionCOMGetCalcTriggerSettings Method

Gets the trigger settings for the specified channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetCalcTriggerSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    COMCalcTriggerSettingsSettingItem Mask,
    out COMChannelTriggerMode Mode,
    out double PrimaryLevel,
    out double SecondaryLevel,
    out COMChannelTriggerDirection Direction,
    out double Hysteresis
)
Sub GetCalcTriggerSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As COMCalcTriggerSettingsSettingItem,
    <OutAttribute> ByRef Mode As COMChannelTriggerMode,
    <OutAttribute> ByRef PrimaryLevel As Double,
    <OutAttribute> ByRef SecondaryLevel As Double,
    <OutAttribute> ByRef Direction As COMChannelTriggerDirection,
    <OutAttribute> ByRef Hysteresis As Double
)
void GetCalcTriggerSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    COMCalcTriggerSettingsSettingItem Mask,
    [OutAttribute] COMChannelTriggerMode% Mode,
    [OutAttribute] double% PrimaryLevel,
    [OutAttribute] double% SecondaryLevel,
    [OutAttribute] COMChannelTriggerDirection% Direction,
    [OutAttribute] double% Hysteresis
)
abstract GetCalcTriggerSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : COMCalcTriggerSettingsSettingItem *
        Mode : COMChannelTriggerMode byref *
        PrimaryLevel : float byref *
        SecondaryLevel : float byref *
        Direction : COMChannelTriggerDirection byref *
        Hysteresis : float byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Calculated channel name or index
Mask
Type: RPC_COMCOMCalcTriggerSettingsSettingItem
Parameter mask, 0xFF, applies all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

Mode
Type: RPC_COMCOMChannelTriggerMode
Trigger mode used
PrimaryLevel
Type: SystemDouble
Primary trigger level
SecondaryLevel
Type: SystemDouble
Secondary trigger level, usage depends on mode
Direction
Type: RPC_COMCOMChannelTriggerDirection
Trigger direction of primary level, secondary trigger will trigger in reverse direction
Hysteresis
Type: SystemDouble
Hysteresis applied on trigger level(s)
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.GetCalculatedChannelCount Method

IPerceptionCOMGetCalculatedChannelCount Method

Get the number of calculated channels available on a recorder, note that this number may change depending on system configuration

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetCalculatedChannelCount(
    string Mainframe,
    string Recorder,
    out long Count
)
Sub GetCalculatedChannelCount (
    Mainframe As String,
    Recorder As String,
    <OutAttribute> ByRef Count As Long
)
void GetCalculatedChannelCount(
    String^ Mainframe,
    String^ Recorder,
    [OutAttribute] long long% Count
)
abstract GetCalculatedChannelCount :
        Mainframe : string *
        Recorder : string *
        Count : int64 byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Count
Type: SystemInt64
Number of available calculated channels, this number may differ depending system parameters such as the sampling rate and board type.
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.GetCalcUserScalingSettings Method

IPerceptionCOMGetCalcUserScalingSettings Method

Sets the settings used to transform between physical units and user units

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetCalcUserScalingSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    COMUserScalingSettingItem Mask,
    out double Multiplier,
    out double Offset,
    out string UserUnits
)
Sub GetCalcUserScalingSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As COMUserScalingSettingItem,
    <OutAttribute> ByRef Multiplier As Double,
    <OutAttribute> ByRef Offset As Double,
    <OutAttribute> ByRef UserUnits As String
)
void GetCalcUserScalingSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    COMUserScalingSettingItem Mask,
    [OutAttribute] double% Multiplier,
    [OutAttribute] double% Offset,
    [OutAttribute] String^% UserUnits
)
abstract GetCalcUserScalingSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : COMUserScalingSettingItem *
        Multiplier : float byref *
        Offset : float byref *
        UserUnits : string byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Calculated channel name or index
Mask
Type: RPC_COMCOMUserScalingSettingItem
Parameter mask, 0xFF, applies all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

The conversion from physical to user units is done using the following function: UserSampelValue = Offset + (Multiplier*PhysicalSampleValue)

Multiplier
Type: SystemDouble
Multiplier applied to convert from physical to user units
Offset
Type: SystemDouble
Offset applied to convert from physical to user units
UserUnits
Type: SystemString
User units string
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.GetCalibrationInfo Method

IPerceptionCOMGetCalibrationInfo Method

Get channel calibration information

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetCalibrationInfo(
    string Mainframe,
    string Recorder,
    string Channel,
    int Mask,
    out double CalibrationDate,
    out double VerificationDate,
    out string CalibrationLab,
    out string VerificationLab
)
Sub GetCalibrationInfo (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As Integer,
    <OutAttribute> ByRef CalibrationDate As Double,
    <OutAttribute> ByRef VerificationDate As Double,
    <OutAttribute> ByRef CalibrationLab As String,
    <OutAttribute> ByRef VerificationLab As String
)
void GetCalibrationInfo(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    int Mask,
    [OutAttribute] double% CalibrationDate,
    [OutAttribute] double% VerificationDate,
    [OutAttribute] String^% CalibrationLab,
    [OutAttribute] String^% VerificationLab
)
abstract GetCalibrationInfo :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : int *
        CalibrationDate : float byref *
        VerificationDate : float byref *
        CalibrationLab : string byref *
        VerificationLab : string byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case CalibrationDate

if Mask = 2 then only the second parameter will be returned in this case VerificationDate

if Mask = 3 then both the first and second parameter will be returned

CalibrationDate
Type: SystemDouble
Calibration date
VerificationDate
Type: SystemDouble
Verification date
CalibrationLab
Type: SystemString
Calibration lab
VerificationLab
Type: SystemString
Verification lab
Examples
Copy
string cMainframe = "GEN7t I";
string cRecorder = "Recorder A";
string cChannel = "Ch A1";

int Mask = 0xFF;

double CalibrationDate;
double VerificationDate;
string CalibrationLab;
string VerificationLab;

RPC.GetCalibrationInfo(cMainframe, cRecorder, cChannel, Mask, out CalibrationDate, out VerificationDate, out CalibrationLab, out VerificationLab);

DateTime CalDate = DateTime.FromOADate(CalibrationDate);
lblCalibrationDate.Text = CalDate.ToShortDateString();
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.GetCalibrationSettings Method

IPerceptionCOMGetCalibrationSettings Method

Get the calibration settings of a channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetCalibrationSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    int Mask,
    out int Method,
    out double StartPointReference,
    out double StartPointActual,
    out double EndPointReference,
    out double EndPointActual,
    out bool UseShuntForEndPoint,
    out double ShuntStabilizeTime,
    out bool ManualEntry
)
Sub GetCalibrationSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As Integer,
    <OutAttribute> ByRef Method As Integer,
    <OutAttribute> ByRef StartPointReference As Double,
    <OutAttribute> ByRef StartPointActual As Double,
    <OutAttribute> ByRef EndPointReference As Double,
    <OutAttribute> ByRef EndPointActual As Double,
    <OutAttribute> ByRef UseShuntForEndPoint As Boolean,
    <OutAttribute> ByRef ShuntStabilizeTime As Double,
    <OutAttribute> ByRef ManualEntry As Boolean
)
void GetCalibrationSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    int Mask,
    [OutAttribute] int% Method,
    [OutAttribute] double% StartPointReference,
    [OutAttribute] double% StartPointActual,
    [OutAttribute] double% EndPointReference,
    [OutAttribute] double% EndPointActual,
    [OutAttribute] bool% UseShuntForEndPoint,
    [OutAttribute] double% ShuntStabilizeTime,
    [OutAttribute] bool% ManualEntry
)
abstract GetCalibrationSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : int *
        Method : int byref *
        StartPointReference : float byref *
        StartPointActual : float byref *
        EndPointReference : float byref *
        EndPointActual : float byref *
        UseShuntForEndPoint : bool byref *
        ShuntStabilizeTime : float byref *
        ManualEntry : bool byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case Method

if Mask = 2 then only the second parameter will be returned in this case StartPointReference

if Mask = 3 then both the first and second parameter will be returned

Method
Type: SystemInt32
Channel calibration method
  • None = 0
  • SinglePoint = 1
  • TwoPoint = 2
StartPointReference
Type: SystemDouble
Reference start point
StartPointActual
Type: SystemDouble
Actual start point
EndPointReference
Type: SystemDouble
Reference end point
EndPointActual
Type: SystemDouble
Actual end point
UseShuntForEndPoint
Type: SystemBoolean
Enable shunt for end point
ShuntStabilizeTime
Type: SystemDouble
Shunt stabilization time in seconds
ManualEntry
Type: SystemBoolean
Enable manual entry
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetCalibrationSettings(String, String, String, Int32, Int32, Double, Double, Double, Double, Boolean, Double, Boolean)


IPerceptionCOM.GetChannelBatteryStatus Method

IPerceptionCOMGetChannelBatteryStatus Method

Get the battery status of a fiber channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetChannelBatteryStatus(
    string Mainframe,
    string Recorder,
    string Channel,
    int Index,
    out bool BatteryPresent,
    out COMBatAgeStatus AgeStatus,
    out int CycleCount,
    out COMBatChargeStat ChargeStatus,
    out double Current,
    out double Voltage,
    out double Temperature,
    out int CapacityRemainingPercentage,
    out double TotalCapacity
)
Sub GetChannelBatteryStatus (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Index As Integer,
    <OutAttribute> ByRef BatteryPresent As Boolean,
    <OutAttribute> ByRef AgeStatus As COMBatAgeStatus,
    <OutAttribute> ByRef CycleCount As Integer,
    <OutAttribute> ByRef ChargeStatus As COMBatChargeStat,
    <OutAttribute> ByRef Current As Double,
    <OutAttribute> ByRef Voltage As Double,
    <OutAttribute> ByRef Temperature As Double,
    <OutAttribute> ByRef CapacityRemainingPercentage As Integer,
    <OutAttribute> ByRef TotalCapacity As Double
)
void GetChannelBatteryStatus(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    int Index,
    [OutAttribute] bool% BatteryPresent,
    [OutAttribute] COMBatAgeStatus% AgeStatus,
    [OutAttribute] int% CycleCount,
    [OutAttribute] COMBatChargeStat% ChargeStatus,
    [OutAttribute] double% Current,
    [OutAttribute] double% Voltage,
    [OutAttribute] double% Temperature,
    [OutAttribute] int% CapacityRemainingPercentage,
    [OutAttribute] double% TotalCapacity
)
abstract GetChannelBatteryStatus :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Index : int *
        BatteryPresent : bool byref *
        AgeStatus : COMBatAgeStatus byref *
        CycleCount : int byref *
        ChargeStatus : COMBatChargeStat byref *
        Current : float byref *
        Voltage : float byref *
        Temperature : float byref *
        CapacityRemainingPercentage : int byref *
        TotalCapacity : float byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
Index
Type: SystemInt32
Battery index: 1 = Battery A, 2 = Battery B
BatteryPresent
Type: SystemBoolean
Battery present
AgeStatus
Type: RPC_COMCOMBatAgeStatus
Age Status
CycleCount
Type: SystemInt32
Number of battery charge cycles to date for battery A/B
ChargeStatus
Type: RPC_COMCOMBatChargeStat
Indication of the charge status of battery A/B.
Current
Type: SystemDouble
Current of battery A/B. A positive value indicates that the battery is loading
Voltage
Type: SystemDouble
Voltage supplied by battery A/B
Temperature
Type: SystemDouble
Temperature in C° of battery A/B
CapacityRemainingPercentage
Type: SystemInt32
Remaining total battery capacity of all installed batteries together in %

Some front-ends include two batteries. When one battery has 100 % and the other one has 80 % capacity, the total capacity remaining equals 90 %.

TotalCapacity
Type: SystemDouble
Capacity in Ah.

The amount of electrical energy battery A/B can deliver over a certain period of time, measured in Ampere-hours (Ah)

Examples
Copy
private bool GetChannelBatteryStatus()
{
      string cMainframe = "GEN7t I";
      string cRecorder = "Recorder A";
      string cChannel = "Ch A1";

     bool BatteryPresent;
     COMBatAgeStatus AgeStatus;
     int CycleCount;
     COMBatChargeStat ChargeStatus;
     double Current;
     double Voltage;
     double Temperature;
     int CapacityRemainingPercentage;
     double TotalCapacity;

     // Battery A
     m_Perception.GetChannelBatteryStatus(cMainframe, cRecorder, cChannel, 1, out BatteryPresent, out AgeStatus, out CycleCount,
                                  out ChargeStatus, out Current, out Voltage, out Temperature, out CapacityRemainingPercentage, out TotalCapacity);

     if (BatteryPresent)
     {
          grbxBatteryA.Enabled = true;
          lblBatteryAPresent.Text = "Yes";

          switch (AgeStatus)
          {
               case COMBatAgeStatus.COMBatAgeStatus_Nominal:
                    lblAgeStatusBatteryA.Text = "Nominal";
                    break;
               case COMBatAgeStatus.COMBatAgeStatus_ReplaceNow:
                    lblAgeStatusBatteryA.Text = "Replace Now";
                    break;
               case COMBatAgeStatus.COMBatAgeStatus_ReplaceSoon:
                    lblAgeStatusBatteryA.Text = "Replace Soon";
                    break;
               case COMBatAgeStatus.COMBatAgeStatus_Unknown:
                    lblAgeStatusBatteryA.Text = "Unknown";
                    break;
               default:
                    lblAgeStatusBatteryA.Text = "Unknown";
                    break;
          }

          lblCyclecountBatteryA.Text = CycleCount.ToString();

          switch (ChargeStatus)
          {
               case COMBatChargeStat.COMBatChargeStat_ChargeCompleted:
                    lblChargeStatusBatteryA.Text = "Charge completed";
                    break;
               case COMBatChargeStat.COMBatChargeStat_Charging:
                    lblChargeStatusBatteryA.Text = "Charging";
                    break;
               case COMBatChargeStat.COMBatChargeStat_DisCharging:
                    lblChargeStatusBatteryA.Text = "Discharging";
                    break;
               case COMBatChargeStat.COMBatChargeStat_Idle:
                    lblChargeStatusBatteryA.Text = "Idle";
                    break;
               default:
                    lblChargeStatusBatteryA.Text = "Unknown";
                    break;
          }

          lblCurrentBatteryA.Text = Current.ToString() + " A";
          lblVoltageBatteryA.Text = Voltage.ToString() + " V";
          lblTemperatureBatteryA.Text = Temperature.ToString() + " °C";
          lblRemainingCapacityBateryA.Text = CapacityRemainingPercentage.ToString() + " %";
          lblTotalCapacityBatteryA.Text = TotalCapacity.ToString(("#,###.00")) + " Ah";
     }
     else
     {
          grbxBatteryA.Enabled = false;
          lblBatteryAPresent.Text = "No";
     }
}
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.GetChannelEnabled Method

IPerceptionCOMGetChannelEnabled Method

Returns whether a channels data is stored or not.

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetChannelEnabled(
    string Mainframe,
    string Recorder,
    string Channel,
    out bool Enabled
)
Sub GetChannelEnabled (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    <OutAttribute> ByRef Enabled As Boolean
)
void GetChannelEnabled(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    [OutAttribute] bool% Enabled
)
abstract GetChannelEnabled :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Enabled : bool byref -> unit

Parameters

Mainframe
Type: SystemString
Name or index of mainframe
Recorder
Type: SystemString
Name or index of recorder
Channel
Type: SystemString
Name or index of channel
Enabled
Type: SystemBoolean
Channel enabled true or false
Remarks
Examples
Copy
string cMainframe = "GEN7t I";
string cRecorder = "Recorder A";
string cChannel = "Ch A1";
bool bEnabled;

m_Perception.GetChannelEnabled(cMainframe, cRecorder, cChannel, out bEnabled);

if (bEnabled)
   lblStorage.Text = "Storage ON";
else
   lblStorage.Text = "Storage OFF";
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetChannelEnabled(String, String, String, Boolean)
IPerceptionCOMGetEventChannelEnabled(String, String, String, Boolean)
IPerceptionCOMSetEventChannelEnabled(String, String, String, Boolean)
IPerceptionCOMGetTimerCounterChannelEnabled(String, String, String, Boolean)
IPerceptionCOMSetTimerCounterChannelEnabled(String, String, String, Boolean)


IPerceptionCOM.GetChannelName Method

IPerceptionCOMGetChannelName Method

Retrieve the name of a channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetChannelName(
    string MainframeIndex,
    string RecorderIndex,
    string ChannelIndex,
    out string Name
)
Sub GetChannelName (
    MainframeIndex As String,
    RecorderIndex As String,
    ChannelIndex As String,
    <OutAttribute> ByRef Name As String
)
void GetChannelName(
    String^ MainframeIndex,
    String^ RecorderIndex,
    String^ ChannelIndex,
    [OutAttribute] String^% Name
)
abstract GetChannelName :
        MainframeIndex : string *
        RecorderIndex : string *
        ChannelIndex : string *
        Name : string byref -> unit

Parameters

MainframeIndex
Type: SystemString
Mainframe index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

RecorderIndex
Type: SystemString
Recorder index; one based
ChannelIndex
Type: SystemString
Channel index; one based
Name
Type: SystemString
Name of the channel
Examples
Copy
// Get the names of all the channels belonging to a selected mainframe/recorder in the system
private void GetChannelNames()
{
     // Clear Combo-box
     cbxChannels.Items.Clear();

     if (m_Perception == null) return;
     if (!m_bConnected) return;

     if (cbxMainframes.SelectedIndex < 0)
     {
          MessageBox.Show(this, "Can not continue because there is no mainframe selected!", Application.ProductName);
          return;
     }
     string cMainframeName = cbxMainframes.SelectedItem.ToString();

     if (cbxRecorders.SelectedIndex < 0)
     {
          MessageBox.Show(this, "Can not continue because there is no Recorder selected!", Application.ProductName);
          return;
     }

     string cRecorderName = cbxRecorders.SelectedItem.ToString();

     int nChannelIndex = 1;
     string cChannelIndex = "";
     string cChannelName = "";
     do
     {
          // Index is surrounded by $ character!!!
          cChannelIndex = "$" + nChannelIndex.ToString() + "$";
          m_Perception.GetChannelName(cMainframeName, cRecorderName, cChannelIndex, out cChannelName);
          if (string.IsNullOrEmpty(cChannelName))
               break;
          // Add Channel to combo-box
          cbxChannels.Items.Add(cChannelName);
          nChannelIndex++;
     } while (true);

     // Let the combo-box show the first available Channel
     if (cbxChannels.Items.Count > 0)
          cbxChannels.SelectedIndex = 0;
}
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetMainframeName(String, String)
IPerceptionCOMGetRecorderName(String, String, String)


IPerceptionCOM.GetCommonSettings Method

IPerceptionCOMGetCommonSettings Method

Get the common settings of a mainframe

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetCommonSettings(
    string Mainframe,
    int Mask,
    out string Name,
    out double RealTimeClock
)
Sub GetCommonSettings (
    Mainframe As String,
    Mask As Integer,
    <OutAttribute> ByRef Name As String,
    <OutAttribute> ByRef RealTimeClock As Double
)
void GetCommonSettings(
    String^ Mainframe,
    int Mask,
    [OutAttribute] String^% Name,
    [OutAttribute] double% RealTimeClock
)
abstract GetCommonSettings :
        Mainframe : string *
        Mask : int *
        Name : string byref *
        RealTimeClock : float byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case Name

if Mask = 2 then only the second parameter will be returned in this case RealTimeClock

Name
Type: SystemString
Returns the name of the mainframe
RealTimeClock
Type: SystemDouble
Returns the time of the real-time clock, use DateTime.FromOADate() to convert from double to DateTime
Examples
Copy
protected override void btnGet_Click(object sender, EventArgs e)
{
     int Mask = 0xFF;
     string cName;
     double dRealTimeClock;

     RPC.GetCommonSettings(SelectedMainframe, Mask, out cName, out dRealTimeClock);

     txtName.Text = cName;
     DateTime dt = DateTime.FromOADate(dRealTimeClock);

     txtRealTimeClock.Text = dRealTimeClock.ToString();
     dateTimePicker1.Value = dt;
}
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetCommonSettings(String, Int32, String, Double)


IPerceptionCOM.GetCommunicationAddress Method

IPerceptionCOMGetCommunicationAddress Method

Get the communication address of a mainframe

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetCommunicationAddress(
    string Mainframe,
    out string Address
)
Sub GetCommunicationAddress (
    Mainframe As String,
    <OutAttribute> ByRef Address As String
)
void GetCommunicationAddress(
    String^ Mainframe,
    [OutAttribute] String^% Address
)
abstract GetCommunicationAddress :
        Mainframe : string *
        Address : string byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Address
Type: SystemString
IP address of the mainframe
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.GetConnectedMainframeCount Method

IPerceptionCOMGetConnectedMainframeCount Method

Returns the amount of currently connected mainframes

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetConnectedMainframeCount(
    out long Count
)
Sub GetConnectedMainframeCount (
    <OutAttribute> ByRef Count As Long
)
void GetConnectedMainframeCount(
    [OutAttribute] long long% Count
)
abstract GetConnectedMainframeCount :
        Count : int64 byref -> unit

Parameters

Count
Type: SystemInt64
Number of mainframes
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetRecorderCount(String, Int64)


IPerceptionCOM.GetContinuousSettings Method

IPerceptionCOMGetContinuousSettings Method

Note: This API is now obsolete.

This method is no longer supported and has been replaced by the GetGroupStorageSettings

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is no longer supported and has been replaced by the GetGroupStorageSettings")]
void GetContinuousSettings(
    string Mainframe,
    string Recorder,
    out int RecordingMode,
    out double RecordingTimeHistory,
    out double PostTriggerRecordingTime
)
<ObsoleteAttribute("This method is no longer supported and has been replaced by the GetGroupStorageSettings")>
Sub GetContinuousSettings (
    Mainframe As String,
    Recorder As String,
    <OutAttribute> ByRef RecordingMode As Integer,
    <OutAttribute> ByRef RecordingTimeHistory As Double,
    <OutAttribute> ByRef PostTriggerRecordingTime As Double
)
[ObsoleteAttribute(L"This method is no longer supported and has been replaced by the GetGroupStorageSettings")]
void GetContinuousSettings(
    String^ Mainframe,
    String^ Recorder,
    [OutAttribute] int% RecordingMode,
    [OutAttribute] double% RecordingTimeHistory,
    [OutAttribute] double% PostTriggerRecordingTime
)
[<ObsoleteAttribute("This method is no longer supported and has been replaced by the GetGroupStorageSettings")>]
abstract GetContinuousSettings :
        Mainframe : string *
        Recorder : string *
        RecordingMode : int byref *
        RecordingTimeHistory : float byref *
        PostTriggerRecordingTime : float byref -> unit

Parameters

Mainframe
Type: SystemString
Recorder
Type: SystemString
RecordingMode
Type: SystemInt32
RecordingTimeHistory
Type: SystemDouble
PostTriggerRecordingTime
Type: SystemDouble
Remarks
In Perception 6.30 this method has been replaced with the method GetGroupStorageSettings
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetGroupStorageSettings(String, COMStorageMode, COMRecordingMode, Double, Double)


IPerceptionCOM.GetControlOut Method

IPerceptionCOMGetControlOut Method

Getting the status of the control output (7600 Isolated Digitizer Subsystem)

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetControlOut(
    string Mainframe,
    string Recorder,
    string Channel,
    out bool Enabled
)
Sub GetControlOut (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    <OutAttribute> ByRef Enabled As Boolean
)
void GetControlOut(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    [OutAttribute] bool% Enabled
)
abstract GetControlOut :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Enabled : bool byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
Enabled
Type: SystemBoolean
Control output enabled
Remarks
The 7600 provides a control output that can be used to drive an external device. This output is located at the back of the instrument and has a BNC connector. The output is an open-collector type. For electrical details refer to the specification section.
Examples
Copy
private bool GetControlOutput()
{
     string cMainframe = "GEN7t I";
     string cRecorder = "Recorder F";
     string cChannel = "Ch F1";
     bool bEnabled;

     m_Perception.GetControlOut(cMainframe, cRecorder, cChannel, out bEnabled);

     chkControlOutput.Checked = bEnabled;
     return true;
}
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetControlOut(String, String, String, Boolean)


IPerceptionCOM.GetCycleMasterSettings Method

IPerceptionCOMGetCycleMasterSettings Method

Setup the cycle detector

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetCycleMasterSettings(
    string Mainframe,
    string Recorder,
    long CycleMasterIndex,
    COMCycleMasterSettingsSettingItem Mask,
    out COMCycleMasterType CycleMasterType,
    out string InputChannel,
    out double Level,
    out double ThresHold,
    out double CycleCount,
    out COMChannelTriggerDirection Direction,
    out double Period
)
Sub GetCycleMasterSettings (
    Mainframe As String,
    Recorder As String,
    CycleMasterIndex As Long,
    Mask As COMCycleMasterSettingsSettingItem,
    <OutAttribute> ByRef CycleMasterType As COMCycleMasterType,
    <OutAttribute> ByRef InputChannel As String,
    <OutAttribute> ByRef Level As Double,
    <OutAttribute> ByRef ThresHold As Double,
    <OutAttribute> ByRef CycleCount As Double,
    <OutAttribute> ByRef Direction As COMChannelTriggerDirection,
    <OutAttribute> ByRef Period As Double
)
void GetCycleMasterSettings(
    String^ Mainframe,
    String^ Recorder,
    long long CycleMasterIndex,
    COMCycleMasterSettingsSettingItem Mask,
    [OutAttribute] COMCycleMasterType% CycleMasterType,
    [OutAttribute] String^% InputChannel,
    [OutAttribute] double% Level,
    [OutAttribute] double% ThresHold,
    [OutAttribute] double% CycleCount,
    [OutAttribute] COMChannelTriggerDirection% Direction,
    [OutAttribute] double% Period
)
abstract GetCycleMasterSettings :
        Mainframe : string *
        Recorder : string *
        CycleMasterIndex : int64 *
        Mask : COMCycleMasterSettingsSettingItem *
        CycleMasterType : COMCycleMasterType byref *
        InputChannel : string byref *
        Level : float byref *
        ThresHold : float byref *
        CycleCount : float byref *
        Direction : COMChannelTriggerDirection byref *
        Period : float byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
CycleMasterIndex
Type: SystemInt64
Detector to setup
Mask
Type: RPC_COMCOMCycleMasterSettingsSettingItem
Parameter mask, 0xFF, applies all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

CycleMasterType
Type: RPC_COMCOMCycleMasterType
Cycle detection type
InputChannel
Type: SystemString
Input channel name, case sensitive
Level
Type: SystemDouble
Detection level
ThresHold
Type: SystemDouble
Detection threshold
CycleCount
Type: SystemDouble
Cycles count
Direction
Type: RPC_COMCOMChannelTriggerDirection
Level crossing direction indicating start of cycle
Period
Type: SystemDouble
Time of period in case of using a periodic timer
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetCycleMasterSettings(String, String, Int64, COMCycleMasterSettingsSettingItem, COMCycleMasterType, String, Double, Double, Double, COMChannelTriggerDirection, Double)


IPerceptionCOM.GetData Method

IPerceptionCOMGetData Method

Get live data from Perception

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetData(
    int SubscriberID,
    int MaxSegmentCount,
    int MaxBinCount,
    out Array SegementLengths,
    out Array SegementStartTimes,
    out Array SegementEndTimes,
    out int ResultSegmentCount,
    out Array BinMins,
    out Array BinMaxs,
    out int ResultBinCount
)
Sub GetData (
    SubscriberID As Integer,
    MaxSegmentCount As Integer,
    MaxBinCount As Integer,
    <OutAttribute> ByRef SegementLengths As Array,
    <OutAttribute> ByRef SegementStartTimes As Array,
    <OutAttribute> ByRef SegementEndTimes As Array,
    <OutAttribute> ByRef ResultSegmentCount As Integer,
    <OutAttribute> ByRef BinMins As Array,
    <OutAttribute> ByRef BinMaxs As Array,
    <OutAttribute> ByRef ResultBinCount As Integer
)
void GetData(
    int SubscriberID,
    int MaxSegmentCount,
    int MaxBinCount,
    [OutAttribute] Array^% SegementLengths,
    [OutAttribute] Array^% SegementStartTimes,
    [OutAttribute] Array^% SegementEndTimes,
    [OutAttribute] int% ResultSegmentCount,
    [OutAttribute] Array^% BinMins,
    [OutAttribute] Array^% BinMaxs,
    [OutAttribute] int% ResultBinCount
)
abstract GetData :
        SubscriberID : int *
        MaxSegmentCount : int *
        MaxBinCount : int *
        SegementLengths : Array byref *
        SegementStartTimes : Array byref *
        SegementEndTimes : Array byref *
        ResultSegmentCount : int byref *
        BinMins : Array byref *
        BinMaxs : Array byref *
        ResultBinCount : int byref -> unit

Parameters

SubscriberID
Type: SystemInt32
ID as returned by the corresponding SubscribeLiveWaveform function.
MaxSegmentCount
Type: SystemInt32
Maximum number of segments to get. Limited to 10 by Perception.
MaxBinCount
Type: SystemInt32
The maximum number of min-max pairs to receive.
SegementLengths
Type: SystemArray
Array containing the lengths of the returned segments
SegementStartTimes
Type: SystemArray
Array containing the start times of the returned segments
SegementEndTimes
Type: SystemArray
Array containing the end times of the returned segments
ResultSegmentCount
Type: SystemInt32
Number of segments returned by the function call.
BinMins
Type: SystemArray
Array containing the min value of the data points
BinMaxs
Type: SystemArray
Array containing the max value of the data points
ResultBinCount
Type: SystemInt32
The number of bins returned by the function call.
Remarks
GetData

The GetData function is used to actually fetch data from a data stream of a subscribed waveform. You can only fetch data when the acquisition hardware is recording or is in pause mode. In each function call you receive data that is available at that time. For more data you need subsequent function calls, typically within a loop.

More on live data

When you subscribe to a waveform, a buffer of specified length with the specified number of min-max pairs is prepared. When this buffer is filled, an additional buffer is created, up to a maximum of ten buffers. When you fetch the contents of one or more buffers, the buffer queue is reduced by the number of buffers you retrieve.

The "MaxSegmentCount" defines how many segments you want to retrieve in one go at maximum. Valid values range from 1 (one) to 10 (ten). What you get depends on how many filled buffers are available at the time of request. Typically requesting the data will be done in an (almost) endless loop. The buffer mechanism is then used for the asynchronous transfer of synchronized data.

"MaxBinCount" is equal to the "MaxSegmentCount" multiplied by maximum number of min-max pairs per buffer. This value is used in the SubscribeLivewaveform function. The number of min-max pairs can be very low (1 to 10) but also very high (> 1000). This all depends on the processing capabilities of the client software: it is the client's responsibility to fetch the data fast enough to prevent overrun and to do the other things too.

In the GetData function the value "MaxBinCount" is used to allocate memory for the transfer.

For each segment that is returned there is an entry in the SegementLengths, SegementStartTimes and SegementEndTimes arrays.

Each SegementLengths entry has information on the number of min-max pairs in that segment.

Each SegementStartTimes entry has information on the time of the first pair.

Each SegementEndTimes entry has information on the time of the last pair.

All the waveform data is returned in the arrays: BinMins and BinMaxs. The data is stored sequentially in the array.

Since the data is stored sequentially, the first pair of the first segment has index 0 and the first pair of the second segment has index length of first segment + 0, etc. Note that, although usually the segment lengths will be the same, the length of the retrieved segments within a single function call may have different lengths.

Understanding min-max pairs

The data is supplied as a series of min-max pairs. Each pair gives the minimum and maximum value that has been encountered in a specific interval. Assume a sample rate of 10000 samples per second and a requested 100 pairs in a buffer of 0.5 seconds. This will yield one min-max pair per 50 samples, i.e. the pair gives you the minimum and maximum values encountered in each subsequent 50 samples.

To draw data correctly using min-max pairs you will have to know your math. Min-max pairs are only effective when you use one pair for each X-axis pixel on the screen. For each X-axis pixel you draw a line from the minimum value to the maximum value.

This could result in gaps however, since the minimum value of a pair can be greater than the maximum of a previous pair. Also the maximum value of a pair can be less than the minimum value of the previous pair. To make things even more complicated it is also possible that small values (less than one pixel) are not drawn.

In your program you will need to take these deviations into consideration to make sure that the display on the screen is an actual representation of the data.

Examples
Copy
private int m_iSubscriberID;
private bool m_bHasSubscription = false;
private int m_iRequestedNumberOfBins = 500;
private int m_nTimePerBuffer = 200; // Time per buffer in ms

// m_Perception.SubscribeLiveWaveform(txtSelectedWaveform.Text, m_iRequestedNumberOfBins, m_nTimePerBuffer / 1000.0, 0, 0, out m_iSubscriberID);

private void GetData()
{
    if (!m_bHasSubscription)
    {
         MessageBox.Show(this, "No subscription available!", Application.ProductName);
         return;
    }

    List<=float> m_aYValues = new List<=float>();
    double dStartTime = double.NaN;
    double dXStep = double.NaN;

    int nPointsToRead = m_iRequestedNumberOfBins;
    while (nPointsToRead > 0)
    {
         Array SegementLengths;
         Array SegementStartTimes;
         Array SegementEndTimes;
         int ResultSegmentCount;
         Array BinMins;
         Array BinMaxs;
         int ResultBinCount;
         try
         {
              m_Perception.GetData(m_iSubscriberID, 1, nPointsToRead, out SegementLengths,
                             out SegementStartTimes, out SegementEndTimes, out ResultSegmentCount,
                             out BinMins, out BinMaxs, out ResultBinCount);
              nPointsToRead = nPointsToRead - ResultBinCount;
         }
         catch
         {
              UnSubScribe();
              return;
         }

         if (ResultSegmentCount <= 0 || ResultBinCount <= 0)
         {
              lblXLeft.Text = "";
              lblXRight.Text = "";
              lblNumberofPoints.Text = "";
              plotXY1.DataPoints = null;
              return;
         }

         double[] StartTimes = SegementStartTimes as double[];
         double[] EndTimes = SegementEndTimes as double[];

         float[] fBinMaxs = BinMaxs as float[];
         float[] fBinMins = BinMaxs as float[];

         if (double.IsNaN(dStartTime))
         {
              dStartTime = StartTimes[0];
              if (fBinMaxs.Length > 1)
              {
                   dXStep = (EndTimes[0] - StartTimes[0]) / (fBinMaxs.Length - 1);
              }
         }

         if (double.IsNaN(dXStep))
         {
              if (fBinMaxs.Length > 1)
              {
                   dXStep = (EndTimes[0] - StartTimes[0]) / (fBinMaxs.Length - 1);
              }
         }

         for (int n = 0; n < fBinMaxs.Length; n++)
         {
              m_aYValues.Add((fBinMaxs[n] + fBinMins[n]) / 2);
         }
    }

    float[] aY = m_aYValues.ToArray();
    plotXY1.DataPoints = aY;
    lblNumberofPoints.Text = aY.Length.ToString();

    lblXLeft.Text = dStartTime.ToString();
    double dEndTime = dStartTime + (aY.Length - 1) * dXStep;
    lblXRight.Text = dEndTime.ToString();
}
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSubscribeLiveWaveform(String, Int32, Double, Int32, Double, Int32)
IPerceptionCOMUnsubscribeLiveWaveform(Int32)
IPerceptionCOMGetAvailableWaveforms(Array)


IPerceptionCOM.GetDiskMemoryUsage Method

IPerceptionCOMGetDiskMemoryUsage Method

Get the acquisition disk memory total size and free size

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetDiskMemoryUsage(
    string Mainframe,
    out double TotalSize,
    out double SizeFree
)
Sub GetDiskMemoryUsage (
    Mainframe As String,
    <OutAttribute> ByRef TotalSize As Double,
    <OutAttribute> ByRef SizeFree As Double
)
void GetDiskMemoryUsage(
    String^ Mainframe,
    [OutAttribute] double% TotalSize,
    [OutAttribute] double% SizeFree
)
abstract GetDiskMemoryUsage :
        Mainframe : string *
        TotalSize : float byref *
        SizeFree : float byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

TotalSize
Type: SystemDouble
Total memory size in Bytes
SizeFree
Type: SystemDouble
Free memory size in Bytes
Examples
Copy
 double TotalSize;
 double SizeFree;
 RPC.GetDiskMemoryUsage("Rack1", out TotalSize, out SizeFree);

 // TotalSize = 100808998912
 // SizeFree = 23503556608
 string cTotalSize = ConvertToBytes((Int64)TotalSize);
 string cSizeFree = ConvertToBytes((Int64)SizeFree);
 // cTotalSize = "93.89 G"
 // cSizeFree = "21.89 G"

public string ConvertToBytes(Int64 nBytes)
{
     int nPower = 1;
     double nTmp = 0;
     string cExtend = "";

     if (nBytes > 0)
          nPower = (int)Math.Round(Math.Log(nBytes) / Math.Log(2));

     if (nPower > 59)                       // E (Exa) = 10 ^ 18 = 2 ^ 60 Bytes
     {
          nTmp = nBytes / Math.Pow(2, 60);
          cExtend = "E";
     }
     else if (nPower > 49)                  // P (Peta) = 10 ^ 15 = 2 ^ 50 Bytes
     {
          nTmp = nBytes / Math.Pow(2, 50);
          cExtend = "P";
     }
     else if (nPower > 39)                  // T (Tera) = 10 ^ 12 = 2 ^ 40 Bytes
     {
          nTmp = nBytes / Math.Pow(2, 40);
          cExtend = "T";
     }
     else if (nPower > 29)                  // G (Giga) = 10 ^ 9 = 2 ^ 30 Bytes
     {
          nTmp = nBytes / Math.Pow(2, 30);
          cExtend = "G";
     }
     else if (nPower > 19)                  // M (Mega) = 10 ^ 6 = 2 ^ 20 Bytes
     {
          nTmp = nBytes / Math.Pow(2, 20);
          cExtend = "M";
     }
     else if (nPower > 9)                   // K (Kilo) = 10 ^ 3 = 2 ^ 10 Bytes
     {
          nTmp = nBytes / Math.Pow(2, 10);
          cExtend = "K";
     }
     else
     {
          nTmp = nBytes;
     }

     if (string.IsNullOrEmpty(cExtend))
     {
          return nTmp.ToString();
     }
     else
     {
          return string.Format("{0:0.00}", nTmp) + " " + cExtend;
     }
}
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.GetDiskSettings Method

IPerceptionCOMGetDiskSettings Method

Get the disk settings of a mainframe

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetDiskSettings(
    string Mainframe,
    int Mask,
    out int DiskLocation,
    out int DiskUsage,
    out int LocalDiskStatus1,
    out int LocalDiskStatus2,
    out double LocalDiskSize1,
    out double LocalDiskSize2
)
Sub GetDiskSettings (
    Mainframe As String,
    Mask As Integer,
    <OutAttribute> ByRef DiskLocation As Integer,
    <OutAttribute> ByRef DiskUsage As Integer,
    <OutAttribute> ByRef LocalDiskStatus1 As Integer,
    <OutAttribute> ByRef LocalDiskStatus2 As Integer,
    <OutAttribute> ByRef LocalDiskSize1 As Double,
    <OutAttribute> ByRef LocalDiskSize2 As Double
)
void GetDiskSettings(
    String^ Mainframe,
    int Mask,
    [OutAttribute] int% DiskLocation,
    [OutAttribute] int% DiskUsage,
    [OutAttribute] int% LocalDiskStatus1,
    [OutAttribute] int% LocalDiskStatus2,
    [OutAttribute] double% LocalDiskSize1,
    [OutAttribute] double% LocalDiskSize2
)
abstract GetDiskSettings :
        Mainframe : string *
        Mask : int *
        DiskLocation : int byref *
        DiskUsage : int byref *
        LocalDiskStatus1 : int byref *
        LocalDiskStatus2 : int byref *
        LocalDiskSize1 : float byref *
        LocalDiskSize2 : float byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

  • if Mask = 1 then only the first parameter will be returned in this case DiskLocation
  • if Mask = 2 then only the second parameter will be returned in this case DiskUsage
DiskLocation
Type: SystemInt32
Disk location:
  • None = 0
  • PC Storage = 1
  • Mainframe Disk 1 = 2
  • Mainframe Disk 2 = 3
DiskUsage
Type: SystemInt32
Disk usage:
  • Single Disk = 0
  • Multiple Disk = 1
LocalDiskStatus1
Type: SystemInt32
Disk status local disk 1:
  • No Drive = 0
  • No Disk = 1
  • Not Formatted = 2
  • Wrong Format = 3
  • Write Protected = 4
  • Disk Available = 5
LocalDiskStatus2
Type: SystemInt32
Disk status local disk 2:
  • No Drive = 0
  • No Disk = 1
  • Not Formatted = 2
  • Wrong Format = 3
  • Write Protected = 4
  • Disk Available = 5
LocalDiskSize1
Type: SystemDouble
Local disk size in bytes
LocalDiskSize2
Type: SystemDouble
Local disk size in bytes
Examples
Copy
int DiskLocation;
int DiskUsage;
int LocalDiskStatus1;
int LocalDiskStatus2;
double LocalDiskSize1;
double LocalDiskSize2;
m_Perception.GetDiskSettings("Rack1", Mask, out DiskLocation, out DiskUsage, out LocalDiskStatus1,
                           out LocalDiskStatus2, out LocalDiskSize1, out LocalDiskSize2);
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetDiskSettings(String, Int32, Int32, Int32)


IPerceptionCOM.GeteDriveConfiguration Method

IPerceptionCOMGeteDriveConfiguration Method

Gets current configuration an eDrive calculator engine

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GeteDriveConfiguration(
    int EngineId,
    out Array Keys,
    out Array Values
)
Sub GeteDriveConfiguration (
    EngineId As Integer,
    <OutAttribute> ByRef Keys As Array,
    <OutAttribute> ByRef Values As Array
)
void GeteDriveConfiguration(
    int EngineId,
    [OutAttribute] Array^% Keys,
    [OutAttribute] Array^% Values
)
abstract GeteDriveConfiguration :
        EngineId : int *
        Keys : Array byref *
        Values : Array byref -> unit

Parameters

EngineId
Type: SystemInt32
integer engine ids
Keys
Type: SystemArray
An array of integers, with values taken from COMeDriveConfigKey enumeration
Values
Type: SystemArray
An array of doubles containing the values of the various eDrive configuration keys
Examples
Copy
// Example of a wrapper function to get one specific configuration key
static public double GeteDriveConfiguration(PerceptionCOM RPCServer, int EngineId, eDriveConfigKey Key)
{
      Array SysKeys = null;
      Array SysKeyValues = null;
      RPCServer.GeteDriveConfiguration(EngineId, out SysKeys, out SysKeyValues);

      int[] aConfigKey = SysKeys as int[];
      double[] aConfigKeyValue = SysKeyValues as double[];
      for (int i = 0; i < aConfigKey.Length; i++)
      {
           if ((int)Key == aConfigKey[i])
           {
                return aConfigKeyValue[i];
           }
      }
      return double.NaN;
}
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
RPC_COMCOMeDriveConfigKey
IPerceptionCOMSeteDriveConfiguration(Int32, Array, Array)


IPerceptionCOM.GeteDriveConfigurationStrings Method

IPerceptionCOMGeteDriveConfigurationStrings Method

Gets current configuration an eDrive calculator engine

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GeteDriveConfigurationStrings(
    int EngineId,
    out Array Keys,
    out Array Values
)
Sub GeteDriveConfigurationStrings (
    EngineId As Integer,
    <OutAttribute> ByRef Keys As Array,
    <OutAttribute> ByRef Values As Array
)
void GeteDriveConfigurationStrings(
    int EngineId,
    [OutAttribute] Array^% Keys,
    [OutAttribute] Array^% Values
)
abstract GeteDriveConfigurationStrings :
        EngineId : int *
        Keys : Array byref *
        Values : Array byref -> unit

Parameters

EngineId
Type: SystemInt32
integer engine ids
Keys
Type: SystemArray
An array of integers, with values taken from COMeDriveConfigStringKey enumeration
Values
Type: SystemArray
An array of strings containing the values of the various eDrive configuration keys
Examples
Copy
// Example of a wrapper function to get one specific configuration key
static public double GeteDriveConfigurationStrings(PerceptionCOM RPCServer, int EngineId, eDriveConfigStringKey Key)
{
      Array SysKeys = null;
      Array SysKeyValues = null;
      RPCServer.GeteDriveConfigurationStrings(EngineId, out SysKeys, out SysKeyValues);

      int[] aConfigKey = SysKeys as int[];
      string[] aConfigKeyValue = SysKeyValues as string[];
      for (int i = 0; i < aConfigKey.Length; i++)
      {
           if ((int)Key == aConfigKey[i])
           {
                return aConfigKeyValue[i];
           }
      }
      return string.Empty;
}
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
RPC_COMCOMeDriveConfigStringKey
IPerceptionCOMSeteDriveConfigurationStrings(Int32, Array, Array)


IPerceptionCOM.GeteDriveEngineNames Method

IPerceptionCOMGeteDriveEngineNames Method

Gets the ids and names of all available eDrive calculator engines. The ids are used in subsequent calls to GeteDriveValues, GeteDriveConfiguration and SeteDriveConfiguration.

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GeteDriveEngineNames(
    out Array EngineIds,
    out Array EngineNames
)
Sub GeteDriveEngineNames (
    <OutAttribute> ByRef EngineIds As Array,
    <OutAttribute> ByRef EngineNames As Array
)
void GeteDriveEngineNames(
    [OutAttribute] Array^% EngineIds,
    [OutAttribute] Array^% EngineNames
)
abstract GeteDriveEngineNames :
        EngineIds : Array byref *
        EngineNames : Array byref -> unit

Parameters

EngineIds
Type: SystemArray
An array of integers containing calculator engine ids
EngineNames
Type: SystemArray
A string array containing names of calculator engines
Examples
Copy
private bool GetEngineID(out int nEngineID)
{
     Array aSysEngineIds;
     Array aSysEngineNames;
     m_Perception.GeteDriveEngineNames(out aSysEngineIds, out aSysEngineNames);

     if (aSysEngineIds != null && aSysEngineNames != null && aSysEngineIds.Length == aSysEngineNames.Length)
     {
          int[] aEngineIds = aSysEngineIds as int[];
          string[] aEngineNames = aSysEngineNames as string[];

          nEngineID = aEngineIds[0];
          return true;
     }
     else
     {
          nEngineID = -1;
          return false;
     }
}
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGeteDriveValues(Int32, Array, Array)


IPerceptionCOM.GeteDriveNextRecordingComment Method

IPerceptionCOMGeteDriveNextRecordingComment Method

Get recording comment from eDrive application

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GeteDriveNextRecordingComment(
    out string Comment
)
Sub GeteDriveNextRecordingComment (
    <OutAttribute> ByRef Comment As String
)
void GeteDriveNextRecordingComment(
    [OutAttribute] String^% Comment
)
abstract GeteDriveNextRecordingComment :
        Comment : string byref -> unit

Parameters

Comment
Type: SystemString
current recording comment
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.GeteDriveValues Method

IPerceptionCOMGeteDriveValues Method

Gets calculated results from an eDrive calculator engine. Returns 2 output arrays: an array of Int32 Keys, and an array of double values. Key[x] corresponds with Values[x].

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GeteDriveValues(
    int EngineId,
    out Array Keys,
    out Array Values
)
Sub GeteDriveValues (
    EngineId As Integer,
    <OutAttribute> ByRef Keys As Array,
    <OutAttribute> ByRef Values As Array
)
void GeteDriveValues(
    int EngineId,
    [OutAttribute] Array^% Keys,
    [OutAttribute] Array^% Values
)
abstract GeteDriveValues :
        EngineId : int *
        Keys : Array byref *
        Values : Array byref -> unit

Parameters

EngineId
Type: SystemInt32
integer engine id
Keys
Type: SystemArray
An array of integers, with values taken from COMeDriveKeys enumeration
Values
Type: SystemArray
An array of doubles containing the eDrive calculated values
Examples
Copy
// Example of the GeteDriveValues function
Array aSysKeys = null;
Array aSysValues = null;

m_Perception.GeteDriveValues(m_nEngineID, out aSysKeys, out aSysValues);

if (aSysValues != null && aSysKeys != null && aSysValues.Length > 0 && aSysValues.Length == aSysKeys.Length)
{
     int[] aKeys = aSysKeys as int[];
     double[] aValues = aSysValues as double[];
     for (int i = 0; i < aKeys.Length; i++)
     {
          string cKeyName = eDriveKeysHelper.GetKeyName(aKeys[i]);
          listBox2.Items.Add(string.Format("Key[{0}] = {1}", cKeyName, aValues[i]));
     }
}

static public string GetKeyName(int nKey)
{
     eDriveKeys eDriveKey;
     if (GeteDriveKeysEnum(nKey, out eDriveKey))
     {
          return eDriveKey.ToString();
     }
     else
     {
          return string.Format("{0} (Unknown)", nKey);
     }
}

static public bool GeteDriveKeysEnum(int nKey, out eDriveKeys eDriveKey)
{
     int nMax = Enum.GetNames(typeof(eDriveKeys)).Length;
     if ((nKey >= 0) && (nKey < nMax))
     {
          eDriveKey = (eDriveKeys)nKey;
          return true;
     }
     else
     {
          eDriveKey = eDriveKeys.eDriveKey_UpdateCounter;
          return false;
     }
}
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
RPC_COMCOMeDriveKeys
IPerceptionCOMGeteDriveEngineNames(Array, Array)


IPerceptionCOM.GetESIFile Method

IPerceptionCOMGetESIFile Method

Returns the content of an ESI file describing the current system setup as published on EtherCAT.

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetESIFile(
    string Mainframe,
    out string FileContent
)
Sub GetESIFile (
    Mainframe As String,
    <OutAttribute> ByRef FileContent As String
)
void GetESIFile(
    String^ Mainframe,
    [OutAttribute] String^% FileContent
)
abstract GetESIFile :
        Mainframe : string *
        FileContent : string byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

FileContent
Type: SystemString
The content of the ESI file.

Empty string if no etherCAT available.

Remarks
Will return the EtherCAT information on the first EtherCAT module found.
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.GetEventChannelEnabled Method

IPerceptionCOMGetEventChannelEnabled Method

Returns whether a channels data is stored or not.

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetEventChannelEnabled(
    string Mainframe,
    string Recorder,
    string Channel,
    out bool Enabled
)
Sub GetEventChannelEnabled (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    <OutAttribute> ByRef Enabled As Boolean
)
void GetEventChannelEnabled(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    [OutAttribute] bool% Enabled
)
abstract GetEventChannelEnabled :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Enabled : bool byref -> unit

Parameters

Mainframe
Type: SystemString
Name or index of mainframe
Recorder
Type: SystemString
Name or index of recorder
Channel
Type: SystemString
Name or index of marker channel
Enabled
Type: SystemBoolean
Marker channel enabled true or false
Remarks
Examples
Copy
string cMainframe = "GEN7t I";
string cRecorder = "Recorder A";
string cChannel = "Ev1";
bool bEnabled;

m_Perception.GetEventChannelEnabled(cMainframe, cRecorder, cChannel, out bEnabled);

if (bEnabled)
   lblStorage.Text = "Storage ON";
else
   lblStorage.Text = "Storage OFF";
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetChannelEnabled(String, String, String, Boolean)
IPerceptionCOMSetChannelEnabled(String, String, String, Boolean)
IPerceptionCOMSetEventChannelEnabled(String, String, String, Boolean)
IPerceptionCOMGetTimerCounterChannelEnabled(String, String, String, Boolean)
IPerceptionCOMSetTimerCounterChannelEnabled(String, String, String, Boolean)


IPerceptionCOM.GetFilenames Method

IPerceptionCOMGetFilenames Method

With this function you can retrieve all available file names that match a search pattern, from a specified directory.

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetFilenames(
    string Location,
    string SearchString,
    out Array fileNames
)
Sub GetFilenames (
    Location As String,
    SearchString As String,
    <OutAttribute> ByRef fileNames As Array
)
void GetFilenames(
    String^ Location,
    String^ SearchString,
    [OutAttribute] Array^% fileNames
)
abstract GetFilenames :
        Location : string *
        SearchString : string *
        fileNames : Array byref -> unit

Parameters

Location
Type: SystemString
Search directory / folder
SearchString
Type: SystemString
Search string
fileNames
Type: SystemArray
A string array that holds the search results
Remarks
File operations are used to open and save setups. It is also possible to retrieve a list of available files in a specified directory. The GetFileNames function supports virtual directory names that get replaced automatically by the real locations. These virtual directories are:

SharedDocs - Represents the Shared Documents folder on the computer (C:\Documents and Settings\All Users\Documents)

MyDocs - Represents the My Documents folder of the currently logged in user (C:\Documents and Settings\Username\My Documents)

Virtual directories names are surrounded by the two characters < and >, called angle brackets.

Examples
Copy
using PerceptionCOMRpc;

private PerceptionCOM m_Perception = new PerceptionCOM();

m_Perception.SetServerAddress("localhost");
m_Perception.ConnectToServer();

internal void RetrieveVWBFiles()
{
     listBox1.Items.Clear();
     Array aVWBFileNames;
     m_Perception.GetFilenames("<MyDocs>\\My Workbench\\", "*.pVwb", out aVWBFileNames);

     string[] strVWBFileNames = aVWBFileNames as string[];

     for (int i = 0; i < strVWBFileNames.Length; i++)
     {
          listBox1.Items.Add(strVWBFileNames[i]);
     }
}
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMLoadVWB(String)
IPerceptionCOMSaveVWB(String)


IPerceptionCOM.GetGroups Method

IPerceptionCOMGetGroups Method

Return a list of all the time-base groups currently in the system

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetGroups(
    out Array groups
)
Sub GetGroups (
    <OutAttribute> ByRef groups As Array
)
void GetGroups(
    [OutAttribute] Array^% groups
)
abstract GetGroups :
        groups : Array byref -> unit

Parameters

groups
Type: SystemArray
Names of all the time-base groups in the system
Examples
Copy
Array arrayGroups;
m_RPC.GetGroups(out arrayGroups);
string[] aGroups = arrayGroups as string[];
foreach (string cGroup in aGroups)
{
    // Do something with cGroup
}
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.GetGroupStorageSettings Method

IPerceptionCOMGetGroupStorageSettings Method

Get the recorder storage mode

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetGroupStorageSettings(
    string Group,
    out COMStorageMode StorageMode,
    out COMRecordingMode RecordingMode,
    out double RecordingTimeHistory,
    out double PostTriggerRecordingTime
)
Sub GetGroupStorageSettings (
    Group As String,
    <OutAttribute> ByRef StorageMode As COMStorageMode,
    <OutAttribute> ByRef RecordingMode As COMRecordingMode,
    <OutAttribute> ByRef RecordingTimeHistory As Double,
    <OutAttribute> ByRef PostTriggerRecordingTime As Double
)
void GetGroupStorageSettings(
    String^ Group,
    [OutAttribute] COMStorageMode% StorageMode,
    [OutAttribute] COMRecordingMode% RecordingMode,
    [OutAttribute] double% RecordingTimeHistory,
    [OutAttribute] double% PostTriggerRecordingTime
)
abstract GetGroupStorageSettings :
        Group : string *
        StorageMode : COMStorageMode byref *
        RecordingMode : COMRecordingMode byref *
        RecordingTimeHistory : float byref *
        PostTriggerRecordingTime : float byref -> unit

Parameters

Group
Type: SystemString
Name or index of group
StorageMode
Type: RPC_COMCOMStorageMode
Storage mode of group:
  • None, no data will be written into the recording = 0
  • Sweeped storage = 1
  • Continuous data storage= 2
  • Continuous data storage with high rate sweep segments = 3
  • Slow fast storage mode = 4
RecordingMode
Type: RPC_COMCOMRecordingMode
Recording mode of the group
RecordingTimeHistory
Type: SystemDouble
Time to use for circular recordings
PostTriggerRecordingTime
Type: SystemDouble
Time to record after a trigger was detected in continuous mode with stop on trigger
Remarks
The storage settings define what part of the recording to store:
  • None - although you are recording, nothing is stored
  • Sweeps - triggered segments at high sample rate are stored. This can be in transient (sweep) recording mode, but also in continuous recording mode when only the triggered segments are stored.
  • Continuous - the continuous data stream at low sample rate is stored
  • Dual - When using dual timebase (slow-fast-slow), both the triggered segments and the continuous data are stored each with their own sample rate.
Examples
Copy
string cGroup = "Group1";

// Get storage mode
COMStorageMode StorageMode;
COMRecordingMode RecordingMode;
double dRecTimeHis, dPostTrigger;

m_Perception.GetStorageSettings(cGroup, out StorageMode, out RecordingMode, out dRecTimeHis, out dPostTrigger);
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetGroupStorageSettings(String, COMStorageSettingItem, COMStorageMode, COMRecordingMode, Double, Double)


IPerceptionCOM.GetGroupSweepSettings Method

IPerceptionCOMGetGroupSweepSettings Method

Get the group sweep settings

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetGroupSweepSettings(
    string Group,
    out int SweepLength,
    out COMSweepMode SweepMode,
    out double TriggerPosition,
    out double Delay,
    out bool SweepCountEnabled,
    out int SweepCount,
    out int SlowSweepLength,
    out double SlowTriggerPosition,
    out bool SweepStretchEnabled
)
Sub GetGroupSweepSettings (
    Group As String,
    <OutAttribute> ByRef SweepLength As Integer,
    <OutAttribute> ByRef SweepMode As COMSweepMode,
    <OutAttribute> ByRef TriggerPosition As Double,
    <OutAttribute> ByRef Delay As Double,
    <OutAttribute> ByRef SweepCountEnabled As Boolean,
    <OutAttribute> ByRef SweepCount As Integer,
    <OutAttribute> ByRef SlowSweepLength As Integer,
    <OutAttribute> ByRef SlowTriggerPosition As Double,
    <OutAttribute> ByRef SweepStretchEnabled As Boolean
)
void GetGroupSweepSettings(
    String^ Group,
    [OutAttribute] int% SweepLength,
    [OutAttribute] COMSweepMode% SweepMode,
    [OutAttribute] double% TriggerPosition,
    [OutAttribute] double% Delay,
    [OutAttribute] bool% SweepCountEnabled,
    [OutAttribute] int% SweepCount,
    [OutAttribute] int% SlowSweepLength,
    [OutAttribute] double% SlowTriggerPosition,
    [OutAttribute] bool% SweepStretchEnabled
)
abstract GetGroupSweepSettings :
        Group : string *
        SweepLength : int byref *
        SweepMode : COMSweepMode byref *
        TriggerPosition : float byref *
        Delay : float byref *
        SweepCountEnabled : bool byref *
        SweepCount : int byref *
        SlowSweepLength : int byref *
        SlowTriggerPosition : float byref *
        SweepStretchEnabled : bool byref -> unit

Parameters

Group
Type: SystemString
Group name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first group

SweepLength
Type: SystemInt32
Sweep length in samples
SweepMode
Type: RPC_COMCOMSweepMode
Sweep mode:
  • Normal = 0
  • PreTrigger = 1
  • Delayed = 2
TriggerPosition
Type: SystemDouble
Trigger position in %
Delay
Type: SystemDouble
Delay in seconds
SweepCountEnabled
Type: SystemBoolean
If true recording stops after receiving a defined number of sweeps ("SweepCount"), if false recording stops after stop command
SweepCount
Type: SystemInt32
Number of sweeps before recording stops automatically
SlowSweepLength
Type: SystemInt32
The total amount of data to be recorded for slow sweeps

This setting is enabled when the Storage mode is Slow Fast Sweep.

It sets the number of samples that the slow-speed sweep will contain.

SlowTriggerPosition
Type: SystemDouble
Sets the trigger position within the slow sweep

The trigger position within a sweep defines the amount of pre- and post-trigger information to be stored.

In the Slow Fast Sweep storage mode, the low-speed sweep uses the trigger of the high-speed sweep.

When set to zero the complete sweep contains post-trigger data. When set to the sweep length the sweep contains all pre-trigger data.

SweepStretchEnabled
Type: SystemBoolean
Enables the sweep stretch
Examples
Copy
protected override void btnGet_Click(object sender, EventArgs e)
{
     int SweepLength;
     int SweepMode;
     double TriggerPosition;
     double Delay;
     bool SweepCountEnabled;
     int SweepCount;
     int SlowSweepLength;
     double SlowSweepTriggerPosition;
     bool SweepStretchEnabled;

     m_Perception.GetGroupSweepSettings("Group1", out SweepLength, out TriggerPosition,out Delay,
                         out SweepMode, out SweepCountEnabled, out SweepCount, out SlowSweepLength,
                         out SlowSweepTriggerPosition, out SweepStretchEnabled );
     txtDelay.Text = Delay.ToString();
     txtSweepcount.Text = SweepCount.ToString();
     cbxSweepMode.SelectedIndex = SweepMode;
     txtTriggerPosition.Text = TriggerPosition.ToString();
     txtSweepLength.Text = SweepLength.ToString();
     chkCountEnabled.Checked = SweepCountEnabled;
}
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetGroupSweepSettings(String, COMSweepSettingItem, Int32, COMSweepMode, Double, Double, Boolean, Int32, Int32, Double, Boolean)


IPerceptionCOM.GetGroupTimebaseSettings Method

IPerceptionCOMGetGroupTimebaseSettings Method

Get timebase settings of a group

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetGroupTimebaseSettings(
    string Group,
    out double HighSamplingFrequency,
    out double LowSamplingFrequency,
    out COMClockSource ClkSource,
    out int ClockDivider
)
Sub GetGroupTimebaseSettings (
    Group As String,
    <OutAttribute> ByRef HighSamplingFrequency As Double,
    <OutAttribute> ByRef LowSamplingFrequency As Double,
    <OutAttribute> ByRef ClkSource As COMClockSource,
    <OutAttribute> ByRef ClockDivider As Integer
)
void GetGroupTimebaseSettings(
    String^ Group,
    [OutAttribute] double% HighSamplingFrequency,
    [OutAttribute] double% LowSamplingFrequency,
    [OutAttribute] COMClockSource% ClkSource,
    [OutAttribute] int% ClockDivider
)
abstract GetGroupTimebaseSettings :
        Group : string *
        HighSamplingFrequency : float byref *
        LowSamplingFrequency : float byref *
        ClkSource : COMClockSource byref *
        ClockDivider : int byref -> unit

Parameters

Group
Type: SystemString
Group name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first group

HighSamplingFrequency
Type: SystemDouble
High (fast) sample rate in Hz
LowSamplingFrequency
Type: SystemDouble
Low (slow) sample rate in Hz
ClkSource
Type: RPC_COMCOMClockSource
Recorder clock source:
  • Internal = 0
  • ExternalA = 1
ClockDivider
Type: SystemInt32
The external clock divider
Remarks
The ClkSource (Recorder clock source) depends also on the master-timebase mode of the mainframe.
Examples
Copy
int nMask = 0xFF;
double HighSamplingFrequency;
double LowSamplingFrequency;
COMClockSource ClkSource;
int ClkDivider;
m_Perception.GetGroupTimebaseSettings("Group1", out HighSamplingFrequency, out LowSamplingFrequency, out ClkSource, out ClkDivider);
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetGroupTimebaseSettings(String, COMTimebaseSettingItem, Double, Double, COMClockSource, Int32)
IPerceptionCOMGetMasterTimebaseMode(COMMasterTimebaseMode)


IPerceptionCOM.GetInfoSettings Method

IPerceptionCOMGetInfoSettings Method

Get the channel information

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetInfoSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    int Mask,
    out string PhysicalName,
    out string SerialNumber,
    out string ChannelType,
    out string SoftwareVersion
)
Sub GetInfoSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As Integer,
    <OutAttribute> ByRef PhysicalName As String,
    <OutAttribute> ByRef SerialNumber As String,
    <OutAttribute> ByRef ChannelType As String,
    <OutAttribute> ByRef SoftwareVersion As String
)
void GetInfoSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    int Mask,
    [OutAttribute] String^% PhysicalName,
    [OutAttribute] String^% SerialNumber,
    [OutAttribute] String^% ChannelType,
    [OutAttribute] String^% SoftwareVersion
)
abstract GetInfoSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : int *
        PhysicalName : string byref *
        SerialNumber : string byref *
        ChannelType : string byref *
        SoftwareVersion : string byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case PhysicalName

if Mask = 2 then only the second parameter will be returned in this case SerialNumber

PhysicalName
Type: SystemString
Physical name of a channel
SerialNumber
Type: SystemString
Serial number of a channel
ChannelType
Type: SystemString
Channel type
SoftwareVersion
Type: SystemString
Software version
Examples
Copy
string PhysicalName;
string SerialNumber;
string ChannelType;
string SoftwareVersion;

RPC.GetInfoSettings("Rack1", "Recorder A", "Ch A1", Mask, out PhysicalName, out SerialNumber,
                     out ChannelType, out SoftwareVersion);

// PhysicalName = "Ch A1"
// SerialNumber = "UnitTest1"
// ChannelType = "GEN 1MS/s Diff Amp."
// SoftwareVersion = "4.04.7033"
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.GetiSCSISettings Method

IPerceptionCOMGetiSCSISettings Method

Get the iSCSI settings

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetiSCSISettings(
    string Mainframe,
    COMDiskLocation DiskLocation,
    out COMNetworkSelect NetworkSelect,
    out string IPAddress,
    out int PortNumber,
    out string TargetName,
    out string UserName,
    out string Password,
    out bool Enabled,
    out COMIScsiStatus Status,
    out string PhysicalName,
    out bool UseDNS
)
Sub GetiSCSISettings (
    Mainframe As String,
    DiskLocation As COMDiskLocation,
    <OutAttribute> ByRef NetworkSelect As COMNetworkSelect,
    <OutAttribute> ByRef IPAddress As String,
    <OutAttribute> ByRef PortNumber As Integer,
    <OutAttribute> ByRef TargetName As String,
    <OutAttribute> ByRef UserName As String,
    <OutAttribute> ByRef Password As String,
    <OutAttribute> ByRef Enabled As Boolean,
    <OutAttribute> ByRef Status As COMIScsiStatus,
    <OutAttribute> ByRef PhysicalName As String,
    <OutAttribute> ByRef UseDNS As Boolean
)
void GetiSCSISettings(
    String^ Mainframe,
    COMDiskLocation DiskLocation,
    [OutAttribute] COMNetworkSelect% NetworkSelect,
    [OutAttribute] String^% IPAddress,
    [OutAttribute] int% PortNumber,
    [OutAttribute] String^% TargetName,
    [OutAttribute] String^% UserName,
    [OutAttribute] String^% Password,
    [OutAttribute] bool% Enabled,
    [OutAttribute] COMIScsiStatus% Status,
    [OutAttribute] String^% PhysicalName,
    [OutAttribute] bool% UseDNS
)
abstract GetiSCSISettings :
        Mainframe : string *
        DiskLocation : COMDiskLocation *
        NetworkSelect : COMNetworkSelect byref *
        IPAddress : string byref *
        PortNumber : int byref *
        TargetName : string byref *
        UserName : string byref *
        Password : string byref *
        Enabled : bool byref *
        Status : COMIScsiStatus byref *
        PhysicalName : string byref *
        UseDNS : bool byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe using the iSCSI device
DiskLocation
Type: RPC_COMCOMDiskLocation
Select the iSCSI device
NetworkSelect
Type: RPC_COMCOMNetworkSelect
Which network device is the iSCSI connected to
IPAddress
Type: SystemString
The IP-address of the iSCSI device
PortNumber
Type: SystemInt32
Port used by the iSCSI device
TargetName
Type: SystemString
iSCSI device target-name
UserName
Type: SystemString
User name to log-in to the iSCSI device
Password
Type: SystemString
Password to log-in to the iSCSI device
Enabled
Type: SystemBoolean
Gets if the iSCSI device is enabled
Status
Type: RPC_COMCOMIScsiStatus
Status of the connection with the iSCSI device
PhysicalName
Type: SystemString
iSCSI device physical name
UseDNS
Type: SystemBoolean
Indicates if DNS should be used to resolve the IP-address
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.GetLastError Method

IPerceptionCOMGetLastError Method

The PerceptionCOMRPC makes calls to the RPC server via the RPC protocol. Most calls in the RPC protocol return an integer value indicating pass/failure of the call. This method allows the last returned value to be retrieved.

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetLastError(
    out int ErrorCode
)
Sub GetLastError (
    <OutAttribute> ByRef ErrorCode As Integer
)
void GetLastError(
    [OutAttribute] int% ErrorCode
)
abstract GetLastError :
        ErrorCode : int byref -> unit

Parameters

ErrorCode
Type: SystemInt32
Last returned error code. 0 is success, all other values indicate a non main success result.
  • -1 = No Such Object: An internal object is not valid. The name or index could be incorrect.
  • -2 = No Call Back: Perception needs to register callback to provide GUI functionality like load workbench.
  • -3 = Unknown Command: The command is not supported by Perception
  • -4 = Callback Failure: Perception failed to perform the requested action
  • -5 = Unknown Result: Perception didn't return a proper result.
  • -6 = Recording Active: Command cannot be performed because a recording is active
  • -7 = Invalid Argument: One of the arguments is invalid
  • -8 = Obsolete Function: Obsolete function called
If the error code is not in this list try to get the Hexadecimal value and look at the Microsoft Internet site for COM errors
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.GetLinkStatus Method

IPerceptionCOMGetLinkStatus Method

Gives information about the communication status

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetLinkStatus(
    string Mainframe,
    string Recorder,
    string Channel,
    out COMLinkStatus Status,
    out double Quality,
    out double CableLength
)
Sub GetLinkStatus (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    <OutAttribute> ByRef Status As COMLinkStatus,
    <OutAttribute> ByRef Quality As Double,
    <OutAttribute> ByRef CableLength As Double
)
void GetLinkStatus(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    [OutAttribute] COMLinkStatus% Status,
    [OutAttribute] double% Quality,
    [OutAttribute] double% CableLength
)
abstract GetLinkStatus :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Status : COMLinkStatus byref *
        Quality : float byref *
        CableLength : float byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name
Recorder
Type: SystemString
Recorder name
Channel
Type: SystemString
Channel name
Status
Type: RPC_COMCOMLinkStatus
Link status, Gives information about the communication status: OK, bad or no communication
Quality
Type: SystemDouble
Link quality (BER), gives the Bit Error Ratio
CableLength
Type: SystemDouble
Cable length in meters
Remarks

Link Status When no errors are detected for more than 1.5 second, the connection is OK. Otherwise the connection is bad. When no 'light' is detected, communication is lost.

Link quality The BER is an indication of the link quality. With a typical measurement time the front-end firmware can determine a BER better than 10-11 with a confidence level (CL) of > 99 %. When a unit starts up, the unit can determine within 10 seconds a BER of 10-10 with a CL of 85 %; after 2.5 minutes a BER of 10-11 with a CL of 95 %.

Cable length in meters Accuracy is ± 1 meter. For some fiber systems this can go up to 4000 meter standard or even 12000 meter with low-loss cables.

See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.GetMacros Method

IPerceptionCOMGetMacros Method

Get the names of all available macros in Perception

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetMacros(
    out Array macros
)
Sub GetMacros (
    <OutAttribute> ByRef macros As Array
)
void GetMacros(
    [OutAttribute] Array^% macros
)
abstract GetMacros :
        macros : Array byref -> unit

Parameters

macros
Type: SystemArray
String array that holds the found macro names
Remarks
This function is used to retrieve all the available macro names in Perception
Examples
Copy
// Get all available macro names
internal void RetrieveMacros()
{
     listBox1.Items.Clear();
     Array aMacros;
     m_Perception.GetMacros(out aMacros);

     string[] aMacroNames = aMacros as string[];

     // Show names in a listbox
     for (int i = 0; i < aMacroNames.Length; i++)
     {
          listBox1.Items.Add(aMacroNames[i]);
     }
}
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMRunMacro(String)


IPerceptionCOM.GetMainframeBatteryStatus Method

IPerceptionCOMGetMainframeBatteryStatus Method

Get the battery status of a mainframe (LIBERTY)

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetMainframeBatteryStatus(
    string Mainframe,
    int Index,
    out int Position,
    out bool BatteryPresent,
    out COMBatAgeStatus AgeStatus,
    out int CycleCount,
    out COMBatChargeStat ChargeStatus,
    out double Current,
    out double Voltage,
    out double Temperature,
    out int CapacityRemainingPercentage,
    out double TotalCapacity
)
Sub GetMainframeBatteryStatus (
    Mainframe As String,
    Index As Integer,
    <OutAttribute> ByRef Position As Integer,
    <OutAttribute> ByRef BatteryPresent As Boolean,
    <OutAttribute> ByRef AgeStatus As COMBatAgeStatus,
    <OutAttribute> ByRef CycleCount As Integer,
    <OutAttribute> ByRef ChargeStatus As COMBatChargeStat,
    <OutAttribute> ByRef Current As Double,
    <OutAttribute> ByRef Voltage As Double,
    <OutAttribute> ByRef Temperature As Double,
    <OutAttribute> ByRef CapacityRemainingPercentage As Integer,
    <OutAttribute> ByRef TotalCapacity As Double
)
void GetMainframeBatteryStatus(
    String^ Mainframe,
    int Index,
    [OutAttribute] int% Position,
    [OutAttribute] bool% BatteryPresent,
    [OutAttribute] COMBatAgeStatus% AgeStatus,
    [OutAttribute] int% CycleCount,
    [OutAttribute] COMBatChargeStat% ChargeStatus,
    [OutAttribute] double% Current,
    [OutAttribute] double% Voltage,
    [OutAttribute] double% Temperature,
    [OutAttribute] int% CapacityRemainingPercentage,
    [OutAttribute] double% TotalCapacity
)
abstract GetMainframeBatteryStatus :
        Mainframe : string *
        Index : int *
        Position : int byref *
        BatteryPresent : bool byref *
        AgeStatus : COMBatAgeStatus byref *
        CycleCount : int byref *
        ChargeStatus : COMBatChargeStat byref *
        Current : float byref *
        Voltage : float byref *
        Temperature : float byref *
        CapacityRemainingPercentage : int byref *
        TotalCapacity : float byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Index
Type: SystemInt32
Battery index: 1 = Battery A, 2 = Battery B
Position
Type: SystemInt32
Position
BatteryPresent
Type: SystemBoolean
Battery present
AgeStatus
Type: RPC_COMCOMBatAgeStatus
Age Status
CycleCount
Type: SystemInt32
Number of battery charge cycles to date for battery A/B
ChargeStatus
Type: RPC_COMCOMBatChargeStat
Indication of the charge status of battery A/B.
Current
Type: SystemDouble
Current of battery A/B. A positive value indicates that the battery is loading
Voltage
Type: SystemDouble
Voltage supplied by battery A/B
Temperature
Type: SystemDouble
Temperature in C° of battery A/B
CapacityRemainingPercentage
Type: SystemInt32
Remaining total battery capacity of all installed batteries together in %

Some front-ends include two batteries. When one battery has 100 % and the other one has 80 % capacity, the total capacity remaining equals 90 %.

TotalCapacity
Type: SystemDouble
Capacity in Wh.
Remarks
This command can be used for a LIBERTY with battery power supply.
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.GetMainframeInfoSettings Method

IPerceptionCOMGetMainframeInfoSettings Method

Get mainframe information

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetMainframeInfoSettings(
    string Mainframe,
    int Mask,
    out string PhysicalName,
    out string SerialNumber,
    out string MainframeType,
    out string SoftwareVersion
)
Sub GetMainframeInfoSettings (
    Mainframe As String,
    Mask As Integer,
    <OutAttribute> ByRef PhysicalName As String,
    <OutAttribute> ByRef SerialNumber As String,
    <OutAttribute> ByRef MainframeType As String,
    <OutAttribute> ByRef SoftwareVersion As String
)
void GetMainframeInfoSettings(
    String^ Mainframe,
    int Mask,
    [OutAttribute] String^% PhysicalName,
    [OutAttribute] String^% SerialNumber,
    [OutAttribute] String^% MainframeType,
    [OutAttribute] String^% SoftwareVersion
)
abstract GetMainframeInfoSettings :
        Mainframe : string *
        Mask : int *
        PhysicalName : string byref *
        SerialNumber : string byref *
        MainframeType : string byref *
        SoftwareVersion : string byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case PhysicalName

if Mask = 2 then only the second parameter will be returned in this case SerialNumber

PhysicalName
Type: SystemString
Physical name of a mainframe
SerialNumber
Type: SystemString
Serial number of a mainframe
MainframeType
Type: SystemString
Mainframe type
SoftwareVersion
Type: SystemString
Mainframe software version
Examples
Copy
string PhysicalName;
string SerialNumber;
string MainframeType;
string SoftwareVersion;

GetMainframeInfoSettings("Mainframe 1", Mask, out PhysicalName, out SerialNumber, out MainframeType, out SoftwareVersion);

// PhysicalName = "UnitTest"
// SerialNumber = "IDJ0304003"
// MainframeType = "GEN Interface"
// SoftwareVersion = "5.00.8237"
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.GetMainframeName Method

IPerceptionCOMGetMainframeName Method

Retrieve the name of a mainframe

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetMainframeName(
    string MainframeIndex,
    out string Name
)
Sub GetMainframeName (
    MainframeIndex As String,
    <OutAttribute> ByRef Name As String
)
void GetMainframeName(
    String^ MainframeIndex,
    [OutAttribute] String^% Name
)
abstract GetMainframeName :
        MainframeIndex : string *
        Name : string byref -> unit

Parameters

MainframeIndex
Type: SystemString
Mainframe index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Name
Type: SystemString
Name of the mainframe
Examples
Copy
// Get the names of all the mainframes in the system
private void GetMainFrameNames()
{
     // Clear Combo-box
     cbxMainframes.Items.Clear();

     if (m_Perception == null) return;
     if (!m_bConnected) return;

     int nMainframeIndex = 1;
     string cMainframeIndex = "";
     string cMainframeName = "";
     do
     {
          cMainframeIndex = "$" + nMainframeIndex.ToString() + "$";
          m_Perception.GetMainframeName(cMainframeIndex, out cMainframeName);

          if (string.IsNullOrEmpty(cMainframeName))
               break;

          // Add mainframe to combo-box
          cbxMainframes.Items.Add(cMainframeName);
          nMainframeIndex++;
     } while (true);

     // Let the combo-box show the first available mainframe
     if (cbxMainframes.Items.Count > 0)
          cbxMainframes.SelectedIndex = 0;
}
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetRecorderName(String, String, String)
IPerceptionCOMGetChannelName(String, String, String, String)


IPerceptionCOM.GetMasterTimebaseMode Method

IPerceptionCOMGetMasterTimebaseMode Method

Get the current system master-timebase mode

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetMasterTimebaseMode(
    out COMMasterTimebaseMode Mode
)
Sub GetMasterTimebaseMode (
    <OutAttribute> ByRef Mode As COMMasterTimebaseMode
)
void GetMasterTimebaseMode(
    [OutAttribute] COMMasterTimebaseMode% Mode
)
abstract GetMasterTimebaseMode :
        Mode : COMMasterTimebaseMode byref -> unit

Parameters

Mode
Type: RPC_COMCOMMasterTimebaseMode
Current mode
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetGroupTimebaseSettings(String, COMTimebaseSettingItem, Double, Double, COMClockSource, Int32)
IPerceptionCOMGetGroupTimebaseSettings(String, Double, Double, COMClockSource, Int32)
IPerceptionCOMSetMasterTimebaseMode(COMMasterTimebaseMode)


IPerceptionCOM.GetMasterTimebaseSettings Method

IPerceptionCOMGetMasterTimebaseSettings Method

Note: This API is now obsolete.

This method is no longer supported and has been replaced by the GetMasterTimebaseSettingsEx

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is no longer supported and has been replaced by the GetMasterTimebaseSettingsEx")]
void GetMasterTimebaseSettings(
    string Mainframe,
    int Mask,
    out int Mode,
    out int SyncSource,
    out int SyncStatus,
    out int MasterSlaveMode
)
<ObsoleteAttribute("This method is no longer supported and has been replaced by the GetMasterTimebaseSettingsEx")>
Sub GetMasterTimebaseSettings (
    Mainframe As String,
    Mask As Integer,
    <OutAttribute> ByRef Mode As Integer,
    <OutAttribute> ByRef SyncSource As Integer,
    <OutAttribute> ByRef SyncStatus As Integer,
    <OutAttribute> ByRef MasterSlaveMode As Integer
)
[ObsoleteAttribute(L"This method is no longer supported and has been replaced by the GetMasterTimebaseSettingsEx")]
void GetMasterTimebaseSettings(
    String^ Mainframe,
    int Mask,
    [OutAttribute] int% Mode,
    [OutAttribute] int% SyncSource,
    [OutAttribute] int% SyncStatus,
    [OutAttribute] int% MasterSlaveMode
)
[<ObsoleteAttribute("This method is no longer supported and has been replaced by the GetMasterTimebaseSettingsEx")>]
abstract GetMasterTimebaseSettings :
        Mainframe : string *
        Mask : int *
        Mode : int byref *
        SyncSource : int byref *
        SyncStatus : int byref *
        MasterSlaveMode : int byref -> unit

Parameters

Mainframe
Type: SystemString
Mask
Type: SystemInt32
Mode
Type: SystemInt32
SyncSource
Type: SystemInt32
SyncStatus
Type: SystemInt32
MasterSlaveMode
Type: SystemInt32
Remarks
In Perception 6.30 this method has been replaced with the method GetMasterTimebaseSettingsEx
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetMasterTimebaseSettingsEx(String, COMMasterTimebaseSyncSource, COMMasterTimebaseSyncStatus, COMMasterSlaveMode)


IPerceptionCOM.GetMasterTimebaseSettingsEx Method

IPerceptionCOMGetMasterTimebaseSettingsEx Method

Get the master timebase settings of a mainframe

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetMasterTimebaseSettingsEx(
    string Mainframe,
    out COMMasterTimebaseSyncSource SyncSource,
    out COMMasterTimebaseSyncStatus SyncStatus,
    out COMMasterSlaveMode MasterSlaveMode
)
Sub GetMasterTimebaseSettingsEx (
    Mainframe As String,
    <OutAttribute> ByRef SyncSource As COMMasterTimebaseSyncSource,
    <OutAttribute> ByRef SyncStatus As COMMasterTimebaseSyncStatus,
    <OutAttribute> ByRef MasterSlaveMode As COMMasterSlaveMode
)
void GetMasterTimebaseSettingsEx(
    String^ Mainframe,
    [OutAttribute] COMMasterTimebaseSyncSource% SyncSource,
    [OutAttribute] COMMasterTimebaseSyncStatus% SyncStatus,
    [OutAttribute] COMMasterSlaveMode% MasterSlaveMode
)
abstract GetMasterTimebaseSettingsEx :
        Mainframe : string *
        SyncSource : COMMasterTimebaseSyncSource byref *
        SyncStatus : COMMasterTimebaseSyncStatus byref *
        MasterSlaveMode : COMMasterSlaveMode byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

SyncSource
Type: RPC_COMCOMMasterTimebaseSyncSource
Defines the source used for the actual time synchronization in a mainframe:
  • RTC = 0
  • IRIG = 1
  • GPS = 2
  • MasterSlave = 3
  • IRIG_A_AM = 4
  • IRIG_B_AM = 5
  • IRIG_A_DCLS = 6
  • IRIG_B_DCLS = 7
  • IEEE1344 = 8
SyncStatus
Type: RPC_COMCOMMasterTimebaseSyncStatus
Synchronization status:
  • NotSynced = 0
  • Syncing = 1
  • Synced = 2
  • SyncLost = 3
  • NoSignal = 4
MasterSlaveMode
Type: RPC_COMCOMMasterSlaveMode
Defines the system’s role in a master/slave configuration:
  • StandAlone = 0
  • Master = 1
  • Slave = 2
Remarks

Synchronization source

The synchronization source is used to synchronize recordings within recordings with the mainframe. The internal clock (RTC) of a system is synchronized with the PC time every time Perception connects to the system. Time Zone Correction is also applied. This correction is added to the source's UTC time when “local time” is requested. When working with multiple mainframes, the internal clocks of the mainframes may differ. Even if initially set accurately, real clocks will differ after some time due to clock drift, caused by clocks counting time at slightly different rates. To solve this issue in a multiple mainframe setup, it is possible to use global synchronization sources like IRIG and GPS. The most common synchronization sources are RTC (internal clock), IRIG and GPS. For detailed information on IRIG and GPS consult your hardware manual.

Master/slave configuration

Defines whether or not the system is part of a master/slave configuration and if yes, which role it has in this setup. Master/slave is a model for a communication protocol where one system has unidirectional control over one or more other systems. Once a master/slave relationship between systems is established, the direction of control is always from the master to the slaves. The most common modes are Master, Slave and Stand-Alone. For details on master/slave operation refer to the separate manual that came with your master/slave hardware option.

Examples
Copy
COMMasterTimebaseSyncSource SyncSource;
COMMasterTimebaseSyncStatus SyncStatus;
COMMasterSlaveMode MasterSlaveMode;

GetMasterTimebaseSettingsEx("Mainframe 1", Mask, out SyncSource, out SyncStatus, out MasterSlaveMode);
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetMasterTimebaseSettingsEx(String, COMMasterTmbSettingsItem, COMMasterTimebaseSyncSource, COMMasterTimebaseSyncStatus, COMMasterSlaveMode)


IPerceptionCOM.GetMFExternalStartStopSettings Method

IPerceptionCOMGetMFExternalStartStopSettings Method

Gets the external start and / or stop behavior of the mainframe when a signal is applied to the external start / stop connector.

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetMFExternalStartStopSettings(
    string Mainframe,
    out COMExternalStartStopMode StartMode,
    out COMExternalStartStopMode StopMode
)
Sub GetMFExternalStartStopSettings (
    Mainframe As String,
    <OutAttribute> ByRef StartMode As COMExternalStartStopMode,
    <OutAttribute> ByRef StopMode As COMExternalStartStopMode
)
void GetMFExternalStartStopSettings(
    String^ Mainframe,
    [OutAttribute] COMExternalStartStopMode% StartMode,
    [OutAttribute] COMExternalStartStopMode% StopMode
)
abstract GetMFExternalStartStopSettings :
        Mainframe : string *
        StartMode : COMExternalStartStopMode byref *
        StopMode : COMExternalStartStopMode byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

StartMode
Type: RPC_COMCOMExternalStartStopMode
The external start mode for the specified mainframe.
StopMode
Type: RPC_COMCOMExternalStartStopMode
The external stop mode for the specified mainframe.
Remarks
This setting is not available on all mainframes. Please refer to the GEN Series manual to verify if the mainframe used supports this setting.
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.GetModule2EtherCATMapping Method

IPerceptionCOMGetModule2EtherCATMapping Method

Returns the information necessary to map how information from the acquisition system is published on the EtherCAT bus

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetModule2EtherCATMapping(
    string Mainframe,
    out long MappingCount,
    out Array BusNames,
    out Array ModuleNames
)
Sub GetModule2EtherCATMapping (
    Mainframe As String,
    <OutAttribute> ByRef MappingCount As Long,
    <OutAttribute> ByRef BusNames As Array,
    <OutAttribute> ByRef ModuleNames As Array
)
void GetModule2EtherCATMapping(
    String^ Mainframe,
    [OutAttribute] long long% MappingCount,
    [OutAttribute] Array^% BusNames,
    [OutAttribute] Array^% ModuleNames
)
abstract GetModule2EtherCATMapping :
        Mainframe : string *
        MappingCount : int64 byref *
        BusNames : Array byref *
        ModuleNames : Array byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

MappingCount
Type: SystemInt64
Number of channels published to the EtherCAT bus.
BusNames
Type: SystemArray
Name of channels on the EtherCAT bus.
ModuleNames
Type: SystemArray
Name of data acquisition channel published to this EtherCAT bus channel. ///

- - - in case no channel is mapped to this bus channel.

See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.GetNetworkSettings Method

IPerceptionCOMGetNetworkSettings Method

Get a mainframes network settings

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetNetworkSettings(
    string Mainframe,
    int Mask,
    out string NetworkName,
    out bool UseDHCP,
    out string IPAddress,
    out string IPMask,
    out string DefaultGateway,
    out string MacAddress
)
Sub GetNetworkSettings (
    Mainframe As String,
    Mask As Integer,
    <OutAttribute> ByRef NetworkName As String,
    <OutAttribute> ByRef UseDHCP As Boolean,
    <OutAttribute> ByRef IPAddress As String,
    <OutAttribute> ByRef IPMask As String,
    <OutAttribute> ByRef DefaultGateway As String,
    <OutAttribute> ByRef MacAddress As String
)
void GetNetworkSettings(
    String^ Mainframe,
    int Mask,
    [OutAttribute] String^% NetworkName,
    [OutAttribute] bool% UseDHCP,
    [OutAttribute] String^% IPAddress,
    [OutAttribute] String^% IPMask,
    [OutAttribute] String^% DefaultGateway,
    [OutAttribute] String^% MacAddress
)
abstract GetNetworkSettings :
        Mainframe : string *
        Mask : int *
        NetworkName : string byref *
        UseDHCP : bool byref *
        IPAddress : string byref *
        IPMask : string byref *
        DefaultGateway : string byref *
        MacAddress : string byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case NetworkName

if Mask = 2 then only the second parameter will be returned in this case UseDHCP

NetworkName
Type: SystemString
Network name
UseDHCP
Type: SystemBoolean
When ON (= true) use a DHCP server to get network information, when OFF (= false) select your own network settings for IP address, mask and gateway.

If this setting is ON the mainframe will scan the network for available DHCP servers which will assign an IP address, subnet masker and gateway rather than using the manually entered addresses. When OFF, IP address, IP mask and Default gateway will be used.

IPAddress
Type: SystemString
Mainframe IP address.

The manually entered IP address will be used to identify the mainframe on the network when DHCP server is OFF. When DHCP server is ON, this setting will not be editable.

IPMask
Type: SystemString
Mainframe IP mask.

Specifies the subnet mask for the network the mainframe is in. This will only be used when DHCP server is OFF. When DHCP server is ON, this setting will not be editable.

DefaultGateway
Type: SystemString
Default gateway to use with the mainframe

This is the address of the default gateway the mainframe will use when DHCP server is OFF. When DHCP server is ON, this setting will not be editable.

MacAddress
Type: SystemString
MAC address

In computer networking, a Media Access Control address (MAC address) or Ethernet Hardware Address (EHA), hardware address, adapter address or physical address is a quasi-unique identifier assigned to most network adapters or network interface cards (NICs) by the manufacturer for identification.

See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetNetworkSettings(String, Int32, String, Boolean, String, String, String, String)


IPerceptionCOM.GetPowerControlSettings Method

IPerceptionCOMGetPowerControlSettings Method

Get the power control settings of a fiber channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetPowerControlSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    int Mask,
    out bool AmplifierPowerEnabled,
    out bool AmplifierOutEnabled,
    out COMPowerStatus Status
)
Sub GetPowerControlSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As Integer,
    <OutAttribute> ByRef AmplifierPowerEnabled As Boolean,
    <OutAttribute> ByRef AmplifierOutEnabled As Boolean,
    <OutAttribute> ByRef Status As COMPowerStatus
)
void GetPowerControlSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    int Mask,
    [OutAttribute] bool% AmplifierPowerEnabled,
    [OutAttribute] bool% AmplifierOutEnabled,
    [OutAttribute] COMPowerStatus% Status
)
abstract GetPowerControlSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : int *
        AmplifierPowerEnabled : bool byref *
        AmplifierOutEnabled : bool byref *
        Status : COMPowerStatus byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

  • if Mask = 1 then only the first parameter will be returned in this case AmplifierPowerEnabled
  • if Mask = 2 then only the second parameter will be returned in this case AmplifierOutEnabled
AmplifierPowerEnabled
Type: SystemBoolean
Enables remote front-end channel to be switched on

When working with a fiber-optic isolated digitizing front-end it is possible to switch the power at the front-end on or off under software control. By switching the power off, the operating time of the front-end before recharging will be extended.

AmplifierOutEnabled
Type: SystemBoolean
Enables analog output signal on mainframe front panel of remote front-end channel

When working with a fiber-optic isolated digitizing front-end it is possible to enable an analog output signal on the mainframe front panel. This signal is equivalent to the measured signal at the front-end

Status
Type: RPC_COMCOMPowerStatus
Power status of remote front-end channel
Examples
Copy
private bool GetPowerControlSettings()
{

     string cMainframe = "GEN7t I";
     string cRecorder = "Recorder A";
     string cChannel = "Ch A1";
     int Mask = 0xFF;
     bool AmplifierPowerEnabled;
     bool AmplifierOutEnabled;
     COMPowerStatus Status;

     m_Perception.GetPowerControlSettings(cMainframe, cRecorder, cChannel, Mask,
                                   out AmplifierPowerEnabled, out AmplifierOutEnabled, out Status);

     chkAmplifierPower.Checked = AmplifierPowerEnabled;
     chkAmplifierOut.Checked = AmplifierOutEnabled;

     switch (Status)
     {
          case COMPowerStatus.COMPowerStatus_BatteryLow:
               lblAmplifierPowerStatus.Text = "Battery Low";
               break;
          case COMPowerStatus.COMPowerStatus_NoSignal:
               lblAmplifierPowerStatus.Text = "No Signal";
               break;
          case COMPowerStatus.COMPowerStatus_PowerOK:
               lblAmplifierPowerStatus.Text = "Power OK";
               break;
          case COMPowerStatus.COMPowerStatus_PowerOff:
               lblAmplifierPowerStatus.Text = "Power Off";
               break;
          case COMPowerStatus.COMPowerStatus_ThermalShutdown:
               lblAmplifierPowerStatus.Text = "Thermal Shutdown";
               break;
          case COMPowerStatus.COMPowerStatus_WarmingUp:
               lblAmplifierPowerStatus.Text = "Warming Up";
               break;
          default:
               lblAmplifierPowerStatus.Text = "---";
              break;
     }
     return true;
}
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetPowerControlSettings(String, String, String, Int32, Boolean, Boolean, COMPowerStatus)


IPerceptionCOM.GetPowerStatus Method

IPerceptionCOMGetPowerStatus Method

Get the power status of a fiber channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetPowerStatus(
    string Mainframe,
    string Recorder,
    string Channel,
    out COMPowerLevel PowerLevel,
    out COMExternalPowerStatus ExternalPowerStatus,
    out COMPowerSource PowerSource,
    out int RemainingCapacityPercentage,
    out int RemainTimeSeconds
)
Sub GetPowerStatus (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    <OutAttribute> ByRef PowerLevel As COMPowerLevel,
    <OutAttribute> ByRef ExternalPowerStatus As COMExternalPowerStatus,
    <OutAttribute> ByRef PowerSource As COMPowerSource,
    <OutAttribute> ByRef RemainingCapacityPercentage As Integer,
    <OutAttribute> ByRef RemainTimeSeconds As Integer
)
void GetPowerStatus(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    [OutAttribute] COMPowerLevel% PowerLevel,
    [OutAttribute] COMExternalPowerStatus% ExternalPowerStatus,
    [OutAttribute] COMPowerSource% PowerSource,
    [OutAttribute] int% RemainingCapacityPercentage,
    [OutAttribute] int% RemainTimeSeconds
)
abstract GetPowerStatus :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        PowerLevel : COMPowerLevel byref *
        ExternalPowerStatus : COMExternalPowerStatus byref *
        PowerSource : COMPowerSource byref *
        RemainingCapacityPercentage : int byref *
        RemainTimeSeconds : int byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
PowerLevel
Type: RPC_COMCOMPowerLevel
Front-end power level
ExternalPowerStatus
Type: RPC_COMCOMExternalPowerStatus
Front-end external power status
PowerSource
Type: RPC_COMCOMPowerSource
Front-end power source

Current power source on which the front-end operates: mains(external) or battery

RemainingCapacityPercentage
Type: SystemInt32
Remaining battery capacity of battery A/B in %
RemainTimeSeconds
Type: SystemInt32
Estimated remaining operation time of unit based on capacity and power consumption in seconds.
Examples
Copy
 private bool GetPowerStatusSettings()
 {
     string cMainframe = "GEN7t I";
     string cRecorder = "Recorder A";
     string cChannel = "Ch A1";

     COMPowerLevel PowerLevel;
     COMExternalPowerStatus ExternalPowerStatus;
     COMPowerSource PowerSource;
     int RemainingCapacityPercentage;
     int RemainTimeSeconds;

     m_Perception.GetPowerStatus(cMainframe, cRecorder, cChannel,
          out PowerLevel, out ExternalPowerStatus, out PowerSource,
          out RemainingCapacityPercentage, out RemainTimeSeconds);

     switch (PowerLevel)
     {
          case COMPowerLevel.COMPowerLevel_Low:
               lblPowerLevel.Text = "Low";
               break;
          case COMPowerLevel.COMPowerLevel_NotValid:
               lblPowerLevel.Text = "Not valid";
               break;
          case COMPowerLevel.COMPowerLevel_OK:
               lblPowerLevel.Text = "OK";
               break;
          default:
               break;
     }

     switch (ExternalPowerStatus)
     {
          case COMExternalPowerStatus.COMExternalPowerStatus_BlownFuse:
               lblExternalPowerStatus.Text = "Blown fuse";
               break;
          case COMExternalPowerStatus.COMExternalPowerStatus_Nominal:
               lblExternalPowerStatus.Text = "Nominal";
               break;
          case COMExternalPowerStatus.COMExternalPowerStatus_NotPresent:
               lblExternalPowerStatus.Text = "Not present";
               break;
          case COMExternalPowerStatus.COMExternalPowerStatus_NotValid:
               lblExternalPowerStatus.Text = "Not valid";
               break;
          case COMExternalPowerStatus.COMExternalPowerStatus_OverRange:
               lblExternalPowerStatus.Text = "Over range";
               break;
          case COMExternalPowerStatus.COMExternalPowerStatus_ReversePolarity:
               lblExternalPowerStatus.Text = "Reverse polarity";
               break;
          case COMExternalPowerStatus.COMExternalPowerStatus_UnderRange:
               lblExternalPowerStatus.Text = "Under Range";
               break;
          default:
               lblExternalPowerStatus.Text = ExternalPowerStatus.ToString();
               break;
     }

     switch (PowerSource)
     {
          case COMPowerSource.COMPowerSource_Battery:
               lblPowerSource.Text = "Battery";
               break;
          case COMPowerSource.COMPowerSource_External:
               lblPowerSource.Text = "External";
               break;
          case COMPowerSource.COMPowerSource_NotValid:
               lblPowerSource.Text = "Not Valid";
               break;
          case COMPowerSource.COMPowerSource_Undetermined:
               lblPowerSource.Text = "Undetermined";
               break;
          default:
               lblPowerSource.Text = PowerSource.ToString();
               break;
     }

    lblRemainingCapacityPercentage.Text = RemainingCapacityPercentage.ToString() + "%";
    lblRemainingTime.Text = RemainTimeSeconds.ToString() + "s";

    return true;
}
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetPowerControlSettings(String, String, String, Int32, Boolean, Boolean, COMPowerStatus)


IPerceptionCOM.GetRecCommonSettings Method

IPerceptionCOMGetRecCommonSettings Method

Get common settings of a recorder

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetRecCommonSettings(
    string Mainframe,
    string Recorder,
    int Mask,
    out string Name
)
Sub GetRecCommonSettings (
    Mainframe As String,
    Recorder As String,
    Mask As Integer,
    <OutAttribute> ByRef Name As String
)
void GetRecCommonSettings(
    String^ Mainframe,
    String^ Recorder,
    int Mask,
    [OutAttribute] String^% Name
)
abstract GetRecCommonSettings :
        Mainframe : string *
        Recorder : string *
        Mask : int *
        Name : string byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Mask
Type: SystemInt32
Mask, always use 0xFF
Name
Type: SystemString
Recorder name
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetRecCommonSettings(String, String, Int32, String)


IPerceptionCOM.GetRecInfoSettings Method

IPerceptionCOMGetRecInfoSettings Method

Get recorder information

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetRecInfoSettings(
    string Mainframe,
    string Recorder,
    int Mask,
    out string PhysicalName,
    out string Serial,
    out string Type,
    out string FirmwareVersion
)
Sub GetRecInfoSettings (
    Mainframe As String,
    Recorder As String,
    Mask As Integer,
    <OutAttribute> ByRef PhysicalName As String,
    <OutAttribute> ByRef Serial As String,
    <OutAttribute> ByRef Type As String,
    <OutAttribute> ByRef FirmwareVersion As String
)
void GetRecInfoSettings(
    String^ Mainframe,
    String^ Recorder,
    int Mask,
    [OutAttribute] String^% PhysicalName,
    [OutAttribute] String^% Serial,
    [OutAttribute] String^% Type,
    [OutAttribute] String^% FirmwareVersion
)
abstract GetRecInfoSettings :
        Mainframe : string *
        Recorder : string *
        Mask : int *
        PhysicalName : string byref *
        Serial : string byref *
        Type : string byref *
        FirmwareVersion : string byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case PhysicalName

if Mask = 2 then only the second parameter will be returned in this case Serial

PhysicalName
Type: SystemString
Serial
Type: SystemString
Type
Type: SystemString
FirmwareVersion
Type: SystemString
Examples
Copy
string PhysicalName;
string Serial;
string Type;
string Type;
string FirmwareVersion;

m_Perception.GetRecInfoSettings(string Mainframe, string Recorder, int Mask, out PhysicalName, out Serial, out Type, out FirmwareVersion);

// PhysicalName = "Recorder A"
// Serial = "UnitTest1"
// Type = "GEN7t 1MS/s"
// FirmwareVersion = "5.00.8237"
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.GetRecorderCount Method

IPerceptionCOMGetRecorderCount Method

Returns the amount of recorders on the specified mainframe

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetRecorderCount(
    string Mainframe,
    out long Count
)
Sub GetRecorderCount (
    Mainframe As String,
    <OutAttribute> ByRef Count As Long
)
void GetRecorderCount(
    String^ Mainframe,
    [OutAttribute] long long% Count
)
abstract GetRecorderCount :
        Mainframe : string *
        Count : int64 byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Count
Type: SystemInt64
Number of recorders
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetConnectedMainframeCount(Int64)


IPerceptionCOM.GetRecorderCountInGroup Method

IPerceptionCOMGetRecorderCountInGroup Method

Returns the number of recorders in a certain group

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetRecorderCountInGroup(
    string GroupName,
    out int Count
)
Sub GetRecorderCountInGroup (
    GroupName As String,
    <OutAttribute> ByRef Count As Integer
)
void GetRecorderCountInGroup(
    String^ GroupName,
    [OutAttribute] int% Count
)
abstract GetRecorderCountInGroup :
        GroupName : string *
        Count : int byref -> unit

Parameters

GroupName
Type: SystemString
Name of the group
Count
Type: SystemInt32
Number of recorders in the group
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.GetRecorderGroup Method

IPerceptionCOMGetRecorderGroup Method

Returns the name of the group to which the recorder is assigned

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetRecorderGroup(
    string Mainframe,
    string Recorder,
    out string GroupName
)
Sub GetRecorderGroup (
    Mainframe As String,
    Recorder As String,
    <OutAttribute> ByRef GroupName As String
)
void GetRecorderGroup(
    String^ Mainframe,
    String^ Recorder,
    [OutAttribute] String^% GroupName
)
abstract GetRecorderGroup :
        Mainframe : string *
        Recorder : string *
        GroupName : string byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe that contains the recorder
Recorder
Type: SystemString
Recorder
GroupName
Type: SystemString
Group that contains the recorder
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.GetRecorderName Method

IPerceptionCOMGetRecorderName Method

Retrieve the name of a recorder

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetRecorderName(
    string MainframeIndex,
    string RecorderIndex,
    out string Name
)
Sub GetRecorderName (
    MainframeIndex As String,
    RecorderIndex As String,
    <OutAttribute> ByRef Name As String
)
void GetRecorderName(
    String^ MainframeIndex,
    String^ RecorderIndex,
    [OutAttribute] String^% Name
)
abstract GetRecorderName :
        MainframeIndex : string *
        RecorderIndex : string *
        Name : string byref -> unit

Parameters

MainframeIndex
Type: SystemString
Mainframe index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

RecorderIndex
Type: SystemString
Recorder index; one based
Name
Type: SystemString
Name of the recorder
Examples
Copy
// Get the names of all the recorders belonging to a specific mainframe
private void GetRecorderNames()
{
     cbxRecorders.Items.Clear();

     if (m_Perception == null) return;
     if (!m_bConnected) return;

     if (cbxMainframes.SelectedIndex < 0)
     {
          MessageBox.Show(this, "Can not continue because there is no mainframe selected!", Application.ProductName);
          return;
     }
     string cMainframeName = cbxMainframes.SelectedItem.ToString();
     int nRecorderIndex = 1;
     string cRecorderIndex = "";
     string cRecorderName = "";
     do
     {
          // Index is surrounded by $ character!!!
          cRecorderIndex = "$" + nRecorderIndex.ToString() + "$";
          m_Perception.GetRecorderName(cMainframeName, cRecorderIndex, out cRecorderName);
          if (string.IsNullOrEmpty(cRecorderName))
               break;
          // Add Recorder to combo-box
          cbxRecorders.Items.Add(cRecorderName);
          nRecorderIndex++;
     } while (true);

     // Let the combo-box show the first available Recorder
     if (cbxRecorders.Items.Count > 0)
          cbxRecorders.SelectedIndex = 0;
}
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetMainframeName(String, String)
IPerceptionCOMGetChannelName(String, String, String, String)


IPerceptionCOM.GetRecordingName Method

IPerceptionCOMGetRecordingName Method

Gets the current recording name, path is not included.

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetRecordingName(
    out string Name
)
Sub GetRecordingName (
    <OutAttribute> ByRef Name As String
)
void GetRecordingName(
    [OutAttribute] String^% Name
)
abstract GetRecordingName :
        Name : string byref -> unit

Parameters

Name
Type: SystemString
Current recording name.
Remarks
If no recording is active this will be the next recording name.
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.GetRecStorageSettings Method

IPerceptionCOMGetRecStorageSettings Method

Note: This API is now obsolete.

This method is no longer supported and has been replaced by the GetGroupStorageSettings

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is no longer supported and has been replaced by the GetGroupStorageSettings")]
void GetRecStorageSettings(
    string Mainframe,
    string Recorder,
    int Mask,
    out int StorageMode,
    out int RecordingMode,
    out double RecordingTimeHistory,
    out double PostTriggerRecordingTime
)
<ObsoleteAttribute("This method is no longer supported and has been replaced by the GetGroupStorageSettings")>
Sub GetRecStorageSettings (
    Mainframe As String,
    Recorder As String,
    Mask As Integer,
    <OutAttribute> ByRef StorageMode As Integer,
    <OutAttribute> ByRef RecordingMode As Integer,
    <OutAttribute> ByRef RecordingTimeHistory As Double,
    <OutAttribute> ByRef PostTriggerRecordingTime As Double
)
[ObsoleteAttribute(L"This method is no longer supported and has been replaced by the GetGroupStorageSettings")]
void GetRecStorageSettings(
    String^ Mainframe,
    String^ Recorder,
    int Mask,
    [OutAttribute] int% StorageMode,
    [OutAttribute] int% RecordingMode,
    [OutAttribute] double% RecordingTimeHistory,
    [OutAttribute] double% PostTriggerRecordingTime
)
[<ObsoleteAttribute("This method is no longer supported and has been replaced by the GetGroupStorageSettings")>]
abstract GetRecStorageSettings :
        Mainframe : string *
        Recorder : string *
        Mask : int *
        StorageMode : int byref *
        RecordingMode : int byref *
        RecordingTimeHistory : float byref *
        PostTriggerRecordingTime : float byref -> unit

Parameters

Mainframe
Type: SystemString
Recorder
Type: SystemString
Mask
Type: SystemInt32
StorageMode
Type: SystemInt32
RecordingMode
Type: SystemInt32
RecordingTimeHistory
Type: SystemDouble
PostTriggerRecordingTime
Type: SystemDouble
Remarks
In Perception 6.30 this method has been replaced with the method GetGroupStorageSettings
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetGroupStorageSettings(String, COMStorageMode, COMRecordingMode, Double, Double)


IPerceptionCOM.GetRecSweepSettings Method

IPerceptionCOMGetRecSweepSettings Method

Note: This API is now obsolete.

This method is no longer supported and has been replaced by the GetGroupSweepSettings

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is no longer supported and has been replaced by the GetGroupSweepSettings")]
void GetRecSweepSettings(
    string Mainframe,
    string Recorder,
    int Mask,
    out int SweepLength,
    out double TriggerPosition,
    out double Delay,
    out int SweepMode,
    out bool SweepCountEnabled,
    out int SweepCount
)
<ObsoleteAttribute("This method is no longer supported and has been replaced by the GetGroupSweepSettings")>
Sub GetRecSweepSettings (
    Mainframe As String,
    Recorder As String,
    Mask As Integer,
    <OutAttribute> ByRef SweepLength As Integer,
    <OutAttribute> ByRef TriggerPosition As Double,
    <OutAttribute> ByRef Delay As Double,
    <OutAttribute> ByRef SweepMode As Integer,
    <OutAttribute> ByRef SweepCountEnabled As Boolean,
    <OutAttribute> ByRef SweepCount As Integer
)
[ObsoleteAttribute(L"This method is no longer supported and has been replaced by the GetGroupSweepSettings")]
void GetRecSweepSettings(
    String^ Mainframe,
    String^ Recorder,
    int Mask,
    [OutAttribute] int% SweepLength,
    [OutAttribute] double% TriggerPosition,
    [OutAttribute] double% Delay,
    [OutAttribute] int% SweepMode,
    [OutAttribute] bool% SweepCountEnabled,
    [OutAttribute] int% SweepCount
)
[<ObsoleteAttribute("This method is no longer supported and has been replaced by the GetGroupSweepSettings")>]
abstract GetRecSweepSettings :
        Mainframe : string *
        Recorder : string *
        Mask : int *
        SweepLength : int byref *
        TriggerPosition : float byref *
        Delay : float byref *
        SweepMode : int byref *
        SweepCountEnabled : bool byref *
        SweepCount : int byref -> unit

Parameters

Mainframe
Type: SystemString
Recorder
Type: SystemString
Mask
Type: SystemInt32
SweepLength
Type: SystemInt32
TriggerPosition
Type: SystemDouble
Delay
Type: SystemDouble
SweepMode
Type: SystemInt32
SweepCountEnabled
Type: SystemBoolean
SweepCount
Type: SystemInt32
Remarks
In Perception 6.30 this method has been replaced with the method GetGroupSweepSettings
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetGroupSweepSettings(String, Int32, COMSweepMode, Double, Double, Boolean, Int32, Int32, Double, Boolean)


IPerceptionCOM.GetRecSweepSettingsEx Method

IPerceptionCOMGetRecSweepSettingsEx Method

Note: This API is now obsolete.

This method is no longer supported and has been replaced by the GetGroupSweepSettings

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is no longer supported and has been replaced by the GetGroupSweepSettings")]
void GetRecSweepSettingsEx(
    string Mainframe,
    string Recorder,
    out int SweepLength,
    out double TriggerPosition,
    out double Delay,
    out int SweepMode,
    out bool SweepCountEnabled,
    out int SweepCount,
    out int SlowSweepLength,
    out double SlowSweepTriggerPosition,
    out bool SweepStretchEnabled
)
<ObsoleteAttribute("This method is no longer supported and has been replaced by the GetGroupSweepSettings")>
Sub GetRecSweepSettingsEx (
    Mainframe As String,
    Recorder As String,
    <OutAttribute> ByRef SweepLength As Integer,
    <OutAttribute> ByRef TriggerPosition As Double,
    <OutAttribute> ByRef Delay As Double,
    <OutAttribute> ByRef SweepMode As Integer,
    <OutAttribute> ByRef SweepCountEnabled As Boolean,
    <OutAttribute> ByRef SweepCount As Integer,
    <OutAttribute> ByRef SlowSweepLength As Integer,
    <OutAttribute> ByRef SlowSweepTriggerPosition As Double,
    <OutAttribute> ByRef SweepStretchEnabled As Boolean
)
[ObsoleteAttribute(L"This method is no longer supported and has been replaced by the GetGroupSweepSettings")]
void GetRecSweepSettingsEx(
    String^ Mainframe,
    String^ Recorder,
    [OutAttribute] int% SweepLength,
    [OutAttribute] double% TriggerPosition,
    [OutAttribute] double% Delay,
    [OutAttribute] int% SweepMode,
    [OutAttribute] bool% SweepCountEnabled,
    [OutAttribute] int% SweepCount,
    [OutAttribute] int% SlowSweepLength,
    [OutAttribute] double% SlowSweepTriggerPosition,
    [OutAttribute] bool% SweepStretchEnabled
)
[<ObsoleteAttribute("This method is no longer supported and has been replaced by the GetGroupSweepSettings")>]
abstract GetRecSweepSettingsEx :
        Mainframe : string *
        Recorder : string *
        SweepLength : int byref *
        TriggerPosition : float byref *
        Delay : float byref *
        SweepMode : int byref *
        SweepCountEnabled : bool byref *
        SweepCount : int byref *
        SlowSweepLength : int byref *
        SlowSweepTriggerPosition : float byref *
        SweepStretchEnabled : bool byref -> unit

Parameters

Mainframe
Type: SystemString
Recorder
Type: SystemString
SweepLength
Type: SystemInt32
TriggerPosition
Type: SystemDouble
Delay
Type: SystemDouble
SweepMode
Type: SystemInt32
SweepCountEnabled
Type: SystemBoolean
SweepCount
Type: SystemInt32
SlowSweepLength
Type: SystemInt32
SlowSweepTriggerPosition
Type: SystemDouble
SweepStretchEnabled
Type: SystemBoolean
Remarks
In Perception 6.30 this method has been replaced with the method GetGroupSweepSettings
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetGroupSweepSettings(String, Int32, COMSweepMode, Double, Double, Boolean, Int32, Int32, Double, Boolean)


IPerceptionCOM.GetRecTimebaseSettings Method

IPerceptionCOMGetRecTimebaseSettings Method

Note: This API is now obsolete.

This method is no longer supported and has been replaced by the GetGroupTimebaseSettings

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is no longer supported and has been replaced by the GetGroupTimebaseSettings")]
void GetRecTimebaseSettings(
    string Mainframe,
    string Recorder,
    int Mask,
    double HighSamplingFrequency,
    double LowSamplingFrequency,
    int ClkSource
)
<ObsoleteAttribute("This method is no longer supported and has been replaced by the GetGroupTimebaseSettings")>
Sub GetRecTimebaseSettings (
    Mainframe As String,
    Recorder As String,
    Mask As Integer,
    HighSamplingFrequency As Double,
    LowSamplingFrequency As Double,
    ClkSource As Integer
)
[ObsoleteAttribute(L"This method is no longer supported and has been replaced by the GetGroupTimebaseSettings")]
void GetRecTimebaseSettings(
    String^ Mainframe,
    String^ Recorder,
    int Mask,
    double HighSamplingFrequency,
    double LowSamplingFrequency,
    int ClkSource
)
[<ObsoleteAttribute("This method is no longer supported and has been replaced by the GetGroupTimebaseSettings")>]
abstract GetRecTimebaseSettings :
        Mainframe : string *
        Recorder : string *
        Mask : int *
        HighSamplingFrequency : float *
        LowSamplingFrequency : float *
        ClkSource : int -> unit

Parameters

Mainframe
Type: SystemString
Recorder
Type: SystemString
Mask
Type: SystemInt32
HighSamplingFrequency
Type: SystemDouble
LowSamplingFrequency
Type: SystemDouble
ClkSource
Type: SystemInt32
Remarks
In Perception 6.30 this method has been replaced with the method GetGroupTimebaseSettings
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetGroupTimebaseSettings(String, Double, Double, COMClockSource, Int32)


IPerceptionCOM.GetRecTriggerBusSettings Method

IPerceptionCOMGetRecTriggerBusSettings Method

Get the trigger bus settings of a recorder

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetRecTriggerBusSettings(
    string Mainframe,
    string Recorder,
    int Mask,
    out int MasterSlaveTriggerBusMode,
    out int TriggerBus1Mode,
    out int TriggerBus2Mode,
    out int TriggerBus3Mode,
    out bool ExternalTriggerInEnabled,
    out bool ExternalTriggerOutEnabled,
    out bool AutoTriggerEnabled,
    out bool AlarmOutEnabled
)
Sub GetRecTriggerBusSettings (
    Mainframe As String,
    Recorder As String,
    Mask As Integer,
    <OutAttribute> ByRef MasterSlaveTriggerBusMode As Integer,
    <OutAttribute> ByRef TriggerBus1Mode As Integer,
    <OutAttribute> ByRef TriggerBus2Mode As Integer,
    <OutAttribute> ByRef TriggerBus3Mode As Integer,
    <OutAttribute> ByRef ExternalTriggerInEnabled As Boolean,
    <OutAttribute> ByRef ExternalTriggerOutEnabled As Boolean,
    <OutAttribute> ByRef AutoTriggerEnabled As Boolean,
    <OutAttribute> ByRef AlarmOutEnabled As Boolean
)
void GetRecTriggerBusSettings(
    String^ Mainframe,
    String^ Recorder,
    int Mask,
    [OutAttribute] int% MasterSlaveTriggerBusMode,
    [OutAttribute] int% TriggerBus1Mode,
    [OutAttribute] int% TriggerBus2Mode,
    [OutAttribute] int% TriggerBus3Mode,
    [OutAttribute] bool% ExternalTriggerInEnabled,
    [OutAttribute] bool% ExternalTriggerOutEnabled,
    [OutAttribute] bool% AutoTriggerEnabled,
    [OutAttribute] bool% AlarmOutEnabled
)
abstract GetRecTriggerBusSettings :
        Mainframe : string *
        Recorder : string *
        Mask : int *
        MasterSlaveTriggerBusMode : int byref *
        TriggerBus1Mode : int byref *
        TriggerBus2Mode : int byref *
        TriggerBus3Mode : int byref *
        ExternalTriggerInEnabled : bool byref *
        ExternalTriggerOutEnabled : bool byref *
        AutoTriggerEnabled : bool byref *
        AlarmOutEnabled : bool byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case MasterSlaveBusMode

if Mask = 2 then only the second parameter will be returned in this case TriggerBus1Mode

MasterSlaveTriggerBusMode
Type: SystemInt32
Sends and/or receives a trigger to/from another mainframe using this trigger line
  • Disabled = 0
  • Transmit = 1
  • Receive = 2
  • Transceive = 3

When multiple mainframes are used to perform acquisition(s), a master/slave module is used in order to synchronize them. The master/slave line is used to transfer trigger signals between mainframes, and this setting configures how it is used.

TriggerBus1Mode
Type: SystemInt32
Sends and/or receives a trigger to/from another recorder using trigger line 1
  • Disabled = 0
  • Transmit = 1
  • Receive = 2
  • Transceive = 3

There are three trigger lines on the hardware that can be used to transfer trigger signals among recorders. Each recorder can use these lines as input to or output from its trigger detection logic, or even both. Therefore this setting can take the values Disabled, Transmit, Receive, or Transceive.

TriggerBus2Mode
Type: SystemInt32
Sends and/or receives a trigger to/from another recorder using trigger line 2
  • Disabled = 0
  • Transmit = 1
  • Receive = 2
  • Transceive = 3
TriggerBus3Mode
Type: SystemInt32
Sends and/or receives a trigger to/from another recorder using trigger line 3
  • Disabled = 0
  • Transmit = 1
  • Receive = 2
  • Transceive = 3
ExternalTriggerInEnabled
Type: SystemBoolean
Enable or disables the external trigger in

Enables the use of the external trigger input on the mainframe

The trigger can come from an external signal which is fed to the respective port on the mainframe’s controller module. If this setting is enabled, a logical OR is applied to the combination of the internal trigger detectors of each channel and the external trigger signal. Although this is a per-recorder setting, there is only one external trigger input for the complete mainframe. Each individual recorder can be set to accept this trigger. However, a direction setting (if provided by the hardware) is mainframe-wide and cannot be set on a per-recorder basis.

ExternalTriggerOutEnabled
Type: SystemBoolean
Enable or disables the external trigger out

Sends the internal recorder trigger to the external trigger output on the mainframe

AutoTriggerEnabled
Type: SystemBoolean
Not used
AlarmOutEnabled
Type: SystemBoolean
Not Used
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetRecTriggerBusSettings(String, String, Int32, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean)


IPerceptionCOM.GetSCBridgeBalancingSettings Method

IPerceptionCOMGetSCBridgeBalancingSettings Method

Get the bridge channel balancing settings

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetSCBridgeBalancingSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    int Mask,
    out bool AutoBalancingEnabled,
    out double BalanceValue,
    out int GroupBalanceSelection,
    out int BalanceStatus
)
Sub GetSCBridgeBalancingSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As Integer,
    <OutAttribute> ByRef AutoBalancingEnabled As Boolean,
    <OutAttribute> ByRef BalanceValue As Double,
    <OutAttribute> ByRef GroupBalanceSelection As Integer,
    <OutAttribute> ByRef BalanceStatus As Integer
)
void GetSCBridgeBalancingSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    int Mask,
    [OutAttribute] bool% AutoBalancingEnabled,
    [OutAttribute] double% BalanceValue,
    [OutAttribute] int% GroupBalanceSelection,
    [OutAttribute] int% BalanceStatus
)
abstract GetSCBridgeBalancingSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : int *
        AutoBalancingEnabled : bool byref *
        BalanceValue : float byref *
        GroupBalanceSelection : int byref *
        BalanceStatus : int byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case AutoBalancingEnabled

if Mask = 2 then only the second parameter will be returned in this case BalanceValue

AutoBalancingEnabled
Type: SystemBoolean
Balance enable.

Allows the channel to be balanced

Specifies whether the channel is allowed to be balanced. This option must be ON (= true) for actual balancing.

BalanceValue
Type: SystemDouble
Deviation. (Read Only)

The correction made when balancing, it is expressed in user units

GroupBalanceSelection
Type: SystemInt32
Not used
BalanceStatus
Type: SystemInt32
The status and result of the balancing (Read Only):
  • Not Balanced = 0
  • Balanced = 1
  • Restored = 2
  • Busy = 3
  • Error = 4
  • Overload = 5
  • No Factory Cal = 6
  • Not Implemented = 7
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetSCBridgeBalancingSettings(String, String, String, Int32, Boolean, Double, Int32, Int32)


IPerceptionCOM.GetSCBridgeCalibrationSettings Method

IPerceptionCOMGetSCBridgeCalibrationSettings Method

Get bridge channel calibration settings

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetSCBridgeCalibrationSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    int Mask,
    out bool InternalShuntUsed,
    out double ShuntValue,
    out int CalibrationSource,
    out double ShuntDeflection,
    out bool ShuntAutoCalEnabled,
    out int GroupCalSelection,
    out int CalibrationStatus
)
Sub GetSCBridgeCalibrationSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As Integer,
    <OutAttribute> ByRef InternalShuntUsed As Boolean,
    <OutAttribute> ByRef ShuntValue As Double,
    <OutAttribute> ByRef CalibrationSource As Integer,
    <OutAttribute> ByRef ShuntDeflection As Double,
    <OutAttribute> ByRef ShuntAutoCalEnabled As Boolean,
    <OutAttribute> ByRef GroupCalSelection As Integer,
    <OutAttribute> ByRef CalibrationStatus As Integer
)
void GetSCBridgeCalibrationSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    int Mask,
    [OutAttribute] bool% InternalShuntUsed,
    [OutAttribute] double% ShuntValue,
    [OutAttribute] int% CalibrationSource,
    [OutAttribute] double% ShuntDeflection,
    [OutAttribute] bool% ShuntAutoCalEnabled,
    [OutAttribute] int% GroupCalSelection,
    [OutAttribute] int% CalibrationStatus
)
abstract GetSCBridgeCalibrationSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : int *
        InternalShuntUsed : bool byref *
        ShuntValue : float byref *
        CalibrationSource : int byref *
        ShuntDeflection : float byref *
        ShuntAutoCalEnabled : bool byref *
        GroupCalSelection : int byref *
        CalibrationStatus : int byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case InternalShuntUsed

if Mask = 2 then only the second parameter will be returned in this case ShuntValue

InternalShuntUsed
Type: SystemBoolean
Location of the shunt resistor, if 'true' then internal shunt is used else external shunt is used
ShuntValue
Type: SystemDouble
Resistive value of shunt, external or internal (Ohm)
CalibrationSource
Type: SystemInt32
Shunt active gage:
  • Positive = 0
  • Negative = 1

Defines the location of the shunt resistor: either in parallel with the gage that is located in the positive arm of the bridge circuit or in parallel with the gage located in the negative arm.

ShuntDeflection
Type: SystemDouble
Calculated shunt deflection or target deflection.

When doing a shunt verification, the measured Deflection is compared to an expected deflection. The Target is the expected deflection. The value entered here will be used to verify if the difference between the bridge output value with and without a shunt resistor is within the specified tolerance. The difference between this value and the Deflection is represented as the error of the balance.

ShuntAutoCalEnabled
Type: SystemBoolean
Not used
GroupCalSelection
Type: SystemInt32
Not used
CalibrationStatus
Type: SystemInt32
Calibration status (Read Only):
  • Not Calibrated = 0
  • Calibrated = 1
  • Busy = 2
  • Error = 3
  • No Shunt Deflection = 4
  • Not Implemented = 5
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetSCBridgeCalibrationSettings(String, String, String, Int32, Boolean, Double, Int32, Double, Boolean, Int32, Int32)


IPerceptionCOM.GetSCBridgeSetupSettings Method

IPerceptionCOMGetSCBridgeSetupSettings Method

Get channel bridge setup settings

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetSCBridgeSetupSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    int Mask,
    out double Sensitivity,
    out int CompletionType
)
Sub GetSCBridgeSetupSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As Integer,
    <OutAttribute> ByRef Sensitivity As Double,
    <OutAttribute> ByRef CompletionType As Integer
)
void GetSCBridgeSetupSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    int Mask,
    [OutAttribute] double% Sensitivity,
    [OutAttribute] int% CompletionType
)
abstract GetSCBridgeSetupSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : int *
        Sensitivity : float byref *
        CompletionType : int byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case Sensitivity

if Mask = 2 then only the second parameter will be returned in this case CompletionType

Sensitivity
Type: SystemDouble
Returns the measured voltage as function of applied strain and excitation.

This value represents the degree to which changes in the applied strain or stress causes changes in the measured output voltage as function of the applied excitation.

CompletionType
Type: SystemInt32
Bridge completion type:
  • Quarter = 0
  • Half = 1
  • Full = 2
  • QuarterAuto = 3

Specifies the configuration of the internal and external resistors that all together complete the bridge circuit. Typical values are Quarter, Half, Full, where Full means that the bridge consists only of external resistors.

See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetSCBridgeSetupSettings(String, String, String, Int32, Double, Int32)


IPerceptionCOM.GetSCCommonSettings Method

IPerceptionCOMGetSCCommonSettings Method

Get the common settings of a channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetSCCommonSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    int Mask,
    out int Mode,
    out bool Enabled,
    out string Name,
    out int PrimaryColor,
    out int SecondaryColor,
    out string UserNote1,
    out string UserNote2,
    out string UserNote3,
    out string UserNote4
)
Sub GetSCCommonSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As Integer,
    <OutAttribute> ByRef Mode As Integer,
    <OutAttribute> ByRef Enabled As Boolean,
    <OutAttribute> ByRef Name As String,
    <OutAttribute> ByRef PrimaryColor As Integer,
    <OutAttribute> ByRef SecondaryColor As Integer,
    <OutAttribute> ByRef UserNote1 As String,
    <OutAttribute> ByRef UserNote2 As String,
    <OutAttribute> ByRef UserNote3 As String,
    <OutAttribute> ByRef UserNote4 As String
)
void GetSCCommonSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    int Mask,
    [OutAttribute] int% Mode,
    [OutAttribute] bool% Enabled,
    [OutAttribute] String^% Name,
    [OutAttribute] int% PrimaryColor,
    [OutAttribute] int% SecondaryColor,
    [OutAttribute] String^% UserNote1,
    [OutAttribute] String^% UserNote2,
    [OutAttribute] String^% UserNote3,
    [OutAttribute] String^% UserNote4
)
abstract GetSCCommonSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : int *
        Mode : int byref *
        Enabled : bool byref *
        Name : string byref *
        PrimaryColor : int byref *
        SecondaryColor : int byref *
        UserNote1 : string byref *
        UserNote2 : string byref *
        UserNote3 : string byref *
        UserNote4 : string byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
Mask
Type: SystemInt32
Parameter mask, 0xFFFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case Mode

if Mask = 2 then only the second parameter will be returned in this case Enabled

Mode
Type: SystemInt32
Amplifier mode:
  • Basic (Differential) = 0
  • Bridge = 1
  • Icp = 2
  • ThermoCouple = 3
  • BasicSensor = 4

Most channels can only be used in one amplifier mode; this mode is described as “basic” mode. However, there are also channels which support different modes like the bridge amplifier. This amplifier can work in basic mode, basic sensor mode and in bridge mode.

Once a type has been set, you can find the detailed settings of the selected type of input in the Input group.

Enabled
Type: SystemBoolean
Storage, When ON the channel is enabled for data storage.
Name
Type: SystemString
Logical name of the channel
PrimaryColor
Type: SystemInt32
Default trace color in displays
SecondaryColor
Type: SystemInt32
Secondary trace color
UserNote1
Type: SystemString
First additional field to enter miscellaneous information
UserNote2
Type: SystemString
Second additional field to enter miscellaneous information
UserNote3
Type: SystemString
Third additional field to enter miscellaneous information
UserNote4
Type: SystemString
Fourth additional field to enter miscellaneous information
Examples
Copy
int Mask = 0xFFFF;
int Mode;
bool Enabled;
string cName;
int PrimaryColor;
int SecondaryColor;
string UserNote1;
string UserNote2;
string UserNote3;
string UserNote4;

RPC.GetSCCommonSettings("Mainframe 1", "Recorder A", "Ch A1", Mask, out Mode,
out Enabled, out cName, out PrimaryColor, out SecondaryColor, out UserNote1, out UserNote2, out UserNote3, out UserNote4);
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetSCCommonSettings(String, String, String, Int32, Int32, Boolean, String, Int32, Int32, String, String, String, String)


IPerceptionCOM.GetSCCouplingSettings Method

IPerceptionCOMGetSCCouplingSettings Method

Get the couplings settings of a channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetSCCouplingSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    int Mask,
    out int InCoupling,
    out int SigCoupling,
    out double MeasuringPeriod,
    out double ReferenceLevel,
    out double Impedance
)
Sub GetSCCouplingSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As Integer,
    <OutAttribute> ByRef InCoupling As Integer,
    <OutAttribute> ByRef SigCoupling As Integer,
    <OutAttribute> ByRef MeasuringPeriod As Double,
    <OutAttribute> ByRef ReferenceLevel As Double,
    <OutAttribute> ByRef Impedance As Double
)
void GetSCCouplingSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    int Mask,
    [OutAttribute] int% InCoupling,
    [OutAttribute] int% SigCoupling,
    [OutAttribute] double% MeasuringPeriod,
    [OutAttribute] double% ReferenceLevel,
    [OutAttribute] double% Impedance
)
abstract GetSCCouplingSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : int *
        InCoupling : int byref *
        SigCoupling : int byref *
        MeasuringPeriod : float byref *
        ReferenceLevel : float byref *
        Impedance : float byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case InCoupling

if Mask = 2 then only the second parameter will be returned in this case SigCoupling

InCoupling
Type: SystemInt32
Input coupling of a channel:
  • Single Ended Positive = 0
  • Single Ended Negative = 1
  • Differential = 2
  • Current = 3
  • Floating Differential = 4

This setting determines how the input signal is routed to the amplifier. If for example “Single Ended Positive” is selected, the negative input of the amplifier is grounded and the positive input is connected to the incoming signal. For a better understanding it is useful to look at the graphics on top of the settings sheet.

SigCoupling
Type: SystemInt32
Signal coupling:
  • GND = 0
  • DC = 1
  • AC = 2
  • DC_RMS = 3
  • AC_RMS = 4
  • DC_Frequency = 5
  • AC_Frequency = 6
  • DC_TrueRMS = 7
  • AC_TrueRMS = 8
  • DC_ExternalProbe = 9
  • AC_ExternalProbe = 10
  • Reference = 11

Defines how the analog signal is "coupled" into the amplifier

This setting defines how the analog signal is "coupled" into the amplifier. The coupling feature defines which signal component (content) is passed to the amplifier. When "AC" is selected, the AC content of a signal without any DC bias voltage is measured. With "DC" selection, both AC and DC content are passed to the amplifier. A "GND" mode is usually provided to ground an amplifier to minimize the influence of random noise.

MeasuringPeriod
Type: SystemDouble
Not yet used, reserved for future purposes
ReferenceLevel
Type: SystemDouble
Not yet used, reserved for future purposes
Impedance
Type: SystemDouble
Input impedance is the effective resistance and capacitance seen at the input to the digitizer.

This setting is read-only and shows the effective resistance and capacitance seen at the input to the digitizer.

See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetSCCouplingSettings(String, String, String, Int32, Int32, Int32, Double, Double, Double)


IPerceptionCOM.GetSCExcitationSettings Method

IPerceptionCOMGetSCExcitationSettings Method

Get the channel excitation settings

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetSCExcitationSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    int Mask,
    out bool Enable,
    out int ExcitationType,
    out double Voltage,
    out double Current
)
Sub GetSCExcitationSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As Integer,
    <OutAttribute> ByRef Enable As Boolean,
    <OutAttribute> ByRef ExcitationType As Integer,
    <OutAttribute> ByRef Voltage As Double,
    <OutAttribute> ByRef Current As Double
)
void GetSCExcitationSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    int Mask,
    [OutAttribute] bool% Enable,
    [OutAttribute] int% ExcitationType,
    [OutAttribute] double% Voltage,
    [OutAttribute] double% Current
)
abstract GetSCExcitationSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : int *
        Enable : bool byref *
        ExcitationType : int byref *
        Voltage : float byref *
        Current : float byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case Enable

if Mask = 2 then only the second parameter will be returned in this case ExitationType

Enable
Type: SystemBoolean
Sets system excitation yes or no.

Use this settings to enable or disable the excitation. It is good practice to remove excitation before you connect or disconnect a (bridge) sensor to the input.

ExcitationType
Type: SystemInt32
Excitation type:
  • Voltage = 0
  • Voltage_Sense = 1
  • Current = 2
  • Voltage_Strobed = 3
  • Voltage_Sense_Strobed = 4
  • Current_Strobed = 5

The bridge circuit can be supplied with either a voltage or a current. Choose the one that applies.

Voltage
Type: SystemDouble
Excitation voltage in Volt (Only used when Excitation type is set to Voltage)
Current
Type: SystemDouble
Excitation current in Ampere (Only used when Excitation type is set to Current)
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetSCExcitationSettings(String, String, String, Int32, Boolean, Int32, Double, Double)


IPerceptionCOM.GetSCFilterSettings Method

IPerceptionCOMGetSCFilterSettings Method

Set the filter settings of a channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetSCFilterSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    int Mask,
    out int Type,
    out int Mode,
    out double TrackingRatio,
    out double Frequency,
    out double ActualFrequency
)
Sub GetSCFilterSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As Integer,
    <OutAttribute> ByRef Type As Integer,
    <OutAttribute> ByRef Mode As Integer,
    <OutAttribute> ByRef TrackingRatio As Double,
    <OutAttribute> ByRef Frequency As Double,
    <OutAttribute> ByRef ActualFrequency As Double
)
void GetSCFilterSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    int Mask,
    [OutAttribute] int% Type,
    [OutAttribute] int% Mode,
    [OutAttribute] double% TrackingRatio,
    [OutAttribute] double% Frequency,
    [OutAttribute] double% ActualFrequency
)
abstract GetSCFilterSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : int *
        Type : int byref *
        Mode : int byref *
        TrackingRatio : float byref *
        Frequency : float byref *
        ActualFrequency : float byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case InCoupling

if Mask = 2 then only the second parameter will be returned in this case SigCoupling

Type
Type: SystemInt32
Filter type:
  • Bessel = 0
  • Butterworth = 1
  • Elliptic = 2
  • FIR = 3
  • IIR = 4
  • Wideband = 5
  • Bessel Analog = 6
  • Butterworth Analog = 7
  • Sigma Delta Wideband = 8
Mode
Type: SystemInt32
Filter mode:
  • Tracking = 0
  • Fixed = 1
TrackingRatio
Type: SystemDouble
Tracking ratio
Frequency
Type: SystemDouble
Frequency above which the power is 0.5 the power of the pass band (-3 dBpoint)

The filter frequency defines the pass band of the filter. This frequency is also often called the cut-off frequency. This is the frequency where the signal has been attenuated to half the power of the pass band. The available filter frequencies depend on the sample rate and the Filter type.

Typical available values are:

- FIR: 1/4, 1/10,1/20 and 1/40 of the sample rate

- Bessel: 1/10, 1/20, 1/40 and 1/100 of the sample rate

ActualFrequency
Type: SystemDouble
Remarks
Removes unwanted high-frequency signal components by selecting the correct filter type
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetSCFilterSettings(String, String, String, Int32, Int32, Int32, Double, Double, Double)


IPerceptionCOM.GetSCInputRangeSettings Method

IPerceptionCOMGetSCInputRangeSettings Method

Get the input range settings of a channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetSCInputRangeSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    int Mask,
    out double UpperValue,
    out double LowerValue,
    out double ActualUpperValue,
    out double ActualLowerValue,
    out double Span,
    out double Offset,
    out double Gain,
    out bool VariableGain
)
Sub GetSCInputRangeSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As Integer,
    <OutAttribute> ByRef UpperValue As Double,
    <OutAttribute> ByRef LowerValue As Double,
    <OutAttribute> ByRef ActualUpperValue As Double,
    <OutAttribute> ByRef ActualLowerValue As Double,
    <OutAttribute> ByRef Span As Double,
    <OutAttribute> ByRef Offset As Double,
    <OutAttribute> ByRef Gain As Double,
    <OutAttribute> ByRef VariableGain As Boolean
)
void GetSCInputRangeSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    int Mask,
    [OutAttribute] double% UpperValue,
    [OutAttribute] double% LowerValue,
    [OutAttribute] double% ActualUpperValue,
    [OutAttribute] double% ActualLowerValue,
    [OutAttribute] double% Span,
    [OutAttribute] double% Offset,
    [OutAttribute] double% Gain,
    [OutAttribute] bool% VariableGain
)
abstract GetSCInputRangeSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : int *
        UpperValue : float byref *
        LowerValue : float byref *
        ActualUpperValue : float byref *
        ActualLowerValue : float byref *
        Span : float byref *
        Offset : float byref *
        Gain : float byref *
        VariableGain : bool byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case UpperValue

if Mask = 2 then only the second parameter will be returned in this case LowerValue

UpperValue
Type: SystemDouble
Upper value in user units
LowerValue
Type: SystemDouble
Lower value in user units
ActualUpperValue
Type: SystemDouble
Actual upper value in user units
ActualLowerValue
Type: SystemDouble
Actual lower value in user units
Span
Type: SystemDouble
Span in user units
Offset
Type: SystemDouble
Offset in user units
Gain
Type: SystemDouble
Gain
VariableGain
Type: SystemBoolean
Enable variable gain
Examples
Copy
int nMask = 0xFF;
double UpperValue;
double LowerValue;
double ActualUpperValue;
double ActualLowerValue;
double Span;
double Offset;
double Gain;
bool VariableGain;

m_Perception.GetSCInputRangeSettings("Mainframe 1", "Recorder A", "Ch A1", nMask, out  UpperValue,
                    out LowerValue, out ActualUpperValue, out  ActualLowerValue, out Span, out Offset, out Gain, out VariableGain);
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetSCInputRangeSettings(String, String, String, Int32, Double, Double, Double, Double, Double, Double, Double, Boolean)


IPerceptionCOM.GetSCUserScalingSettings Method

IPerceptionCOMGetSCUserScalingSettings Method

Get the user-scaling of a channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetSCUserScalingSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    int Mask,
    out double Multiplier,
    out double Offset,
    out string UserUnits
)
Sub GetSCUserScalingSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As Integer,
    <OutAttribute> ByRef Multiplier As Double,
    <OutAttribute> ByRef Offset As Double,
    <OutAttribute> ByRef UserUnits As String
)
void GetSCUserScalingSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    int Mask,
    [OutAttribute] double% Multiplier,
    [OutAttribute] double% Offset,
    [OutAttribute] String^% UserUnits
)
abstract GetSCUserScalingSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : int *
        Multiplier : float byref *
        Offset : float byref *
        UserUnits : string byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case Multiplier

if Mask = 2 then only the second parameter will be returned in this case Offset

Multiplier
Type: SystemDouble
Technical units multiplier (a)
Offset
Type: SystemDouble
Technical units offset (b)
UserUnits
Type: SystemString
Technical units
Remarks

y = a.x + b (x = input)

The measured input data can be transformed to a different scale by using the linear equation described above. This can be used for example to calibrate the system or convert the measured input into a different unit. The technical units multiplier is the scaling factor “a” in the formula above. The technical units offset is the offset factor “b” in the formula above.

Examples
Copy
int nMask = 0xFF;
double Multiplier;
double Offset;
string UserUnits;
m_Perception.GetSCUserScalingSettings("GEN7t I", "Recorder A", "Ch A1", nMask, out Multiplier, out Offset, out UserUnits);
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetSCUserScalingSettings(String, String, String, Int32, Double, Double, String)


IPerceptionCOM.GetSheetCount Method

IPerceptionCOMGetSheetCount Method

Returns the number of visible sheets

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetSheetCount(
    out int Count
)
Sub GetSheetCount (
    <OutAttribute> ByRef Count As Integer
)
void GetSheetCount(
    [OutAttribute] int% Count
)
abstract GetSheetCount :
        Count : int byref -> unit

Parameters

Count
Type: SystemInt32
The number of visible sheets
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetSheetName(Int32, String)
IPerceptionCOMGetActiveSheet(String)
IPerceptionCOMSetActiveSheet(String)


IPerceptionCOM.GetSheetName Method

IPerceptionCOMGetSheetName Method

Gets the name of the sheet at index.

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetSheetName(
    int Index,
    out string Name
)
Sub GetSheetName (
    Index As Integer,
    <OutAttribute> ByRef Name As String
)
void GetSheetName(
    int Index,
    [OutAttribute] String^% Name
)
abstract GetSheetName :
        Index : int *
        Name : string byref -> unit

Parameters

Index
Type: SystemInt32
Zero based sheet index to return sheet name.
Name
Type: SystemString
Name of the sheet at index.
Remarks
The index is zero-based
Examples
Copy
protected void FillSheetList()
{
      // Get the number of visible sheets
      int iCount = 0;
      m_Perception.GetSheetCount(out iCount);

      for (int i = 0; i < iCount; i++)
      {
           m_Perception.GetSheetName(i, out strOut);
           int iInsertedIndex = lstSheets.Items.Add(strOut);

           //store the sheet index in the list as well
           lstSheets.Items[iInsertedIndex].Tag = i;
      }
}
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetSheetCount(Int32)
IPerceptionCOMGetActiveSheet(String)
IPerceptionCOMSetActiveSheet(String)


IPerceptionCOM.GetShuntResistorActive Method

IPerceptionCOMGetShuntResistorActive Method

Get the shunt resistor

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetShuntResistorActive(
    string Mainframe,
    string Recorder,
    string Channel,
    out bool Active
)
Sub GetShuntResistorActive (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    <OutAttribute> ByRef Active As Boolean
)
void GetShuntResistorActive(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    [OutAttribute] bool% Active
)
abstract GetShuntResistorActive :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Active : bool byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
Active
Type: SystemBoolean
If true the shunt resistor is active, for more information see "Shunt verification" in Perception manual
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetShuntResistorActive(String, String, String, Boolean)


IPerceptionCOM.GetSilentMode Method

IPerceptionCOMGetSilentMode Method

Retrieves the current setting for silent mode.

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetSilentMode(
    out bool SilentModeEnabled
)
Sub GetSilentMode (
    <OutAttribute> ByRef SilentModeEnabled As Boolean
)
void GetSilentMode(
    [OutAttribute] bool% SilentModeEnabled
)
abstract GetSilentMode :
        SilentModeEnabled : bool byref -> unit

Parameters

SilentModeEnabled
Type: SystemBoolean
True if set to silent mode, False otherwise.
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.GetStatusDouble Method

IPerceptionCOMGetStatusDouble Method

Get a status value as double

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetStatusDouble(
    string Mainframe,
    string Recorder,
    string Channel,
    COMStatusID Identifier,
    out double Status
)
Sub GetStatusDouble (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Identifier As COMStatusID,
    <OutAttribute> ByRef Status As Double
)
void GetStatusDouble(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    COMStatusID Identifier,
    [OutAttribute] double% Status
)
abstract GetStatusDouble :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Identifier : COMStatusID *
        Status : float byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
Identifier
Type: RPC_COMCOMStatusID
Selected parameter
Status
Type: SystemDouble
Returns the status of the selected parameter as double
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetStatusInt(String, String, String, COMStatusID, Int32)
IPerceptionCOMGetStatusString(String, String, String, COMStatusID, String)


IPerceptionCOM.GetStatusInt Method

IPerceptionCOMGetStatusInt Method

Get a status value as integer

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetStatusInt(
    string Mainframe,
    string Recorder,
    string Channel,
    COMStatusID Identifier,
    out int Status
)
Sub GetStatusInt (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Identifier As COMStatusID,
    <OutAttribute> ByRef Status As Integer
)
void GetStatusInt(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    COMStatusID Identifier,
    [OutAttribute] int% Status
)
abstract GetStatusInt :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Identifier : COMStatusID *
        Status : int byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
Identifier
Type: RPC_COMCOMStatusID
Selected parameter
Status
Type: SystemInt32
Returns the status of the selected parameter as integer
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetStatusDouble(String, String, String, COMStatusID, Double)
IPerceptionCOMGetStatusString(String, String, String, COMStatusID, String)


IPerceptionCOM.GetStatusString Method

IPerceptionCOMGetStatusString Method

Get a status value as string

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetStatusString(
    string Mainframe,
    string Recorder,
    string Channel,
    COMStatusID Identifier,
    out string Status
)
Sub GetStatusString (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Identifier As COMStatusID,
    <OutAttribute> ByRef Status As String
)
void GetStatusString(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    COMStatusID Identifier,
    [OutAttribute] String^% Status
)
abstract GetStatusString :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Identifier : COMStatusID *
        Status : string byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
Identifier
Type: RPC_COMCOMStatusID
Selected parameter
Status
Type: SystemString
Returns the status of the selected parameter as string
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetStatusInt(String, String, String, COMStatusID, Int32)
IPerceptionCOMGetStatusDouble(String, String, String, COMStatusID, Double)


IPerceptionCOM.GetStorageSettings Method

IPerceptionCOMGetStorageSettings Method

Note: This API is now obsolete.

This method is no longer supported and has been replaced by the GetGroupStorageSettings

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is no longer supported and has been replaced by the GetGroupStorageSettings")]
void GetStorageSettings(
    string Mainframe,
    string Recorder,
    out int StorageMode
)
<ObsoleteAttribute("This method is no longer supported and has been replaced by the GetGroupStorageSettings")>
Sub GetStorageSettings (
    Mainframe As String,
    Recorder As String,
    <OutAttribute> ByRef StorageMode As Integer
)
[ObsoleteAttribute(L"This method is no longer supported and has been replaced by the GetGroupStorageSettings")]
void GetStorageSettings(
    String^ Mainframe,
    String^ Recorder,
    [OutAttribute] int% StorageMode
)
[<ObsoleteAttribute("This method is no longer supported and has been replaced by the GetGroupStorageSettings")>]
abstract GetStorageSettings :
        Mainframe : string *
        Recorder : string *
        StorageMode : int byref -> unit

Parameters

Mainframe
Type: SystemString
Recorder
Type: SystemString
StorageMode
Type: SystemInt32
Remarks
In Perception 6.30 this method has been replaced with the method GetGroupStorageSettings
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetGroupStorageSettings(String, COMStorageMode, COMRecordingMode, Double, Double)


IPerceptionCOM.GetSweepSettings Method

IPerceptionCOMGetSweepSettings Method

Note: This API is now obsolete.

This method is no longer supported and has been replaced by the GetGroupSweepSettings

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is no longer supported and has been replaced by the GetGroupSweepSettings")]
void GetSweepSettings(
    string Mainframe,
    string Recorder,
    out int SweepLength,
    out int SweepMode,
    out double TriggerPosition,
    out double Delay,
    out bool SweepCountEnabled,
    out int SweepCount
)
<ObsoleteAttribute("This method is no longer supported and has been replaced by the GetGroupSweepSettings")>
Sub GetSweepSettings (
    Mainframe As String,
    Recorder As String,
    <OutAttribute> ByRef SweepLength As Integer,
    <OutAttribute> ByRef SweepMode As Integer,
    <OutAttribute> ByRef TriggerPosition As Double,
    <OutAttribute> ByRef Delay As Double,
    <OutAttribute> ByRef SweepCountEnabled As Boolean,
    <OutAttribute> ByRef SweepCount As Integer
)
[ObsoleteAttribute(L"This method is no longer supported and has been replaced by the GetGroupSweepSettings")]
void GetSweepSettings(
    String^ Mainframe,
    String^ Recorder,
    [OutAttribute] int% SweepLength,
    [OutAttribute] int% SweepMode,
    [OutAttribute] double% TriggerPosition,
    [OutAttribute] double% Delay,
    [OutAttribute] bool% SweepCountEnabled,
    [OutAttribute] int% SweepCount
)
[<ObsoleteAttribute("This method is no longer supported and has been replaced by the GetGroupSweepSettings")>]
abstract GetSweepSettings :
        Mainframe : string *
        Recorder : string *
        SweepLength : int byref *
        SweepMode : int byref *
        TriggerPosition : float byref *
        Delay : float byref *
        SweepCountEnabled : bool byref *
        SweepCount : int byref -> unit

Parameters

Mainframe
Type: SystemString
Recorder
Type: SystemString
SweepLength
Type: SystemInt32
SweepMode
Type: SystemInt32
TriggerPosition
Type: SystemDouble
Delay
Type: SystemDouble
SweepCountEnabled
Type: SystemBoolean
SweepCount
Type: SystemInt32
Remarks
In Perception 6.30 this method has been replaced with the method GetGroupSweepSettings
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetGroupSweepSettings(String, Int32, COMSweepMode, Double, Double, Boolean, Int32, Int32, Double, Boolean)


IPerceptionCOM.GetTemperatureStatus Method

IPerceptionCOMGetTemperatureStatus Method

Get the temperature of an amplifier

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetTemperatureStatus(
    string Mainframe,
    string Recorder,
    string Channel,
    out double AmplifierTemperature
)
Sub GetTemperatureStatus (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    <OutAttribute> ByRef AmplifierTemperature As Double
)
void GetTemperatureStatus(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    [OutAttribute] double% AmplifierTemperature
)
abstract GetTemperatureStatus :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        AmplifierTemperature : float byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
AmplifierTemperature
Type: SystemDouble
The temperature of the amplifier in °C
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.GetTimebaseSettings Method

IPerceptionCOMGetTimebaseSettings Method

Note: This API is now obsolete.

This method is no longer supported and has been replaced by the GetGroupTimebaseSettings

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is no longer supported and has been replaced by the GetGroupTimebaseSettings")]
void GetTimebaseSettings(
    string Mainframe,
    string Recorder,
    out double HighSampleRate,
    out double LowSampleRate
)
<ObsoleteAttribute("This method is no longer supported and has been replaced by the GetGroupTimebaseSettings")>
Sub GetTimebaseSettings (
    Mainframe As String,
    Recorder As String,
    <OutAttribute> ByRef HighSampleRate As Double,
    <OutAttribute> ByRef LowSampleRate As Double
)
[ObsoleteAttribute(L"This method is no longer supported and has been replaced by the GetGroupTimebaseSettings")]
void GetTimebaseSettings(
    String^ Mainframe,
    String^ Recorder,
    [OutAttribute] double% HighSampleRate,
    [OutAttribute] double% LowSampleRate
)
[<ObsoleteAttribute("This method is no longer supported and has been replaced by the GetGroupTimebaseSettings")>]
abstract GetTimebaseSettings :
        Mainframe : string *
        Recorder : string *
        HighSampleRate : float byref *
        LowSampleRate : float byref -> unit

Parameters

Mainframe
Type: SystemString
Recorder
Type: SystemString
HighSampleRate
Type: SystemDouble
LowSampleRate
Type: SystemDouble
Remarks
In Perception 6.30 this method has been replaced with the method GetGroupTimebaseSettings
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetGroupTimebaseSettings(String, Double, Double, COMClockSource, Int32)


IPerceptionCOM.GetTimerCounterChannelEnabled Method

IPerceptionCOMGetTimerCounterChannelEnabled Method

Returns whether a channels data is stored or not.

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetTimerCounterChannelEnabled(
    string Mainframe,
    string Recorder,
    string Channel,
    out bool Enabled
)
Sub GetTimerCounterChannelEnabled (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    <OutAttribute> ByRef Enabled As Boolean
)
void GetTimerCounterChannelEnabled(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    [OutAttribute] bool% Enabled
)
abstract GetTimerCounterChannelEnabled :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Enabled : bool byref -> unit

Parameters

Mainframe
Type: SystemString
Name or index of mainframe
Recorder
Type: SystemString
Name or index of recorder
Channel
Type: SystemString
Name or index of the timer/counter channel
Enabled
Type: SystemBoolean
Marker channel enabled true or false
Remarks
Examples
Copy
string cMainframe = "GEN7t I";
string cRecorder = "Recorder A";
string cChannel = "Ev1";
bool bEnabled;

m_Perception.GetTimerCounterChannelEnabled(cMainframe, cRecorder, cChannel, out bEnabled);

if (bEnabled)
   lblStorage.Text = "Storage ON";
else
   lblStorage.Text = "Storage OFF";
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetChannelEnabled(String, String, String, Boolean)
IPerceptionCOMSetChannelEnabled(String, String, String, Boolean)
IPerceptionCOMGetEventChannelEnabled(String, String, String, Boolean)
IPerceptionCOMSetEventChannelEnabled(String, String, String, Boolean)
IPerceptionCOMSetTimerCounterChannelEnabled(String, String, String, Boolean)


IPerceptionCOM.GetTriggerIOSettings Method

IPerceptionCOMGetTriggerIOSettings Method

Get the trigger IO settings of a mainframe

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetTriggerIOSettings(
    string Mainframe,
    int Mask,
    out COMExternalTriggerIn ExtTrigIn,
    out COMExternalTriggerOut ExtTrigOut,
    out int AlarmOutMode,
    out int ExtQualInMode
)
Sub GetTriggerIOSettings (
    Mainframe As String,
    Mask As Integer,
    <OutAttribute> ByRef ExtTrigIn As COMExternalTriggerIn,
    <OutAttribute> ByRef ExtTrigOut As COMExternalTriggerOut,
    <OutAttribute> ByRef AlarmOutMode As Integer,
    <OutAttribute> ByRef ExtQualInMode As Integer
)
void GetTriggerIOSettings(
    String^ Mainframe,
    int Mask,
    [OutAttribute] COMExternalTriggerIn% ExtTrigIn,
    [OutAttribute] COMExternalTriggerOut% ExtTrigOut,
    [OutAttribute] int% AlarmOutMode,
    [OutAttribute] int% ExtQualInMode
)
abstract GetTriggerIOSettings :
        Mainframe : string *
        Mask : int *
        ExtTrigIn : COMExternalTriggerIn byref *
        ExtTrigOut : COMExternalTriggerOut byref *
        AlarmOutMode : int byref *
        ExtQualInMode : int byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case ExtTrigIn

if Mask = 2 then only the second parameter will be returned in this case ExtTrigOut

ExtTrigIn
Type: RPC_COMCOMExternalTriggerIn
External trigger in direction.

Enables the use of the external trigger input on the mainframe

The trigger can come from an external signal which is fed to the respective port on the mainframe’s controller module. If this setting is enabled, a logical OR is applied to the combination of the internal trigger detectors of each channel and the external trigger signal.

Although this is a per-recorder setting, there is only one external trigger input for the complete mainframe. Each individual recorder can be set to accept this trigger.

However, a direction setting (if provided by the hardware) is mainframe-wide and cannot be set on a per-recorder basis.

ExtTrigOut
Type: RPC_COMCOMExternalTriggerOut
External trigger out level.

Sets the edge sensitivity of the external trigger input

AlarmOutMode
Type: SystemInt32
Sets the function of the alarm output on the mainframe.
  • CtrlAlarmOutMode_Disabled = 0
  • CtrlAlarmOutMode_HighLevel = 1
  • CtrlAlarmOutMode_LowLevel = 2
  • CtrlAlarmOutMode_AcqState_HighLevel = 3
  • CtrlAlarmOutMode_AcqState_LowLevel = 4

Each channel has the capability of generating an alarm. The output of a channel’s alarm detector is sent to an alarm line and combined (OR-ed) with alarm conditions of the other channels and recorders. The result is available as an external output located on the mainframe controller.

This setting can have one of the values Alarm High Level, Alarm Low Level, or Recording High Level. When Recording High Level is selected, the output connector on the controller is high when a recording is in process. When Alarm High Level is selected, the output is high when channel alarm detectors activate on the alarm line. When Alarm Low Level is selected, the output is low when the alarm line level is active; the signal is therefore the inverse of the previous setting.

ExtQualInMode
Type: SystemInt32
External qualifier in mode:
  • CtrlExternalQualifierInMode_Disabled = 0
  • CtrlExternalQualifierInMode_HighLevel = 1
  • CtrlExternalQualifierInMode_LowLevel = 2
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetTriggerIOSettings(String, Int32, COMExternalTriggerIn, COMExternalTriggerOut, Int32, Int32)


IPerceptionCOM.GetTriggerLevelSettings Method

IPerceptionCOMGetTriggerLevelSettings Method

Get the trigger level settings of a channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetTriggerLevelSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    int Mask,
    out int Mode,
    out double PrimaryLevel,
    out double SecondaryLevel,
    out int Direction,
    out double Hysterese,
    out bool TriggerDeltaTimeWindowEnabled,
    out double TriggerDeltaTimeWindow,
    out int ChannelSelect
)
Sub GetTriggerLevelSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As Integer,
    <OutAttribute> ByRef Mode As Integer,
    <OutAttribute> ByRef PrimaryLevel As Double,
    <OutAttribute> ByRef SecondaryLevel As Double,
    <OutAttribute> ByRef Direction As Integer,
    <OutAttribute> ByRef Hysterese As Double,
    <OutAttribute> ByRef TriggerDeltaTimeWindowEnabled As Boolean,
    <OutAttribute> ByRef TriggerDeltaTimeWindow As Double,
    <OutAttribute> ByRef ChannelSelect As Integer
)
void GetTriggerLevelSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    int Mask,
    [OutAttribute] int% Mode,
    [OutAttribute] double% PrimaryLevel,
    [OutAttribute] double% SecondaryLevel,
    [OutAttribute] int% Direction,
    [OutAttribute] double% Hysterese,
    [OutAttribute] bool% TriggerDeltaTimeWindowEnabled,
    [OutAttribute] double% TriggerDeltaTimeWindow,
    [OutAttribute] int% ChannelSelect
)
abstract GetTriggerLevelSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : int *
        Mode : int byref *
        PrimaryLevel : float byref *
        SecondaryLevel : float byref *
        Direction : int byref *
        Hysterese : float byref *
        TriggerDeltaTimeWindowEnabled : bool byref *
        TriggerDeltaTimeWindow : float byref *
        ChannelSelect : int byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case Mode

if Mask = 2 then only the second parameter will be returned in this case PrimaryLevel

Mode
Type: SystemInt32
Trigger mode:
  • Off = 0
  • Basic = 1
  • Dual = 2
  • Window = 3
  • DualWindow = 4
  • Sequential = 5
  • BasicQualifier = 6
  • DualQualifier = 7
PrimaryLevel
Type: SystemDouble
Primary level in user units
SecondaryLevel
Type: SystemDouble
Secondary level in user units
Direction
Type: SystemInt32
Direction:
  • Rising Edge = 0
  • Falling Edge = 1
Hysterese
Type: SystemDouble
Hysteresis in user-units
TriggerDeltaTimeWindowEnabled
Type: SystemBoolean
dY/dt enabled
TriggerDeltaTimeWindow
Type: SystemDouble
Delta time window user-units per seconds
ChannelSelect
Type: SystemInt32
UNKOWN
Examples
Copy
protected void Get()
{
     int Mask = 0xFF;
     int TriggerMode;
     double PrimaryLevel;
     double SecondaryLevel;
     int Direction;
     double Hysteresis;
     bool TriggerDeltaTimeWindowEnabled;
     double TriggerDeltaTimeWindow;
     int ChannelSelect;

     m_Perception.GetTriggerLevelSettings(  "GEN7t I", "Recorder A", "Ch A1", Mask,
                                   out TriggerMode, out PrimaryLevel, out SecondaryLevel, out Direction, out Hysteresis,
                                   out TriggerDeltaTimeWindowEnabled, out TriggerDeltaTimeWindow, out ChannelSelect);
}
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetTriggerLevelSettings(String, String, String, Int32, Int32, Double, Double, Int32, Double, Boolean, Double, Int32)
IPerceptionCOMSetTriggerSettings(String, String, String, Int32, Double, Double, Int32)
IPerceptionCOMGetTriggerSettings(String, String, String, Int32, Double, Double, Int32)


IPerceptionCOM.GetTriggerPulseDetectorSettings Method

IPerceptionCOMGetTriggerPulseDetectorSettings Method

Get trigger pulse detector settings

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetTriggerPulseDetectorSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    int Mask,
    out int PulseDetectorMode,
    out double PulseWindowTime
)
Sub GetTriggerPulseDetectorSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As Integer,
    <OutAttribute> ByRef PulseDetectorMode As Integer,
    <OutAttribute> ByRef PulseWindowTime As Double
)
void GetTriggerPulseDetectorSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    int Mask,
    [OutAttribute] int% PulseDetectorMode,
    [OutAttribute] double% PulseWindowTime
)
abstract GetTriggerPulseDetectorSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : int *
        PulseDetectorMode : int byref *
        PulseWindowTime : float byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Name or index of recorder
Channel
Type: SystemString
Name or index of channel
Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case PulseDetectorMode

if Mask = 2 then only the second parameter will be returned in this case PulseWindowTime

PulseDetectorMode
Type: SystemInt32
Enables pulse detection/rejection
  • Disabled = 0
  • Detect = 1
  • Reject = 2

The pulse detector can be used together with the basic (slope) trigger level detector. The possible values are: Disabled, Detect, Reject. The Pulse width is used to define the width of the pulses which should be detected or rejected.

PulseWindowTime
Type: SystemDouble
Pulse width.

Use this setting to set the width of the pulses which should be detected or rejected. The pulse width is only used if the Pulse detector is set to Detect or Reject. The value is specified in seconds or external timebase units depending on the mainframe Clock base setting.

See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetTriggerPulseDetectorSettings(String, String, String, Int32, Int32, Double)


IPerceptionCOM.GetTriggerRepeatTimerSettings Method

IPerceptionCOMGetTriggerRepeatTimerSettings Method

Get trigger repeat timer settings

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetTriggerRepeatTimerSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    int Mask,
    out int RepeatTimerMode,
    out double WindowStart,
    out double WindowWidth,
    out double EventHoldOffTime,
    out int EventOccurrences
)
Sub GetTriggerRepeatTimerSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As Integer,
    <OutAttribute> ByRef RepeatTimerMode As Integer,
    <OutAttribute> ByRef WindowStart As Double,
    <OutAttribute> ByRef WindowWidth As Double,
    <OutAttribute> ByRef EventHoldOffTime As Double,
    <OutAttribute> ByRef EventOccurrences As Integer
)
void GetTriggerRepeatTimerSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    int Mask,
    [OutAttribute] int% RepeatTimerMode,
    [OutAttribute] double% WindowStart,
    [OutAttribute] double% WindowWidth,
    [OutAttribute] double% EventHoldOffTime,
    [OutAttribute] int% EventOccurrences
)
abstract GetTriggerRepeatTimerSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : int *
        RepeatTimerMode : int byref *
        WindowStart : float byref *
        WindowWidth : float byref *
        EventHoldOffTime : float byref *
        EventOccurrences : int byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Name or index of recorder
Channel
Type: SystemString
Name or index of channel
Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case RepeatTimerMode

if Mask = 2 then only the second parameter will be returned in this case WindowStart

RepeatTimerMode
Type: SystemInt32
Repeat timer mode:
  • Disabled = 0
  • Less = 1
  • More = 2
  • Between = 3
  • NotBetween = 4

Defines a time relation between two consecutive trigger events

The interval timer is used to define a time relation between two trigger events. If the time relation is correct, a trigger is generated. The possible timer modes are: Disabled, Less, More, Between, NotBetween.

WindowStart
Type: SystemDouble
Timer window start.

Depending on the interval timer mode, there is a difference in functionality for this setting:

- For the Less and More mode, this setting is the width of the interval.

- For Between and NotBetween, this setting is the time after which the Timer window width interval is used.

The value is specified in seconds or external timebase units depending on the mainframe Clock base setting.

WindowWidth
Type: SystemDouble
Timer window width

Defines the second interval used for the interval timer

The trigger window width is only used if the Timer mode is set to Between or NotBetween. The value is specified in seconds or external timebase units depending on the mainframe Clock base setting.

EventHoldOffTime
Type: SystemDouble
Hold off time.

Disables the trigger detector for a specified period of time after a valid trigger has been generated

The trigger hold-off feature is used to disable the trigger detector for a period of time after a valid trigger has been generated. This can be used to generate only one trigger on a slowly decaying repetitive signal, or eliminate the effect of after-ringing. The feature is most useful in combination with the interval Timer and/or the Event counter.

EventOccurrences
Type: SystemInt32
Event counter.

Counts a number of trigger events before the actual trigger is generated

The event counter adds all generated triggers and generates a final trigger if the count equals the preset value.

See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetTriggerRepeatTimerSettings(String, String, String, Int32, Int32, Double, Double, Double, Int32)


IPerceptionCOM.GetTriggerSettings Method

IPerceptionCOMGetTriggerSettings Method

Gets the basic trigger parameters per channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetTriggerSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    out int TriggerMode,
    out double PrimaryTriggerLevel,
    out double SecondaryTriggerLevel,
    out int Direction
)
Sub GetTriggerSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    <OutAttribute> ByRef TriggerMode As Integer,
    <OutAttribute> ByRef PrimaryTriggerLevel As Double,
    <OutAttribute> ByRef SecondaryTriggerLevel As Double,
    <OutAttribute> ByRef Direction As Integer
)
void GetTriggerSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    [OutAttribute] int% TriggerMode,
    [OutAttribute] double% PrimaryTriggerLevel,
    [OutAttribute] double% SecondaryTriggerLevel,
    [OutAttribute] int% Direction
)
abstract GetTriggerSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        TriggerMode : int byref *
        PrimaryTriggerLevel : float byref *
        SecondaryTriggerLevel : float byref *
        Direction : int byref -> unit

Parameters

Mainframe
Type: SystemString
Name or index of mainframe
Recorder
Type: SystemString
Name or index of recorder
Channel
Type: SystemString
Name or index of channel
TriggerMode
Type: SystemInt32
Channel trigger mode:
  • Off = 0
  • Basic = 1
  • Dual = 2
  • Window = 3
  • DualWindow = 4
  • Sequential = 5
  • BasicQualifier = 6
  • DualQualifier = 7
PrimaryTriggerLevel
Type: SystemDouble
Primary trigger level in technical units
SecondaryTriggerLevel
Type: SystemDouble
Secondary trigger level in technical units
Direction
Type: SystemInt32
Direction of primary level. Direction of secondary level is opposite by default.
  • RisingEdge = 0
  • FallingEdge = 1
Examples
Copy
string cMainframe = "GEN7t I";
string cRecorder = "Recorder A";
string cChannel = "Ch A1";

int TriggerMode;
double PrimaryTriggerLevel;
double SecondaryTriggerLevel;
int Direction;

m_Perception.getTriggerSettings(cMainframe, cRecorder, cChannel, out TriggerMode, out PrimaryTriggerLevel, out SecondaryTriggerLevel, out Direction);
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetTriggerSettings(String, String, String, Int32, Double, Double, Int32)
IPerceptionCOMSetTriggerLevelSettings(String, String, String, Int32, Int32, Double, Double, Int32, Double, Boolean, Double, Int32)
IPerceptionCOMGetTriggerLevelSettings(String, String, String, Int32, Int32, Double, Double, Int32, Double, Boolean, Double, Int32)


IPerceptionCOM.GetTriggerState Method

IPerceptionCOMGetTriggerState Method

Use this function to retrieve the trigger status of all available recorders.

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetTriggerState(
    out int Idle,
    out int Blocked,
    out int WasBlocked,
    out int Armed,
    out int Triggered,
    out int TriggerCount,
    out int AllTriggerCountsEqual
)
Sub GetTriggerState (
    <OutAttribute> ByRef Idle As Integer,
    <OutAttribute> ByRef Blocked As Integer,
    <OutAttribute> ByRef WasBlocked As Integer,
    <OutAttribute> ByRef Armed As Integer,
    <OutAttribute> ByRef Triggered As Integer,
    <OutAttribute> ByRef TriggerCount As Integer,
    <OutAttribute> ByRef AllTriggerCountsEqual As Integer
)
void GetTriggerState(
    [OutAttribute] int% Idle,
    [OutAttribute] int% Blocked,
    [OutAttribute] int% WasBlocked,
    [OutAttribute] int% Armed,
    [OutAttribute] int% Triggered,
    [OutAttribute] int% TriggerCount,
    [OutAttribute] int% AllTriggerCountsEqual
)
abstract GetTriggerState :
        Idle : int byref *
        Blocked : int byref *
        WasBlocked : int byref *
        Armed : int byref *
        Triggered : int byref *
        TriggerCount : int byref *
        AllTriggerCountsEqual : int byref -> unit

Parameters

Idle
Type: SystemInt32
Number of recorders currently idle
Blocked
Type: SystemInt32
(Obsolete)
WasBlocked
Type: SystemInt32
(Obsolete)
Armed
Type: SystemInt32
Number of recorders currently armed
Triggered
Type: SystemInt32
Number of recorders currently triggered
TriggerCount
Type: SystemInt32
Maximum number of triggers so far
AllTriggerCountsEqual
Type: SystemInt32
Nonzero: all recorders have equal trigger count
Remarks
Blocked and WasBlocked are now obsolete.
Examples
Copy
using PerceptionCOMRpc;

private PerceptionCOM m_Perception = new PerceptionCOM();

m_Perception.SetServerAddress("localhost");
m_Perception.ConnectToServer();

private void ShowTriggerState()
{
     int Idle;
     int Blocked;
     int WasBlocked;
     int Armed;
     int Triggered;
     int TriggerCount;
     int AllTriggerCountsEqual;

     m_Perception.GetTriggerState(out Idle, out Blocked, out WasBlocked,
                           out Armed, out Triggered, out TriggerCount,
                           out AllTriggerCountsEqual);

     lblTriggerState.Text = "Idle: " + Idle.ToString() +
                            " Blocked: " + Blocked.ToString() +
                            " WasBlocked: " + WasBlocked.ToString() +
                            " Armed: " + Armed.ToString() +
                            " Triggered: " + Triggered.ToString() +
                            " TriggerCount: " + TriggerCount.ToString();

}
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetAcquisitionState(Int32, Int32, Int32, Int32, Int32)


IPerceptionCOM.GetWindowState Method

IPerceptionCOMGetWindowState Method

Gets the window state of the currently active workbook in Perception

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void GetWindowState(
    out COMWindowState State
)
Sub GetWindowState (
    <OutAttribute> ByRef State As COMWindowState
)
void GetWindowState(
    [OutAttribute] COMWindowState% State
)
abstract GetWindowState :
        State : COMWindowState byref -> unit

Parameters

State
Type: RPC_COMCOMWindowState
State of the workbook
Remarks
When using a single workbook perception workbench this is the main window.
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetWindowState(COMWindowState)


IPerceptionCOM.IsAcquisitionBlocked Method

IPerceptionCOMIsAcquisitionBlocked Method

Returns true if a new acquisition can not be started.

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void IsAcquisitionBlocked(
    out bool AcquisitionBlocked
)
Sub IsAcquisitionBlocked (
    <OutAttribute> ByRef AcquisitionBlocked As Boolean
)
void IsAcquisitionBlocked(
    [OutAttribute] bool% AcquisitionBlocked
)
abstract IsAcquisitionBlocked :
        AcquisitionBlocked : bool byref -> unit

Parameters

AcquisitionBlocked
Type: SystemBoolean
True if acquisition is blocked
Remarks
The acquisition can be blocked when e.g. the data of a recorder is not yet saved, or when exporting has not been finished, or when a information field which has to be filled because it has been defined as "Required". But it also can be blocked by a CSI implementation.
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMControlledStart(Boolean)


IPerceptionCOM.IsCommunicationActive Method

IPerceptionCOMIsCommunicationActive Method

Checks if there was communication between controlling PC and mainframe(s) since last call of this function.

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void IsCommunicationActive(
    string Mainframe,
    out bool Active
)
Sub IsCommunicationActive (
    Mainframe As String,
    <OutAttribute> ByRef Active As Boolean
)
void IsCommunicationActive(
    String^ Mainframe,
    [OutAttribute] bool% Active
)
abstract IsCommunicationActive :
        Mainframe : string *
        Active : bool byref -> unit

Parameters

Mainframe
Type: SystemString
Name or index of mainframe
Active
Type: SystemBoolean
Returns true if there was any communication since last call
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.LoadSettings Method

IPerceptionCOMLoadSettings Method

Use this function to load a saved settings file (*.pSet) into Perception.

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void LoadSettings(
    string FullPath
)
Sub LoadSettings (
    FullPath As String
)
void LoadSettings(
    String^ FullPath
)
abstract LoadSettings :
        FullPath : string -> unit

Parameters

FullPath
Type: SystemString
Full path and file name
Remarks
Examples
Copy
using PerceptionCOMRpc;

private PerceptionCOM m_Perception = new PerceptionCOM();

m_Perception.SetServerAddress("localhost");
m_Perception.ConnectToServer();

internal void RetrieveSettingsFiles()
{
     listBox1.Items.Clear();
     Array aSettingsFileNames;
     try
     {
          m_Perception.GetFilenames("<MyDocs>\\My Workbench\\", "*.pSet", out aSettingsFileNames);
     }
     catch
     {
          MessageBox.Show(this, "No Settings files found!", Application.ProductName);
          return;
     }

     string[] strSettingsFileNames = aSettingsFileNames as string[];

     for (int i = 0; i < strSettingsFileNames.Length; i++)
     {
          listBox1.Items.Add(strSettingsFileNames[i]);
     }
}

private void btnLoadSettingsFile_Click(object sender, EventArgs e)
{
     if (listBox1.SelectedIndex < 0)
     {
          MessageBox.Show(this, "No Settings file has been selected!", Application.ProductName);
          return;
     }
     string cFilename = listBox1.SelectedItem.ToString();
     if (string.IsNullOrEmpty(cFilename))
          return;

     cFilename = "<MyDocs>\\My Workbench\\" + cFilename;
     Cursor CurrentCursor = Cursor.Current;
     try
     {
          Cursor.Current = Cursors.WaitCursor;
          m_Perception.LoadSettings(cFilename);
     }
     finally
     {
          Cursor.Current = CurrentCursor;
     }
}
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMLoadVWB(String)
IPerceptionCOMSaveVWB(String)
IPerceptionCOMSaveSettings(String)
IPerceptionCOMGetFilenames(String, String, Array)


IPerceptionCOM.LoadVWB Method

IPerceptionCOMLoadVWB Method

Use this function to load an existing Virtual WorkBench (*.pVwb) file into Perception.

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void LoadVWB(
    string FullPath
)
Sub LoadVWB (
    FullPath As String
)
void LoadVWB(
    String^ FullPath
)
abstract LoadVWB :
        FullPath : string -> unit

Parameters

FullPath
Type: SystemString
Full path and file name
Remarks
Examples
Copy
using PerceptionCOMRpc;

private PerceptionCOM m_Perception = new PerceptionCOM();

m_Perception.SetServerAddress("localhost");
m_Perception.ConnectToServer();

private void btnLoadVWB_Click(object sender, EventArgs e)
{
     string cFilename = listBox1.SelectedItem.ToString();
     if (string.IsNullOrEmpty(cFilename))
          return;

     cFilename = "<MyDocs>\\My Workbench\\" + cFilename;
     Cursor CurrentCursor = Cursor.Current;
     try
     {
          Cursor.Current = Cursors.WaitCursor;
          m_Perception.LoadVWB(cFilename);
     }
     finally
     {
          Cursor.Current = CurrentCursor;
     }
}
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetFilenames(String, String, Array)
IPerceptionCOMSaveVWB(String)


IPerceptionCOM.MainframeSetDefaultSettings Method

IPerceptionCOMMainframeSetDefaultSettings Method

Note: This API is now obsolete.

This method is no longer supported and has been replaced by the SetDefaultSettings

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is no longer supported and has been replaced by the SetDefaultSettings")]
void MainframeSetDefaultSettings(
    string Mainframe
)
<ObsoleteAttribute("This method is no longer supported and has been replaced by the SetDefaultSettings")>
Sub MainframeSetDefaultSettings (
    Mainframe As String
)
[ObsoleteAttribute(L"This method is no longer supported and has been replaced by the SetDefaultSettings")]
void MainframeSetDefaultSettings(
    String^ Mainframe
)
[<ObsoleteAttribute("This method is no longer supported and has been replaced by the SetDefaultSettings")>]
abstract MainframeSetDefaultSettings :
        Mainframe : string -> unit

Parameters

Mainframe
Type: SystemString
Remarks
In Perception 6.30 this method has been replaced with the method SetDefaultSettings
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetDefaultSettings


IPerceptionCOM.OneShot Method

IPerceptionCOMOneShot Method

To start a single sweep.

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void OneShot()
Sub OneShot
void OneShot()
abstract OneShot : unit -> unit
Remarks
In this mode the recorder acquires data until a valid trigger condition is met and the post-trigger data has been recorded or when a stop command has been received.
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMStop
IPerceptionCOMPause
IPerceptionCOMStart
IPerceptionCOMAbort
IPerceptionCOMControlledStart(Boolean)


IPerceptionCOM.Pause Method

IPerceptionCOMPause Method

Go to pause mode

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void Pause()
Sub Pause
void Pause()
abstract Pause : unit -> unit
Remarks
This command serves two purposes:

1. When no acquisition is active it will place the recorder in the pause or stand-by mode. Although the recorder is digitizing, no data is stored is memory or disk. This is useful for monitoring purposes.

2. When a continuous acquisition is active, it will place the recorder in a hold mode: although the recorder is digitizing, no data is stored in memory or disk. At this point when RUN is selected, the current recording continues, when STOP is selected, the recording is finished.

See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMStop
IPerceptionCOMStart
IPerceptionCOMOneShot
IPerceptionCOMAbort


IPerceptionCOM.PerformeDriveAction Method

IPerceptionCOMPerformeDriveAction Method

Execute an eDrive action as described by the Action ID

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void PerformeDriveAction(
    int EngineId,
    COMeDriveActionType ActionId,
    Array Parameters
)
Sub PerformeDriveAction (
    EngineId As Integer,
    ActionId As COMeDriveActionType,
    Parameters As Array
)
void PerformeDriveAction(
    int EngineId,
    COMeDriveActionType ActionId,
    Array^ Parameters
)
abstract PerformeDriveAction :
        EngineId : int *
        ActionId : COMeDriveActionType *
        Parameters : Array -> unit

Parameters

EngineId
Type: SystemInt32
integer engine id
ActionId
Type: RPC_COMCOMeDriveActionType
ID of the eDrive action to be performed
Parameters
Type: SystemArray
optional: An array of doubles, which can be used as parameters
Examples
Copy
// Example of the eDrive action for logging the values present on the eDrive live sheet to an XML file
m_Perception.PerformeDriveAction(m_nEngineID, COMeDriveActionType.COMeDriveActionType_LogValues, null);
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
RPC_COMCOMeDriveActionType


IPerceptionCOM.RequestAllSettings Method

IPerceptionCOMRequestAllSettings Method

Requests all settings of all connected mainframes. Only returns once all settings have been received.

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void RequestAllSettings()
Sub RequestAllSettings
void RequestAllSettings()
abstract RequestAllSettings : unit -> unit
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.RunMacro Method

IPerceptionCOMRunMacro Method

Runs a macro in Perception

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void RunMacro(
    string macro
)
Sub RunMacro (
    macro As String
)
void RunMacro(
    String^ macro
)
abstract RunMacro :
        macro : string -> unit

Parameters

macro
Type: SystemString
Macro name
Remarks
This function is used to run an existing macro in Perception. The GetMacros function can be used to check if the macro is available
Examples
Copy
m_Perception.RunMacro("SetCursorToMaxMacro");
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetMacros(Array)


IPerceptionCOM.SaveSettings Method

IPerceptionCOMSaveSettings Method

Use this function to save the current hardware settings into a file.

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SaveSettings(
    string FullPath
)
Sub SaveSettings (
    FullPath As String
)
void SaveSettings(
    String^ FullPath
)
abstract SaveSettings :
        FullPath : string -> unit

Parameters

FullPath
Type: SystemString
Full path and file name
Remarks
Examples
Copy
using PerceptionCOMRpc;

private PerceptionCOM m_Perception = new PerceptionCOM();

m_Perception.SetServerAddress("localhost");
m_Perception.ConnectToServer();

private void btnSaveSettingsFile_Click(object sender, EventArgs e)
{
     string cFilename = txtSettingsFile.Text;
     if (string.IsNullOrEmpty(cFilename))
     {
          MessageBox.Show(this, "No Settings file has been entered!", Application.ProductName);
          return;
     }

     cFilename = "<MyDocs>\\My Workbench\\" + cFilename;
     Cursor CurrentCursor = Cursor.Current;
     try
     {
          Cursor.Current = Cursors.WaitCursor;
          m_Perception.SaveSettings(cFilename);
     }
     finally
     {
          Cursor.Current = CurrentCursor;
     }
}
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMLoadVWB(String)
IPerceptionCOMSaveVWB(String)
IPerceptionCOMLoadSettings(String)
IPerceptionCOMGetFilenames(String, String, Array)


IPerceptionCOM.SaveVWB Method

IPerceptionCOMSaveVWB Method

Use this function to save the current Perception workbench into a file.

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SaveVWB(
    string FullPath
)
Sub SaveVWB (
    FullPath As String
)
void SaveVWB(
    String^ FullPath
)
abstract SaveVWB :
        FullPath : string -> unit

Parameters

FullPath
Type: SystemString
Full path and file name
Remarks
Examples
Copy
using PerceptionCOMRpc;

private PerceptionCOM m_Perception = new PerceptionCOM();

m_Perception.SetServerAddress("localhost");
m_Perception.ConnectToServer();

private void btnSaveVWB_Click(object sender, EventArgs e)
{
     string cFilename = txtFilename.Text;
     if (string.IsNullOrEmpty(cFilename))
     {
          MessageBox.Show(this, "No VWB file has been entered!", Application.ProductName);
          return;
     }

     cFilename = "<MyDocs>\\My Workbench\\" + cFilename;
     Cursor CurrentCursor = Cursor.Current;
     try
     {
          Cursor.Current = Cursors.WaitCursor;
          m_Perception.SaveVWB(cFilename);
     }
     finally
     {
          Cursor.Current = CurrentCursor;
     }
}
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMLoadVWB(String)
IPerceptionCOMLoadSettings(String)
IPerceptionCOMGetFilenames(String, String, Array)


IPerceptionCOM.ScanRPCServers Method

IPerceptionCOMScanRPCServers Method

Scans the network for running Perception RPC Servers.

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void ScanRPCServers(
    int TimeOutMs,
    out Array ServerAddresses
)
Sub ScanRPCServers (
    TimeOutMs As Integer,
    <OutAttribute> ByRef ServerAddresses As Array
)
void ScanRPCServers(
    int TimeOutMs,
    [OutAttribute] Array^% ServerAddresses
)
abstract ScanRPCServers :
        TimeOutMs : int *
        ServerAddresses : Array byref -> unit

Parameters

TimeOutMs
Type: SystemInt32
Timeout to wait for RPC Server replies in milliseconds.
ServerAddresses
Type: SystemArray
IP Addresses of the replied servers in an array of strings.
Examples
Copy
protected void SearchForServers()
{
      // Get the ip addresses of all servers that reply within 2 seconds
      Array arAddresses;
      m_Perception.ScanRPCServers(2000, out arAddresses);

      // And display them in a listbox on the form
      string[] arStr = arAddresses as string[];
      int iCount = arAddresses.GetLength(0);
      for (int i = 0; i < iCount; i++)
      {
           lstDisplayAddresses.Items.Add(arStr[i]);
      }
}
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.SetActiveSheet Method

IPerceptionCOMSetActiveSheet Method

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetActiveSheet(
    string Name
)
Sub SetActiveSheet (
    Name As String
)
void SetActiveSheet(
    String^ Name
)
abstract SetActiveSheet :
        Name : string -> unit

Parameters

Name
Type: SystemString
Examples
Copy
protected bool SetSelectedItemAsActiveSheet()
{

      string strSheetToActivate = lstSheets.Items[lstSheets.SelectedIndex].ToString();
      m_Perception.SetActiveSheet(strActiveSheet);

      // This call will be asynchronously invoked to the UI thread, so make sure we allow for some
      // time to process before we verify if it was really set.
      Thread.Sleep(1500);

      string strTmp;
      m_Perception.GetActiveSheet(out strTmp);

      return string.Compare(strTmp, strSheetToActivate, true);
}
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetSheetCount(Int32)
IPerceptionCOMGetSheetName(Int32, String)
IPerceptionCOMGetActiveSheet(String)


IPerceptionCOM.SetAlarmLevelSettings Method

IPerceptionCOMSetAlarmLevelSettings Method

Set the alarm settings of a channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetAlarmLevelSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    int Mask,
    int Mode,
    double PrimaryLevel,
    double SecondaryLevel,
    int Direction,
    int ChannelSelect
)
Sub SetAlarmLevelSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As Integer,
    Mode As Integer,
    PrimaryLevel As Double,
    SecondaryLevel As Double,
    Direction As Integer,
    ChannelSelect As Integer
)
void SetAlarmLevelSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    int Mask,
    int Mode,
    double PrimaryLevel,
    double SecondaryLevel,
    int Direction,
    int ChannelSelect
)
abstract SetAlarmLevelSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : int *
        Mode : int *
        PrimaryLevel : float *
        SecondaryLevel : float *
        Direction : int *
        ChannelSelect : int -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case Mode

if Mask = 2 then only the second parameter will be returned in this case PrimaryLevel

Mode
Type: SystemInt32
Alarm mode:
  • Off = 0
  • Basic = 1
  • Dual = 2
PrimaryLevel
Type: SystemDouble
Primary level in user units for the alarm detection
SecondaryLevel
Type: SystemDouble
Secondary level in user units for the alarm detection
Direction
Type: SystemInt32
Sets the response direction of the primary level. The secondary level will be set to the opposite direction.
  • Rising Edge = 0
  • Falling Edge = 1
ChannelSelect
Type: SystemInt32
UNKNOWN
Examples
Copy
int Mode = 2; // Dual
double PrimaryLevel = 20;
double SecondaryLevel = 40 ;
int Direction = 1; // Falling edge
int ChannelSelect = -1;

RPC.setAlarmLevelSettings("GEN7t I", "Recorder A", "Ch A1", Mask, out Mode, PrimaryLevel, SecondaryLevel, Direction, ChannelSelect);
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetAlarmLevelSettings(String, String, String, Int32, Int32, Double, Double, Int32, Int32)


IPerceptionCOM.SetArchiveFolder Method

IPerceptionCOMSetArchiveFolder Method

Set current archive folder. If the new archive folder is on a disk that has not been profiled yet, the disk will be profiled as part of this call.

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetArchiveFolder(
    string ArchiveFolder
)
Sub SetArchiveFolder (
    ArchiveFolder As String
)
void SetArchiveFolder(
    String^ ArchiveFolder
)
abstract SetArchiveFolder :
        ArchiveFolder : string -> unit

Parameters

ArchiveFolder
Type: SystemString
new archive folder
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetArchiveFolder(String)


IPerceptionCOM.SetAutomationEnabled Method

IPerceptionCOMSetAutomationEnabled Method

Activates/deactivates recording automation

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetAutomationEnabled(
    bool Enabled
)
Sub SetAutomationEnabled (
    Enabled As Boolean
)
void SetAutomationEnabled(
    bool Enabled
)
abstract SetAutomationEnabled :
        Enabled : bool -> unit

Parameters

Enabled
Type: SystemBoolean
True to enable, false to disable
Remarks
This will use the set recording automation settings if enabled.
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetAutomationEnabled(Boolean)


IPerceptionCOM.SetCalcChannelEnabled Method

IPerceptionCOMSetCalcChannelEnabled Method

Enable or disable a calculated channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetCalcChannelEnabled(
    string Mainframe,
    string Recorder,
    string Channel,
    bool Enabled
)
Sub SetCalcChannelEnabled (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Enabled As Boolean
)
void SetCalcChannelEnabled(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    bool Enabled
)
abstract SetCalcChannelEnabled :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Enabled : bool -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Calculated channel name or index
Enabled
Type: SystemBoolean
true to enable the channel, false to disable
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.SetCalcCommonSettings Method

IPerceptionCOMSetCalcCommonSettings Method

Sets general settings of the channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetCalcCommonSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    COMCalcCommonSettingsSettingItem Mask,
    bool Enabled,
    string PhysicalName,
    string Name,
    long PrimaryColor,
    long SecondaryColor,
    bool PublishFieldBus,
    string UserNote1,
    string UserNote2,
    string UserNote3,
    string UserNote4
)
Sub SetCalcCommonSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As COMCalcCommonSettingsSettingItem,
    Enabled As Boolean,
    PhysicalName As String,
    Name As String,
    PrimaryColor As Long,
    SecondaryColor As Long,
    PublishFieldBus As Boolean,
    UserNote1 As String,
    UserNote2 As String,
    UserNote3 As String,
    UserNote4 As String
)
void SetCalcCommonSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    COMCalcCommonSettingsSettingItem Mask,
    bool Enabled,
    String^ PhysicalName,
    String^ Name,
    long long PrimaryColor,
    long long SecondaryColor,
    bool PublishFieldBus,
    String^ UserNote1,
    String^ UserNote2,
    String^ UserNote3,
    String^ UserNote4
)
abstract SetCalcCommonSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : COMCalcCommonSettingsSettingItem *
        Enabled : bool *
        PhysicalName : string *
        Name : string *
        PrimaryColor : int64 *
        SecondaryColor : int64 *
        PublishFieldBus : bool *
        UserNote1 : string *
        UserNote2 : string *
        UserNote3 : string *
        UserNote4 : string -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Calculated channel name or index
Mask
Type: RPC_COMCOMCalcCommonSettingsSettingItem
Parameter mask, 0xFF, applies all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

Enabled
Type: SystemBoolean
Indicates if a channel is enabled or disabled
PhysicalName
Type: SystemString
The physical name of the channel, fixed, may change depending on the math-type settings of the channel
Name
Type: SystemString
User name assigned to the channel
PrimaryColor
Type: SystemInt64
Primary color of the channel
SecondaryColor
Type: SystemInt64
Secondary color of the channel, currently unused
PublishFieldBus
Type: SystemBoolean
Indicates if and how a channel should be published on a field-bus
UserNote1
Type: SystemString
Entry field for user comments 1
UserNote2
Type: SystemString
Entry field for user comments 2
UserNote3
Type: SystemString
Entry field for user comments 3
UserNote4
Type: SystemString
Entry field for user comments 4
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.SetCalcInputRangeSettings Method

IPerceptionCOMSetCalcInputRangeSettings Method

Set the measurement range of the channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetCalcInputRangeSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    COMCalcInputRangeSettingsSettingItem Mask,
    double UpperValue,
    double LowerValue
)
Sub SetCalcInputRangeSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As COMCalcInputRangeSettingsSettingItem,
    UpperValue As Double,
    LowerValue As Double
)
void SetCalcInputRangeSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    COMCalcInputRangeSettingsSettingItem Mask,
    double UpperValue,
    double LowerValue
)
abstract SetCalcInputRangeSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : COMCalcInputRangeSettingsSettingItem *
        UpperValue : float *
        LowerValue : float -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Calculated channel name or index
Mask
Type: RPC_COMCOMCalcInputRangeSettingsSettingItem
Parameter mask, 0xFF, applies all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

UpperValue
Type: SystemDouble
Upper limit to measurement range
LowerValue
Type: SystemDouble
Lower limit to measurement range
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
RPC_COMCOMCalcInputRangeSettingsSettingItem
IPerceptionCOMGetCalcInputRangeSettings(String, String, String, COMCalcInputRangeSettingsSettingItem, Double, Double)


IPerceptionCOM.SetCalcMathSettings Method

IPerceptionCOMSetCalcMathSettings Method

Set the math calculation settings for the calculated channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetCalcMathSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    COMCalculatedMathSettingsSettingItem Mask,
    COMCalculatedMathType MathType,
    long DetectorIndex,
    Array InputChannels
)
Sub SetCalcMathSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As COMCalculatedMathSettingsSettingItem,
    MathType As COMCalculatedMathType,
    DetectorIndex As Long,
    InputChannels As Array
)
void SetCalcMathSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    COMCalculatedMathSettingsSettingItem Mask,
    COMCalculatedMathType MathType,
    long long DetectorIndex,
    Array^ InputChannels
)
abstract SetCalcMathSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : COMCalculatedMathSettingsSettingItem *
        MathType : COMCalculatedMathType *
        DetectorIndex : int64 *
        InputChannels : Array -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Calculated channel name or index
Mask
Type: RPC_COMCOMCalculatedMathSettingsSettingItem
Parameter mask, 0xFF, applies all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

MathType
Type: RPC_COMCOMCalculatedMathType
The math to be supported by the channel
DetectorIndex
Type: SystemInt64
The cycle detection source to consume
InputChannels
Type: SystemArray
The names of the input channels to be used by the calculation, max of 6, requirement depends on selected math type
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetCalcMathSettings(String, String, String, COMCalculatedMathSettingsSettingItem, COMCalculatedMathType, Int64, Array)
IPerceptionCOMGetCalculatedChannelCount(String, String, Int64)
IPerceptionCOMGetCalcInputRangeSettings(String, String, String, COMCalcInputRangeSettingsSettingItem, Double, Double)
IPerceptionCOMSetCalcInputRangeSettings(String, String, String, COMCalcInputRangeSettingsSettingItem, Double, Double)


IPerceptionCOM.SetCalcTriggerSettings Method

IPerceptionCOMSetCalcTriggerSettings Method

Sets the trigger settings for the specified channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetCalcTriggerSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    COMCalcTriggerSettingsSettingItem Mask,
    COMChannelTriggerMode Mode,
    double PrimaryLevel,
    double SecondaryLevel,
    COMChannelTriggerDirection Direction,
    double Hysteresis
)
Sub SetCalcTriggerSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As COMCalcTriggerSettingsSettingItem,
    Mode As COMChannelTriggerMode,
    PrimaryLevel As Double,
    SecondaryLevel As Double,
    Direction As COMChannelTriggerDirection,
    Hysteresis As Double
)
void SetCalcTriggerSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    COMCalcTriggerSettingsSettingItem Mask,
    COMChannelTriggerMode Mode,
    double PrimaryLevel,
    double SecondaryLevel,
    COMChannelTriggerDirection Direction,
    double Hysteresis
)
abstract SetCalcTriggerSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : COMCalcTriggerSettingsSettingItem *
        Mode : COMChannelTriggerMode *
        PrimaryLevel : float *
        SecondaryLevel : float *
        Direction : COMChannelTriggerDirection *
        Hysteresis : float -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Calculated channel name or index
Mask
Type: RPC_COMCOMCalcTriggerSettingsSettingItem
Parameter mask, 0xFF, applies all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

Mode
Type: RPC_COMCOMChannelTriggerMode
Trigger mode used
PrimaryLevel
Type: SystemDouble
Primary trigger level
SecondaryLevel
Type: SystemDouble
Secondary trigger level, usage depends on mode
Direction
Type: RPC_COMCOMChannelTriggerDirection
Trigger direction of primary level, secondary trigger will trigger in reverse direction
Hysteresis
Type: SystemDouble
Hysteresis applied on trigger level(s)
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.SetCalcUserScalingSettings Method

IPerceptionCOMSetCalcUserScalingSettings Method

Gets the settings used to transform between physical units and user units

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetCalcUserScalingSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    COMUserScalingSettingItem Mask,
    double Multiplier,
    double Offset,
    string UserUnits
)
Sub SetCalcUserScalingSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As COMUserScalingSettingItem,
    Multiplier As Double,
    Offset As Double,
    UserUnits As String
)
void SetCalcUserScalingSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    COMUserScalingSettingItem Mask,
    double Multiplier,
    double Offset,
    String^ UserUnits
)
abstract SetCalcUserScalingSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : COMUserScalingSettingItem *
        Multiplier : float *
        Offset : float *
        UserUnits : string -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Calculated channel name or index
Mask
Type: RPC_COMCOMUserScalingSettingItem
Parameter mask, 0xFF, applies all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

The conversion from physical to user units is done using the following function: UserSampelValue = Offset + (Multiplier*PhysicalSampleValue)

Multiplier
Type: SystemDouble
Multiplier applied to convert from physical to user units
Offset
Type: SystemDouble
Offset applied to convert from physical to user units
UserUnits
Type: SystemString
User units string
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.SetCalibrationSettings Method

IPerceptionCOMSetCalibrationSettings Method

Set Calibration settings of a channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetCalibrationSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    int Mask,
    int Method,
    double StartPointReference,
    double StartPointActual,
    double EndPointReference,
    double EndPointActual,
    bool UseShuntForEndPoint,
    double ShuntStabilizeTime,
    bool ManualEntry
)
Sub SetCalibrationSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As Integer,
    Method As Integer,
    StartPointReference As Double,
    StartPointActual As Double,
    EndPointReference As Double,
    EndPointActual As Double,
    UseShuntForEndPoint As Boolean,
    ShuntStabilizeTime As Double,
    ManualEntry As Boolean
)
void SetCalibrationSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    int Mask,
    int Method,
    double StartPointReference,
    double StartPointActual,
    double EndPointReference,
    double EndPointActual,
    bool UseShuntForEndPoint,
    double ShuntStabilizeTime,
    bool ManualEntry
)
abstract SetCalibrationSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : int *
        Method : int *
        StartPointReference : float *
        StartPointActual : float *
        EndPointReference : float *
        EndPointActual : float *
        UseShuntForEndPoint : bool *
        ShuntStabilizeTime : float *
        ManualEntry : bool -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case Method

if Mask = 2 then only the second parameter will be returned in this case StartPointReference

Method
Type: SystemInt32
Channel calibration method
  • None = 0
  • SinglePoint = 1
  • TwoPoint = 2
StartPointReference
Type: SystemDouble
Reference start point
StartPointActual
Type: SystemDouble
Actual start point
EndPointReference
Type: SystemDouble
Reference end point
EndPointActual
Type: SystemDouble
Actual end point
UseShuntForEndPoint
Type: SystemBoolean
Enable shunt for end point
ShuntStabilizeTime
Type: SystemDouble
Shunt stabilization time in seconds
ManualEntry
Type: SystemBoolean
Enable manual entry
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetCalibrationSettings(String, String, String, Int32, Int32, Double, Double, Double, Double, Boolean, Double, Boolean)


IPerceptionCOM.SetChannelEnabled Method

IPerceptionCOMSetChannelEnabled Method

Enable/Disable the storage of a channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetChannelEnabled(
    string Mainframe,
    string Recorder,
    string Channel,
    bool Enabled
)
Sub SetChannelEnabled (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Enabled As Boolean
)
void SetChannelEnabled(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    bool Enabled
)
abstract SetChannelEnabled :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Enabled : bool -> unit

Parameters

Mainframe
Type: SystemString
Name or index of mainframe
Recorder
Type: SystemString
Name or index of recorder
Channel
Type: SystemString
Name or index of channel
Enabled
Type: SystemBoolean
Channel enabled true or false
Examples
Copy
string cMainframe = "GEN7t I";
string cRecorder = "Recorder A";
string cChannel = "Ch A1";

m_Perception.SetChannelEnabled(cMainframe, cRecorder, cChannel, true);

cMainframe = "$1$";   // First mainframe
cRecorder = "$1$";    // First recorder of first mainframe
cChannel = "$1$";     // First channel of first recorder of first mainframe

m_Perception.SetChannelEnabled(cMainframe, cRecorder, cChannel, false);
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetChannelEnabled(String, String, String, Boolean)
IPerceptionCOMGetEventChannelEnabled(String, String, String, Boolean)
IPerceptionCOMSetEventChannelEnabled(String, String, String, Boolean)
IPerceptionCOMGetTimerCounterChannelEnabled(String, String, String, Boolean)
IPerceptionCOMSetTimerCounterChannelEnabled(String, String, String, Boolean)


IPerceptionCOM.SetCommonSettings Method

IPerceptionCOMSetCommonSettings Method

Set the common settings of a mainframe

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetCommonSettings(
    string Mainframe,
    int Mask,
    string Name,
    double RealTimeClock
)
Sub SetCommonSettings (
    Mainframe As String,
    Mask As Integer,
    Name As String,
    RealTimeClock As Double
)
void SetCommonSettings(
    String^ Mainframe,
    int Mask,
    String^ Name,
    double RealTimeClock
)
abstract SetCommonSettings :
        Mainframe : string *
        Mask : int *
        Name : string *
        RealTimeClock : float -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case Name

if Mask = 2 then only the second parameter will be returned in this case RealTimeClock

Name
Type: SystemString
The name of the mainframe
RealTimeClock
Type: SystemDouble
The time of the real-time clock, use ToOADate() to convert from DateTime format
Examples
Copy
DateTime dt = dateTimePicker1.Value;
dRealTimeClock = dt.ToOADate();
txtRealTimeClock.Text = dRealTimeClock.ToString();

cName = txtName.Text;
RPC.SetCommonSettings(SelectedMainframe, Mask, cName, dRealTimeClock);
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetCommonSettings(String, Int32, String, Double)


IPerceptionCOM.SetContinuousSettings Method

IPerceptionCOMSetContinuousSettings Method

Note: This API is now obsolete.

This method is no longer supported and has been replaced by the SetGroupStorageSettings

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is no longer supported and has been replaced by the SetGroupStorageSettings")]
void SetContinuousSettings(
    string Mainframe,
    string Recorder,
    int RecordingMode,
    double RecordingTimeHistory,
    double PostTriggerRecordingTime
)
<ObsoleteAttribute("This method is no longer supported and has been replaced by the SetGroupStorageSettings")>
Sub SetContinuousSettings (
    Mainframe As String,
    Recorder As String,
    RecordingMode As Integer,
    RecordingTimeHistory As Double,
    PostTriggerRecordingTime As Double
)
[ObsoleteAttribute(L"This method is no longer supported and has been replaced by the SetGroupStorageSettings")]
void SetContinuousSettings(
    String^ Mainframe,
    String^ Recorder,
    int RecordingMode,
    double RecordingTimeHistory,
    double PostTriggerRecordingTime
)
[<ObsoleteAttribute("This method is no longer supported and has been replaced by the SetGroupStorageSettings")>]
abstract SetContinuousSettings :
        Mainframe : string *
        Recorder : string *
        RecordingMode : int *
        RecordingTimeHistory : float *
        PostTriggerRecordingTime : float -> unit

Parameters

Mainframe
Type: SystemString
Recorder
Type: SystemString
RecordingMode
Type: SystemInt32
RecordingTimeHistory
Type: SystemDouble
.
PostTriggerRecordingTime
Type: SystemDouble
Remarks
In Perception 6.30 this method has been replaced with the method SetGroupStorageSettings
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetGroupStorageSettings(String, COMStorageSettingItem, COMStorageMode, COMRecordingMode, Double, Double)


IPerceptionCOM.SetControlOut Method

IPerceptionCOMSetControlOut Method

Setting the control output of a 7600 Isolated Digitizer Subsystem

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetControlOut(
    string Mainframe,
    string Recorder,
    string Channel,
    bool Enabled
)
Sub SetControlOut (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Enabled As Boolean
)
void SetControlOut(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    bool Enabled
)
abstract SetControlOut :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Enabled : bool -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
Enabled
Type: SystemBoolean
Enable/Disable control output
Remarks
The 7600 provides a control output that can be used to drive an external device. This output is located at the back of the instrument and has a BNC connector. The output is an open-collector type. For electrical details refer to the specification section.
Examples
Copy
private bool SetControlOutput()
{
     string cMainframe = "GEN7t I";
     string cRecorder = "Recorder F";
     string cChannel = "Ch F1";

     bool bEnabled = chkControlOutput.Checked;

     m_Perception.setControlOut(cMainframe, cRecorder, cChannel, bEnabled);

     return true;
}
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetControlOut(String, String, String, Boolean)


IPerceptionCOM.SetCycleMasterSettings Method

IPerceptionCOMSetCycleMasterSettings Method

Setup the cycle detector

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetCycleMasterSettings(
    string Mainframe,
    string Recorder,
    long CycleMasterIndex,
    COMCycleMasterSettingsSettingItem Mask,
    COMCycleMasterType CycleMasterType,
    string InputChannel,
    double Level,
    double ThresHold,
    double CycleCount,
    COMChannelTriggerDirection Direction,
    double Period
)
Sub SetCycleMasterSettings (
    Mainframe As String,
    Recorder As String,
    CycleMasterIndex As Long,
    Mask As COMCycleMasterSettingsSettingItem,
    CycleMasterType As COMCycleMasterType,
    InputChannel As String,
    Level As Double,
    ThresHold As Double,
    CycleCount As Double,
    Direction As COMChannelTriggerDirection,
    Period As Double
)
void SetCycleMasterSettings(
    String^ Mainframe,
    String^ Recorder,
    long long CycleMasterIndex,
    COMCycleMasterSettingsSettingItem Mask,
    COMCycleMasterType CycleMasterType,
    String^ InputChannel,
    double Level,
    double ThresHold,
    double CycleCount,
    COMChannelTriggerDirection Direction,
    double Period
)
abstract SetCycleMasterSettings :
        Mainframe : string *
        Recorder : string *
        CycleMasterIndex : int64 *
        Mask : COMCycleMasterSettingsSettingItem *
        CycleMasterType : COMCycleMasterType *
        InputChannel : string *
        Level : float *
        ThresHold : float *
        CycleCount : float *
        Direction : COMChannelTriggerDirection *
        Period : float -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
CycleMasterIndex
Type: SystemInt64
Detector to setup
Mask
Type: RPC_COMCOMCycleMasterSettingsSettingItem
Parameter mask, 0xFF, applies all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

CycleMasterType
Type: RPC_COMCOMCycleMasterType
Cycle detection type
InputChannel
Type: SystemString
Input channel name, case sensitive
Level
Type: SystemDouble
Detection level
ThresHold
Type: SystemDouble
Detection threshold
CycleCount
Type: SystemDouble
Cycles count
Direction
Type: RPC_COMCOMChannelTriggerDirection
Level crossing direction indicating start of cycle
Period
Type: SystemDouble
Time of period in case of using a periodic timer
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetCycleMasterSettings(String, String, Int64, COMCycleMasterSettingsSettingItem, COMCycleMasterType, String, Double, Double, Double, COMChannelTriggerDirection, Double)


IPerceptionCOM.SetDefaultSettings Method

IPerceptionCOMSetDefaultSettings Method

To restore hardware settings of a system to their factory defaults

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetDefaultSettings()
Sub SetDefaultSettings
void SetDefaultSettings()
abstract SetDefaultSettings : unit -> unit
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.SetDiskSettings Method

IPerceptionCOMSetDiskSettings Method

Set disk settings of a mainframe

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetDiskSettings(
    string Mainframe,
    int Mask,
    int DiskLocation,
    int DiskUsage
)
Sub SetDiskSettings (
    Mainframe As String,
    Mask As Integer,
    DiskLocation As Integer,
    DiskUsage As Integer
)
void SetDiskSettings(
    String^ Mainframe,
    int Mask,
    int DiskLocation,
    int DiskUsage
)
abstract SetDiskSettings :
        Mainframe : string *
        Mask : int *
        DiskLocation : int *
        DiskUsage : int -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

  • if Mask = 1 then only the first parameter will be returned in this case DiskLocation
  • if Mask = 2 then only the second parameter will be returned in this case DiskUsage
DiskLocation
Type: SystemInt32
Disk location:
  • None = 0
  • PC Storage = 1
  • Mainframe Disk 1 = 2
  • Mainframe Disk 2 = 3
DiskUsage
Type: SystemInt32
Disk usage:
  • Single Disk = 0
  • Multiple Disk = 1

Note: Not supported at the moment, maybe for future usage

See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetDiskSettings(String, Int32, Int32, Int32, Int32, Int32, Double, Double)


IPerceptionCOM.SeteDriveConfiguration Method

IPerceptionCOMSeteDriveConfiguration Method

Sets configuration of an eDrive calculator engine

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SeteDriveConfiguration(
    int EngineId,
    Array Keys,
    Array Values
)
Sub SeteDriveConfiguration (
    EngineId As Integer,
    Keys As Array,
    Values As Array
)
void SeteDriveConfiguration(
    int EngineId,
    Array^ Keys,
    Array^ Values
)
abstract SeteDriveConfiguration :
        EngineId : int *
        Keys : Array *
        Values : Array -> unit

Parameters

EngineId
Type: SystemInt32
integer engine id
Keys
Type: SystemArray
An array of integers, with values taken from COMeDriveConfigKey enumeration
Values
Type: SystemArray
An array of doubles containing the new values of the eDrive configuration keys
Remarks
It is up to you how many keys you want to modify, this means that the length of the used arrays are equal to the number of keys you want to modify.
Examples
Copy
// Example of a wrapper function to set one specific configuration key
static public void SeteDriveConfiguration(PerceptionCOM RPCServer, int EngineId,
                                            eDriveConfigKey Key, double Value)
{
     int[] aConfigKey = new int[1] { (int)Key };
     double[] aConfigKeyValue = new double[1] { Value };

     Array SysKeys = aConfigKey;
     Array SysKeyValues = aConfigKeyValue;
     RPCServer.SeteDriveConfiguration(EngineId, SysKeys, SysKeyValues);
}
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGeteDriveConfiguration(Int32, Array, Array)
RPC_COMCOMeDriveConfigKey


IPerceptionCOM.SeteDriveConfigurationStrings Method

IPerceptionCOMSeteDriveConfigurationStrings Method

Sets configuration of an eDrive calculator engine

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SeteDriveConfigurationStrings(
    int EngineId,
    Array Keys,
    Array Values
)
Sub SeteDriveConfigurationStrings (
    EngineId As Integer,
    Keys As Array,
    Values As Array
)
void SeteDriveConfigurationStrings(
    int EngineId,
    Array^ Keys,
    Array^ Values
)
abstract SeteDriveConfigurationStrings :
        EngineId : int *
        Keys : Array *
        Values : Array -> unit

Parameters

EngineId
Type: SystemInt32
integer engine id
Keys
Type: SystemArray
An array of integers, with values taken from COMeDriveConfigStringKey enumeration
Values
Type: SystemArray
An array of strings containing the new values of the eDrive configuration keys
Remarks
It is up to you how many keys you want to modify, this means that the length of the used arrays are equal to the number of keys you want to modify.
Examples
Copy
// Example of a wrapper function to set one specific configuration key
static public void SeteDriveConfigurationStrings(PerceptionCOM RPCServer, int EngineId,
                                            eDriveConfigStringKey Key, string Value)
{
     int[] aConfigKey = new int[1] { (int)Key };
     string[] aConfigKeyValue = new string[1] { Value };

     Array SysKeys = aConfigKey;
     Array SysKeyValues = aConfigKeyValue;
     RPCServer.SeteDriveConfigurationStrings(EngineId, SysKeys, SysKeyValues);
}
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGeteDriveConfigurationStrings(Int32, Array, Array)
RPC_COMCOMeDriveConfigStringKey


IPerceptionCOM.SeteDriveNextRecordingComment Method

IPerceptionCOMSeteDriveNextRecordingComment Method

Set next recording comment for eDrive application.

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SeteDriveNextRecordingComment(
    string Comment
)
Sub SeteDriveNextRecordingComment (
    Comment As String
)
void SeteDriveNextRecordingComment(
    String^ Comment
)
abstract SeteDriveNextRecordingComment :
        Comment : string -> unit

Parameters

Comment
Type: SystemString
next recording comment
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.SetEventChannelEnabled Method

IPerceptionCOMSetEventChannelEnabled Method

Enable/Disable the storage of a marker channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetEventChannelEnabled(
    string Mainframe,
    string Recorder,
    string Channel,
    bool Enabled
)
Sub SetEventChannelEnabled (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Enabled As Boolean
)
void SetEventChannelEnabled(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    bool Enabled
)
abstract SetEventChannelEnabled :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Enabled : bool -> unit

Parameters

Mainframe
Type: SystemString
Name or index of mainframe
Recorder
Type: SystemString
Name or index of recorder
Channel
Type: SystemString
Name or index of channel
Enabled
Type: SystemBoolean
Channel enabled true or false
Examples
Copy
string cMainframe = "GEN7t I";
string cRecorder = "Recorder A";
string cChannel = "Ch A1";

m_Perception.SetEventChannelEnabled(cMainframe, cRecorder, cChannel, true);

cMainframe = "$1$";   // First mainframe
cRecorder = "$1$";    // First recorder of first mainframe
cChannel = "$9$";     // Ninth marker channel of first recorder of first mainframe

// In case of multiple marker channel connectors, the index traverses over all connectors.
// So in this example if the system would have 2 connectors with eight marker channels each,
// the 9th marker channel of the system will be the first bit of the second connector.

m_Perception.SetEventChannelEnabled(cMainframe, cRecorder, cChannel, false);
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetChannelEnabled(String, String, String, Boolean)
IPerceptionCOMSetChannelEnabled(String, String, String, Boolean)
IPerceptionCOMGetEventChannelEnabled(String, String, String, Boolean)
IPerceptionCOMGetTimerCounterChannelEnabled(String, String, String, Boolean)
IPerceptionCOMSetTimerCounterChannelEnabled(String, String, String, Boolean)


IPerceptionCOM.SetGroupStorageSettings Method

IPerceptionCOMSetGroupStorageSettings Method

Sets the storage mode of a group

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetGroupStorageSettings(
    string Group,
    COMStorageSettingItem Mask,
    COMStorageMode StorageMode,
    COMRecordingMode RecordingMode,
    double RecordingTimeHistory,
    double PostTriggerRecordingTime
)
Sub SetGroupStorageSettings (
    Group As String,
    Mask As COMStorageSettingItem,
    StorageMode As COMStorageMode,
    RecordingMode As COMRecordingMode,
    RecordingTimeHistory As Double,
    PostTriggerRecordingTime As Double
)
void SetGroupStorageSettings(
    String^ Group,
    COMStorageSettingItem Mask,
    COMStorageMode StorageMode,
    COMRecordingMode RecordingMode,
    double RecordingTimeHistory,
    double PostTriggerRecordingTime
)
abstract SetGroupStorageSettings :
        Group : string *
        Mask : COMStorageSettingItem *
        StorageMode : COMStorageMode *
        RecordingMode : COMRecordingMode *
        RecordingTimeHistory : float *
        PostTriggerRecordingTime : float -> unit

Parameters

Group
Type: SystemString
Name or index of group
Mask
Type: RPC_COMCOMStorageSettingItem
Select which setting to set
StorageMode
Type: RPC_COMCOMStorageMode
Storage mode of group:
  • None, no data will be written into the recording = 0
  • Sweeped storage = 1
  • Continuous data storage= 2
  • Continuous data storage with high rate sweep segments = 3
  • Slow fast storage mode = 4
RecordingMode
Type: RPC_COMCOMRecordingMode
Recording mode of group
RecordingTimeHistory
Type: SystemDouble
Time to use for circular recordings
PostTriggerRecordingTime
Type: SystemDouble
Time to record after a trigger was detected in continuous mode with stop on trigger
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetGroupStorageSettings(String, COMStorageMode, COMRecordingMode, Double, Double)


IPerceptionCOM.SetGroupSweepSettings Method

IPerceptionCOMSetGroupSweepSettings Method

Set the group sweep settings

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetGroupSweepSettings(
    string Group,
    COMSweepSettingItem Mask,
    int SweepLength,
    COMSweepMode SweepMode,
    double TriggerPosition,
    double Delay,
    bool SweepCountEnabled,
    int SweepCount,
    int SlowSweepLength,
    double SlowTriggerPosition,
    bool SweepStretchEnabled
)
Sub SetGroupSweepSettings (
    Group As String,
    Mask As COMSweepSettingItem,
    SweepLength As Integer,
    SweepMode As COMSweepMode,
    TriggerPosition As Double,
    Delay As Double,
    SweepCountEnabled As Boolean,
    SweepCount As Integer,
    SlowSweepLength As Integer,
    SlowTriggerPosition As Double,
    SweepStretchEnabled As Boolean
)
void SetGroupSweepSettings(
    String^ Group,
    COMSweepSettingItem Mask,
    int SweepLength,
    COMSweepMode SweepMode,
    double TriggerPosition,
    double Delay,
    bool SweepCountEnabled,
    int SweepCount,
    int SlowSweepLength,
    double SlowTriggerPosition,
    bool SweepStretchEnabled
)
abstract SetGroupSweepSettings :
        Group : string *
        Mask : COMSweepSettingItem *
        SweepLength : int *
        SweepMode : COMSweepMode *
        TriggerPosition : float *
        Delay : float *
        SweepCountEnabled : bool *
        SweepCount : int *
        SlowSweepLength : int *
        SlowTriggerPosition : float *
        SweepStretchEnabled : bool -> unit

Parameters

Group
Type: SystemString
Group name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first group

Mask
Type: RPC_COMCOMSweepSettingItem
Select which settings to set
SweepLength
Type: SystemInt32
Sweep length in samples
SweepMode
Type: RPC_COMCOMSweepMode
Sweep mode:
  • Normal = 0
  • PreTrigger = 1
  • Delayed = 2
TriggerPosition
Type: SystemDouble
Trigger position in %
Delay
Type: SystemDouble
Delay in seconds
SweepCountEnabled
Type: SystemBoolean
If true recording stops after receiving a defined number of sweeps ("SweepCount"), if false recording stops after stop command
SweepCount
Type: SystemInt32
Number of sweeps before recording stops automatically
SlowSweepLength
Type: SystemInt32
The total amount of data to be recorded for slow sweeps

This setting is enabled when the Storage mode is Slow Fast Sweep.

It sets the number of samples that the slow-speed sweep will contain.

SlowTriggerPosition
Type: SystemDouble
Sets the trigger position within the slow sweep

The trigger position within a sweep defines the amount of pre- and post-trigger information to be stored.

In the Slow Fast Sweep storage mode, the low-speed sweep uses the trigger of the high-speed sweep.

When set to zero the complete sweep contains post-trigger data. When set to the sweep length the sweep contains all pre-trigger data.

SweepStretchEnabled
Type: SystemBoolean
Enables the sweep stretch.

If the sweep stretch is switched on then the post trigger time will be extended each time a trigger occurs during the post trigger time

Examples
Copy
protected void SetTheSweepSettings()
{
     int SweepLength = 2500; // samples
     double TriggerPosition = 20; // %
     double Delay = 2; //sec
     int SweepMode = 1; // Pre Trigger
     bool SweepCountEnabled = true;
     int SweepCount = 5;
     int SlowSweepLength = 1000; // samples
     double SlowSweepTriggerPosition = 15; // %
     bool SweepStretchEnabled = true;

     m_Perception.SetGroupSweepSettingsEx("Group1", SweepLength,
                     TriggerPosition, Delay, SweepMode, SweepCountEnabled, SweepCount,
                     SlowSweepLength, SlowSweepTriggerPosition, SweepStretchEnabled);

}
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetGroupSweepSettings(String, Int32, COMSweepMode, Double, Double, Boolean, Int32, Int32, Double, Boolean)


IPerceptionCOM.SetGroupTimebaseSettings Method

IPerceptionCOMSetGroupTimebaseSettings Method

Get timebase settings of a group

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetGroupTimebaseSettings(
    string Group,
    COMTimebaseSettingItem Mask,
    double HighSamplingFrequency,
    double LowSamplingFrequency,
    COMClockSource ClkSource,
    int ClockDivider
)
Sub SetGroupTimebaseSettings (
    Group As String,
    Mask As COMTimebaseSettingItem,
    HighSamplingFrequency As Double,
    LowSamplingFrequency As Double,
    ClkSource As COMClockSource,
    ClockDivider As Integer
)
void SetGroupTimebaseSettings(
    String^ Group,
    COMTimebaseSettingItem Mask,
    double HighSamplingFrequency,
    double LowSamplingFrequency,
    COMClockSource ClkSource,
    int ClockDivider
)
abstract SetGroupTimebaseSettings :
        Group : string *
        Mask : COMTimebaseSettingItem *
        HighSamplingFrequency : float *
        LowSamplingFrequency : float *
        ClkSource : COMClockSource *
        ClockDivider : int -> unit

Parameters

Group
Type: SystemString
Group name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first group

Mask
Type: RPC_COMCOMTimebaseSettingItem
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

  • if Mask = 1 then only the first parameter will be returned in this case HighSamplingFrequency
  • if Mask = 2 then only the second parameter will be returned in this case LowSamplingFrequency
HighSamplingFrequency
Type: SystemDouble
High (fast) sample rate in Hz
LowSamplingFrequency
Type: SystemDouble
Low (slow) sample rate in Hz
ClkSource
Type: RPC_COMCOMClockSource
Recorder clock source: External clock divider
  • Internal = 0
  • ExternalA = 1
ClockDivider
Type: SystemInt32
Examples
Copy
int nMask = 0xFF;
double HighSamplingFrequency = 100000;
double LowSamplingFrequency = 10000;
double ContinuousSamplingFrequency = 10000;
COMClockSource ClkSource = 0; // internal clock used
int Divider = 1;

m_Perception.SetGroupTimebaseSettings("Group1", (COMTimebaseSettingItem)nMask, out HighSamplingFrequency, out LowSamplingFrequency, out ContinuousSamplingFrequency, out ClkSource, out Divider);
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetGroupTimebaseSettings(String, Double, Double, COMClockSource, Int32)


IPerceptionCOM.SetInformationNumericalValue Method

IPerceptionCOMSetInformationNumericalValue Method

Sets the value of a numerical field on the Information sheet

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetInformationNumericalValue(
    string Name,
    double Value
)
Sub SetInformationNumericalValue (
    Name As String,
    Value As Double
)
void SetInformationNumericalValue(
    String^ Name,
    double Value
)
abstract SetInformationNumericalValue :
        Name : string *
        Value : float -> unit

Parameters

Name
Type: SystemString
Name of the variable for which the value must be set
Value
Type: SystemDouble
Value which must be set
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetInformationStringValue(String, String)
IPerceptionCOMDSGetStringValue(String, String)
IPerceptionCOMDSGetNumericalValue(String, Double, Double)


IPerceptionCOM.SetInformationStringValue Method

IPerceptionCOMSetInformationStringValue Method

Sets the value of a string field on the Information sheet

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetInformationStringValue(
    string Name,
    string Value
)
Sub SetInformationStringValue (
    Name As String,
    Value As String
)
void SetInformationStringValue(
    String^ Name,
    String^ Value
)
abstract SetInformationStringValue :
        Name : string *
        Value : string -> unit

Parameters

Name
Type: SystemString
Name of the variable for which the value must be set
Value
Type: SystemString
Value which must be set
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetInformationNumericalValue(String, Double)
IPerceptionCOMDSGetStringValue(String, String)
IPerceptionCOMDSGetNumericalValue(String, Double, Double)


IPerceptionCOM.SetiSCSISettings Method

IPerceptionCOMSetiSCSISettings Method

Set the iSCSI settings

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetiSCSISettings(
    string Mainframe,
    COMDiskLocation DiskLocation,
    COMISCSISettings Mask,
    COMNetworkSelect NetworkSelect,
    string IPAddress,
    int PortNumber,
    string TargetName,
    string UserName,
    string Password,
    bool Enabled,
    string PhysicalName,
    bool UseDNS
)
Sub SetiSCSISettings (
    Mainframe As String,
    DiskLocation As COMDiskLocation,
    Mask As COMISCSISettings,
    NetworkSelect As COMNetworkSelect,
    IPAddress As String,
    PortNumber As Integer,
    TargetName As String,
    UserName As String,
    Password As String,
    Enabled As Boolean,
    PhysicalName As String,
    UseDNS As Boolean
)
void SetiSCSISettings(
    String^ Mainframe,
    COMDiskLocation DiskLocation,
    COMISCSISettings Mask,
    COMNetworkSelect NetworkSelect,
    String^ IPAddress,
    int PortNumber,
    String^ TargetName,
    String^ UserName,
    String^ Password,
    bool Enabled,
    String^ PhysicalName,
    bool UseDNS
)
abstract SetiSCSISettings :
        Mainframe : string *
        DiskLocation : COMDiskLocation *
        Mask : COMISCSISettings *
        NetworkSelect : COMNetworkSelect *
        IPAddress : string *
        PortNumber : int *
        TargetName : string *
        UserName : string *
        Password : string *
        Enabled : bool *
        PhysicalName : string *
        UseDNS : bool -> unit

Parameters

Mainframe
Type: SystemString
Mainframe using the iSCSI device
DiskLocation
Type: RPC_COMCOMDiskLocation
Select the iSCSI device
Mask
Type: RPC_COMCOMISCSISettings
Indicate which setting to apply
NetworkSelect
Type: RPC_COMCOMNetworkSelect
Which network device is the iSCSI connected to
IPAddress
Type: SystemString
The IP-address of the iSCSI device
PortNumber
Type: SystemInt32
Port used by the iSCSI device
TargetName
Type: SystemString
iSCSI device target-name
UserName
Type: SystemString
User name to log-in to the iSCSI device
Password
Type: SystemString
Password to log-in to the iSCSI device
Enabled
Type: SystemBoolean
Gets if the iSCSI device is enabled
PhysicalName
Type: SystemString
iSCSI device physical name
UseDNS
Type: SystemBoolean
Indicates if DNS should be used to resolve the IP-address
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.SetMasterTimebaseMode Method

IPerceptionCOMSetMasterTimebaseMode Method

Set the system master-timebase mode

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetMasterTimebaseMode(
    COMMasterTimebaseMode Mode
)
Sub SetMasterTimebaseMode (
    Mode As COMMasterTimebaseMode
)
void SetMasterTimebaseMode(
    COMMasterTimebaseMode Mode
)
abstract SetMasterTimebaseMode :
        Mode : COMMasterTimebaseMode -> unit

Parameters

Mode
Type: RPC_COMCOMMasterTimebaseMode
Mode to set
Remarks
The sample rate of the digitizer is determined by the clock base: The clock base is a clock that generates pulses used to drive the A-to-D converter. You have the following clock base options:

  • Decimal or binary internal: If you select the internal clock base, the clock used to drive the ADC is the built-in clock.
  • External: If you select the external clock base, the clock used to drive the ADC is the clock signal present at the external clock input.

The internal clock has two operating modes:

  • Internal Clock Base Decimal: This setting is used to create clock base values that are base 10, for example 1 MHz, 100 kHz, 50 kHz, 2.5 Hz, etc. These values are derived from a main oscillator that operates at a base 10 frequency, for example 1 MHz.
  • Internal Clock Base Binary: This setting is used to create clock base values that are base 2, for example 1.024 MHz, 512 kHz, 64 Hz, etc. These values are derived from a main oscillator that operates at a base 2 frequency, for example 1.024 MHz.

See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetGroupTimebaseSettings(String, COMTimebaseSettingItem, Double, Double, COMClockSource, Int32)
IPerceptionCOMGetGroupTimebaseSettings(String, Double, Double, COMClockSource, Int32)
IPerceptionCOMGetMasterTimebaseMode(COMMasterTimebaseMode)


IPerceptionCOM.SetMasterTimebaseSettings Method

IPerceptionCOMSetMasterTimebaseSettings Method

Note: This API is now obsolete.

This method is no longer supported and has been replaced by the SetMasterTimebaseSettingsEx

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is no longer supported and has been replaced by the SetMasterTimebaseSettingsEx")]
void SetMasterTimebaseSettings(
    string Mainframe,
    int Mask,
    int Mode,
    int SyncSource,
    int SyncStatus,
    int MasterSlaveMode
)
<ObsoleteAttribute("This method is no longer supported and has been replaced by the SetMasterTimebaseSettingsEx")>
Sub SetMasterTimebaseSettings (
    Mainframe As String,
    Mask As Integer,
    Mode As Integer,
    SyncSource As Integer,
    SyncStatus As Integer,
    MasterSlaveMode As Integer
)
[ObsoleteAttribute(L"This method is no longer supported and has been replaced by the SetMasterTimebaseSettingsEx")]
void SetMasterTimebaseSettings(
    String^ Mainframe,
    int Mask,
    int Mode,
    int SyncSource,
    int SyncStatus,
    int MasterSlaveMode
)
[<ObsoleteAttribute("This method is no longer supported and has been replaced by the SetMasterTimebaseSettingsEx")>]
abstract SetMasterTimebaseSettings :
        Mainframe : string *
        Mask : int *
        Mode : int *
        SyncSource : int *
        SyncStatus : int *
        MasterSlaveMode : int -> unit

Parameters

Mainframe
Type: SystemString
Mask
Type: SystemInt32
Mode
Type: SystemInt32
SyncSource
Type: SystemInt32
SyncStatus
Type: SystemInt32
MasterSlaveMode
Type: SystemInt32
Remarks
In Perception 6.30 this method has been replaced with the method SetMasterTimebaseSettingsEx
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetMasterTimebaseSettingsEx(String, COMMasterTmbSettingsItem, COMMasterTimebaseSyncSource, COMMasterTimebaseSyncStatus, COMMasterSlaveMode)


IPerceptionCOM.SetMasterTimebaseSettingsEx Method

IPerceptionCOMSetMasterTimebaseSettingsEx Method

Set the master timebase settings of a mainframe

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetMasterTimebaseSettingsEx(
    string Mainframe,
    COMMasterTmbSettingsItem Mask,
    COMMasterTimebaseSyncSource SyncSource,
    COMMasterTimebaseSyncStatus SyncStatus,
    COMMasterSlaveMode MasterSlaveMode
)
Sub SetMasterTimebaseSettingsEx (
    Mainframe As String,
    Mask As COMMasterTmbSettingsItem,
    SyncSource As COMMasterTimebaseSyncSource,
    SyncStatus As COMMasterTimebaseSyncStatus,
    MasterSlaveMode As COMMasterSlaveMode
)
void SetMasterTimebaseSettingsEx(
    String^ Mainframe,
    COMMasterTmbSettingsItem Mask,
    COMMasterTimebaseSyncSource SyncSource,
    COMMasterTimebaseSyncStatus SyncStatus,
    COMMasterSlaveMode MasterSlaveMode
)
abstract SetMasterTimebaseSettingsEx :
        Mainframe : string *
        Mask : COMMasterTmbSettingsItem *
        SyncSource : COMMasterTimebaseSyncSource *
        SyncStatus : COMMasterTimebaseSyncStatus *
        MasterSlaveMode : COMMasterSlaveMode -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Mask
Type: RPC_COMCOMMasterTmbSettingsItem
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case Mode

if Mask = 2 then only the second parameter will be returned in this case SyncSource

SyncSource
Type: RPC_COMCOMMasterTimebaseSyncSource
Defines the source used for the actual time synchronization in a mainframe:
  • RTC = 0
  • IRIG = 1
  • GPS = 2
  • MasterSlave = 3
  • IRIG_A_AM = 4
  • IRIG_B_AM = 5
  • IRIG_A_DCLS = 6
  • IRIG_B_DCLS = 7
  • IEEE1344 = 8
SyncStatus
Type: RPC_COMCOMMasterTimebaseSyncStatus
Synchronization status:
  • NotSynced = 0
  • Syncing = 1
  • Synced = 2
  • SyncLost = 3
  • NoSignal = 4
MasterSlaveMode
Type: RPC_COMCOMMasterSlaveMode
Defines the system’s role in a master/slave configuration:
  • StandAlone = 0
  • Master = 1
  • Slave = 2
Remarks

Synchronization source

The synchronization source is used to synchronize recordings within recordings with the mainframe. The internal clock (RTC) of a system is synchronized with the PC time every time Perception connects to the system. Time Zone Correction is also applied. This correction is added to the source's UTC time when “local time” is requested. When working with multiple mainframes, the internal clocks of the mainframes may differ. Even if initially set accurately, real clocks will differ after some time due to clock drift, caused by clocks counting time at slightly different rates. To solve this issue in a multiple mainframe setup, it is possible to use global synchronization sources like IRIG and GPS. The most common synchronization sources are RTC (internal clock), IRIG and GPS. For detailed information on IRIG and GPS consult your hardware manual.

Master/slave configuration

Defines whether or not the system is part of a master/slave configuration and if yes, which role it has in this setup. Master/slave is a model for a communication protocol where one system has unidirectional control over one or more other systems. Once a master/slave relationship between systems is established, the direction of control is always from the master to the slaves. The most common modes are Master, Slave and Stand-Alone. For details on master/slave operation refer to the separate manual that came with your master/slave hardware option.

Examples
Copy
int SyncSource = 0; // RTC (Real Time Clock)
int SyncStatus = 0; // Not Synced
int MasterSlaveMode = 0; // Stand alone

m_Perception.SetMasterTimebaseSettingsEx("GEN7t I", Mask, SyncSource, SyncStatus, MasterSlaveMode);
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetMasterTimebaseSettingsEx(String, COMMasterTimebaseSyncSource, COMMasterTimebaseSyncStatus, COMMasterSlaveMode)


IPerceptionCOM.SetMFExternalStartStopSettings Method

IPerceptionCOMSetMFExternalStartStopSettings Method

Sets the external start and / or stop behavior of the mainframe when a signal is applied to the external start / stop connector.

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetMFExternalStartStopSettings(
    string Mainframe,
    COMMainframeExtStartStopSettingItem Mask,
    COMExternalStartStopMode StartMode,
    COMExternalStartStopMode StopMode
)
Sub SetMFExternalStartStopSettings (
    Mainframe As String,
    Mask As COMMainframeExtStartStopSettingItem,
    StartMode As COMExternalStartStopMode,
    StopMode As COMExternalStartStopMode
)
void SetMFExternalStartStopSettings(
    String^ Mainframe,
    COMMainframeExtStartStopSettingItem Mask,
    COMExternalStartStopMode StartMode,
    COMExternalStartStopMode StopMode
)
abstract SetMFExternalStartStopSettings :
        Mainframe : string *
        Mask : COMMainframeExtStartStopSettingItem *
        StartMode : COMExternalStartStopMode *
        StopMode : COMExternalStartStopMode -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Mask
Type: RPC_COMCOMMainframeExtStartStopSettingItem
Parameter mask, 0xFF, applies all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be used in this case StartMode

if Mask = 2 then only the second parameter will be used in this case StopMode

StartMode
Type: RPC_COMCOMExternalStartStopMode
The external start mode for the specified mainframe.
StopMode
Type: RPC_COMCOMExternalStartStopMode
The external stop mode for the specified mainframe.
Remarks
This setting is not available on all mainframes. Please refer to the GEN Series manual to verify if the mainframe used supports this setting.
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.SetNetworkSettings Method

IPerceptionCOMSetNetworkSettings Method

Get a mainframes network settings

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetNetworkSettings(
    string Mainframe,
    int Mask,
    string NetworkName,
    bool UseDHCP,
    string IPAddress,
    string IPMask,
    string DefaultGateway,
    string MacAddress
)
Sub SetNetworkSettings (
    Mainframe As String,
    Mask As Integer,
    NetworkName As String,
    UseDHCP As Boolean,
    IPAddress As String,
    IPMask As String,
    DefaultGateway As String,
    MacAddress As String
)
void SetNetworkSettings(
    String^ Mainframe,
    int Mask,
    String^ NetworkName,
    bool UseDHCP,
    String^ IPAddress,
    String^ IPMask,
    String^ DefaultGateway,
    String^ MacAddress
)
abstract SetNetworkSettings :
        Mainframe : string *
        Mask : int *
        NetworkName : string *
        UseDHCP : bool *
        IPAddress : string *
        IPMask : string *
        DefaultGateway : string *
        MacAddress : string -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case NetworkName

if Mask = 2 then only the second parameter will be returned in this case UseDHCP

NetworkName
Type: SystemString
Network name
UseDHCP
Type: SystemBoolean
When ON (= true) use a DHCP server to get network information, when OFF (= false) select your own network settings for IP address, mask and gateway.

If this setting is ON the mainframe will scan the network for available DHCP servers which will assign an IP address, subnet masker and gateway rather than using the manually entered addresses. When OFF, IP address, IP mask and Default gateway will be used.

IPAddress
Type: SystemString
Mainframe IP address.

The manually entered IP address will be used to identify the mainframe on the network when DHCP server is OFF. When DHCP server is ON, this setting will not be editable.

IPMask
Type: SystemString
Mainframe IP mask.

Specifies the subnet mask for the network the mainframe is in. This will only be used when DHCP server is OFF. When DHCP server is ON, this setting will not be editable.

DefaultGateway
Type: SystemString
Default gateway to use with the mainframe

This is the address of the default gateway the mainframe will use when DHCP server is OFF. When DHCP server is ON, this setting will not be editable.

MacAddress
Type: SystemString
MAC address

In computer networking, a Media Access Control address (MAC address) or Ethernet Hardware Address (EHA), hardware address, adapter address or physical address is a quasi-unique identifier assigned to most network adapters or network interface cards (NICs) by the manufacturer for identification.

See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetNetworkSettings(String, Int32, String, Boolean, String, String, String, String)


IPerceptionCOM.SetPowerControlSettings Method

IPerceptionCOMSetPowerControlSettings Method

Get the power control settings of a fiber channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetPowerControlSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    int Mask,
    bool AmplifierPowerEnabled,
    bool AmplifierOutEnabled,
    COMPowerStatus Status
)
Sub SetPowerControlSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As Integer,
    AmplifierPowerEnabled As Boolean,
    AmplifierOutEnabled As Boolean,
    Status As COMPowerStatus
)
void SetPowerControlSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    int Mask,
    bool AmplifierPowerEnabled,
    bool AmplifierOutEnabled,
    COMPowerStatus Status
)
abstract SetPowerControlSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : int *
        AmplifierPowerEnabled : bool *
        AmplifierOutEnabled : bool *
        Status : COMPowerStatus -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case AmplifierPowerEnabled

if Mask = 2 then only the second parameter will be returned in this case AmplifierOutEnabled

AmplifierPowerEnabled
Type: SystemBoolean
Enables remote front-end channel to be switched on
AmplifierOutEnabled
Type: SystemBoolean
Enables analog output signal on mainframe front panel of remote front-end channel
Status
Type: RPC_COMCOMPowerStatus
Power status of remote front-end channel
Examples
Copy
private bool SetPowerControlSettings()
{
     if (!IsValid()) return false;
     int Mask = 0xFF;
     bool AmplifierPowerEnabled = true;
     bool AmplifierOutEnabled = false;
     COMPowerStatus Status = COMPowerStatus.COMPowerStatus_PowerOK;

     m_Perception.SetPowerControlSettings("GEN7t I", "Recorder A", "Ch A1",
                 Mask, AmplifierPowerEnabled, AmplifierOutEnabled, Status);
     return true;
}
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetPowerControlSettings(String, String, String, Int32, Boolean, Boolean, COMPowerStatus)
IPerceptionCOMGetPowerStatus(String, String, String, COMPowerLevel, COMExternalPowerStatus, COMPowerSource, Int32, Int32)


IPerceptionCOM.SetRecCommonSettings Method

IPerceptionCOMSetRecCommonSettings Method

Set common settings of a recorder

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetRecCommonSettings(
    string Mainframe,
    string Recorder,
    int Mask,
    string Name
)
Sub SetRecCommonSettings (
    Mainframe As String,
    Recorder As String,
    Mask As Integer,
    Name As String
)
void SetRecCommonSettings(
    String^ Mainframe,
    String^ Recorder,
    int Mask,
    String^ Name
)
abstract SetRecCommonSettings :
        Mainframe : string *
        Recorder : string *
        Mask : int *
        Name : string -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Mask
Type: SystemInt32
Mask, always use 0xFF
Name
Type: SystemString
Recorder name
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetRecCommonSettings(String, String, Int32, String)


IPerceptionCOM.SetRecDefaultSettings Method

IPerceptionCOMSetRecDefaultSettings Method

Note: This API is now obsolete.

This method is no longer supported and has been replaced by the SetDefaultSettings

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is no longer supported and has been replaced by the SetDefaultSettings")]
void SetRecDefaultSettings(
    string Mainframe,
    string Recorder
)
<ObsoleteAttribute("This method is no longer supported and has been replaced by the SetDefaultSettings")>
Sub SetRecDefaultSettings (
    Mainframe As String,
    Recorder As String
)
[ObsoleteAttribute(L"This method is no longer supported and has been replaced by the SetDefaultSettings")]
void SetRecDefaultSettings(
    String^ Mainframe,
    String^ Recorder
)
[<ObsoleteAttribute("This method is no longer supported and has been replaced by the SetDefaultSettings")>]
abstract SetRecDefaultSettings :
        Mainframe : string *
        Recorder : string -> unit

Parameters

Mainframe
Type: SystemString
Recorder
Type: SystemString
Remarks
In Perception 6.30 this method has been replaced with the method SetDefaultSettings
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetDefaultSettings


IPerceptionCOM.SetRecorderGroup Method

IPerceptionCOMSetRecorderGroup Method

Sets the group of a recorder

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetRecorderGroup(
    string Mainframe,
    string Recorder,
    string GroupName
)
Sub SetRecorderGroup (
    Mainframe As String,
    Recorder As String,
    GroupName As String
)
void SetRecorderGroup(
    String^ Mainframe,
    String^ Recorder,
    String^ GroupName
)
abstract SetRecorderGroup :
        Mainframe : string *
        Recorder : string *
        GroupName : string -> unit

Parameters

Mainframe
Type: SystemString
Mainframe that contains the recorder
Recorder
Type: SystemString
Recorder
GroupName
Type: SystemString
Group to which to add the recorder, will be created if it does not exist
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.SetRecordingName Method

IPerceptionCOMSetRecordingName Method

Sets the recording name and number

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetRecordingName(
    string Name,
    int StartNumber
)
Sub SetRecordingName (
    Name As String,
    StartNumber As Integer
)
void SetRecordingName(
    String^ Name,
    int StartNumber
)
abstract SetRecordingName :
        Name : string *
        StartNumber : int -> unit

Parameters

Name
Type: SystemString
Base name to use for creating the next recording name.
StartNumber
Type: SystemInt32
Start number to use for creating the next recording name.
Remarks
Please note that Perception will use the first available unused name for the set parameters. So setting the recording number to "recording" 1 will only result in "recording001" if that file doesn't already exist in the current recording location.
Examples
Copy
protected void SetRecordingName()
{
      //Set recording name to today's date, first recording
      DateTime dt = DateTime.Now;
      string strToday = string.Format("{0:yyyyMMdd}", dt);

      m_Perception.SetRecordingName(strToday, 1);
}
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.SetRecStorageSettings Method

IPerceptionCOMSetRecStorageSettings Method

Note: This API is now obsolete.

This method is no longer supported and has been replaced by the SetGroupStorageSettings

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is no longer supported and has been replaced by the SetGroupStorageSettings")]
void SetRecStorageSettings(
    string Mainframe,
    string Recorder,
    int Mask,
    int StorageMode,
    int RecordingMode,
    double RecordingTimeHistory,
    double PostTriggerRecordingTime
)
<ObsoleteAttribute("This method is no longer supported and has been replaced by the SetGroupStorageSettings")>
Sub SetRecStorageSettings (
    Mainframe As String,
    Recorder As String,
    Mask As Integer,
    StorageMode As Integer,
    RecordingMode As Integer,
    RecordingTimeHistory As Double,
    PostTriggerRecordingTime As Double
)
[ObsoleteAttribute(L"This method is no longer supported and has been replaced by the SetGroupStorageSettings")]
void SetRecStorageSettings(
    String^ Mainframe,
    String^ Recorder,
    int Mask,
    int StorageMode,
    int RecordingMode,
    double RecordingTimeHistory,
    double PostTriggerRecordingTime
)
[<ObsoleteAttribute("This method is no longer supported and has been replaced by the SetGroupStorageSettings")>]
abstract SetRecStorageSettings :
        Mainframe : string *
        Recorder : string *
        Mask : int *
        StorageMode : int *
        RecordingMode : int *
        RecordingTimeHistory : float *
        PostTriggerRecordingTime : float -> unit

Parameters

Mainframe
Type: SystemString
Recorder
Type: SystemString
Mask
Type: SystemInt32
StorageMode
Type: SystemInt32
RecordingMode
Type: SystemInt32
RecordingTimeHistory
Type: SystemDouble
PostTriggerRecordingTime
Type: SystemDouble
Remarks
In Perception 6.30 this method has been replaced with the method SetGroupStorageSettings
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetGroupStorageSettings(String, COMStorageSettingItem, COMStorageMode, COMRecordingMode, Double, Double)


IPerceptionCOM.SetRecSweepSettings Method

IPerceptionCOMSetRecSweepSettings Method

Note: This API is now obsolete.

This method is no longer supported and has been replaced by the SetGroupSweepSettings

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is no longer supported and has been replaced by the SetGroupSweepSettings")]
void SetRecSweepSettings(
    string Mainframe,
    string Recorder,
    int Mask,
    int SweepLength,
    double TriggerPosition,
    double Delay,
    int SweepMode,
    bool SweepCountEnabled,
    int SweepCount
)
<ObsoleteAttribute("This method is no longer supported and has been replaced by the SetGroupSweepSettings")>
Sub SetRecSweepSettings (
    Mainframe As String,
    Recorder As String,
    Mask As Integer,
    SweepLength As Integer,
    TriggerPosition As Double,
    Delay As Double,
    SweepMode As Integer,
    SweepCountEnabled As Boolean,
    SweepCount As Integer
)
[ObsoleteAttribute(L"This method is no longer supported and has been replaced by the SetGroupSweepSettings")]
void SetRecSweepSettings(
    String^ Mainframe,
    String^ Recorder,
    int Mask,
    int SweepLength,
    double TriggerPosition,
    double Delay,
    int SweepMode,
    bool SweepCountEnabled,
    int SweepCount
)
[<ObsoleteAttribute("This method is no longer supported and has been replaced by the SetGroupSweepSettings")>]
abstract SetRecSweepSettings :
        Mainframe : string *
        Recorder : string *
        Mask : int *
        SweepLength : int *
        TriggerPosition : float *
        Delay : float *
        SweepMode : int *
        SweepCountEnabled : bool *
        SweepCount : int -> unit

Parameters

Mainframe
Type: SystemString
Recorder
Type: SystemString
Mask
Type: SystemInt32
SweepLength
Type: SystemInt32
TriggerPosition
Type: SystemDouble
Delay
Type: SystemDouble
SweepMode
Type: SystemInt32
SweepCountEnabled
Type: SystemBoolean
SweepCount
Type: SystemInt32
Remarks
In Perception 6.30 this method has been replaced with the method SetGroupSweepSettings
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetGroupSweepSettings(String, COMSweepSettingItem, Int32, COMSweepMode, Double, Double, Boolean, Int32, Int32, Double, Boolean)


IPerceptionCOM.SetRecSweepSettingsEx Method

IPerceptionCOMSetRecSweepSettingsEx Method

Note: This API is now obsolete.

This method is no longer supported and has been replaced by the SetGroupSweepSettings

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is no longer supported and has been replaced by the SetGroupSweepSettings",
    true)]
void SetRecSweepSettingsEx(
    string Mainframe,
    string Recorder,
    int SweepLength,
    double TriggerPosition,
    double Delay,
    int SweepMode,
    bool SweepCountEnabled,
    int SweepCount,
    int SlowSweepLength,
    double SlowSweepTriggerPosition,
    bool SweepStretchEnabled
)
<ObsoleteAttribute("This method is no longer supported and has been replaced by the SetGroupSweepSettings",
    true)>
Sub SetRecSweepSettingsEx (
    Mainframe As String,
    Recorder As String,
    SweepLength As Integer,
    TriggerPosition As Double,
    Delay As Double,
    SweepMode As Integer,
    SweepCountEnabled As Boolean,
    SweepCount As Integer,
    SlowSweepLength As Integer,
    SlowSweepTriggerPosition As Double,
    SweepStretchEnabled As Boolean
)
[ObsoleteAttribute(L"This method is no longer supported and has been replaced by the SetGroupSweepSettings",
    true)]
void SetRecSweepSettingsEx(
    String^ Mainframe,
    String^ Recorder,
    int SweepLength,
    double TriggerPosition,
    double Delay,
    int SweepMode,
    bool SweepCountEnabled,
    int SweepCount,
    int SlowSweepLength,
    double SlowSweepTriggerPosition,
    bool SweepStretchEnabled
)
[<ObsoleteAttribute("This method is no longer supported and has been replaced by the SetGroupSweepSettings",
    true)>]
abstract SetRecSweepSettingsEx :
        Mainframe : string *
        Recorder : string *
        SweepLength : int *
        TriggerPosition : float *
        Delay : float *
        SweepMode : int *
        SweepCountEnabled : bool *
        SweepCount : int *
        SlowSweepLength : int *
        SlowSweepTriggerPosition : float *
        SweepStretchEnabled : bool -> unit

Parameters

Mainframe
Type: SystemString
Recorder
Type: SystemString
SweepLength
Type: SystemInt32
TriggerPosition
Type: SystemDouble
Delay
Type: SystemDouble
SweepMode
Type: SystemInt32
SweepCountEnabled
Type: SystemBoolean
SweepCount
Type: SystemInt32
SlowSweepLength
Type: SystemInt32
SlowSweepTriggerPosition
Type: SystemDouble
SweepStretchEnabled
Type: SystemBoolean
Remarks
In Perception 6.30 this method has been replaced with the method SetGroupSweepSettings
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetGroupSweepSettings(String, COMSweepSettingItem, Int32, COMSweepMode, Double, Double, Boolean, Int32, Int32, Double, Boolean)


IPerceptionCOM.SetRecTimebaseSettings Method

IPerceptionCOMSetRecTimebaseSettings Method

Note: This API is now obsolete.

This method is no longer supported and has been replaced by the SetGroupTimebaseSettings

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is no longer supported and has been replaced by the SetGroupTimebaseSettings")]
void SetRecTimebaseSettings(
    string Mainframe,
    string Recorder,
    int Mask,
    out double HighSamplingFrequency,
    out double LowSamplingFrequency,
    out int ClkSource
)
<ObsoleteAttribute("This method is no longer supported and has been replaced by the SetGroupTimebaseSettings")>
Sub SetRecTimebaseSettings (
    Mainframe As String,
    Recorder As String,
    Mask As Integer,
    <OutAttribute> ByRef HighSamplingFrequency As Double,
    <OutAttribute> ByRef LowSamplingFrequency As Double,
    <OutAttribute> ByRef ClkSource As Integer
)
[ObsoleteAttribute(L"This method is no longer supported and has been replaced by the SetGroupTimebaseSettings")]
void SetRecTimebaseSettings(
    String^ Mainframe,
    String^ Recorder,
    int Mask,
    [OutAttribute] double% HighSamplingFrequency,
    [OutAttribute] double% LowSamplingFrequency,
    [OutAttribute] int% ClkSource
)
[<ObsoleteAttribute("This method is no longer supported and has been replaced by the SetGroupTimebaseSettings")>]
abstract SetRecTimebaseSettings :
        Mainframe : string *
        Recorder : string *
        Mask : int *
        HighSamplingFrequency : float byref *
        LowSamplingFrequency : float byref *
        ClkSource : int byref -> unit

Parameters

Mainframe
Type: SystemString
Recorder
Type: SystemString
Mask
Type: SystemInt32
HighSamplingFrequency
Type: SystemDouble
LowSamplingFrequency
Type: SystemDouble
ClkSource
Type: SystemInt32
Remarks
In Perception 6.30 this method has been replaced with the method SetGroupTimebaseSettings
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetGroupTimebaseSettings(String, COMTimebaseSettingItem, Double, Double, COMClockSource, Int32)


IPerceptionCOM.SetRecTriggerBusSettings Method

IPerceptionCOMSetRecTriggerBusSettings Method

Set the trigger bus settings of a recorder

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetRecTriggerBusSettings(
    string Mainframe,
    string Recorder,
    int Mask,
    int MasterSlaveBusMode,
    int TriggerBus1Mode,
    int TriggerBus2Mode,
    int TriggerBus3Mode,
    bool ExternalTriggerInEnabled,
    bool ExternalTriggerOutEnabled,
    bool AutoTriggerEnabled,
    bool AlarmOutEnabled
)
Sub SetRecTriggerBusSettings (
    Mainframe As String,
    Recorder As String,
    Mask As Integer,
    MasterSlaveBusMode As Integer,
    TriggerBus1Mode As Integer,
    TriggerBus2Mode As Integer,
    TriggerBus3Mode As Integer,
    ExternalTriggerInEnabled As Boolean,
    ExternalTriggerOutEnabled As Boolean,
    AutoTriggerEnabled As Boolean,
    AlarmOutEnabled As Boolean
)
void SetRecTriggerBusSettings(
    String^ Mainframe,
    String^ Recorder,
    int Mask,
    int MasterSlaveBusMode,
    int TriggerBus1Mode,
    int TriggerBus2Mode,
    int TriggerBus3Mode,
    bool ExternalTriggerInEnabled,
    bool ExternalTriggerOutEnabled,
    bool AutoTriggerEnabled,
    bool AlarmOutEnabled
)
abstract SetRecTriggerBusSettings :
        Mainframe : string *
        Recorder : string *
        Mask : int *
        MasterSlaveBusMode : int *
        TriggerBus1Mode : int *
        TriggerBus2Mode : int *
        TriggerBus3Mode : int *
        ExternalTriggerInEnabled : bool *
        ExternalTriggerOutEnabled : bool *
        AutoTriggerEnabled : bool *
        AlarmOutEnabled : bool -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case MasterSlaveBusMode

if Mask = 2 then only the second parameter will be returned in this case TriggerBus1Mode

MasterSlaveBusMode
Type: SystemInt32
Sends and/or receives a trigger to/from another mainframe using this trigger line
  • Disabled = 0
  • Transmit = 1
  • Receive = 2
  • Transceive = 3

When multiple mainframes are used to perform acquisition(s), a master/slave module is used in order to synchronize them. The master/slave line is used to transfer trigger signals between mainframes, and this setting configures how it is used.

TriggerBus1Mode
Type: SystemInt32
Sends and/or receives a trigger to/from another recorder using trigger line 1
  • Disabled = 0
  • Transmit = 1
  • Receive = 2
  • Transceive = 3

There are three trigger lines on the hardware that can be used to transfer trigger signals among recorders. Each recorder can use these lines as input to or output from its trigger detection logic, or even both. Therefore this setting can take the values Disabled, Transmit, Receive, or Transceive.

TriggerBus2Mode
Type: SystemInt32
Sends and/or receives a trigger to/from another recorder using trigger line 2
  • Disabled = 0
  • Transmit = 1
  • Receive = 2
  • Transceive = 3
TriggerBus3Mode
Type: SystemInt32
Sends and/or receives a trigger to/from another recorder using trigger line 3
  • Disabled = 0
  • Transmit = 1
  • Receive = 2
  • Transceive = 3
ExternalTriggerInEnabled
Type: SystemBoolean
Enable or disables the external trigger in

Enables the use of the external trigger input on the mainframe

The trigger can come from an external signal which is fed to the respective port on the mainframe’s controller module. If this setting is enabled, a logical OR is applied to the combination of the internal trigger detectors of each channel and the external trigger signal. Although this is a per-recorder setting, there is only one external trigger input for the complete mainframe. Each individual recorder can be set to accept this trigger. However, a direction setting (if provided by the hardware) is mainframe-wide and cannot be set on a per-recorder basis.

ExternalTriggerOutEnabled
Type: SystemBoolean
Enable or disables the external trigger out

Sends the internal recorder trigger to the external trigger output on the mainframe

AutoTriggerEnabled
Type: SystemBoolean
Not Used
AlarmOutEnabled
Type: SystemBoolean
Not Used
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetRecTriggerBusSettings(String, String, Int32, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean)


IPerceptionCOM.SetSCBridgeBalancingSettings Method

IPerceptionCOMSetSCBridgeBalancingSettings Method

Set the bridge channel balancing settings

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetSCBridgeBalancingSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    int Mask,
    bool AutoBalancingEnabled,
    double BalanceValue,
    int GroupBalanceSelection,
    int BalanceStatus
)
Sub SetSCBridgeBalancingSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As Integer,
    AutoBalancingEnabled As Boolean,
    BalanceValue As Double,
    GroupBalanceSelection As Integer,
    BalanceStatus As Integer
)
void SetSCBridgeBalancingSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    int Mask,
    bool AutoBalancingEnabled,
    double BalanceValue,
    int GroupBalanceSelection,
    int BalanceStatus
)
abstract SetSCBridgeBalancingSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : int *
        AutoBalancingEnabled : bool *
        BalanceValue : float *
        GroupBalanceSelection : int *
        BalanceStatus : int -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case AutoBalancingEnabled

if Mask = 2 then only the second parameter will be returned in this case BalanceValue

AutoBalancingEnabled
Type: SystemBoolean
Balance enable.

Allows the channel to be balanced

Specifies whether the channel is allowed to be balanced. This option must be ON (= true) for actual balancing.

BalanceValue
Type: SystemDouble
Deviation. (Read Only)

The correction made when balancing, it is expressed in user units

GroupBalanceSelection
Type: SystemInt32
Not used
BalanceStatus
Type: SystemInt32
The status and result of the balancing (Read Only):
  • Not Balanced = 0
  • Balanced = 1
  • Restored = 2
  • Busy = 3
  • Error = 4
  • Overload = 5
  • No Factory Cal = 6
  • Not Implemented = 7
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetSCBridgeBalancingSettings(String, String, String, Int32, Boolean, Double, Int32, Int32)


IPerceptionCOM.SetSCBridgeCalibrationSettings Method

IPerceptionCOMSetSCBridgeCalibrationSettings Method

Set bridge channel calibration settings

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetSCBridgeCalibrationSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    int Mask,
    bool InternalShuntUsed,
    double ShuntValue,
    int CalibrationSource,
    double ShuntDeflection,
    bool ShuntAutoCalEnabled,
    int GroupCalSelection,
    int CalibrationStatus
)
Sub SetSCBridgeCalibrationSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As Integer,
    InternalShuntUsed As Boolean,
    ShuntValue As Double,
    CalibrationSource As Integer,
    ShuntDeflection As Double,
    ShuntAutoCalEnabled As Boolean,
    GroupCalSelection As Integer,
    CalibrationStatus As Integer
)
void SetSCBridgeCalibrationSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    int Mask,
    bool InternalShuntUsed,
    double ShuntValue,
    int CalibrationSource,
    double ShuntDeflection,
    bool ShuntAutoCalEnabled,
    int GroupCalSelection,
    int CalibrationStatus
)
abstract SetSCBridgeCalibrationSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : int *
        InternalShuntUsed : bool *
        ShuntValue : float *
        CalibrationSource : int *
        ShuntDeflection : float *
        ShuntAutoCalEnabled : bool *
        GroupCalSelection : int *
        CalibrationStatus : int -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case InternalShuntUsed

if Mask = 2 then only the second parameter will be returned in this case ShuntValue

InternalShuntUsed
Type: SystemBoolean
Location of the shunt resistor, if 'true' then internal shunt is used else external shunt is used
ShuntValue
Type: SystemDouble
Resistive value of shunt, external or internal (Ohm)
CalibrationSource
Type: SystemInt32
Shunt active gage:
  • Positive = 0
  • Negative = 1

Defines the location of the shunt resistor: either in parallel with the gage that is located in the positive arm of the bridge circuit or in parallel with the gage located in the negative arm.

ShuntDeflection
Type: SystemDouble
Calculated shunt deflection or target deflection.

When doing a shunt verification, the measured Deflection is compared to an expected deflection. The Target is the expected deflection. The value entered here will be used to verify if the difference between the bridge output value with and without a shunt resistor is within the specified tolerance. The difference between this value and the Deflection is represented as the error of the balance.

ShuntAutoCalEnabled
Type: SystemBoolean
Not used
GroupCalSelection
Type: SystemInt32
Not used
CalibrationStatus
Type: SystemInt32
Calibration status (Read Only):
  • Not Calibrated = 0
  • Calibrated = 1
  • Busy = 2
  • Error = 3
  • No Shunt Deflection = 4
  • Not Implemented = 5
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetSCBridgeCalibrationSettings(String, String, String, Int32, Boolean, Double, Int32, Double, Boolean, Int32, Int32)


IPerceptionCOM.SetSCBridgeSetupSettings Method

IPerceptionCOMSetSCBridgeSetupSettings Method

Set channel bridge setup settings

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetSCBridgeSetupSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    int Mask,
    double Sensitivity,
    int CompletionType
)
Sub SetSCBridgeSetupSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As Integer,
    Sensitivity As Double,
    CompletionType As Integer
)
void SetSCBridgeSetupSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    int Mask,
    double Sensitivity,
    int CompletionType
)
abstract SetSCBridgeSetupSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : int *
        Sensitivity : float *
        CompletionType : int -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case Sensitivity

if Mask = 2 then only the second parameter will be returned in this case CompletionType

Sensitivity
Type: SystemDouble
Returns the measured voltage as function of applied strain and excitation.

This value represents the degree to which changes in the applied strain or stress causes changes in the measured output voltage as function of the applied excitation.

CompletionType
Type: SystemInt32
Bridge completion type:
  • Quarter = 0
  • Half = 1
  • Full = 2
  • QuarterAuto = 3

Specifies the configuration of the internal and external resistors that all together complete the bridge circuit. Typical values are Quarter, Half, Full, where Full means that the bridge consists only of external resistors.

See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetSCBridgeSetupSettings(String, String, String, Int32, Double, Int32)


IPerceptionCOM.SetSCCommonSettings Method

IPerceptionCOMSetSCCommonSettings Method

Get the common settings of a channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetSCCommonSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    int Mask,
    int Mode,
    bool Enabled,
    string Name,
    int PrimaryColor,
    int SecondaryColor,
    string UserNote1,
    string UserNote2,
    string UserNote3,
    string UserNote4
)
Sub SetSCCommonSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As Integer,
    Mode As Integer,
    Enabled As Boolean,
    Name As String,
    PrimaryColor As Integer,
    SecondaryColor As Integer,
    UserNote1 As String,
    UserNote2 As String,
    UserNote3 As String,
    UserNote4 As String
)
void SetSCCommonSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    int Mask,
    int Mode,
    bool Enabled,
    String^ Name,
    int PrimaryColor,
    int SecondaryColor,
    String^ UserNote1,
    String^ UserNote2,
    String^ UserNote3,
    String^ UserNote4
)
abstract SetSCCommonSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : int *
        Mode : int *
        Enabled : bool *
        Name : string *
        PrimaryColor : int *
        SecondaryColor : int *
        UserNote1 : string *
        UserNote2 : string *
        UserNote3 : string *
        UserNote4 : string -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case Mode

if Mask = 2 then only the second parameter will be returned in this case Enabled

Mode
Type: SystemInt32
Amplifier mode:
  • Basic (Differential) = 0
  • Bridge = 1
  • Icp = 2
  • ThermoCouple = 3
  • BasicSensor = 4

Most channels can only be used in one amplifier mode; this mode is described as “basic” mode. However, there are also channels which support different modes like the bridge amplifier. This amplifier can work in basic mode, basic sensor mode and in bridge mode.

Once a type has been set, you can find the detailed settings of the selected type of input in the Input group.

Enabled
Type: SystemBoolean
Storage, When ON the channel is enabled for data storage.
Name
Type: SystemString
Logical name of the channel
PrimaryColor
Type: SystemInt32
Default trace color in displays
SecondaryColor
Type: SystemInt32
Secondary trace color
UserNote1
Type: SystemString
First additional field to enter miscellaneous information
UserNote2
Type: SystemString
Second additional field to enter miscellaneous information
UserNote3
Type: SystemString
Third additional field to enter miscellaneous information
UserNote4
Type: SystemString
Fourth additional field to enter miscellaneous information
Examples
Copy
int Mask = 0xFF;
int Mode = 0; // Basic mode
bool Enabled = true;
string cName = "Channel A";
int PrimaryColor = 0xFFFF; // = 65535 = Yellow
int SecondaryColor = 49344;
string UserNote1 = "Calibration date 08-03-2008";
string UserNote2 = "Owner engineering department";
string UserNote3 = "Location H3";
string UserNote4 = "";

RPC.SetSCCommonSettings("GEN7t I", "Recorder A", "Ch A1", Mask, Mode,
Enabled, cName, PrimaryColor, SecondaryColor, UserNote1, UserNote2, UserNote3, UserNote4);
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetSCCommonSettings(String, String, String, Int32, Int32, Boolean, String, Int32, Int32, String, String, String, String)


IPerceptionCOM.SetSCCouplingSettings Method

IPerceptionCOMSetSCCouplingSettings Method

Set the couplings settings of a channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetSCCouplingSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    int Mask,
    int InCoupling,
    int SigCoupling,
    double MeasuringPeriod,
    double ReferenceLevel,
    double Impedance
)
Sub SetSCCouplingSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As Integer,
    InCoupling As Integer,
    SigCoupling As Integer,
    MeasuringPeriod As Double,
    ReferenceLevel As Double,
    Impedance As Double
)
void SetSCCouplingSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    int Mask,
    int InCoupling,
    int SigCoupling,
    double MeasuringPeriod,
    double ReferenceLevel,
    double Impedance
)
abstract SetSCCouplingSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : int *
        InCoupling : int *
        SigCoupling : int *
        MeasuringPeriod : float *
        ReferenceLevel : float *
        Impedance : float -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case InCoupling

if Mask = 2 then only the second parameter will be returned in this case SigCoupling

InCoupling
Type: SystemInt32
Input coupling of a channel:
  • Single Ended Positive = 0
  • Single Ended Negative = 1
  • Differential = 2
  • Current = 3
  • Floating Differential = 4

This setting determines how the input signal is routed to the amplifier. If for example “Single Ended Positive” is selected, the negative input of the amplifier is grounded and the positive input is connected to the incoming signal. For a better understanding it is useful to look at the graphics on top of the settings sheet.

SigCoupling
Type: SystemInt32
Signal coupling:
  • GND = 0
  • DC = 1
  • AC = 2
  • DC_RMS = 3
  • AC_RMS = 4
  • DC_Frequency = 5
  • AC_Frequency = 6
  • DC_TrueRMS = 7
  • AC_TrueRMS = 8
  • DC_ExternalProbe = 9
  • AC_ExternalProbe = 10
  • Reference = 11

Defines how the analog signal is "coupled" into the amplifier

This setting defines how the analog signal is "coupled" into the amplifier. The coupling feature defines which signal component (content) is passed to the amplifier. When "AC" is selected, the AC content of a signal without any DC bias voltage is measured. With "DC" selection, both AC and DC content are passed to the amplifier. A "GND" mode is usually provided to ground an amplifier to minimize the influence of random noise.

MeasuringPeriod
Type: SystemDouble
ReferenceLevel
Type: SystemDouble
Impedance
Type: SystemDouble
Input impedance is the effective resistance and capacitance seen at the input to the digitizer.

This setting is read-only and shows the effective resistance and capacitance seen at the input to the digitizer.

See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetSCCouplingSettings(String, String, String, Int32, Int32, Int32, Double, Double, Double)


IPerceptionCOM.SetSCExcitationSettings Method

IPerceptionCOMSetSCExcitationSettings Method

Set the channel excitation settings

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetSCExcitationSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    int Mask,
    bool Enable,
    int ExcitationType,
    double Voltage,
    double Current
)
Sub SetSCExcitationSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As Integer,
    Enable As Boolean,
    ExcitationType As Integer,
    Voltage As Double,
    Current As Double
)
void SetSCExcitationSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    int Mask,
    bool Enable,
    int ExcitationType,
    double Voltage,
    double Current
)
abstract SetSCExcitationSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : int *
        Enable : bool *
        ExcitationType : int *
        Voltage : float *
        Current : float -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case Enable

if Mask = 2 then only the second parameter will be returned in this case ExitationType

Enable
Type: SystemBoolean
Sets system excitation yes or no.

Use this settings to enable or disable the excitation. It is good practice to remove excitation before you connect or disconnect a (bridge) sensor to the input.

ExcitationType
Type: SystemInt32
Excitation type:
  • Voltage = 0
  • Voltage_Sense = 1
  • Current = 2
  • Voltage_Strobed = 3
  • Voltage_Sense_Strobed = 4
  • Current_Strobed = 5

The bridge circuit can be supplied with either a voltage or a current. Choose the one that applies.

Voltage
Type: SystemDouble
Excitation voltage in Volt (Only used when Excitation type is set to Voltage)
Current
Type: SystemDouble
Excitation current in Ampere (Only used when Excitation type is set to Current)
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetSCExcitationSettings(String, String, String, Int32, Boolean, Int32, Double, Double)


IPerceptionCOM.SetSCFilterSettings Method

IPerceptionCOMSetSCFilterSettings Method

Get the filter settings of a channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetSCFilterSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    int Mask,
    int Type,
    int Mode,
    double TrackingRatio,
    double Frequency,
    double ActualFrequency
)
Sub SetSCFilterSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As Integer,
    Type As Integer,
    Mode As Integer,
    TrackingRatio As Double,
    Frequency As Double,
    ActualFrequency As Double
)
void SetSCFilterSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    int Mask,
    int Type,
    int Mode,
    double TrackingRatio,
    double Frequency,
    double ActualFrequency
)
abstract SetSCFilterSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : int *
        Type : int *
        Mode : int *
        TrackingRatio : float *
        Frequency : float *
        ActualFrequency : float -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case InCoupling

if Mask = 2 then only the second parameter will be returned in this case SigCoupling

Type
Type: SystemInt32
Filter type:
  • Bessel = 0
  • Butterworth = 1
  • Elliptic = 2
  • FIR = 3
  • IIR = 4
  • Wideband = 5
  • Bessel Analog = 6
  • Butterworth Analog = 7
  • Sigma Delta Wideband = 8
Mode
Type: SystemInt32
Filter mode:
  • Tracking = 0
  • Fixed = 1
TrackingRatio
Type: SystemDouble
Tracking ratio
Frequency
Type: SystemDouble
Frequency above which the power is 0.5 the power of the pass band (-3 dBpoint)

The filter frequency defines the pass band of the filter. This frequency is also often called the cut-off frequency. This is the frequency where the signal has been attenuated to half the power of the pass band. The available filter frequencies depend on the sample rate and the Filter type.

Typical available values are:

- FIR: 1/4, 1/10,1/20 and 1/40 of the sample rate

- Bessel: 1/10, 1/20, 1/40 and 1/100 of the sample rate

ActualFrequency
Type: SystemDouble
Remarks
Removes unwanted high-frequency signal components by selecting the correct filter type
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetSCFilterSettings(String, String, String, Int32, Int32, Int32, Double, Double, Double)


IPerceptionCOM.SetSCInputRangeSettings Method

IPerceptionCOMSetSCInputRangeSettings Method

Set the input range settings of a channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetSCInputRangeSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    int Mask,
    double UpperValue,
    double LowerValue,
    double ActualUpperValue,
    double ActualLowerValue,
    double Span,
    double Offset,
    double Gain,
    bool VariableGain
)
Sub SetSCInputRangeSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As Integer,
    UpperValue As Double,
    LowerValue As Double,
    ActualUpperValue As Double,
    ActualLowerValue As Double,
    Span As Double,
    Offset As Double,
    Gain As Double,
    VariableGain As Boolean
)
void SetSCInputRangeSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    int Mask,
    double UpperValue,
    double LowerValue,
    double ActualUpperValue,
    double ActualLowerValue,
    double Span,
    double Offset,
    double Gain,
    bool VariableGain
)
abstract SetSCInputRangeSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : int *
        UpperValue : float *
        LowerValue : float *
        ActualUpperValue : float *
        ActualLowerValue : float *
        Span : float *
        Offset : float *
        Gain : float *
        VariableGain : bool -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case UpperValue

if Mask = 2 then only the second parameter will be returned in this case LowerValue

UpperValue
Type: SystemDouble
Upper value in user units
LowerValue
Type: SystemDouble
Lower value in user units
ActualUpperValue
Type: SystemDouble
Can not be set
ActualLowerValue
Type: SystemDouble
Can not be set
Span
Type: SystemDouble
Can not be set
Offset
Type: SystemDouble
Can not be set
Gain
Type: SystemDouble
Can not be set
VariableGain
Type: SystemBoolean
Enable variable gain
Examples
Copy
int nMask = 0xFF;
double UpperValue = 1000;
double LowerValue = -1000;
double ActualUpperValue = -1;
double ActualLowerValue = -1;
double Span = -1;
double Offset = -1;
double Gain = -1;
bool VariableGain = false;

m_Perception.SetSCInputRangeSettings("GEN7t I", "Recorder A", "Ch A1", nMask, UpperValue,
                    LowerValue, ActualUpperValue, ActualLowerValue, Span, Offset, Gain, VariableGain);
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetSCInputRangeSettings(String, String, String, Int32, Double, Double, Double, Double, Double, Double, Double, Boolean)


IPerceptionCOM.SetSCUserScalingSettings Method

IPerceptionCOMSetSCUserScalingSettings Method

Set the user-scaling of a channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetSCUserScalingSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    int Mask,
    double Multiplier,
    double Offset,
    string UserUnits
)
Sub SetSCUserScalingSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As Integer,
    Multiplier As Double,
    Offset As Double,
    UserUnits As String
)
void SetSCUserScalingSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    int Mask,
    double Multiplier,
    double Offset,
    String^ UserUnits
)
abstract SetSCUserScalingSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : int *
        Multiplier : float *
        Offset : float *
        UserUnits : string -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case Multiplier

if Mask = 2 then only the second parameter will be returned in this case Offset

Multiplier
Type: SystemDouble
Technical units multiplier (a)
Offset
Type: SystemDouble
Technical units offset (b)
UserUnits
Type: SystemString
Technical units
Remarks

y = a.x + b (x = input)

The measured input data can be transformed to a different scale by using the linear equation described above. This can be used for example to calibrate the system or convert the measured input into a different unit. The technical units multiplier is the scaling factor “a” in the formula above. The technical units offset is the offset factor “b” in the formula above.

Examples
Copy
int nMask = 0xFF;
double Multiplier = 100;
double Offset = 5;
string UserUnits = "psi";
m_Perception.SetSCUserScalingSettings("GEN7t I", "Recorder A", "Ch A1", nMask, out Multiplier, out Offset, out UserUnits);
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetSCUserScalingSettings(String, String, String, Int32, Double, Double, String)


IPerceptionCOM.SetServerAddress Method

IPerceptionCOMSetServerAddress Method

Set the address of the Perception Server machine

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetServerAddress(
    string Address
)
Sub SetServerAddress (
    Address As String
)
void SetServerAddress(
    String^ Address
)
abstract SetServerAddress :
        Address : string -> unit

Parameters

Address
Type: SystemString
Address of Perception server, use "localhost" if Perception is running on the same machine, else use the IP-Address or the computer name
Examples

Copy
using System;
using System.Collections.Generic;
using System.ComponentModel;
using System.Data;
using System.Drawing;
using System.Text;
using System.Windows.Forms;
using PerceptionCOMRpc;

namespace MyFirstCOMClient
{
     public partial class Form1 : Form
     {
          // Define a private member to hold a reference to Perception
          // All the communication to Perception will be done via this member
          private PerceptionCOM m_Perception = null;

          public Form1()
          {
               InitializeComponent();
               // Create an instance of the Perception com server
               m_Perception = new PerceptionCOM();
          }

          private void btnConnect_Click(object sender, EventArgs e)
          {
               // Set the address of the Perception Server machine
               // "localhost" is pointing to your own PC.
               // If however the Perception server is running on another machine then
               // you have to enter the computer name or IP-address of this PC
               m_Perception.SetServerAddress("localhost");
               m_Perception.ConnectToServer();

               // Get the acquisition state to check if we have communication
               ShowAcquisitionState();
          }

          private void ShowAcquisitionState()
          {
               int Run;
               int OneShot;
               int Stop;
               int Pause;
               int Idle;
               m_Perception.GetAcquisitionState(out Run, out OneShot, out Stop, out Pause, out Idle);
               label1.Text = "Run: " + Run.ToString() + " OneShot: " + OneShot.ToString() +
                            " Stop: " + Stop.ToString() + " Pause: " + Pause.ToString() +
                            " Idle: " + Idle.ToString();
          }
     }
}
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMConnectToServer
IPerceptionCOMDisconnectFromServer


IPerceptionCOM.SetShuntResistorActive Method

IPerceptionCOMSetShuntResistorActive Method

Set the shunt resistor

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetShuntResistorActive(
    string Mainframe,
    string Recorder,
    string Channel,
    bool Active
)
Sub SetShuntResistorActive (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Active As Boolean
)
void SetShuntResistorActive(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    bool Active
)
abstract SetShuntResistorActive :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Active : bool -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
Active
Type: SystemBoolean
If true the shunt resistor is active, for more information see "Shunt verification" in Perception manual
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetShuntResistorActive(String, String, String, Boolean)


IPerceptionCOM.SetSilentMode Method

IPerceptionCOMSetSilentMode Method

Toggle Perception to run in silent mode. If set to silent mode, most UI interaction will be suppressed and automatically handled.

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetSilentMode(
    bool SilentModeEnabled
)
Sub SetSilentMode (
    SilentModeEnabled As Boolean
)
void SetSilentMode(
    bool SilentModeEnabled
)
abstract SetSilentMode :
        SilentModeEnabled : bool -> unit

Parameters

SilentModeEnabled
Type: SystemBoolean
True to set Perception to silent mode
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.SetStorageSettings Method

IPerceptionCOMSetStorageSettings Method

Note: This API is now obsolete.

This method is no longer supported and has been replaced by the SetGroupStorageSettings

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is no longer supported and has been replaced by the SetGroupStorageSettings")]
void SetStorageSettings(
    string Mainframe,
    string Recorder,
    int StorageMode
)
<ObsoleteAttribute("This method is no longer supported and has been replaced by the SetGroupStorageSettings")>
Sub SetStorageSettings (
    Mainframe As String,
    Recorder As String,
    StorageMode As Integer
)
[ObsoleteAttribute(L"This method is no longer supported and has been replaced by the SetGroupStorageSettings")]
void SetStorageSettings(
    String^ Mainframe,
    String^ Recorder,
    int StorageMode
)
[<ObsoleteAttribute("This method is no longer supported and has been replaced by the SetGroupStorageSettings")>]
abstract SetStorageSettings :
        Mainframe : string *
        Recorder : string *
        StorageMode : int -> unit

Parameters

Mainframe
Type: SystemString
Recorder
Type: SystemString
StorageMode
Type: SystemInt32
Remarks
In Perception 6.30 this method has been replaced with the method SetGroupStorageSettings
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetGroupStorageSettings(String, COMStorageSettingItem, COMStorageMode, COMRecordingMode, Double, Double)


IPerceptionCOM.SetSweepSettings Method

IPerceptionCOMSetSweepSettings Method

Note: This API is now obsolete.

This method is no longer supported and has been replaced by the SetGroupSweepSettings

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is no longer supported and has been replaced by the SetGroupSweepSettings")]
void SetSweepSettings(
    string Mainframe,
    string Recorder,
    int SweepLength,
    int SweepMode,
    double TriggerPosition,
    double Delay,
    bool SweepCountEnabled,
    int SweepCount
)
<ObsoleteAttribute("This method is no longer supported and has been replaced by the SetGroupSweepSettings")>
Sub SetSweepSettings (
    Mainframe As String,
    Recorder As String,
    SweepLength As Integer,
    SweepMode As Integer,
    TriggerPosition As Double,
    Delay As Double,
    SweepCountEnabled As Boolean,
    SweepCount As Integer
)
[ObsoleteAttribute(L"This method is no longer supported and has been replaced by the SetGroupSweepSettings")]
void SetSweepSettings(
    String^ Mainframe,
    String^ Recorder,
    int SweepLength,
    int SweepMode,
    double TriggerPosition,
    double Delay,
    bool SweepCountEnabled,
    int SweepCount
)
[<ObsoleteAttribute("This method is no longer supported and has been replaced by the SetGroupSweepSettings")>]
abstract SetSweepSettings :
        Mainframe : string *
        Recorder : string *
        SweepLength : int *
        SweepMode : int *
        TriggerPosition : float *
        Delay : float *
        SweepCountEnabled : bool *
        SweepCount : int -> unit

Parameters

Mainframe
Type: SystemString
Recorder
Type: SystemString
SweepLength
Type: SystemInt32
SweepMode
Type: SystemInt32
TriggerPosition
Type: SystemDouble
Delay
Type: SystemDouble
SweepCountEnabled
Type: SystemBoolean
SweepCount
Type: SystemInt32
Remarks
In Perception 6.30 this method has been replaced with the method SetGroupSweepSettings
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetGroupSweepSettings(String, COMSweepSettingItem, Int32, COMSweepMode, Double, Double, Boolean, Int32, Int32, Double, Boolean)


IPerceptionCOM.SetTimebaseSettings Method

IPerceptionCOMSetTimebaseSettings Method

Note: This API is now obsolete.

This method is no longer supported and has been replaced by the SetGroupTimebaseSettings

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is no longer supported and has been replaced by the SetGroupTimebaseSettings")]
void SetTimebaseSettings(
    string Mainframe,
    string Recorder,
    double HigSampleRate,
    double LowSampleRate
)
<ObsoleteAttribute("This method is no longer supported and has been replaced by the SetGroupTimebaseSettings")>
Sub SetTimebaseSettings (
    Mainframe As String,
    Recorder As String,
    HigSampleRate As Double,
    LowSampleRate As Double
)
[ObsoleteAttribute(L"This method is no longer supported and has been replaced by the SetGroupTimebaseSettings")]
void SetTimebaseSettings(
    String^ Mainframe,
    String^ Recorder,
    double HigSampleRate,
    double LowSampleRate
)
[<ObsoleteAttribute("This method is no longer supported and has been replaced by the SetGroupTimebaseSettings")>]
abstract SetTimebaseSettings :
        Mainframe : string *
        Recorder : string *
        HigSampleRate : float *
        LowSampleRate : float -> unit

Parameters

Mainframe
Type: SystemString
Recorder
Type: SystemString
HigSampleRate
Type: SystemDouble
LowSampleRate
Type: SystemDouble
Remarks
In Perception 6.30 this method has been replaced with the method SetGroupTimebaseSettings
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSetGroupTimebaseSettings(String, COMTimebaseSettingItem, Double, Double, COMClockSource, Int32)


IPerceptionCOM.SetTimerCounterChannelEnabled Method

IPerceptionCOMSetTimerCounterChannelEnabled Method

Enable/Disable the storage of a timer-counter channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetTimerCounterChannelEnabled(
    string Mainframe,
    string Recorder,
    string Channel,
    bool Enabled
)
Sub SetTimerCounterChannelEnabled (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Enabled As Boolean
)
void SetTimerCounterChannelEnabled(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    bool Enabled
)
abstract SetTimerCounterChannelEnabled :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Enabled : bool -> unit

Parameters

Mainframe
Type: SystemString
Name or index of mainframe
Recorder
Type: SystemString
Name or index of recorder
Channel
Type: SystemString
Name or index of channel
Enabled
Type: SystemBoolean
Channel enabled true or false
Examples
Copy
string cMainframe = "GEN7t I";
string cRecorder = "Recorder A";
string cChannel = "Ch A1";

m_Perception.SetTimerCounterChannelEnabled(cMainframe, cRecorder, cChannel, true);

cMainframe = "$1$";   // First mainframe
cRecorder = "$1$";    // First recorder of first mainframe
cChannel = "$1$";     // First timer-counter channel of first recorder of first mainframe

m_Perception.SetTimerCounterChannelEnabled(cMainframe, cRecorder, cChannel, false);
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetChannelEnabled(String, String, String, Boolean)
IPerceptionCOMSetChannelEnabled(String, String, String, Boolean)
IPerceptionCOMGetEventChannelEnabled(String, String, String, Boolean)
IPerceptionCOMSetEventChannelEnabled(String, String, String, Boolean)
IPerceptionCOMGetTimerCounterChannelEnabled(String, String, String, Boolean)


IPerceptionCOM.SetTriggerIOSettings Method

IPerceptionCOMSetTriggerIOSettings Method

Set the trigger IO settings of a mainframe

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetTriggerIOSettings(
    string Mainframe,
    int Mask,
    COMExternalTriggerIn ExtTrigIn,
    COMExternalTriggerOut ExtTrigOut,
    int AlarmOutMode,
    int ExtQualInMode
)
Sub SetTriggerIOSettings (
    Mainframe As String,
    Mask As Integer,
    ExtTrigIn As COMExternalTriggerIn,
    ExtTrigOut As COMExternalTriggerOut,
    AlarmOutMode As Integer,
    ExtQualInMode As Integer
)
void SetTriggerIOSettings(
    String^ Mainframe,
    int Mask,
    COMExternalTriggerIn ExtTrigIn,
    COMExternalTriggerOut ExtTrigOut,
    int AlarmOutMode,
    int ExtQualInMode
)
abstract SetTriggerIOSettings :
        Mainframe : string *
        Mask : int *
        ExtTrigIn : COMExternalTriggerIn *
        ExtTrigOut : COMExternalTriggerOut *
        AlarmOutMode : int *
        ExtQualInMode : int -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case ExtTrigIn

if Mask = 2 then only the second parameter will be returned in this case ExtTrigOut

ExtTrigIn
Type: RPC_COMCOMExternalTriggerIn
External trigger in mode:
  • COMExternalTriggerInMode_Disabled = 0
  • COMExternalTriggerInMode_RisingEdge = 1
  • COMExternalTriggerInMode_FallingEdge = 2
  • COMExternalTriggerInMode_RisingEdge_InToOut = 3
  • COMExternalTriggerInMode_FallingEdge_InToOut = 4

The trigger can come from an external signal which is fed to the respective port on the mainframe’s controller module. If this setting is enabled, a logical OR is applied to the combination of the internal trigger detectors of each channel and the external trigger signal.

Although this is a per-recorder setting, there is only one external trigger input for the complete mainframe. Each individual recorder can be set to accept this trigger.

However, a direction setting (if provided by the hardware) is mainframe-wide and cannot be set on a per-recorder basis.

ExtTrigOut
Type: RPC_COMCOMExternalTriggerOut
Sets the active level of the external trigger output:
  • COMExternalTriggerOutMode_Disabled = 0
  • COMExternalTriggerOutMode_HighLevel = 1
  • COMExternalTriggerOutMode_LowLevel = 2
  • COMExternalTriggerOutMode_HoldHighLevel = 3
  • COMExternalTriggerOutMode_HoldLowLevel = 4

This setting is applicable if External trigger out is enabled.

Depending on your hardware, one or more of the following settings may be applicable:

- If its value is set to High Level, the output voltage of the output port is high only when a trigger occurs (an active-high pulse).

- If its value is set to Low Level, the output voltage is constantly high and becomes low when a trigger occurs (an active-low pulse).

- If its value is Hold High Level, the output signal becomes high when a trigger occurs and stays high until the end of the acquisition.

AlarmOutMode
Type: SystemInt32
Sets the function of the alarm output on the mainframe.
  • CtrlAlarmOutMode_Disabled = 0
  • CtrlAlarmOutMode_HighLevel = 1
  • CtrlAlarmOutMode_LowLevel = 2
  • CtrlAlarmOutMode_AcqState_HighLevel = 3
  • CtrlAlarmOutMode_AcqState_LowLevel = 4

Each channel has the capability of generating an alarm. The output of a channel’s alarm detector is sent to an alarm line and combined (OR-ed) with alarm conditions of the other channels and recorders. The result is available as an external output located on the mainframe controller.

This setting can have one of the values Alarm High Level, Alarm Low Level, or Recording High Level. When Recording High Level is selected, the output connector on the controller is high when a recording is in process. When Alarm High Level is selected, the output is high when channel alarm detectors activate on the alarm line. When Alarm Low Level is selected, the output is low when the alarm line level is active; the signal is therefore the inverse of the previous setting.

ExtQualInMode
Type: SystemInt32
External qualifier in mode:
  • CtrlExternalQualifierInMode_Disabled = 0
  • CtrlExternalQualifierInMode_HighLevel = 1
  • CtrlExternalQualifierInMode_LowLevel = 2

If enabled, qualifies the trigger logic

When enabled, the qualifier signal is used as a “gate” for the channel and external triggers.

As long as the qualifier is inactive, no trigger event is passed and the recorder will not (generate a) trigger.

When enabled and the qualifier is active, triggers are “passed” and the recorder can (generate a) trigger.

See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetTriggerIOSettings(String, Int32, COMExternalTriggerIn, COMExternalTriggerOut, Int32, Int32)


IPerceptionCOM.SetTriggerLevelSettings Method

IPerceptionCOMSetTriggerLevelSettings Method

Set the trigger level settings of a channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetTriggerLevelSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    int Mask,
    int Mode,
    double PrimaryLevel,
    double SecondaryLevel,
    int Direction,
    double Hysterese,
    bool TriggerDeltaTimeWindowEnabled,
    double TriggerDeltaTimeWindow,
    int ChannelSelect
)
Sub SetTriggerLevelSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As Integer,
    Mode As Integer,
    PrimaryLevel As Double,
    SecondaryLevel As Double,
    Direction As Integer,
    Hysterese As Double,
    TriggerDeltaTimeWindowEnabled As Boolean,
    TriggerDeltaTimeWindow As Double,
    ChannelSelect As Integer
)
void SetTriggerLevelSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    int Mask,
    int Mode,
    double PrimaryLevel,
    double SecondaryLevel,
    int Direction,
    double Hysterese,
    bool TriggerDeltaTimeWindowEnabled,
    double TriggerDeltaTimeWindow,
    int ChannelSelect
)
abstract SetTriggerLevelSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : int *
        Mode : int *
        PrimaryLevel : float *
        SecondaryLevel : float *
        Direction : int *
        Hysterese : float *
        TriggerDeltaTimeWindowEnabled : bool *
        TriggerDeltaTimeWindow : float *
        ChannelSelect : int -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case Mode

if Mask = 2 then only the second parameter will be returned in this case PrimaryLevel

Mode
Type: SystemInt32
Trigger mode:
  • Off = 0
  • Basic = 1
  • Dual = 2
  • Window = 3
  • DualWindow = 4
  • Sequential = 5
  • BasicQualifier = 6
  • DualQualifier = 7
PrimaryLevel
Type: SystemDouble
Primary level in user units
SecondaryLevel
Type: SystemDouble
Secondary level in user units
Direction
Type: SystemInt32
Direction:
  • Rising Edge = 0
  • Falling Edge = 1
Hysterese
Type: SystemDouble
Hysteresis in user-units
TriggerDeltaTimeWindowEnabled
Type: SystemBoolean
dY/dt enabled
TriggerDeltaTimeWindow
Type: SystemDouble
Delta time window user-units per seconds
ChannelSelect
Type: SystemInt32
UNKOWN
Examples
Copy
protected void Set()
{
     int Mask = 0xFF;
     int TriggerMode = 1; // Basic
     double PrimaryLevel = 0.5;
     double SecondaryLevel = 1.25;
     int Direction 0;
     double Hysteresis = 0.001;
     bool TriggerDeltaTimeWindowEnabled = false;
     double TriggerDeltaTimeWindow = 0;
     int ChannelSelect = -1;

     m_Perception.SetTriggerLevelSettings("GEN7t I", "Recorder A", "Ch A1", Mask,
                                   TriggerMode, PrimaryLevel, SecondaryLevel, Direction, Hysteresis,
                                   TriggerDeltaTimeWindowEnabled, TriggerDeltaTimeWindow, ChannelSelect);
}
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetTriggerLevelSettings(String, String, String, Int32, Int32, Double, Double, Int32, Double, Boolean, Double, Int32)
IPerceptionCOMSetTriggerSettings(String, String, String, Int32, Double, Double, Int32)
IPerceptionCOMGetTriggerSettings(String, String, String, Int32, Double, Double, Int32)


IPerceptionCOM.SetTriggerPulseDetectorSettings Method

IPerceptionCOMSetTriggerPulseDetectorSettings Method

Set trigger pulse detector settings

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetTriggerPulseDetectorSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    int Mask,
    int PulseDetectorMode,
    double PulseWindowTime
)
Sub SetTriggerPulseDetectorSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As Integer,
    PulseDetectorMode As Integer,
    PulseWindowTime As Double
)
void SetTriggerPulseDetectorSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    int Mask,
    int PulseDetectorMode,
    double PulseWindowTime
)
abstract SetTriggerPulseDetectorSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : int *
        PulseDetectorMode : int *
        PulseWindowTime : float -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Name or index of recorder
Channel
Type: SystemString
Name or index of channel
Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case PulseDetectorMode

if Mask = 2 then only the second parameter will be returned in this case PulseWindowTime

PulseDetectorMode
Type: SystemInt32
Enables pulse detection/rejection
  • Disabled = 0
  • Detect = 1
  • Reject = 2

The pulse detector can be used together with the basic (slope) trigger level detector. The possible values are: Disabled, Detect, Reject. The Pulse width is used to define the width of the pulses which should be detected or rejected.

PulseWindowTime
Type: SystemDouble
Pulse width.

Use this setting to set the width of the pulses which should be detected or rejected. The pulse width is only used if the Pulse detector is set to Detect or Reject. The value is specified in seconds or external timebase units depending on the mainframe Clock base setting.

See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetTriggerPulseDetectorSettings(String, String, String, Int32, Int32, Double)


IPerceptionCOM.SetTriggerRepeatTimerSettings Method

IPerceptionCOMSetTriggerRepeatTimerSettings Method

Set trigger repeat timer settings

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetTriggerRepeatTimerSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    int Mask,
    int RepeatTimerMode,
    double WindowStart,
    double WindowWidth,
    double EventHoldOffTime,
    int EventOccurrences
)
Sub SetTriggerRepeatTimerSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    Mask As Integer,
    RepeatTimerMode As Integer,
    WindowStart As Double,
    WindowWidth As Double,
    EventHoldOffTime As Double,
    EventOccurrences As Integer
)
void SetTriggerRepeatTimerSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    int Mask,
    int RepeatTimerMode,
    double WindowStart,
    double WindowWidth,
    double EventHoldOffTime,
    int EventOccurrences
)
abstract SetTriggerRepeatTimerSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        Mask : int *
        RepeatTimerMode : int *
        WindowStart : float *
        WindowWidth : float *
        EventHoldOffTime : float *
        EventOccurrences : int -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Name or index of recorder
Channel
Type: SystemString
Name or index of channel
Mask
Type: SystemInt32
Parameter mask, 0xFF, returns all parameters

Each parameter represents a bit in the mask, the first parameter is the first bit etc.

if Mask = 1 then only the first parameter will be returned in this case RepeatTimerMode

if Mask = 2 then only the second parameter will be returned in this case WindowStart

RepeatTimerMode
Type: SystemInt32
Repeat timer mode:
  • Disabled = 0
  • Less = 1
  • More = 2
  • Between = 3
  • NotBetween = 4

Defines a time relation between two consecutive trigger events

The interval timer is used to define a time relation between two trigger events. If the time relation is correct, a trigger is generated. The possible timer modes are: Disabled, Less, More, Between, NotBetween.

WindowStart
Type: SystemDouble
Timer window start.

Depending on the interval timer mode, there is a difference in functionality for this setting:

- For the Less and More mode, this setting is the width of the interval.

- For Between and NotBetween, this setting is the time after which the Timer window width interval is used.

The value is specified in seconds or external timebase units depending on the mainframe Clock base setting.

WindowWidth
Type: SystemDouble
Timer window width

Defines the second interval used for the interval timer

The trigger window width is only used if the Timer mode is set to Between or NotBetween. The value is specified in seconds or external timebase units depending on the mainframe Clock base setting.

EventHoldOffTime
Type: SystemDouble
Hold off time.

Disables the trigger detector for a specified period of time after a valid trigger has been generated

The trigger hold-off feature is used to disable the trigger detector for a period of time after a valid trigger has been generated. This can be used to generate only one trigger on a slowly decaying repetitive signal, or eliminate the effect of after-ringing. The feature is most useful in combination with the interval Timer and/or the Event counter.

EventOccurrences
Type: SystemInt32
Event counter.

Counts a number of trigger events before the actual trigger is generated

The event counter adds all generated triggers and generates a final trigger if the count equals the preset value.

See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetTriggerRepeatTimerSettings(String, String, String, Int32, Int32, Double, Double, Double, Int32)


IPerceptionCOM.SetTriggerSettings Method

IPerceptionCOMSetTriggerSettings Method

Set the basic trigger parameters per channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetTriggerSettings(
    string Mainframe,
    string Recorder,
    string Channel,
    int TriggerMode,
    double PrimaryTriggerLevel,
    double SecondaryTriggerLevel,
    int Direction
)
Sub SetTriggerSettings (
    Mainframe As String,
    Recorder As String,
    Channel As String,
    TriggerMode As Integer,
    PrimaryTriggerLevel As Double,
    SecondaryTriggerLevel As Double,
    Direction As Integer
)
void SetTriggerSettings(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel,
    int TriggerMode,
    double PrimaryTriggerLevel,
    double SecondaryTriggerLevel,
    int Direction
)
abstract SetTriggerSettings :
        Mainframe : string *
        Recorder : string *
        Channel : string *
        TriggerMode : int *
        PrimaryTriggerLevel : float *
        SecondaryTriggerLevel : float *
        Direction : int -> unit

Parameters

Mainframe
Type: SystemString
Name or index of mainframe
Recorder
Type: SystemString
Name or index of recorder
Channel
Type: SystemString
Name or index of channel
TriggerMode
Type: SystemInt32
Channel trigger mode:
  • CTM_Off = 0
  • CTM_Basic = 1
  • CTM_Dual = 2
  • CTM_Window = 3
  • CTM_DualWindow = 4
  • CTM_Sequential = 5
  • CTM_BasicQualifier = 6
  • CTM_DualQualifier = 7
PrimaryTriggerLevel
Type: SystemDouble
Primary trigger level in technical units
SecondaryTriggerLevel
Type: SystemDouble
Secondary trigger level in technical units
Direction
Type: SystemInt32
Direction of primary level. Direction of secondary level is opposite by default.
  • CTD_RisingEdge = 0
  • CTD_FallingEdge = 1
Examples
Copy
string cMainframe = "GEN7t I";
string cRecorder = "Recorder A";
string cChannel = "Ch A1";

// Set trigger mode to basic mode; primary level to 2 and secondary to 0; Direction is rising edge.
m_Perception.SetTriggerSettings(cMainframe, cRecorder, cChannel, 1, 2, 0, 0);
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetTriggerSettings(String, String, String, Int32, Double, Double, Int32)
IPerceptionCOMSetTriggerLevelSettings(String, String, String, Int32, Int32, Double, Double, Int32, Double, Boolean, Double, Int32)
IPerceptionCOMGetTriggerLevelSettings(String, String, String, Int32, Int32, Double, Double, Int32, Double, Boolean, Double, Int32)


IPerceptionCOM.SetWindowState Method

IPerceptionCOMSetWindowState Method

Sets the window state of all workbooks in Perception

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SetWindowState(
    COMWindowState State
)
Sub SetWindowState (
    State As COMWindowState
)
void SetWindowState(
    COMWindowState State
)
abstract SetWindowState :
        State : COMWindowState -> unit

Parameters

State
Type: RPC_COMCOMWindowState
State to set windows to
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMGetWindowState(COMWindowState)


IPerceptionCOM.Start Method

IPerceptionCOMStart Method

The Start command starts acquisition of data.

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void Start()
Sub Start
void Start()
abstract Start : unit -> unit
Examples
Copy
using System;
using System.Collections.Generic;
using System.ComponentModel;
using System.Data;
using System.Drawing;
using System.Text;
using System.Windows.Forms;
using PerceptionCOMRpc;

namespace MyFirstCOMClient
{
     public partial class Form1 : Form
     {
          // Define a private member to hold a reference to Perception
          // All the communication to Perception will be done via this member
          private PerceptionCOM m_Perception = null;

          public Form1()
          {
               InitializeComponent();
               // Create an instance of the COM server
               m_Perception = new PerceptionCOM();
          }

          private void btnConnect_Click(object sender, EventArgs e)
          {
               // Set the address of the Perception Server machine
               // "localhost" is pointing to your own PC.
               // If however the Perception server is running on another machine then
               // you have to enter the computer name or IP-address of this PC
               m_Perception.SetServerAddress("localhost");
               m_Perception.ConnectToServer();

               // Get the acquisition state to check if we have communication
               ShowAcquisitionState();
          }

          private void ShowAcquisitionState()
          {
               int Run;
               int OneShot;
               int Stop;
               int Pause;
               int Idle;
               m_Perception.GetAcquisitionState(out Run, out OneShot, out Stop, out Pause, out Idle);
               label1.Text = "Run: " + Run.ToString() + " OneShot: " + OneShot.ToString() +
                            " Stop: " + Stop.ToString() + " Pause: " + Pause.ToString() +
                            " Idle: " + Idle.ToString();
          }

          private void btnDisconnect_Click(object sender, EventArgs e)
          {
               m_Perception.DisconnectFromServer();
               label1.Text = "Disconnected";
          }

          private void btnStart_Click(object sender, EventArgs e)
          {
               m_Perception.Start();
          }

          private void btnStop_Click(object sender, EventArgs e)
          {
               m_Perception.Stop();
          }

          private void btnSingleShot_Click(object sender, EventArgs e)
          {
               m_Perception.OneShot();
          }

          private void btnPause_Click(object sender, EventArgs e)
          {
               m_Perception.Pause();
          }

          private void btnTrigger_Click(object sender, EventArgs e)
          {
               m_Perception.Trigger();
          }

          private void btnShowAcqState_Click(object sender, EventArgs e)
          {
               ShowAcquisitionState();
          }

          private void btnGetTriggerState_Click(object sender, EventArgs e)
          {
               ShowTriggerState();
          }

          private void ShowTriggerState()
          {
               int Idle;
               int Blocked;
               int WasBlocked;
               int Armed;
               int Triggered;
               int TriggerCount;
               int AllTriggerCountsEqual;

               m_Perception.GetTriggerState(out Idle, out Blocked, out WasBlocked,
                                     out Armed, out Triggered, out TriggerCount,
                                     out AllTriggerCountsEqual);

               lblTriggerState.Text = "Idle: " + Idle.ToString() +
                                      " Blocked: " + Blocked.ToString() +
                                      " WasBlocked: " + WasBlocked.ToString() +
                                      " Armed: " + Armed.ToString() +
                                      " Triggered: " + Triggered.ToString() +
                                      " TriggerCount: " + TriggerCount.ToString();

          }
     }
}
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMControlledStart(Boolean)
IPerceptionCOMStop
IPerceptionCOMPause
IPerceptionCOMOneShot


IPerceptionCOM.StartAsyncRTFDBSubscription Method

IPerceptionCOMStartAsyncRTFDBSubscription Method

This call prepares the system such that it can yield a snapshot containing all asynchronous RT-FDB channels available at the moment of the call

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void StartAsyncRTFDBSubscription()
Sub StartAsyncRTFDBSubscription
void StartAsyncRTFDBSubscription()
abstract StartAsyncRTFDBSubscription : unit -> unit
Remarks
When the RT-FDB channels have changed, this call needs to be executed again
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMStopAsyncRTFDBSubscription
IPerceptionCOMGetAsyncRTFDBNames(Array)
IPerceptionCOMGetAsyncRTFDBValues(Double, Array)


IPerceptionCOM.StartAutoBalance Method

IPerceptionCOMStartAutoBalance Method

Auto balance a bridge channel

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void StartAutoBalance(
    string Mainframe,
    string Recorder,
    string Channel
)
Sub StartAutoBalance (
    Mainframe As String,
    Recorder As String,
    Channel As String
)
void StartAutoBalance(
    String^ Mainframe,
    String^ Recorder,
    String^ Channel
)
abstract StartAutoBalance :
        Mainframe : string *
        Recorder : string *
        Channel : string -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Recorder
Type: SystemString
Recorder name or index
Channel
Type: SystemString
Channel name or index
Remarks
This command will actually balance the selected channel. To balance the selected channel the system must be acquiring data. Typically the Pause mode is used to do this. When the system is not acquiring data, a confirmation dialog will come up. The balance process by itself will try to bring the input voltage as close to zero as possible. Corrections as well as remainders will be indicated. Initially the Status of a channel will be Not Balanced. The actual balancing may take a few seconds. The final result should be Balanced. In the rare event that a channel is not factory-calibrated, the Status will indicate this after the actual balancing.
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.Stop Method

IPerceptionCOMStop Method

Stops an acquisition

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void Stop()
Sub Stop
void Stop()
abstract Stop : unit -> unit
Remarks
The current recording will be stopped. When in a sweep acquisition mode, a stop command while acquiring post-trigger data will be processed at the end of the sweep; this means that the sweep will be processed as specified. If you want to abort the sweep you must select the abort command. This will abort the current sweep immediately.
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMStart
IPerceptionCOMPause
IPerceptionCOMOneShot
IPerceptionCOMAbort


IPerceptionCOM.StopAsyncRTFDBSubscription Method

IPerceptionCOMStopAsyncRTFDBSubscription Method

This call cancels snapshot behavior, freeing up system resources

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void StopAsyncRTFDBSubscription()
Sub StopAsyncRTFDBSubscription
void StopAsyncRTFDBSubscription()
abstract StopAsyncRTFDBSubscription : unit -> unit
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMStartAsyncRTFDBSubscription
IPerceptionCOMGetAsyncRTFDBNames(Array)
IPerceptionCOMGetAsyncRTFDBValues(Double, Array)


IPerceptionCOM.StorageActive Method

IPerceptionCOMStorageActive Method

Check if the storage of a mainframe is active

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void StorageActive(
    string Mainframe,
    out bool Active
)
Sub StorageActive (
    Mainframe As String,
    <OutAttribute> ByRef Active As Boolean
)
void StorageActive(
    String^ Mainframe,
    [OutAttribute] bool% Active
)
abstract StorageActive :
        Mainframe : string *
        Active : bool byref -> unit

Parameters

Mainframe
Type: SystemString
Mainframe name or index; one based

Numerical index has to be surrounded by "$" character e.g. "$1$" for getting the name of the first mainframe

Active
Type: SystemBoolean
Returns true if storage is active
Remarks
When the system is recording the storage active flag is true, if the acquisition has been stopped then depending on the amount of data and the transfer speed of the network the system can still be active with saving the data, the storage data flag is then still be true. In many cases you have to check if the system is still saving data before you can use the last recording to do calculations on the complete recording.
Examples
Copy
bool Active;

RPC.StorageActive("GEN7t I", out Active);
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.SubscribeLiveWaveform Method

IPerceptionCOMSubscribeLiveWaveform Method

Function to subscribe to a live waveform stream

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void SubscribeLiveWaveform(
    string Waveform,
    int PairsPerBuffer,
    double TimePerBuffer,
    int TriggerMode,
    double TimeShift,
    out int SubscriberID
)
Sub SubscribeLiveWaveform (
    Waveform As String,
    PairsPerBuffer As Integer,
    TimePerBuffer As Double,
    TriggerMode As Integer,
    TimeShift As Double,
    <OutAttribute> ByRef SubscriberID As Integer
)
void SubscribeLiveWaveform(
    String^ Waveform,
    int PairsPerBuffer,
    double TimePerBuffer,
    int TriggerMode,
    double TimeShift,
    [OutAttribute] int% SubscriberID
)
abstract SubscribeLiveWaveform :
        Waveform : string *
        PairsPerBuffer : int *
        TimePerBuffer : float *
        TriggerMode : int *
        TimeShift : float *
        SubscriberID : int byref -> unit

Parameters

Waveform
Type: SystemString
Name of waveform
PairsPerBuffer
Type: SystemInt32
Number of min-max pairs per buffer (segment)
TimePerBuffer
Type: SystemDouble
Time per buffer in seconds
TriggerMode
Type: SystemInt32
Display stabilizer:
  • FreeRunning = 0
  • Trig Only = 1
  • Trig or Stabilizer = 3
  • Trig or Timeout = 5
  • Trig or Stabilizer or Timeout = 7
TimeShift
Type: SystemDouble
Time shift of trigger position in percentage of the buffer length.
SubscriberID
Type: SystemInt32
Returned ID
Remarks
More on data buffers

Live data is supplied in pieces called buffers or segments. When you subscribe to the live data you need to specify the length of such a piece. This length is specified in seconds. E.g. you can subscribe to get pieces of data that equal 0.5 seconds or 1 second. You also need to specify how many data points you want to be within that segment. A data point here is defined as one min-max pair. When acquisition is active, live data is processed to deliver the required data in buffers. It is the responsibility of the client program to retrieve the data fast enough. Up to 10 buffers can be stored in the system before overrun occurs. If the client program is not fast enough then this will cause delays in the shown monitor data in the client program. Attention: If the .NET Timer class (System.Windows.Forms.Timer) is used then a timing of 100 ms might be 110 ms due to inaccuracy of this timer, therefore it can happen that delays occur when you have set the time per buffer to 100 ms.

The Waveform Monitor Trigger Mode can be used to deliver pieces of data that are synchronized to a trigger level. For more details refer to the Perception manual. When a mode is selected that uses a trigger you can specify a shift for that trigger point within the data buffer.

The following diagram is a graphical example of some of the trigger modes.

See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMUnsubscribeLiveWaveform(Int32)
IPerceptionCOMGetData(Int32, Int32, Int32, Array, Array, Array, Int32, Array, Array, Int32)
IPerceptionCOMGetAvailableWaveforms(Array)


IPerceptionCOM.Trigger Method

IPerceptionCOMTrigger Method

This command initiates a trigger. Depending on the acquisition settings this can finish the active acquisition.

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void Trigger()
Sub Trigger
void Trigger()
abstract Trigger : unit -> unit
Examples
Copy
using System;
using System.Collections.Generic;
using System.ComponentModel;
using System.Data;
using System.Drawing;
using System.Text;
using System.Windows.Forms;
using PerceptionCOMRpc;

namespace MyFirstCOMClient
{
     public partial class Form1 : Form
     {
          // Define a private member to hold a reference to Perception
          // All the communication to Perception will be done via this member
          private PerceptionCOM m_Perception = null;

          public Form1()
          {
               InitializeComponent();
               // Create an instance of the Perception Com server
               m_Perception = new PerceptionCOM();
          }

          private void btnConnect_Click(object sender, EventArgs e)
          {
               // Set the address of the Perception Server machine
               // "localhost" is pointing to your own PC.
               // If however the Perception server is running on another machine then
               // you have to enter the computer name or IP-address of this PC
               m_Perception.SetServerAddress("localhost");
               m_Perception.ConnectToServer();

               // Get the acquisition state to check if we have communication
          }

          private void btnTrigger_Click(object sender, EventArgs e)
          {
               m_Perception.Trigger();
          }
     }
}
See Also

Reference

IPerceptionCOM Interface


IPerceptionCOM.UnsubscribeLiveWaveform Method

IPerceptionCOMUnsubscribeLiveWaveform Method

Use this function to un-subscribe when your done using the data from a subscribed waveform

Namespace: RPC_COM
Assembly: RPC_COM (in RPC_COM.dll) Version: 7.40.19169.801 7_40
Syntax
C#
VB
C++
F#
Copy
void UnsubscribeLiveWaveform(
    int SubscriberID
)
Sub UnsubscribeLiveWaveform (
    SubscriberID As Integer
)
void UnsubscribeLiveWaveform(
    int SubscriberID
)
abstract UnsubscribeLiveWaveform :
        SubscriberID : int -> unit

Parameters

SubscriberID
Type: SystemInt32
ID as returned by the corresponding SubscribeLiveWaveform function.
Examples
Copy
private int m_iSubscriberID;

m_Perception.SubscribeLiveWaveform(txtSelectedWaveform.Text, m_iRequestedNumberOfBins, 1.0 / m_iNumberOfUpdatesPerSecond, 0, 0, out m_iSubscriberID);

// use subscriber id to get data ......

m_Perception.UnsubscribeLiveWaveform(m_iSubscriberID);
See Also

Reference

IPerceptionCOM Interface
RPC_COM Namespace
IPerceptionCOMSubscribeLiveWaveform(String, Int32, Double, Int32, Double, Int32)
IPerceptionCOMGetData(Int32, Int32, Int32, Array, Array, Array, Int32, Array, Array, Int32)
IPerceptionCOMGetAvailableWaveforms(Array)