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1 Update information

These release notes describe changes in Perception (including GEN series firmware) V8.50.
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2 Mid and long-term support roadmap

Starting with Perception V8.00 some legacy features, mainframe and card support are no longer present. (A
Perception V7.6x maintenance version is available for critical bug fix support.)

2.1 Supported on latest Windows versions

Including all updates until June 2023:

• Windows 10 Pro 1607 and higher (64 bit only)
• Windows 11 Pro

Installation requirements:

• Dot Net Framework V4.8 (distributed with the install CD and available for download on the internet)
• Microsoft Direct3D® capable graphics card.

2.2 Downgrade

Perception V8.50 can be downgraded to the following versions.
Note: When an EtherCAT card is installed, a downgrade to any version before V8.28 must go
through version V8.28 first.

• Perception V8.4x
• Perception V8.3x
• Perception V8.2x
• Perception V8.1x
• Perception V8.0x
• Perception V7.6x
• Perception V7.5x
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3 Perception Versions

Table 3.1: Perception Versions
Version Description

Perception Standard Free
1-PERC-AD-0x Perception Advanced Paid
1-PERC-VA-0x Perception Viewer Enterprise Paid
1-PERC-E64-0x Perception Enterprise Paid

Perception supports the following application extensions:

Table 3.2: Application Extensions
Version Description
1-PERC-OP-EDR eDrive application (setup, live and efficiency mapping table) Paid
1-PERC-OP-STL Advanced High Voltage/High Power analysis according STL

standards
Paid

1-PERC-OP-HIA High Voltage Impulse Analysis Paid
1-PERC-OP-CSI CSI Runtime extensions (Customized Software Interfaces) Paid
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4 Known Issues

Table 4.1: Known Issues
GN310B Card The GN310B card supports Power Calibration. Currently Perception fails to show the

correct power calibration date. The date shown maps on ‘12/30/1899’.

Perception
settings

Mainframe settings changed via the Fieldbus remote control are not updated in the UI.
Reconnecting to the mainframe will show the changes.
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5 New Features

5.1 Perception – General new features

Continuous
fieldbus output
and split
recordings

When making a recording in GHS/Perception, various signals may be published on
the fieldbuses, and data is written into the recording file. Depending on the
acquisition mode that was selected for the recording, the data in the recording file
may be a combination of continuous data (acquired at a reduced sample rate and
written continuously during a recording) and on top of that sweep data (initiated by
trigger events and acquired at a (higher) sample rate and written only around the
time a trigger occurs).
Up until now:

• All data were written into a single recording file that could only be accessed by
3rd party applications when the whole recording was finished

• When recording files were getting very large, depending on what the file
system could handle as maximum file size, recordings were cut up into several
files. All files were required to be able to open a recording

• Fieldbus output was only available when the system was either in preview
mode or in recording mode. No fieldbus output was available when the system
was in Pause mode

In this release, several important changes were made to those
mechanisms ( see also in Perception, File → Preferences... → Perception →
Recordings, the blue information buttons in the Recording creation box):

• It is possible to save every sweep as a separate recording that can be opened
immediately after this sweep has been finished. Such recording files can be
recognized by the post-fix Sxxxx, where xxxx is the number of the sweep. If a
recording also contains continuous data, a separate recording file can be
generated for each part of the recording between a resume (or start) and a
pause (or stop). Such recording files can be recognized by the post-fix Cxxxx,
where xxxx is the number of resume(or start) - pause(or stop) interval. Go to
File → Preferences... → Perception → Recordings and, in the Recording creation
box, check 'Split recording into....and pause/resume'

• It is also possible to split the continuous part of the recording into smaller
individual recordings, for example to split the recording between each resume
and a pause into segments of, e.g., 10 seconds. Go to File → Preferences... →
Perception → Recordings and, in the Recording creation box, check 'Split
continuous recording into subrecordings after', and choose the length of each
part of the recording in seconds.

• When the user chooses not to generate a split recording, there is a choice to
have a single recording file or to cut up the recording into several files. Go to
File → Preferences... → Perception → Recordings and, in the Recording creation
box choose either 'Create recording as single file' or 'Create recording as
multiple files'. File size limitations of the underlying operating system apply.
The files obtained for this situation are not individual recording files and all
files are required to be able to open a recording

• Between a pause and resume, the system will continue publishing data on the
fieldbuses

The continuous fieldbus output together with the split recording functionality allows
a user to immediately inspect parts of the recording while at the same time the
system keeps on interacting with 3rd party systems through the fieldbuses.
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Start in pause
mode

Normally, when starting a recording, the system immediately starts writing into the
recording file. Once it is recording, the system can then be changed to pause mode
where data is no longer written to the recording file but the fieldbuses keep
generating output (see the new feature 'Continuous fieldbus output and split
recordings'). In this release, it is possible to start recording in pause mode. In this
case, fieldbuses start generating output from the start but no data is written until
the system is changing from pause mode to resume. This is convenient to check if
everything is set up correctly and if the fieldbuses are generating output without
storing data yet. To enable starting a recording in pause mode, go to File →
Preferences... → Perception → Recordings and, in the Recording creation box, check
'Suspend storage at start of recording'. This setting is only relevant for recordings
with continuous data being stored and it also affects remote acquisition commands
but only when Perception is connected.

Three new RTFDB
formulas for
determining
efficiencies

Three new application-specific Real-Time Formula DataBase (RTFDB) formulas are
now available called EfficiencyMode(), EfficiencyValue(), and PowerLoss(). Those
functions are typically used with power signals as an input and in this case
generate as an output the direction of the power flow, the efficiency (as ≤100%) for
the given power flow direction and the power loss for the given power flow direction.
For more details, also see the new feature ”Calculate efficiencies only once”.

Delete a
component by
clicking the 'X' in
the header

A component (e.g. a Display) can now quickly be deleted by clicking the 'X' in the
top-right of the component.

Temporarily allow
maximizing one
component

In Perception it is possible to have many components open simultaneously,
possibly leading to the situation where the information in certain components is
hard to read. It is now possible to temporarily maximize one component to have a
closer look at its content without the need to rearrange the layout of all
components: in a component header, click the (single) square icon on the right
side of the header and the component will be shown temporarily covering all other
components. For a maximized component, clicking the (double) square icon on the
right side of the header will restore the initial layout of all components.

In the Harmonic
Analysis Display,
select a range of
harmonics to be
shown and scale
the Y-axis.

The Harmonic Analysis Display shows harmonics of a signal in the form of a bar
chart based on spectral signals. In earlier version it was possible to show a range of
harmonics that is, the ranges always started with the zero-th harmonics (or, the
harmonic of order zero). In the new release it is possible to show harmonics
starting at a different order than zero. In the Harmonic Analysis Display, right-click
→ Properties... → Display Setup tab and choose the Start order in the Orders box.
Furthermore, it is now possible to scale the Y-axis: in the Harmonic Analysis Display,
right-click → Properties... → Display Setup tab and choose the scaling in the Y-axis
scale box.

In the MU sheet,
also store the
input values as
data sources

The MU sheet uses a number inputs to determine the measurement uncertainty of
calculated powers. One set of inputs consist of the input values (for example,
U_RMS, phi, I_in). Those input values are now also stored as data sources. After
performing a calculation in the MU sheet, in Perception go to Data sources → MU
and go the the folder DC, AC, or Mechanical.

Select which
channels are to be
exported

When exporting data to some other format (e.g., ASCII, Excel), it is now possible to
select on a per channel bases which channels should be exported. In Perception,
select File → Export Recording... , go to the Channels to export box, check Custom
channel selection, click ... and select the channels to be exported.

Suppress
duplicated range
annotation

In the Yt display in Perception, the range of each signal is given close to the Y-axis.
When many signals are present, also many range annotations are present which
may lead to a cluttered and unclear view of the annotations. It is now possible to
show only the range of the selected trace: right-click → Properties... → Annotation &
Grid tab and check Show annotation only for selected trace in the Y-Annotation box.
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Stabilize the Live
signals by
triggering on a
cycle signal

The signals in the Live view of a Yt time display are often 'running' even though
quite often, measured signals are often close to periodic due to the cycles of a
machine. From this release onward, it is possible to trigger (like in an oscilloscope)
the signals on a cycle signal. This functionality is currently recommended when
there is only one cycle source present in the setup. To activate cycle-based
triggering, right-click in the Live display → View mode and then select Cycle
Triggered. Alternatively, select the hamburger menu in the top-left of the Live
display and select Cycle Triggered.

5.2 Perception – New ePower Suite Features

In the ePower
suite, also change
user-defined
names when a
component name
is changed

In the ePower suite, the names of the automatically generated RTFDB formulas are
derived from the component/connector names in the ePower setup. The user can
manually add user-defined formulas using the same names as in the automatically
generated formulas. When the user changes the component/connector names, the
names of the automatically generated RTFDB formulas are changed but in previous
releases, the corresponding names of the user-defined formulas were not updated.
In this release, if a user uses component/connector names in the user-defined
formulas, those user-defined formulas will also be updated.

Calculate
efficiencies only
once

The efficiency blocks in the ePower suite take power signals as designated input
and outputs. Currently, depending on the user-defined energy flow direction, from
input to output or vice versa, the efficiency is calculated as P_out/P_in or as
P_in/P_out, respectively. It is also possible to generate efficiencies for both
directions if the direction is not known beforehand, and in the RTFDB formulas, two
efficiencies are calculated with postfix I>O or O>I, respectively. In this case, in
steady-state, one of the efficiencies will be >100% and the other one <100% and
based on this information, the user currently has to find out the direction of the
power flow. In some cases, outside steady-state behavior, it is possible for P_in and
P_out to have opposite signs leading to negative efficiencies which can, in absolute
value be <100% or >100%. In such situations, the efficiency is not defined.
In this release, the user can define that an efficiency is always ≤100%. An
additional signal then indicates the mode i.e., the actual direction of the power flow
(either from input to output or vice versa). In the ePower suite, in the efficiency
panel under Energy flow, select 'As ≤100% and mode'.
When efficiencies are not defined, NaN will be published on the field buses for
those signals.

Invert
Timer/Counter
channels

In some situations it is convenient to be able to invert the sign of a measurement
channel immediately in the hardware rather than, for example, in the Real-Time
Formula DataBase (RTFDB). This was already possible for standard analog input
signals but from this release, it is now also possible for Timer/Counter input signals
measured in frequency mode, for example used for digital torque signals. In the
ePower suite, select a connector with a digital torque/speed sensor, go to the part
Torque transducer and check the Invert signal box. In Perception, go to Settings →
Input box and select Timer-Counter and check the box in the Invert signal column.

Artificial gearbox
as connector

In an eDrive setup where a gearbox is included, it is not always possible to measure
the mechanical power on both the input shaft and output shaft of the gearbox, for
example due to space limitations. Measuring one of the shafts only, it is then useful
to still have some information about the shaft that is not measured in terms of this
non-measured shaft's torque and speed. For this reason, an artificial gearbox was
added allowing to specify the RPM ratio between the input and output shaft, as well
as artificially introduced mechanical losses (losses in terms of torque). In the
ePower suite, select a connector and as connector type, select Mechanical -
Gearbox.
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Show
Timer/Counter
measuring time
more prominently

In digital torque sensors, the actual torque value is related to the frequency of the
sensor output. In order to get the torque from the frequency, the frequency is
determined as the number of periods counted in a certain measuring time which
has an impact on several properties of the measured torque (e.g., accuracy, time
resolution). The user was always able to select this measuring time but only from
Perception, not from the ePower suite. It is now possible to also select the
measuring time from the ePower suite: in the ePower suite, select a connector with
a digital torque/speed sensor, go to the part Torque transducer and fill out the box
next to Measuring time.

Show meter
values in review

In the ePower suite, the scope display and the meters are only populated during
preview or recording and when a recording is stopped, the scope display and
meters will become empty. Now, by clicking on Create Results, a new sheet is
generated for the active component. The scope display contains the synchronous
signals of the active component a cursor. The meters will be populated with the
asynchronous signals of the active component at the time of cursor location.

5.3 New Features for Fieldbuses

RTFDB processing
on CAN signal

In the mainframes, the regular analog inputs can be processed in real-time using
the Real-Time Formula Database (RTFDB). The results of this processing can then
be stored in a recording or be published on one of the field buses. From this release
onward, CAN inputs can also be processed by the RTFDB and the results can be
treated just like processed analog signals i.e., they can be stored in a recording
and/or be published on one of the field buses. When CAN signals are available, they
are shown in Data Source Navigator and they can be selected by name in RTFDB
formulas, just like other signals. This allows to perform calculations on CAN signals
(and then to publish the results on, for example, the CAN bus). Since some RTFDB
functions can generate triggers, this also makes it possible to generate triggers
based on CAN signals.

Extended
acquisition status
as a result
channel

In terms of acquisition, a Genesis mainframe can be in several states such as,
Recording, Waiting for Trigger, Trigger armed, etc. The number of states was
extended to give more detail about the acquisition state the system is in. All those
different states are now coded as a unique integer value which can now be
published on the field buses: in Perception, go to Settings → Real-time Data →
Publishing and select for relevant field buses to publish Acquisition State
(predefined). For the Gen DAQ API, the method GHSGetExtendedAcquisitionState
was added which returns the extended acquisition state. In Perception, the
extended acquisition states can be seen in the Acquisition Control palette under
Acquisition and in the Status palette under Acquisition in text format. The integer
encoding for the states for publishing is as follows:

HBK-Public Page 9



6 Improvements

6.1 Improvements in the Perception ePower Suite

Creating FDB formulas
from RTFDB formulas
in the ePower suite
without hardware
connected

In the ePower suite, real-time formulas (RTFDB formulas) are automatically
generated and will lead to real-time results. In many cases it is useful to
re-process the recorded data in post-process mode using the FDB formulas.
The ePower suite could already automatically generate FDB formulas from
RTFDB formulas but up until now, it was required for hardware to be
connected. In the new release, FDB formulas can also be generated without
connected hardware.

Improved interpolation
for efficiency maps

Efficiency maps (and other 3D maps) use a limited number of points and
values between those points are determined by interpolation. In some case,
this interpolation gave unexpected results. In this release, the interpolation
methods were adjusted to behave more as expected by the user.

6.2 Improvements for Fieldbuses

Change from relative
addressing to absolute
addressing

In earlier major releases, in CAN remote control, relative addressing was used
for recorders. This means that: if we use the address x in a CAN command,
this refers to the x-th occupied recorder slot. This means that the address of a
recorder may change when recorders are added or removed. Because this is
inconvenient and error prone, we implemented the following change:
This is the first major release where, absolute addressing will be
used for all recorders in a mainframe.
In the 1-byte address available to address recorders, the range 1...127 is used
for physical recorders and the range 128...255 for CAN recorders, irrespective
of a physical recorder being present or not and a CAN recorder being used or
not.
NOTE: With this change. The user already using a setup and using
the old relative addressing may have to change their setup

EtherCAT Compliance New EEPROM contents will be applied when ESI file generation is triggered by
Perception

• Set unused FMMUs in EEPROM to 0xFF
• Removed unused Sync Managers from EEPROM (SM 4, 5, 6, 7)
• Added dynamic generation of default length for SM3. Saving EDI file will
regenerate EEPROM to match configuration.

GN815 new flash Added support for MT25Q FLASH on the GN815 card.

10



Release Notes

6.3 Improvements for Hardware

Support for new
B-type mainframes

We have introduced three new B-type mainframes, the GEN7tB, GEN17tB and
GEN7iB. The difference is that the updated mainframes support legacy cards
not in all slots:

• GEN2tB: no support of legacy cards
• GEN4tB: no support of legacy cards
• GEN7tB: limited support of legacy cards: slots A to C only!
• GEN17tB: no support of legacy cards
• GEN3iA: full support of legacy cards
• GEN7iB: limited support of legacy cards slots: A to C only!

Increase the
bandwidth of GN310B
and GN610B cards to
~400 kHz

This feature increases the bandwidth for the GN310B, GN311B and the
GN610B, GN611B cards to ~400 kHz. With this feature implementation, two
additional filter type (analog only) options are being offered:

• Bessel (analog only) - 7-pole Bessel, 395 kHz ± 25 kHz (-3 dB)
• Butterworth (analog only) - 7-pole Butterworth,460 kHz ± 25 kHz

To choose the analog-only filter option, in the Perception Settings sheet, go to
Input ® Basic – Voltage/Current and in the Filter type column, select either
“Bessel (Analog, Fc@-3dB)” or “Butterworth (Analog, Fc@-3dB)”
This is the first major release where in total SIX filter type selections (as listed
below) are supported:

• Bessel IIR (Fc@-3dB)
• Butterworth (Fc@-3dB)
• Elliptic (Fc@-0.1dB)
• Wideband (off)
• Bessel (Analog, Fc@-3dB)
• Butterworth (Analog, Fc@-3dB)

6.4 Support items and requests

Perception display
freeze in Display
Triggered mode

SUPEPT-142 A freeze occuring in Display Triggered mode was solved.

Perception forces
downgrade of QX
module and it fails
(caused by new chip
in the QX)

SUPEPT-150 If Perception cannot downgrade the firmware of a QuantumX
module, a dedicated message is shown.

Part of ePower suite
setpoint table empty

SUPEPT-204 A problem with RTFDB triggers not leading to setpoint table
entries was solved.

Mistake in the RPC
help file

SUPEPT-207 A mistake in the RPC manual for the newest release was
solved.

Standard pulse length
bug in Sequencer
sheet

SUPEPT-211 A problem with interpreting the standard pulse length in the
Sequencer sheet was solved.

Creating report makes
Perception sluggish

SUPEPT-214 A problem requiring a very long time to generate reports in
Perception was solved.

Y-scale annotation is
wrongly displayed

SUPEPT-215 A problem with the Y-annotation in a Yt display was solved.

BE3200 standard
pulse issue

SUPEPT-216 A problem with interpreting the standard pulse length in the
Sequencer sheet was solved.
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Sequencer pulses
were gone with a Beta
version of 8.40

SUPEPT-217 A problem with sequencer pulses no longer present in a Beta
version of 8.40 was solved.

VFrameFormat in our
dbc files not complete

SUPEPT-219 A problem with an incomplete definition of VFrameFormat
was solved.

Add UTC indication in
time stamp of a
recording on a
mainframe

SUPEPT-222 For mainframe recordings, it is now properly indicated when
it concerns UTC.

Add explanation of
the averaging method
in ePower

SUPEPT-223 In the ePower suite, additional information was added
concerning the difference between the different types of
averaging that are now available.

The average value of
current and voltage is
calculated incorrectly
with n-phase setup

SUPEPT-224 In some situations in the ePower suite, the average value of
current and voltage was calculated incorrectly with an
n-phase setup where n was not 3. The values are now
correctly calculated for any n (solve

Corrected some
settings in workbench
not being visible

SUPEPT-227 For a certain sequence of actions, part of the settings in a
virtual workbench were not visible in Perception. This is now
solved.

Put a limitation/text
into the Sensor
Database itself to
limit users to creating
tables with 9 entries

SUPEPT-232 When doing sensor linearization using look-up tables. the
maximum number of points that can be used is 9. This is
now more clearly indicated.

Assigned CAN signals
aren't assigned
properly to CAN
Recorder

SUPEPT-233 A problem where in some cases, CAN signals were
incorrectly shown as analog channels was solved.

Improved text in
properties window of
the Phasor display

SUPEPT-235 An explanatory text in the properties window of the Phasor
display concerning linked displays was clarified indicating
that linkage for time reference only applies to Review mode.

The filter settings of
the digital channels
are not updated
correctly

SUPEPT-240 A discrepancy between the filter settings of a digital channel
in Perception and the ePower suite was solved.

Trigger source
unknown when trigger
arm via CAN is used

SUPEPT-241 A problem that the source of a trigger source was unknown
when trigger arm via CAN was used is solved.

Harmonize trigger
times in Perception
display and for
ePower setpoints

SUPEPT-244 Both the Perception display and the setpoint table in the
ePower suite indicate the time of a trigger. Both had a
different format which is now harmonized such that both
have the same format.

Add cursor table to
ReviewSweep display

SUPEPT-246 In regular displays, there is a small cursor table to show the
values of a signal at the cursor position. This cursor table is
now also added to the ReviewSweep display.

Garbled characters in
calculator in Chinese

SUPEPT-249 A problem with garbled characters in the calculator when
Perception is switched to Chinese was solved.

Perception 8.40 Live
Display Flicker

SUPEPT-250 A problem of a flickering Live display possibly introduced in
8.40 was solved.

Missing entries in
setpoint table

SUPEPT-253 A problem with missing entries in the setpoint table was
solved.
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Perception crash at
opening PNRF file

SUPEPT-254 A problem with Perception crashing when opening a PNRF
file was solved.* -

'Start and stop trigger
on cycles' not properly
restored in Perception

SUPEPT-255 When in the ePower suite 'Start and stop trigger on cycles'
was toggled, the dependent settings in Perception were not
correctly toggled. This is solved.

Configuration
mismatch occurs
when loading
workbench

SUPEPT-256 A problem with loading a configuration in a mainframe and
restarting and giving a configuration mismatch error is
solved.

Fixed workbench
sharing problem

SUPEPT-257 In some situations, virtual workbenches made on one system
caused issues when using them on another system especially
in the context of the ePower suite. This is now solved.

Rounding / truncating
in display marker and
user table harmonized

SUPEPT-258 In the display marker and user table, transforming
non-integer values into an integer was done in a different
way. This is now harmonized.

Additional robustness
was added against
illegal characters in
the name of the logfile

SUPEPT-259 When there were illegal characters in the the name of the
logfile, Perception would crash. This is now made more
robust.

CAN bus load >100%
now gives an error

SUPEPT-260 The user can configure the CAN output of a mainframe such
that the total load is larger than 100%. An error message is
now given when this occurs.

Part of a workbench
was not saved

SUPEPT-261 Sometimes, recent edits to a virtual workbench were not
saved, This is now solved.

Improved robustness
triggering and trigger
arm

SUPEPT-280 In some situation GHS/Perception could end up in an
incorrect state saying ”5% loading”. This problem is now
solved.

Merging of RTFDB
formulas made more
robust

SUPEPT-289 The ePower suite automatically generates RTFDB formulas
between two special comments (*** Automatic formulas are
created below this line, you can add your own formulas at
the bottom *** and *** Automatic created formulas are
finished, below this line you can add your own formulas ***)
If one of those lines is removed, automatically generated
formulas can be mixed with user-generated formulas. The
approach to keeping both sets of formulas separate was
made more robust.
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7 Deprecated support

The following is no longer supported within Perception:

• GPS2750
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8 Supported Genesis HighSpeed Mainframes

The following Genesis HighSpeed Mainframes are supported:

• GEN2tB
• GEN3t
• GEN4tB
• GEN7tA
• GEN17tA
• GEN3i
• GEN3iA
• GEN7i
• GEN7iA
• GEN7iB
• GEN7tB
• GEN17tB
• BE3200
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9 Supported QuantumX Modules

Note: The support of QuantumX Modules in Perception will stop with future versions of Per-
ception! QuantumX modules can be integrated in systems with tethered mainframes using the
CAN-interface together with a QuantumX MX471C.
The following QuantumX models are supported:

• MX1609KB
• MX1609TB
• MX471B
• MX809B
• CX27B as single network access point only, no setup or control of CX27B

Patents no: 7,868,886
©Hottinger Brüel & Kjaer GmbH. All rights reserved.
All details describe our products in general form only.
They are not to be understood as express warranty and do not constitute any liability whatsoever.

Hottinger Brüel & Kjaer GmbH
Im Tiefen See 45 ∙ 64293 Darmstadt ∙ Germany
Tel. +49 6151 803-0 ∙ Fax: +49 6151 803-9100
E-mail: info@hbkworld.com ∙ www.hbm.com
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