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1 Update information

These release notes describe changes in Perception (including GEN series firmware) V8.70.
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2 Mid and long-term support roadmap

Starting with Perception V8.00 some legacy features, mainframe and card support are no longer present. (A
Perception V7.6x maintenance version is available for critical bug fix support.)

2.1 Supported on latest Windows versions

Including all updates until April 2024:

• Windows 10 Pro 20H2 and higher (64 bit only)
• Windows 11 Pro

Installation requirements:

• Dot Net Framework V4.8.1 (distributed with Perception installer)
• Microsoft Direct3D® capable graphics card.

2.2 Network license server

The license server for network licenses can run on Windows 10 or Windows 11. Note that Windows Server
2008 is the last version of Windows Server which can be used to run the license server.

2.3 Downgrade

Perception V8.70 can be downgraded to the following versions.
Note: When an EtherCAT card is installed, a downgrade to any version before V8.28 must go
through version V8.28 first.

• Perception V8.6x
• Perception V8.5x
• Perception V8.4x
• Perception V8.3x
• Perception V8.2x
• Perception V8.1x
• Perception V8.0x
• Perception V7.6x
• Perception V7.5x
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3 Perception Versions

Version Description
Perception Standard Free

1-PERC-AD-0x Perception Advanced Paid
1-PERC-VA-0x Perception Viewer Enterprise Paid
1-PERC-E70-0x Perception Enterprise Paid

Perception supports the following application extensions:

Version Description
1-PERC-OP-EDR eDrive application (setup, live and efficiency mapping table) Paid
1-PERC-OP-STL Advanced High Voltage/High Power analysis according STL

standards
Paid

1-PERC-OP-HIA High Voltage Impulse Analysis Paid
1-PERC-OP-CSI CSI Runtime extensions (Customized Software Interfaces) Paid
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4 Known Issues

Perception
recording

When in Perception -> Settings -> Acquisition all optional storage is disabled, the
recording will not stop the normal way. It will stop after a timeout of several minutes.

Split recording
and RTFDB
functions

When using the option for split recording (in Perception go to File -> Preferences… ->
Perception -> Recordings) together with one of the RTFDB functions TimedMean(),
TimedStdDev(), NumSamplesMean() or NumSamplesStdDev(), the different parts of
the recording will remain locked until the end of the acquisition.

Limit of 900
sweeps when
using split
recording
using the
mainframe
disk

When a recording is made to the drive in a mainframe and split recording is active,
after 900 sweeps, the recording continues but no longer as a split recording. Also, a
continuous recording can be split every 'x' seconds, if this is the case, the same will
stop and the number of splits in continuous and sweeps is added together and cannot
exceed 900.
Workaround: The user can record to the PC drive instead of to the mainframe drive.
Alternatively, the user may stop and start the recording again after a large number of
sweeps.

Robustness
issue when
wrongly
connecting the
remote probes

In earlier versions, the assignment of an ePower suite connector to a recorder was an
absolute channel assignment (e.g., for an application template, the connector at the
inverter output was always assigned to Recorder A), this assignment has now been
changed into a relative channel assignment (e.g., the connector at the inverter output
is assigned to the first applicable recorder). However, this is not true for the remote
probes. In this case, no default assignment is made and the user has to assign the
proper channels manually.

Perception
does not
update
settings
modified
through the
fieldbuses

If Perception is connected and mainframe settings are change via CAN acquisition
control, Perception doesn't update setting with new value. Workaround: disconnect
and reconnect to the mainframe.

Remote
Probes: The
Analog
Settings are
not properly
restored upon
disconnection
of Probes

If the Probes are disconnected for a short or long time, then upon reconnection the
default settings for the channel are getting applied. This has been noticed for the span
settings.
The intent is to recover the actual settings when the same probe is reconnected
(within a reasonable time). This is not yet the case.
The current behavior will lead to problems when reloading a workbench while the
channels are switched off. To avoid losing the reloaded settings when Probes are
currently switched off, the user may want to make sure to switch on the probes first
and then reload the workbench (when the channels report Warming Up or Power On) to
retain the workbench settings.
The fix to restore the analog settings upon re-connection will be available in the next
upcoming release.
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5 New Features

5.1 Perception – General new features

Allow to manually
arm triggers from
Perception

In GHS/Perception it is possible to use a trigger arming mechanism. If this
mechanism is activated, triggers must first be armed before triggers can be
processed to generate a sweep in a recording. At the end of a sweep, the triggers
are automatically disarmed and must be armed again before the next trigger can
be processed.
Up until now, triggers could only be armed at the mainframe directly, for example
by sending the proper fieldbus command to a mainframe. From this release, it is
also possible to arm triggers in Perception: if the trigger arming mechanism is
activated and the triggers are not armed, in Perception in the Acquisition Control
window, the regular large trigger button (T) changes into an arming button (A).
When this button is pushed, the triggers are armed and the system is ready to
process triggers from all the regular trigger sources. At the same time, the arming
button (A) changes into the regular trigger button (T) such that it is also possible to
give a manual trigger by pushing this T button.

Semi-automatic
renumbering of
CAN and EtherCAT
message IDs

When publishing signals on the fieldbuses, for some fieldbuses (like CAN and
EtherCAT), signals names are linked to a message ID or publishing ID. Initially,
Perception or the ePower suite assign default values to those IDs but those can be
modified by the user one-by-one (go to Settings → Real-time Data → Publishing).
However, when many signals are published, it can be time consuming to modify
the ID of each individual signal to be published. For this reason, functionality was
added to modify the IDs for a range of signals in one go as follows. First select a
range of signals in the 'ID column' of the relevant fieldbus. Right-click the first
selected signal, type in an ID number and Enter. All the selected IDs will now be
renumbered sequentially. For CAN, subsequent signals will get the same ID but get
assigned a different byte range (0..3, or 4..7). Note that IDs should be unique such
that when an ID used for renumbering was already in use, an error will occur, just
as when renumbering IDs one-by-one.

Allow exporting
asynchronous
signals as low
sample rate
synchronous
signals to
ASCII/Excel

Asynchronous signals are the results of cycle-based processing and the time
between samples is at least 0.5ms. When exporting, those signals were resampled
at a high sample rate leading to large files. In the previous release (8.60),
asynchronous signals could already be exported to MATLAB and MDF4 as
synchronous signals at a user-defined sample rate. In this new release, this is now
also possible when exporting to ASCII or Excel. This option can be found in the
regular export dialog (File → Export Recording ...).

Frequency,
amplitude and
phase from
spectral data type
in the FDB

In an earlier release, functionality was introduced to calculate the harmonics of
periodic 50Hz/60Hz eGrid signals according to the IEC61000-4-7 standard using the
@HarmonicsIEC61000() RTFDB function. To allow storing harmonic (spectral)
information over time, a new spectral signal type was introduced. Up until now, this
information could only be shown and interpreted by the Harmonic Analysis Display.
In this release, three functions were added to the FDB that can postprocess those
spectral signals:
@HSOneHarmonicAmplitude(): returns a waveform containing the amplitude of a
specified harmonic over time derived from the spectral input signal, with or without
frequency grouping.
@HSOneHarmonicPhase(): returns a waveform containing the phase of a specified
harmonic over time derived from the spectral input signal. It returns the phase of
the pure harmonic only (i.e., interharmonics are not used).
@HSFundamentalFrequency(): returns a waveform containing the fundamental
frequency over time of the original time signal derived from the spectral input
signal.
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Release Notes

Channel selection
during export in
batch processing

In earlier releases of Perception, it was made possible to select which channels
should be included when exporting a recording to an external format such as
MATLAB, MDF4, etc. In this release it is now also possible to select channels when
exporting recordings from Perception in batch processing (i.e., exporting a large
number of recordings in one go). To prevent unexpected results, make sure that all
recordings in a batch contain the same signal names and signal hierarchy (such as
multiple recordings of the same setup).

5.2 Perception – New ePower Suite Features

Support for
GN800B Receiver
card, and voltage
and current
Remote Probes

The ePower suite supports the Remote probes. In earlier versions, the assignment
of an ePower suite connector to a recorder was an absolute channel assignment
(e.g., for an application template, the connector at the inverter output was always
assigned to Recorder A), this assignment has now been changed into a relative
channel assignment (e.g., the connector at the inverter output is assigned to the
first applicable recorder). This is also true for the remote probes in which case the
Remote Probes receiver card is interpreted as a recorder with 8 channels (4 voltage
channels and 4 current channels).

Measurement
uncertainty for
power and
efficiency setpoint
values

Setpoint maps are indispensable in characterizing and studying electrical motors
and electrical drive trains. Important examples are setpoints maps where powers
and efficiencies are shown as a function of, for example, torque and speed. In the
ePower suite, setpoint maps based on setpoint values can be generated easily.
Although Perception and the ePower suite are designed to measure physical
quantities with high accuracy, for various reasons, such as uncontrollable
environmental conditions, even with the highest quality standards, it is impossible
to measure a quantity exactly and without error. Therefore, when stating
measurement results, it is important to also consider the measurement uncertainty.
In this release, the ePower suite setpoint functionality has been extended with the
measurement uncertainty (MU) of the power and efficiency setpoint values. The
MU for those setpoint values is made available as an Optional Analysis (in the
ePower suite, click the Optional Analysis button and in the Measurement
Uncertainty column, select for which connectors and for which efficiencies the MU
must be determined). The MU of a measurement depends on the used sensors,
acquisition cards, span, etc. In the new functionality, all the hardware and setting
information required to determine the MU is automatically retrieved from the
measurement setup. The only information to be provided by the user are
environmental conditions, such as the expected ambient temperature and the
expected working range of a sensor. The MUs for powers and efficiencies are made
available as regular setpoint values making it possible to not only generate, for
example, a setpoint map of the efficiency as a function of torque and speed, but
also to generate a setpoint map giving the relative or absolute MU of the efficiency
as a function of torque and speed.
For further information, also refer to the Quick Start Guide ”Measurement
Uncertainty Estimation for Power and Efficiency Setpoint Values”
(Perception_QSG_MU_for_Setpoints) that comes with a Perception installation.

Torque ripple
analysis

In the ePower suite, an optional analysis was added to determine the torque ripple.
In Perception, load the ePower suite sheet, click Optional Analysis and in the
'Torque ripple' column, select the mechanical connectors for which the torque
ripple must be determined. The absolute torque ripple is calculated for each
user-specified cycle interval by taking the absolute difference between the
maximum and minimum torque value in the cycle interval. The relative torque
ripple is determined by dividing the absolute torque ripple by the absolute value of
the average torque in a cycle interval.
Note that meaningful results for the torque ripple will only be obtained if the
measuring time of the torque Timer-Counter channel is larger than the 1 divided by
the minimum frequency generated by the torque sensor. Refer to the context help
of the ePower suite Optional Analysis Settings for further details.
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Release Notes

Modifying
cycle-detect
parameters from
the fieldbuses

The RTFDB function CycleDetect() allows detecting cycles in a measured signal. In
the ePower suite, cycle detection is important to allow computing entities like
cycle-based powers and efficiencies. How cycles are detected in detail is
determined by 8 scalar inputs to a CycleDetect() function (such as Cycles, Level,
Direction, Hysteresis). When used in the ePower suite, some of those parameters
get default values and some can be edited by the user, such as Cycles and Level.
From this release, it is possible to modify those 8 cycle-detect parameters using
fieldbus commands. This is convenient when a system is set up using the ePower
suite and after that controlled through the fieldbuses by an AuSy. To allow
modifying cycle-detect parameters using fieldbus commands for an existing
ePower suite setup, in the ePower suite go to Generic settings and in the tab Setup
Behavior check 'Set cycle detect parameters from fieldbuses'. The default selection
for new ePower suite setups can be done by loading the ePower suite, go to File →
Preferences → ePower suite → Generic → Setup Parameters and check 'Set cycle
detect parameters from fieldbuses'.

User-defined
variable naming
for ePower suite
signals

In the ePower suite, a major part of the name of a signal (or variable) is derived
from the user-defined names of ePower suite Components and Connectors. For
example, if an ePower setup contains a component named 'Inverter' and a
connector named 'Out' as user-selected names, then the name of the cycle-based
power signal measured at the connector is called Inverter.Out.P. The last part of the
name ('P') is chosen by the system and is shown, for example, in Meters. In many
cases, users want to use their own dedicated signal names throughout (in displays,
on the fieldbuses, in the recording, etc.) such that all those signals can easily be
referred to in the outside world by the same name. It is now possible for the user to
define the last part of this signal name. In the ePower Suite entry in the Menu bar,
click 'User Defined Variable Naming...'. The 'User Defined Variable Naming' window
will pop up listing listing all the signals (variables) in the first column called 'ePower
suite name'. In the 2nd column, a user-defined name can be given. A user-defined
name can be removed by selecting a cell (or multiple cells) and clicking the Delete
button on the keyboard. Note that by default, the user-defined name is also used
when publishing signals on the fieldbuses.

Optional analysis
for harmonic
active power and
harmonic RMS

In electric machines, the electrical power in the fundamental (1st harmonic) is the
most important for converting electrical power into mechanical power. Higher
harmonics in the active power may negatively impact the properties of the
machine by causing additional heat dissipation, torque ripple, and unwanted
mechanical oscillations/vibrations, etc. In this context, it is therefore useful to know
the amount of harmonic content in both the active power signal (i.e., the difference
between the total power and the power in the fundamental) and the voltage and
current signals (i.e., the difference between the RMS value of the voltage (or
current) and the RMS value of the fundamental of the voltage (or current)). In this
new release, an optional analysis 'Harmonic Power and RMS' is added generating
additional RTFDB formulas giving the above information on harmonic content of
active power/voltage/current signals. Within this context, the total active power is
decomposed into fundamental active power and non-fundamental active power
including all other harmonics. In the ePower suite, go to 'Optional Analysis' and in
the column 'Harmonic Power and RMS' of the 'Optional Analysis Settings' window,
select the (electrical) connectors for which signals representing harmonic content
must be generated.

5.3 New Features for Hardware

HBK-Public Page 8



Release Notes

Support for
GN800B Receiver
card

The GN800B receiver card can connect to up two remote probes via optical fiber
cables. The digital transmission does not add any drift or error to the measured
signal while an automatic cable length compensation ensures phase-matched
signals between remote probes. Using a voltage and a current remote probe, the
probes become power channels. The real-time formula database of the receiver
card comes with all standard formulas for real-time power calculations up to 2 MS/s,
while user-defined formulas are also possible. Digital cycle detection enables
dynamic power calculations with up to 2000 results/s, with a typical latency < 1 ms
and real-time bus transfer. All raw data including real-time results can be stored
continuously or in a triggered mode for applications like real-time machine
mapping.

Support for
P101I-4 Voltage
Remote Probe

The P101I-4 Voltage remote probe is a remote front end for the GN800B receiver
card. It offers four analog voltage inputs with ranges up to ±2000 V and sample
rates of 2 MS/s. The remote probe is connected to the mainframe only via optical
fiber, which offers several advantages: It can be placed close to the device under
test, short test leads minimize reflections and increase accuracy, prevent EMC
disturbances sent out from the cables and eliminate crosstalk. The input ranges go
up to ±2000 V serve the most demanding applications, and the overvoltage CAT
ratings prevent instrument damage in case of overvoltage conditions. In
combination with a P111I-4 or P112I-4 Current Remote Probe and a GN800B
receiver card it offers unmatched performance, accuracy, and safety in electric
power measurement.

Support for
Current Remote
Probes: P111I-4
without CT power,
P112I-4 with CT
power

The P111I-4 / P112I-4 Current Remote Probe is a remote front end for the GN800B
receiver card. It offers four analog current inputs with ranges up to ± 2 A for direct
connection to current transducers (CT’s) and a sample rate of 2 MS/s. Alternatively,
a voltage input is available to use current clamps for current measurement. Being
remote and only connected via optical fiber, it offers several advantages compared
to a traditional power analyzer. Placed close to the device under test, short test
leads minimize reflections and increase accuracy, prevent EMC disturbances
received on the low-level transducer connection cables and eliminate crosstalk.
Also, the Current Remote Probe can be calibrated independent from the receiver
card or the mainframe. The P111I-4 / P112I-4 Current Remote Probe in combination
with a GN800B receiver card offers unmatched performance, accuracy, and safety
in electric power measurement.
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New ”Remote
Probes” status
sheet

This is the first release that supports measuring voltage and current signals using
the new Remote Probes which are connected to the new GN800B receiver card
using a fiber connection. The GN800B card can be used in a regular mainframe.
In Perception, the status of receiver card and the probes can be viewed in the
'Remote Probes' sheet (In Perception, go to Sheets → Manage sheets... , select
'Remote Probes' and click 'Load'). By default, a limited amount of status
information is displayed. By right-clicking on a column entry or by clicking the blue
'i' in the menu bar, advanced status information is shown.
The columns in the Remote Probes sheet have the following meaning:

• Channel Status: Offline, Busy (initializing), OK/Online
• Channel Temperature: Maximum temperature measured inside the
channel

• Channel Power Status: Internal power supply status of channel
• Channel CT Power Status: CT power supply status (only applicable
for P112I-4)

• Channel Serial: Channel serial number
• Channel Companion Serial: Companion channel serial number
• Probe Link Status: Fiber link status between GN800B and Remote
Probe

• Probe Link Quality (BER): Bit error rate of fiber link between GN800B
and Remote Probe

• Probe Cable Length: Indication fiber cable length (+/- 3 m)
• Probe Serial: Remote Probe serial number
• Probe Temperature: Maximum temperature of Remote Probe with
excl. channels

• Probe Power Status: Internal power supply status of remote probe
excl. channels

• General SFP Status: SFP+ module overall status
• Probe SFP status: Remote Probe SFP+ module status
• Probe SFP Manufacturer: Remote Probe SFP+ module manufacturer
• Probe SFP TX Power: Remote Probe SFP+ module optical power
transmitted

• Probe SFP RX Power: Remote Probe SFP+ module optical power
received

• Probe SFP Serial: Remote Probe SFP+ module serial number
• Receiver SFP status: GN800B SFP+ module status
• Receiver SFP Manufacturer: GN800B SFP+ module manufacturer
• Receiver SFP TX Power: GN800B SFP+ module optical power
transmitted

• Receiver SFP RX Power: GN800B SFP+ module optical power
received

• Receiver SFP Serial: GN800B SFP+ module serial number
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6 Improvements

6.1 Improvements in Perception

Improvements to
user-interface design

The user-interface of Perception is updated and modernized with every
release. In this release, improvements were made to the headers of
components. Furthermore, a scroll bar was added to the window where user
keys can be selected.

Mainframe password
protection now also
prevents firmware
upgrade/downgrade

It is possible to protect Genesis HighSpeed mainframes from unauthorized or
accidental access by setting a password. This is especially useful when
mainframes are used in a critical environment such as production
environments. However, up until now, password protected mainframes would
still automatically perform a firmware upgrade when connected to a newer
version of Perception, causing the mainframe to be temporarily unavailable.
From this release on, for password protected mainframes, the password must
be used also when a firmware upgrade is to be done. This prevents accidental
or unwanted firmware upgrades.

Improved calculations
when doing setpoint
averaging on the
mainframe

In many cases, setpoint values are determined by averaging several
cycle-based results. In an earlier release, functionality was introduced to
perform this averaging on the mainframes rather than in Perception. This has
the additional benefit that setpoint values can be published on the fieldbuses.
Additionally, setpoint values can be traced back in a recording. In this new
release, the averaging intervals are improved in that the first sample after the
trigger for generating a setpoint is now the first sample in the average.

Additional optional
argument for type of
modulo operation for
FDB and RTFDB
modulo functions

In both the FDB and RTFDB there is a function for determining the modulo
value of a signal. A typical example where this is useful is when an angle is
available that is larger than 360 degrees. In this case it is common to
represent this angle as an equivalent angle between 0 and 360 degrees. This
can be done by calculating the angle modulo 360. More generally this is
denoted as 'a mod n'. There are, however, several slightly different ways to
calculate 'a mod n'. Examples are 'a mod n' = a - trunc(a/n), or 'a mod n' = a -
floor(a/n). Where in previous releases the modulo functions in the FDB and
RTFDB used 'trunc', in this release an additional 'Mode' argument was added
to the functions allowing to also use the 'floor' version for modulo calculations.
Although this highly technical explanation might be seen as a mere detail,
using the 'floor' version has benefits when measuring angles and speeds of
rotating machines.

6.2 Improvements in the Perception ePower Suite
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Improved cycle-based
recording in the
ePower suite

Setpoint values are typically determined by averaging several cycle-based
results. In the ePower suite, the collection of the cycle-based results to be
averaged can be done in a number of different ways (based on a fixed
averaging time where all the cycle-based results in the averaging time are
taken, by specifying the number of cycle-based results, etc.). The mode 'Start
and stop trigger on cycles' has been improved as follows. The number of
cycle-based results as specified by the user is used to determine the average
setpoint value. The pre- and post-trigger times default to 0, such that exactly
the data that was used for generating a setpoint ends up in the recording
allowing to reproduce setpoint values in post-processing.
To select the mode 'Start and stop trigger on cycles', in the ePower suite in the
Acquisition setup area, select 'Wait for trigger to trigger memory first' and
check 'Start and stop trigger on cycles'.

Improved user
interface for selecting
Setpoint map
parameters and
properties

In the ePower suite, a Setpoint map shows the dependency of one measured
entity (e.g., the efficiency) as a function of two other measured entities (e.g.,
torque and speed). The user can freely choose which measured entities to
use. The design of how to choose the entities has been improved. In the
ePower suite, after clicking 'Create Mapping', in the 'Setpoint Map' window,
select '...' → Properties to select the entities for the X, Y and Z-axes, the
scaling, the number of lines, colors, etc.

Context help In this release a start is made with context help. In several locations in the
software, question mark icons are added. Clicking such an icon will open a
PDF file with a short manual page explaining the context where the question
mark refers to as well as an explanation for all of the settings. In subsequent
releases, more context help will be added.

Improved layout for
ePower suite
Preferences and
Generic settings

For the ePower suite, several settings can be specified. The default settings
for new ePower suite setups can be done by loading the ePower suite and
going to File → Preferences → ePower suite → Generic. The settings for an
existing ePower suite setup can be modified by going to Generic Settings in
the ePower suite. The layout of the default settings has been improved by
grouping related settings together under File → Preferences → ePower suite →
Generic in the left pane of the Preference window. The layout of the Generic
Settings has been improved by grouping related settings together under
individual tabs.

Additional step
required when
changing the default
measuring time in the
ePower suite

When measuring torque using a digital torque sensor, the so-called
'measuring time' of the Timer/Counter channel is an important parameter,
also in the ePower suite. For this reason, in an earlier release, the measuring
time could directly be set from the ePower suite. The default value of 1us
guarantees that the torque signal is stored in the recording with a very high
time resolution. Given a certain time resolution in the recording, it is not
possible afterwards to get a higher time resolution, so there is a certain risk in
changing measuring time to a higher value. For this reason, when changing
the measuring time in the ePower suite, an additional window with a short
explanation will pop up after which the measuring time can be changed.

6.3 Improvements for Hardware

Fast Span Change via
fieldbus Remote
Control

For fast setpoint measurement, it is important to change multiple ranges very
fast via fieldbus remote control.
Up until now, the span of channels can only be changed sequentially via
remote control. From release 8.64 onwards, there has been improvement
made for fast span change, this enhancement will allow changing a set of
spans in one go. The fieldbus remote control document may be referred for
details of commands for both CAN and EtherCAT.
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6.4 Support items and requests

The speed of batch
processing is
improved

SUPEPT-307 The speed of batch processing was improved by solving an
underlying cache issue.

Add current archive
folder does not work
with user key (save
report as PDF)

SUPEPT-348 When using User Keys and using the %recstore%
construction, information was not stored in the correct
location. This is solved in this release.

Scaling in the report
display differs from
the display source

SUPEPT-352 A problem with a different scaling in Perception and a report
made from Perception was solved.

Phase shift parameter
for current
transformers with
burden resistor is
confusing

SUPEPT-355 When choosing a current transducer and burden resistor in
the Sensor database, there was a field called 'Phase shift'.
Values entered in this field are not yet used so it was
confusing which effect those values have. Therefore, the
field was removed.

Unable to open large
recording file on FAT
file system

SUPEPT-360 In some cases, a recording file can be so large that is cannot
be supported by the underlying file system (e.g., when a file
is copied to a FAT file system). When this is done from
Perception, there is a recovery procedure which did not
always work well. This problem is now fixed in this release.

Default setting of the
measuring time for
torque changed from
50ms to 1us

SUPEPT-367 The measuring time is used for the so-called Timer/Counter
channels. In recently releases, in the ePower suite, this time
was set to 50ms as a default which is too long for most
applications. In this release the default is set to 1us allowing
the highest possible time resolution for Timer/Counter
signals.

Delayed trace in
display when
exporting/importing
ASCII

SUPEPT-372 When a recording saved as an ASCII file was re-imported, it
showed up with a slight delay as compared to the original
recording when using absolute time. This is now solved.

Perception V8.60
cannot read a pNRF
file saved by V7.60

SUPEPT-376 In some situations a pNRF file generated using version V7.60
could not correctly be opened by V8.60.

Export recording of
data loaded as
reference is not
working

SUPEPT - 377 A problem with exporting a recording loaded as reference
was solved.

Recording file size
increases drastically
when load the
workbench the first
time

SUPEPT-381 A problem causing a large recording file due to a high sample
rate when loading a workbench for the first time was solved.

EtherCAT state
machine failed with
establishing state OP

SUPEPT-382 A problem that caused failure to establish EtherCAT state
machine in state OP has been solved.

Mainframe is endless
rebooting with stored
user settings

SUPEPT-385 A problem with an endless rebooting loop using specific user
settings was solved.
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Filter digital torque
and speed values
were not saved
correctly to the
workbench

SUPEPT-389 A problem with not storing the settings for the pulse width
filters at the input of digital timer/counter channels was
solved.

Perception crash in
Preview mode when
only one group's
storage is enabled

SUPEPT-392 A problem that caused Perception to crash in Preview mode
when only one group's storage is enabled was solved.

The data published
through XCP over
Ethernet to CANape
are not corresponding
to Perception display

SUPEPT-394 A problem with data publishing through XCP over Ethernet
was solved, the data published through XCP over Ethernet to
CANape is inline and corresponds to Perception display.

Copying table content
from Publishing table
does only work
row-wise

SUPEPT-397 A problem with copying multiple rows in one go in the
Publishing table was solved.

Mainframe alert -
ConfiguredBoot file is
based on a different
version of software
than currently used.

SUPEPT-400 A problem causing this unwanted mainframe alert
”ConfiguredBoot file is based on a different version of
software than currently used” was solved.

Gen3i and sudden
restarts

SUPEPT-401 The problem was not reproducible from the log analysis, logs
captured were overwritten upon restart. For integrated
systems, there has been improvements made to better
capture the logs. Functionality to copy all the files in the
diagnostics folder to a timestamped subfolder, upon fatal
assert has been added. This allows to better investigate the
root cause on any future re-occurrence of such problem.

Saving a .txt file as a
recording does not
work

SUPEPT-403 A text file can never be saved as a Perception recording file
(pnrf). When trying to do this anyways, an error message will
be given.

RPC call SetGroup-
SweepSettings not
shown in Perception

SUPEPT-406 The effect of the SetGroupSweepSettings RPC call is now
also shown in Perception.

Recording Suspension
issues noticed when
two groups use
different sample rates

SUPEPT-408 A problem that was causing recording suspensions in dual
mode has been solved.

Set Column Width
setting (user table) is
gone reloading a
workbench

SUPEPT-412 For a User table it is possible to change the column width.
The problem was solved that this new column width was not
stored in the recording (and thus was not applied after
reloadin

System crash during a
test, mainframe runs
out of memory when
split recording is
active.

SUPEPT-416 A problem that was causing the crash has been prevented
with a fix. Please refer known issue section to be informed
on the current behavior and possible workaround when split
recording is active for large number of sweeps.

Problem with adding
actions to macro's

SUPEPT-417 A problem with adding actions to macro's was solved.

No data is stored
when triggering after
loading a settings file

SUPEPT-418 A problem with saving and reloading a settings file (.pSET)
was solved.
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Release Notes

Digital signals are
displayed incorrectly
on Live displays

SUPEPT-419 A problem with signals that were incorrectly displayed in the
Live display was solved.

CAN values are not
updated properly in
the user table

SUPEPT-420 CAN data assigned to a user table were not updated always.
This problem is solved.
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7 Deprecated support

The following is no longer supported within Perception:

• GPS2750
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8 Supported Genesis HighSpeed Mainframes

The following Genesis HighSpeed Mainframes are supported:

• GEN2tB
• GEN3t
• GEN4tB
• GEN7tA
• GEN17tA
• GEN3i
• GEN3iA
• GEN7i
• GEN7iA
• GEN7iB
• GEN7tB
• GEN17tB
• BE3200
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9 Supported QuantumX Modules

Note: The support of QuantumX Modules in Perception will stop with future versions of Per-
ception! QuantumX modules can be integrated in systems with tethered mainframes using the
CAN-interface together with a QuantumX MX471C.
The following QuantumX models are supported:

• MX1609KB
• MX1609TB
• MX471B
• MX809B
• CX27B as single network access point only, no setup or control of CX27B

Patents no: 7,868,886
©Hottinger Brüel & Kjaer GmbH. All rights reserved.
All details describe our products in general form only.
They are not to be understood as express warranty and do not constitute any liability whatsoever.

Hottinger Brüel & Kjaer GmbH
Im Tiefen See 45 ∙ 64293 Darmstadt ∙ Germany
Tel. +49 6151 803-0 ∙ Fax: +49 6151 803-9100
E-mail: info@hbkworld.com ∙ www.hbm.com
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