Frequently asked questions regarding the QuantumX Software / Firmware Update

Quali moduli possono essere aggiornati col nuovo Firmware?

Possono essere aggiornati tutti i moduli. 

Guardate la seguente figura per ulteriori informazioni:

 

Dopo l'aggiornamento dei moduli non riesco più a trovarli con il vostro software!

  • Ha atteso abbastanza a lungo affinché il PC definisca il proprio indirizzo?
  • È possibile che il suo firewall stia bloccando l'interrogazione UDP?
    • provi a disattivare il proprio Firewall o rilasci le seguenti porte con il QuantumX:
      TCP port 5001, incoming UDP ports: 31416 e 31417
  •  È spenta la WLAN?
    • provi a disattivare la WLAN giusto per effettuare l'interrogazione ed il collegamento
  • È possibile che il suo programma antivirus sia responsabile del blocco dell'interrogazione UDP?
    • provi a disattivarlo. Se lo strumento viene poi trovato, trovi nella documentazione del programma antivirus come abilitare l'accesso alla rete (subnet locale) per i singoli programmi. Si devono abilitare le stesse porte come descritto sotto il Firewall.
  • Verificare gli indirizzi IP dei propri moduli
    • DHCP (indirizzamento IP automatico) o configurazione alternativa (indirizzo definito dall'utente)
    • se riparametrizzate qualcosa, attendete ca. 20 - 30 secondi prima di settare un indirizzo IP 
  • Se il proprio PC dispone di più interfacce Ethernet, provare a disattivare tutte le altre interfacce Ethernet.
  • Se state usando una grande rete, contattate il vostro amministratore di rete. Nelle reti gestite esistono numerosi metodi per limitare od impedire del tutto il trasferimento dei dati fra i singoli strumenti. In tal caso può essere necessario il rilascio o l'abilitazione da parte dell'amministratore.

Dove posso ottenere la panoramica completa delle ultime versioni di firmware e software?

Le Note di Rilascio QuantumX si trovano nelle nostre pagine per lo scaricamento del  firmware e software.

Attuale matrice delle versioni:

CD di sistema 4.01 del QuantumX

Versione

QuantumX Assistant 4

4.0 (Build 190)

QuantumX Firmware Updater

1.4.6.173

QuantumX Data Recorder Assistant (CX22-W)

3.0.0.1

QuantumX LabView™ Driver

4.0 (Build 130)

QuantumX .NET/COM API 4

4.0 (Build 130)

QuantumX CANape Driver ($)

4.0 (Build 41)

TEDS Editor (integriert in Sensordatenbank)

3.4.0.37

FireWire Driver

1.45.0.0

$ = necessaria la licenza

 

Pacchetti di Software

Versione

HBM catman Easy / catman AP

3.5.1

HBM catman Enterprise

6.5

HBM DIAdem™ Driver

4.x BETA (via canale di supporto)

 

Firmware per QuantumX 

Versione

MX840/A, MX440A, MX410/B, MX460, MX403B, MX1609/-T/KB/TB, MX1601/B, MX1615/B, MX878, MX879, CX27
MX840A-P, MX1609-P, MX411-P, MX460-P, MX1601-P

4-0-12-0-t.qxb (~ 400 MB,  vecchio su nuovo)

4-0-12-0.hbg (~ 12 MB)

Quali sono i vantaggi dei nuovi moduli tipo B e dello hardware in generale?

Le nuove funzionalità e vantaggi dei moduli tipo B che saranno rilasciati nel Maggio 2014 sono, in generale:

  • Meccanismo addizionale di sincronizzazione temporale basata su Ethernet supportante IEEE 1588:2008 time PTPv2
  • Cadenze dati addizionali insieme l quelle classiche della HBM (1200, …, 9600, 19200, …):
    • Decimali [S/sec]: …, 1000, 2000, 5000, 10000, 20000, …
  • Filtri digitali addizionali per tutte le diverse cadenze dati, con orientamento -3 dB oltre a  Bessel e Butterworth:
    • Fase Lineare

Entro i prossimi mesi aggiorneremo passo per passo tutti i moduli con queste funzionalità  hardware, a partire dal modulo per tensioni MX403B (10, 100, 1000 V). Inoltre, saranno rilasciati i seguenti moduli:

  • MX1601B – Ingressi standard, sostituirà l'esistente MX1601
  • MX1615B – Amplificatore per ponti di estensimetri, sostituirà l'esistente MX1615
  • MX410B – Amplificatore Universale ad Alta Velocità, sostituirà l'esistente MX410

Quali sono i vantaggi del nuovo firmware versione 4.x?

Funzionalità e vantaggi del nuovo firmware versione 4:

  • a prova di architettura firmware e software del futuro,
  • il nuovo protocollo del flusso dati (aperto) consente di integrarlo in qualsiasi S.O. (p. es.  Linux),
  • miglioramento della interrogazione moduli basata sul web con le porte UDP per la risposta all'interrogazione (scan) (31416 e 31417). Le nuove porte possono essere registrate in un  Windows Firewall durante l'installazione dell'Assistente di QuantumX, dell'Aggiornatore o del  catmanEASY sia automaticamente che manualmente, 
  • il nuovo sicuro aggiornamento del firmware basato sul web consente l'aggiornamento basato sul web oppure l'integrazione in qualsiasi software,
  • la parametrizzazione si comporta in modo analogo - minimo impegno per i programmatori.

Se uso il catman 3.5, posso ancora utilizzare i miei script creati con catman 3.4?

Sì. gli script restano ancora compatibili.

Quando è necessario aggiornare il software?

È necessario l'aggiornamento del software preesistente allorché 

  • si riceva un nuovo modulo con firmware versione 4.x,
  • si operi con i nuovi moduli del tipo B (essi funzionano solo con il firmware versione 4.x).

Quando è necessario aggiornare il Firmware dei miei moduli QuantumX?

È necessario l'aggiornamento dei moduli preesistenti allorché 

  • si operi con i nuovi moduli del tipo B (essi funzionano solo con il firmware versione 4.x),
  • si riceve un nuovo modulo con firmware versione 4.x.

Posso usare il catman 3.5 con i moduli QuantumX aventi firmware 1.x/2.x?

Sì, essi funzionano insieme. Il catman attiverà poi la modalità compatibile QuantumX.

È necessario aggiornare il firmware dell'MGCplus per formare un sistema ibrido con i nuovi moduli QuantumX?

No, non è richiesto alcun aggiornamento.

L'Assistente 4 del QuantumX funziona con i moduli aventi firmware 1.x/2.x?

No, essi non funzionano insieme. In effetti i moduli vengono trovati, ma poi non possono essere connessi.

Posso usare il catman 3.4 con i nuovi moduli QuantumX?

No, non è possibile usarli insieme. Per tali moduli è necessario il catman 3.5.

Come posso effettuare l'aggiornamento al firmware 4.x di un modulo QuantumX preesistente?

Si raccomanda di effettuare questo aggiornamento con il catman 3.5 o con l'aggiornatore di firmware del QuantumX.

Posso declassare il firmware dei nuovi moduli QuantumX alla versione 1.x / 2.x?

No, sfortunatamente non è possibile declassare il firmware.

Posso formare un sistema mescolando i moduli QuantumX aventi il nuovo firmware 4.x ed il vecchio firmware 1.x / 2.x?

No, sfortunatamente non è possibile formare un sistema di tal genere.

Posso formare un sistema misto con moduli QuantumX vecchi e nuovi?

Si, effettuando l'aggiornamento del firmware dei moduli. Tutti i moduli devono avere la versione del firmware 4.0 o superiore. 

Contatti Prego, contattateci se desiderate conoscere cosa può offrirvi la HBM.